
VivaDesigner 10
Manual WE PUBLISH THE WORLD





Contents

Version 10 — Wednesday, January 5, 2022



Contents

General Information
General Information.............................................................................2

Delivery & Updates ........................................................................................2
Prior knowledge ............................................................................................2
Conventions .................................................................................................3

Services .............................................................................................5
Program Help ................................................................................................5
Additional Services ........................................................................................5

Legal notices ......................................................................................6
VIVA Trademarks ...........................................................................................6
Trademarks of other manufacturers ..................................................................6

Installation
Preparing the Installation.....................................................................10
Licensing additional options and add-on modules....................................11
Installation on Microsoft Windows.........................................................12
Uninstalling or deleting the program.....................................................13
Installation on Mac OS X.......................................................................14
Update an installed program version.....................................................14
Uninstalling/Deleting the program........................................................14
Installation on Linux............................................................................15
Program start (emergency mode)..........................................................16
Update License Key..............................................................................17
Install third-party dictionaries..............................................................18

Install Hunspell spell checker..........................................................................18
Install Hunspell Hyphenation..........................................................................18

Automated Installation (for System Administrators only) ..........................19
Preferences file.............................................................................................19
Create Preferences file:...................................................................................19
Windows Registry.........................................................................................20
License file...................................................................................................20
Paths for the License file in the user folder:.......................................................20
Paths for the License file in the program folder:.................................................20
VCP file........................................................................................................21

User Interface
The Document Window........................................................................24

Move document window................................................................................25
Change the size of the document window.........................................................25

Menus...............................................................................................25
Dialogs & Palettes...............................................................................26

Dialog Construction and Behavior...................................................................26
Move dialog window.....................................................................................26
Change the size of the dialog window..............................................................26

X-2



Contents

Palette Construction and Behavior...................................................................27
Positioning palettes......................................................................................27
Change palette size.......................................................................................27
Group palettes.............................................................................................27
Stack palettes..............................................................................................28
Group palettes next to/above one another........................................................28
Save workspace............................................................................................28
Options in dialogs and palettes......................................................................29
Command areas...........................................................................................29
Values for entry fields...................................................................................29
Delete values in entry fields............................................................................29
Display values in entry fields..........................................................................29
Measurement units in entry fields...................................................................29
Calculations in entry fields.............................................................................30
Checkboxes.................................................................................................30
Radio Buttons..............................................................................................30
Popup Menus................................................................................................31
Lists............................................................................................................31
Scroll boxes..................................................................................................31
Buttons........................................................................................................31
Program Palettes...........................................................................................31

Errors, Warnings and Queries................................................................33

Working with Documents
Working with Documents.....................................................................36
Open Document.................................................................................36

Open Document with the program dialog.........................................................36
Open Document with the operating system dialog.............................................38
Open Document with a double click.................................................................39
Open Document by Drag & Drop.....................................................................39
Open last saved version of a document............................................................39

Opening automatic backup copies........................................................40
Open backup copy automatically....................................................................40
Open backup copy manually..........................................................................40

Closing Documents..............................................................................41
Close document............................................................................................41

Creating new documents......................................................................41
Create a new document..................................................................................41

Saving Documents..............................................................................43
Save a new document...................................................................................43
Save a new document with a preview..............................................................44
Save document using OS dialog......................................................................45
Save an existing document............................................................................45
Save a document with a different name...........................................................45

Document views.................................................................................45
Selecting Open documents.............................................................................45

X-3



Contents

Sort document windows................................................................................46
Split document window.................................................................................47
Choose document zoom/views........................................................................48
Choose view with menu options......................................................................48
Zoom with the zoom field...............................................................................49
Zoom in with the zoom tool............................................................................49
Zoom out with the zoom tool..........................................................................49
Zoom in/zoom out with the mouse wheel..........................................................49
Zoom in/zoom out with shortcuts....................................................................50
Presentation Mode........................................................................................50
Activate Presentation Mode............................................................................50
Leave Presentation Mode...............................................................................50
Choose document section view.......................................................................50
Choose document section freely.......................................................................51
Choose document section page by page...........................................................51

Working with Pages
Working with Pages............................................................................54

Create a new document page ........................................................................54
Create new document pages using the dialog ..................................................54
Create new (blank) document page(s) interactively ..........................................55
Create new (default) document page(s) interactively ........................................55
Select document pages .................................................................................55
Select a document page ................................................................................55
Page Preview in the Pages palette...................................................................56
Activate/Deactivate Page View.......................................................................56
Deleting document pages .............................................................................56
Deleting document pages with the dialog ........................................................56
Deleting document pages interactively ...........................................................56
Move document pages ..................................................................................57
Move document pages interactively ...............................................................57

Working with Alias pages ....................................................................58
Switch between Alias and document pages ......................................................58
Switch to an Alias page .................................................................................58
Switch to document pages ............................................................................58
Create new Alias page ..................................................................................58
Create new Alias page ..................................................................................59
Switch between Alias pages ...........................................................................59
Switch between Alias pages ...........................................................................59
Assign an Alias page to a document page .......................................................60
Assign an Alias page to a document page with the dialog ..................................60
Assign an Alias page to a document page interactively .....................................60
Assign one Alias page to several document pages simultaneously .......................60
Deleting the assignment of Alias pages ...........................................................60
Create new document pages with Alias page ....................................................61
Create new document pages with Alias page using Dialog ..................................61

X-4



Contents

Create new document pages with Alias page interactively ..................................61
Deleting Alias pages .....................................................................................61
Delete Alias page ..........................................................................................61
Change Alias page name ...............................................................................62
Change Alias page name ...............................................................................62
Duplicate Alias Pages....................................................................................62
Duplicate Alias Page......................................................................................62
Protect Alias Pages........................................................................................62
Protect Alias Page.........................................................................................62
Unlock Alias Page.........................................................................................63

Working with page numbers ...............................................................63
Define page numbering ................................................................................63
Change page numbering ..............................................................................63
Use variables for page numbers .....................................................................64
Inserting variables for page numbers in text ....................................................64
Logical and physical page numbers ................................................................64
Define the page number display in the Preferences ...........................................65

Working with Objects
Introduction......................................................................................68
Creating objects ................................................................................69

Creating closed objects .................................................................................69
Create a rectangle or square interactively ........................................................69
Create a rectangle/square automatically .........................................................70
Create a curved rectangle .............................................................................70
Create an oval/circle interactively ..................................................................70
Create a polygon/Bézier object .......................................................................71
Create line objects/paths...............................................................................72
Create a simple straight line ..........................................................................72
Create an orthogonal line ..............................................................................72
Create a multiple line/path ............................................................................72

Summary Creating Objects ..................................................................73
Selecting objects................................................................................74

Select objects with a mouse-click ...................................................................74
Select objects through dragging ....................................................................74
Select objects in content mode (menu) or Esc....................................................75
Deselect all selected objects ...........................................................................75

Summary Selecting objects .................................................................76
Editing Objects...................................................................................76

Quick Access palette.....................................................................................76
Module palette.............................................................................................76

Positioning objects ............................................................................76
Move objects ...............................................................................................77
Move an object interactively with the mouse ....................................................77
Move/nudge object(s) with the keyboard ........................................................77
Move an object with the Module palette/Quick Access palette .............................77

X-5



Contents

Changing object hierarchy ............................................................................78
Change object hierarchy ...............................................................................78
Object alignment .........................................................................................78
Align objects with menu commands ...............................................................78
Align objects with the Align/Distribute dialog ..................................................79
Align objects automatically on the page..........................................................79
Align object to each other automatically..........................................................80
Align objects numerically .............................................................................80
Rotate........................................................................................................80
Rotate an object Interactively ........................................................................80
Rotate numerically .......................................................................................80
Mirror .........................................................................................................81
Skew objects ................................................................................................81

Basic commands ................................................................................81
Delete objects ..............................................................................................81
Delete objects ..............................................................................................81
Cut objects .................................................................................................82
Cut objects .................................................................................................82
Copying objects ..........................................................................................82
Copy objects ...............................................................................................82
Pasting Objects............................................................................................82
Paste objects ...............................................................................................83
Duplicate objects .........................................................................................83
Duplicate objects .........................................................................................83
Split objects ................................................................................................84
Split objects ................................................................................................84
Lock objects ................................................................................................84
Lock objects ................................................................................................84
Unlock objects ............................................................................................84
Protect objects ............................................................................................85
Protect objects ............................................................................................85
Cancel protection ........................................................................................85

Modifying object properties.................................................................85
Resizing objects interactively ........................................................................85
Resize/scale rectangle and oval interactively ...................................................86
Resize polygons and lines interactively ...........................................................86
Resize curves and Bézier objects .....................................................................87
Delete sizing handles ....................................................................................87
Delete sizing and control handles ...................................................................87
Create a half-circle ......................................................................................87
Add sizing handles ......................................................................................87
Add a sizing handle .....................................................................................88
Automatic Scaling .......................................................................................88
Scale objects and groups proportionally with the dialog ...................................88

Summary Resizing objects ...................................................................89
Object fill .........................................................................................89

Fill Color, Density, Transparency ....................................................................89
Change fill color with the Module or Quick Access palette ..................................89

X-6



Contents

Change fill color...........................................................................................90
Lines and Frames ...............................................................................90

Line Color, Shade, Transparency .....................................................................90
Change Line color with the Module/Quick Access palette ....................................90
Change Line/Frame Width ..............................................................................91
Change Line Width with the Module/Quick Access palette ...................................91
Change Frame type (line style)........................................................................91
Change Line Style..........................................................................................91
Change Line ends .........................................................................................92
Change Line ends.........................................................................................92
Change Line Join...........................................................................................92
Change Line Cap...........................................................................................92
Change Radius ............................................................................................92
Change radius with the Module/Quick Access palette .........................................92
Objects with predefined settings.....................................................................92

Object Grouping ................................................................................93
Create and recognize a Group ........................................................................93
Create a Group ............................................................................................93
Creating a Group Hierarchy ...........................................................................93
Create a Group with an Alias object ................................................................93
Create Alias of a Group .................................................................................93
Select objects in a group ...............................................................................94
Select object in a group ................................................................................94
Ungroup ....................................................................................................94
Ungroup ....................................................................................................94
Resize a group.............................................................................................94
Resize a group proportionally ........................................................................94
Resize a group disproportionally ....................................................................95

Summary Object Grouping ..................................................................95
Combine Objects with the Pathfinder.....................................................95

Preparing objects.........................................................................................95
Unite Paths..................................................................................................95
Subtract Paths..............................................................................................95
Intersect Paths.............................................................................................96
Exclude overlap............................................................................................96
Convert text to paths....................................................................................96
Combine the paths of the objects/letters of the word..........................................96

Special object properties and commands...............................................97
Printable/non-printable................................................................................97
Make objects non-printable...........................................................................97

Effects..............................................................................................98
Shadow/Drop Shadow...................................................................................98
Create closed objects with Drop Shadow...........................................................98
Create text content with Drop Shadow.............................................................98
Create picture content with Drop Shadow.........................................................98
Change Drop Shadow settings........................................................................98
Inner ShadowOuter GlowInner GlowColor OverlayReflectionTransparency incl. new tool 99
Create and use an object with Run Around features............................................99

X-7



Contents

Special object settings for images..................................................................100
Special settings for images............................................................................100
Apply Automatic Clipping to an image...........................................................100
Special object settings for text.......................................................................101
Enter special settings for text.........................................................................101
Notes ........................................................................................................102

Using Guide Objects ..........................................................................103
Create Guide Objects automatically ...............................................................103
Create Guide object with Ruler ......................................................................103
Create Guide Objects manually .....................................................................104
Create Guide object manually .......................................................................104
Select Guide Objects ....................................................................................104
Guide Objects Selectable On/Off ....................................................................104
Show Guide objects .....................................................................................105
Hide/Show Guide objects ..............................................................................105
Magnetism ................................................................................................105
Change Snap to Distance for Guide objects .....................................................105

Summary Using Guide Objects ............................................................105
Working with Alias Objects..................................................................106

Creating Alias objects ..................................................................................106
Create an Alias object...................................................................................106
Duplicate objects as Alias objects onto following pages.....................................107
Duplicate objects as Alias objects on new pages...............................................107
Find Original...............................................................................................108
Find Original...............................................................................................108
Change Alias into a Copy..............................................................................108
Change Alias into a Copy..............................................................................108
Flexible Alias Content...................................................................................108
Create a Flexible Alias Text and/or Picture Object..............................................108
Cancel the flexible content of an Alias Object...................................................109

Summary Alias Objects.......................................................................109

Working with Text
Working with Text..............................................................................112
Basics...............................................................................................112

Creating text objects.....................................................................................112
Create a text object interactively.....................................................................112
Create a text object with another shape and writing direction.............................112
Create rectangular text object with menu/shortcut keys.....................................112
Convert an existing object into a text object.....................................................112
Text mode...................................................................................................113
Choose Text mode.........................................................................................113
Leave Text mode ..........................................................................................113
Insertion point (cursor).................................................................................113

Entering and importing text.................................................................113
Keyboard....................................................................................................114

X-8



Contents

Special characters........................................................................................114
Insert special characters................................................................................114
Insert spaces................................................................................................114
Insert Hyphen/Em Dash..................................................................................115
Breaks........................................................................................................116
Insert break.................................................................................................116
Character Map.............................................................................................116
Insert characters of a font into the text............................................................117
Show Favorites list........................................................................................118
Save single characters of a font as Favorites......................................................118
Remove characters from the Favorites list.........................................................118
OpenType Menu...........................................................................................118
Insert OpenType character.............................................................................119
Variables....................................................................................................119
Insert variables for page numbers...................................................................119
Insert Variables for Document name and path..................................................119
Insert Variables for Running Titles...................................................................119
Insert Variables for Footnotes and Endnotes.....................................................120
Insert Variable for Dates...............................................................................120
Change settings for date variables..................................................................122

Importing text files............................................................................122
Import text file with the Import dialog............................................................122
Import text file by Drag & Drop......................................................................122
Insert Placeholder Text..................................................................................123
Insert Placeholder Text..................................................................................123
Objects.......................................................................................................123
Anchor image in text....................................................................................123
Anchor table in text.....................................................................................123
Anchor formula in text..................................................................................124
Anchoring objects and groups in the text........................................................124
Anchor Objects............................................................................................124
Anchor objects in the line..............................................................................125
Anchor objects above the line........................................................................125
Anchor objects individually...........................................................................125
Edit anchor objects......................................................................................126
Edit the position of anchor objects..................................................................126
Select, cut, copy or delete anchor objects........................................................126

Selecting text....................................................................................126
Select Text..................................................................................................126
Deselect a text selection................................................................................127

Editing text.......................................................................................127
Delete/replace text.......................................................................................127
Delete single character.................................................................................127
Delete text selection.....................................................................................127
Delete text selection by replacing it................................................................127
Cut text......................................................................................................128
Cut text .....................................................................................................128
Copy text...................................................................................................128

X-9



Contents

Copy text...................................................................................................128
Paste copied/cut text...................................................................................129
Paste text...................................................................................................129

Text layout.......................................................................................129
Text object layout options.............................................................................129
Define the position of the first baseline...........................................................130
Text object columns.....................................................................................130
Header & Footer............................................................................................131
Text layout options.......................................................................................131
Create several Layouts...................................................................................131
Change Layout options..................................................................................131
Line Orientation...........................................................................................132
Line Justification..........................................................................................132
Justified space between lines and paragraphs..................................................132
Layout offsets..............................................................................................132
Layout Columns...........................................................................................133
Automatic and Manual Layout columns...........................................................133

Exporting text...................................................................................133
Export Text.................................................................................................133

Language, Spelling and Hyphenation...................................................134
Language...................................................................................................134
Assign language to a text passage.................................................................134
Assign a new language to be applied to all new text objects..............................134
Hyphenation...............................................................................................135
Activate Automatic Hyphenation....................................................................135
Deactivate Automatic Hyphenation ................................................................136
Show Automatic Hyphenation Suggestion........................................................136
Discretionary hyphenation............................................................................136
Delete discretionary hyphen..........................................................................137
Manual hyphenation....................................................................................137
User dictionaries for hyphenation exceptions ..................................................137
Spell Check.................................................................................................137
Start manual Spell Check...............................................................................137
Automatic Spell and Grammar Check..............................................................138

Search and Replace............................................................................139
Simple Search and Replace............................................................................139
Search and Replace......................................................................................139
Search and Replace invisibles........................................................................140
Complex Search and Replace.........................................................................140
Search and Replace Regular Expressions...........................................................141

Index and Tables................................................................................141
Create an index entry for a text string.............................................................141
Generate an index........................................................................................141

Footnotes and Endnotes......................................................................142
Preparations for Footnotes and Endnotes.........................................................142
Define Preferences for Footnotes and Endnotes.................................................143
Footnote Position.........................................................................................143
Define the Footnote Position..........................................................................144

X-10



Contents

Working with Footnotes and Endnotes............................................................144
Insert Footnotes and Endnotes.......................................................................144
Convert Footnotes and Endnotes....................................................................144
Automatic Numbering..................................................................................145
Switch off Automatic Numbering...................................................................145
Switch on Automatic Numbering....................................................................145
Deleting Footnotes and Endnotes...................................................................145
General Tips for Footnotes and Endnotes.........................................................146

The Line Counter................................................................................146
Switch the Line Counter on or off for the whole text Story...................................146
Suppress the line count for a paragraph..........................................................147
Changing Line Counter Preferences.................................................................147
Define font attributes for the Line counter.......................................................148

Working with Pictures
Working with Pictures........................................................................150
Raster or Vector Images .....................................................................150
Commonly used image formats ............................................................151

Raster Image Formats ...................................................................................151
The JPEG format ...........................................................................................151
The BMP format ...........................................................................................152
The PNG format ...........................................................................................152
The SCITEX formats ......................................................................................153

Vector Image Formats ........................................................................153
The EPS Format ............................................................................................153
The EPS/DCS Format .....................................................................................154
The PDF Format ...........................................................................................154
OPI Images .................................................................................................154

EPSF Vector Images and Fonts .............................................................154
Vector Images and Colors ...................................................................155
Creating Picture Objects .....................................................................156

Create a new picture object interactively ........................................................156
Create a new picture object with menu/shortcut keys .......................................156
Convert an existing object into a picture object ...............................................156

Summary Creating Picture Objects .......................................................156
Image Mode .....................................................................................157

Activate/Leave Image Mode ..........................................................................157
Activate Picture mode ..................................................................................157
Ways of leaving Picture Mode .......................................................................157

Importing Pictures ............................................................................157
The Import Command ..................................................................................157
Import picture with the dialog ......................................................................157
Drag and Drop ...........................................................................................158
Import pictures to existing picture objects with Drag and Drop ..........................158
Import several pictures with Drag and Drop ....................................................159
Clipboard ..................................................................................................159

X-11



Contents

Deleting, Cutting and Copying Image Content ......................................159
Deleting/Cutting/Replacing picture content ...................................................159
Copy & Paste picture content ........................................................................159

Defining the Crop .............................................................................160
Moving Picture Content ...............................................................................160
Move picture content interactively ................................................................160
Display options for moving pictures ...............................................................161
Move picture preview using menu ..................................................................161
Move picture preview precisely with the dialog ...............................................162
Resizing Picture Object ................................................................................162
Resizing a picture object ..............................................................................162
Fitting the picture object (frame) to the picture preview ...................................162

Summary Moving Picture Content ........................................................163
Mirror, Rotate and Skew .....................................................................163

Mirroring with the Picture Slider.....................................................................163
Mirroring, rotating or skewing picture previews with the palette ........................163
Mirroring, rotating or skewing picture previews with the dialog ........................164

Scaling Image Preview........................................................................164
Scaling image preview proportionally ............................................................165
Scaling image preview unproportionally ........................................................166
Scaling image preview unproportionally with the dialog ..................................166

Preflight for Images ..........................................................................166
Tips and Tricks with Images ................................................................167

Image import .............................................................................................167
Image display.............................................................................................167

The Pictures palette............................................................................167

Working with Tables
Working with Tables..........................................................................170
Create Tables....................................................................................170

Create a table object....................................................................................170
Selecting table rows, columns and cells.................................................171

Activate Table mode.....................................................................................171
Leave Table mode.........................................................................................171
Select a table cell.........................................................................................171
Select several table cells................................................................................172
Select one or more table rows........................................................................172
Select one or more table columns...................................................................172

Table width and height, column width and row height............................172
Table width.................................................................................................172
Width with numeric width entries...................................................................172
Width with percentage width entries..............................................................173
Column width.............................................................................................173
olumn Width in a table (general)...................................................................173
olumn Width in a table with numeric width.....................................................173
olumn Width in a table with percentage width.................................................174

X-12



Contents

Table height................................................................................................175
Row height.................................................................................................175

Editing table rows and columns...........................................................176
Defining row height and column width...........................................................176
Define row height or column width interactively...............................................176
Define row height or column width numerically................................................176
Inserting/Adding rows and columns...............................................................177
Insert columns............................................................................................177
Insert rows.................................................................................................178
Add rows and/or columns on the right or bottom of the table............................178
Delete/Remove a column or row.....................................................................178
Delete/Remove rows and/or columns from the right or bottom of the table...........178

Editing table cells..............................................................................179
Extend cells................................................................................................179
Merge cells.................................................................................................179
Split merged cells........................................................................................179
Cell Indents................................................................................................179
Define cell indents.......................................................................................180
Cell content................................................................................................180
Cell alignment............................................................................................180
Define cell alignment...................................................................................180
Define cell rotation.......................................................................................181

Enter/import text in tables...................................................................181
Navigation in Tables.....................................................................................181
Type text into tables.....................................................................................181
Import text into tables..................................................................................182
Import text into a cell...................................................................................182
Import tab stop separated text......................................................................182

Graphic attributes for Tables...............................................................183
Colors for cells, rows and columns..................................................................183
Separators..................................................................................................183
Create table with standard grid.....................................................................183
Edit the grid...............................................................................................184
Switch grid off............................................................................................184
Define Separators for individual cells, columns or rows.....................................184

Graphic Style Sheets for Tables............................................................184
Create a Cell Style Sheet................................................................................185
Create a Row Style Sheet...............................................................................185
Create a Column Style Sheet..........................................................................185
Create a Table Style Sheet with alternating columns..........................................186
Create a Table Style Sheet with alternating rows...............................................186

Working with Style Sheets
Working with Style Sheets...................................................................190
Introduction.....................................................................................190
Create/Import Text Style Sheets...........................................................190

X-13



Contents

Create Text Style Sheets................................................................................190
Create a simple Text Style Sheet:....................................................................190
Create a Text Style Sheet with a template: ........................................................191
Importing Text Style Sheets...........................................................................192

Assigning Text Style Sheets.................................................................192
Assigning Text Style Sheets manually..............................................................192
Assign Text Style Sheets manually: ................................................................192
Assigning Text Style sheets automatically........................................................193
Assign Text Style Sheets automatically:...........................................................193
Replace Text Style Sheets automatically:.........................................................193
Assign Text Style Sheets automatically using the Preferences:.............................194
Changing the assignment of Text Style Sheets..................................................194
Cancel or change a Text Style Sheet assignment manually:.................................194
Cancel or change a Text Style Sheet assignment automatically:..........................194

Editing Style Sheets............................................................................195
Renaming Style Sheets..................................................................................195
Rename Style Sheets:....................................................................................195
Duplicate Style Sheets:..................................................................................195
Delete one or more Style Sheets:.....................................................................196

Graphic Style Sheets...........................................................................197
Create a simple graphic style sheet:................................................................197
Assigning Graphic Style Sheets......................................................................197
Assign Graphic Style Sheet with Style Sheets palette:.........................................197
Assign Graphic Style Sheet with a shortcut:......................................................197
Graphic Style Sheets with Preference...............................................................198
Creating Object Style Sheets with Preferences:..................................................198
Assigning several Graphic Style Sheets............................................................198
Assign two Graphic Style Sheets:....................................................................198

Picture Style Sheets............................................................................199
Creating Picture Style Sheets.........................................................................199
Create a simple Picture Style Sheet:................................................................199
Assigning Picture Style Sheets........................................................................199
Assign Picture Style sheet with the palette:......................................................199
Picture Style Sheets with Preference...............................................................200
Create a Picture Style Sheet with Preferences:..................................................200
Assigning several Picture Style Sheets............................................................200
Assign two Picture Style Sheets:.....................................................................200

Style Sheets for Table Objects..............................................................201

Working with Colors
Working with Colors..........................................................................204
Create and manage colors..................................................................204

Open the Colors & Blends dialog:...................................................................204
Define/create a new color:............................................................................205
Define/create a new simple blend/gradient:...................................................206
Create a complex blend with additional options:.............................................207

X-14



Contents

Edit a Color or Blend:...................................................................................207
Deleting a Color or Blend:.............................................................................208
Clear all colors/blends:................................................................................208
Import Colors:............................................................................................208
Color Trapping...........................................................................................209
Specify trapping for a color:.........................................................................209

Printing
Printing............................................................................................212
Print................................................................................................212
Preparation.......................................................................................212

Fonts..........................................................................................................212
Colors........................................................................................................213
Images.......................................................................................................213

Printing options................................................................................213
Pages.........................................................................................................213
Format.......................................................................................................214
Colors........................................................................................................216
Objects......................................................................................................216

Print Presets......................................................................................217
Create a new preset......................................................................................217
Edit and save an existing preset.....................................................................218
Delete preset...............................................................................................218

Export
Export.............................................................................................220
PDF Export........................................................................................220
PDF Options......................................................................................220

Compatibility and color settings...................................................................220
General......................................................................................................222
Optimize....................................................................................................222
Security.....................................................................................................223
View.........................................................................................................224
Output......................................................................................................225

Postscript Export...............................................................................227
PostScript Options.............................................................................227
EPS Export........................................................................................227
EPS Export Options............................................................................228
JPEG/PNG/SVG Export.........................................................................228

Export document pages...............................................................................228
JPEG/PNG/SVG Options.................................................................................228
Export objects............................................................................................229

Exporting an InDesign file..................................................................229
Export InDesign IDML file..............................................................................229

XML Export.......................................................................................230

X-15



Contents

Export document........................................................................................230
Export Objects............................................................................................230
XML Export options.....................................................................................230

Preferences
Preferences......................................................................................234
Introduction.....................................................................................234
Manage preferences..........................................................................234

Reset preferences........................................................................................234
Reset preferences at program startup.............................................................234

Program preferences.........................................................................235
General program options.............................................................................235
Scrolling....................................................................................................237
Fonts.........................................................................................................237
Images......................................................................................................237
PS/PDF.......................................................................................................238
Colors.......................................................................................................238
Backup......................................................................................................239
Updates.....................................................................................................239

Document preferences.......................................................................240
Objects......................................................................................................240
Object Properties........................................................................................242
Pages........................................................................................................242
Grid..........................................................................................................243
Embedded fonts.........................................................................................243
Measurements............................................................................................243
Search Paths...............................................................................................244
Text..........................................................................................................244
General Text Preferences..............................................................................244
Preferences for Style Sheets...........................................................................245
Preferences for Footnotes.............................................................................246
Preferences for Endnotes..............................................................................246
Language..................................................................................................247
User Dictionaries.........................................................................................247
Define hyphenation exceptions ....................................................................247
Define a No Hyphenation .............................................................................248
Define hyphenation quality .........................................................................248
Hyphenations with automatic substitution......................................................248
Color Management......................................................................................249
Access Rights.............................................................................................249
Drives........................................................................................................249
Set up a drive for VivaCloud.........................................................................249
Set up a drive for a MySQL database...............................................................250
Set up a drive for an ODBC database...............................................................251
Set up a Drive for Canto Cumulus....................................................................251
Set up a drive for Six OMC.............................................................................252

X-16



Contents

Set up a drive for Mediamid M@ars................................................................252
Set up a drive for ResourceSpace...................................................................252
Using the drive...........................................................................................253
Place images interactively............................................................................253
Technical notes on drives.............................................................................253
XMP Custom Info.........................................................................................254
Preflight....................................................................................................254

Working in a Team
Working in a Team............................................................................256
Overview of the team functions...........................................................256

Editing of documents..................................................................................256
Change Tracking.........................................................................................256
Notes........................................................................................................256
Restrict document editing............................................................................256
Tasks.........................................................................................................256
Libraries....................................................................................................256
Embedded Fonts.........................................................................................256
Embedded Images.......................................................................................257
Document Management...............................................................................257
VivaCloud..................................................................................................257
Collection..................................................................................................257
Status information......................................................................................257
Package & Send (VIVA FileSender).................................................................257

Change Tracking...............................................................................258
Activate/Deactivate Change Tracking.............................................................258
Activate/Deactivate Change Tracking.............................................................258
Display of changed text passages..................................................................258
Accept/Reject changes.................................................................................258
Accept or reject changes..............................................................................258
Changing the preferences for change tracking.................................................259
Define the Author Name...............................................................................259
Define display of changed text passages........................................................259

Notes..............................................................................................260
Create Notes...............................................................................................260
Create a Note for an object...........................................................................260
Create a Note in a text.................................................................................260
Change a Note for an Object.........................................................................260
Change a Note in text..................................................................................260
Managing notes..........................................................................................261
Changing preferences for notes.....................................................................261
Define the Author Name................................................................................261

Access Rights....................................................................................261
Basic working methods................................................................................262
Dynamic Access Rights (Web workflow)..........................................................262
Static and Dynamic Access Rights (Web workflow)...........................................262

X-17



Contents

Create/Unlock Access Rights.........................................................................262
Change access rights for a document.............................................................263
Unlock access rights temporarily/permanently................................................263
Options for Access Rights.............................................................................263
Options for Documents................................................................................263
Options for Output......................................................................................263
Options for Layout & Content........................................................................264
Options for displaying palettes.....................................................................265
Hints for creating templates.........................................................................266
Conceptual notes........................................................................................266
Notes on document pages............................................................................267
Notes on objects and layers..........................................................................267
Notes on graphic and picture objects.............................................................267
Notes on text objects...................................................................................268
Notes on text style sheets.............................................................................268
Hints for the creation of templates in InDesign................................................268

Working with Scripts
Working with Scripts.........................................................................270
Introduction.....................................................................................270
Manage scripts.................................................................................270

Script file...................................................................................................270
Move/copy individual script file into the user folder.........................................270
Using Scripts...............................................................................................271
Apply a script.............................................................................................271
Modify Scripts.............................................................................................271

Example scripts.................................................................................271
Legal information........................................................................................271
Example 1: Import all images in a folder..........................................................271

X-18



Contents

X-19



Contents

X-20



General Information

Version 10 — Wednesday, January 5, 2022



General Information | About this manual

General Information

About this manual
The programs are constructed in such a way that the options are almost self-explanatory. Thus you
do not have to read this manual completely to be able to work with the program. We have tried to
build this manual didactically, but in the first instance it serves as a work of reference. The manual is
therefore not a substitute for training and was not written to solve specific problems (e.g., “How to
make a book”). Please refer to the information in the section Additional Services. You can go
through each section separately. If individual descriptions refer to options described in other sec-
tions, an appropriate reference is made.

Please note that not all the options described in this manual are available in certain program versions
and editions. This is not a defect, but may be related to the operating system used, the program ver-
sion used or to some missing modules.

This manual was created with the greatest possible care. Despite all our efforts, some errors may be
contained in the manual. We would therefore be pleased to receive all your comments and criticisms
that will help us to improve the quality of our products.

Delivery & Updates

The manual is supplied in electronic form and is not part of the installation program of every appli-
cation. In such cases the application enables an option to open the manual which is stored in the
Internet. Thus the manual may be updated at any time. To read the manual, you need an application
for reading PDF files that is available free of charge on the Internet.

Prior knowledge

To understand the instructions in this manual, you should have the following prior knowledge:

• Basic knowledge of the operating system, especially working with files and folders,
especially copying, deleting, opening, saving and closing files, as well as working with win-
dows.

• Basic knowledge of layout programs.

• The input of text via a keyboard and application of keyboard commands (shortcuts) and the
mouse.

• The installation and starting of a computer program.

• Switching between program and operating system.

• Using printers.
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Conventions

In the manual, a series of expressions and conventions helps for better comprehension.

Operating systems — The manual was written for a computer program that may be used on several
operating systems. The manual therefore only refers to a specific operating system when the program
behaves differently under different operating systems, or if another operation is necessary. The oper-
ating systems are abbreviated in the manual as Windows (for Windows operating systems), Linux (for
all Linux operating systems) and Mac (for Mac OS X operating systems).

Mouse buttons — In the manual we have dispensed with the expressions »right mouse button« or
»left mouse button«, as the functions for these but tons in the operating system are adjustable for
left- or righthanders and are therefore not clear. For this reason we use the expressions primary
mouse but ton and secondary mouse button.

• If in the manual the term “mouse button” or “click” is used, then the primary mouse button is
always meant.

• If in the manual the term “context menu” is used, then the secondary mouse button is always
meant.

• If the term mouse wheel is used in the manual, it means the mouse wheel of the computer
mouse or the mouse wheel sensor (e.g. the Apple computer mouse).

Keyboards — Not all keyboards use the same names for the same options. Below are a few examples
with their equivalents:

• “Strg” = “Ctrl”

• “Entf” = “Del” or “forward delete”

• “Pos 1” = “Home”

Style — The manual uses special styles to help you read and understand the program:

• Text passages marked in red represent a program option. This may be a shortcut key sequence
or an option in a menu, an option or an item in a dialog, a palette or a pop-up menu.

• Several consecutive options will be separated by a “greater” sign (>). The text File > Close
means that you first have to choose the option “Close” in the “File” menu.

• Keyboard shortcuts are described system-specifically if necessary. A keyboard shortcut consists
of one or more key combinations. With a shortcut the keys must be pressed simultaneously in
the specified order. The keys are separated by a plus sign (+). The shortcut Ctrl + Shift + B means
that you have to hold down the “Ctrl” key, then the “Shift” key and finally the “B” key.

• Text passages enclosed in quotation marks represent a special expression.

• Text passages displayed in a typewriter font represent an input to be made by the user.
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Examples — The manual always uses the same terms for repetitive descriptions:

• “Choose YYY ...” means that the option may become YYY. This can be an option in a menu or in
a dialog or in a palette.

• “Choose XXX > YYY ...” means that the YYY option can be chosen via a menu/submenu XXX or a
dialog box or a pop-up menu.

• “Choose XXX > YYY and then ZZZ ...” means that the ZZZ option can be chosen in a dialog or
palette after choosing the menu XXX > YYY.

• “Choose XXX > YYY ... in the context menu” means that the YYY option can be chosen via the
context menu.

• “Choose XXX > YYY (Windows/Linux) or ZZZ > YYY (Mac) ...” means that the YYY option must be
chosen under a different menu depending on the operating system.

• “Choose XXX > YYY in the menu or YYY in the context menu ...” means that the option YYY can
be chosen via the menu and a context menu.

• “Choose XXX > YYY in the menu or ZZZ > YYY ... in the context menu” means that the YYY
option can be chosen in the menu and/or context menu via a submenu.

• “Choose one of the following options ...” means that there are several ways to chose the same
option (for example, via a menu and a shortcut).

• “Optionally Select/Click/Specify ...” means that this option is not mandatory and may be
ignored or skipped.

• “Select an object” means that you should explicitly select only one object.

• “Select at least one object” means that you can select one or more objects.

• “Select at least two objects” means that you can select at least two or more objects.

• “Press XXX ...” means that the option can be selected with the XXX key.

• “Press XXX + YYY + ZZZ ...” means that the option can be selected with the shortcut. To do this,
you must hold down all the keys in the specified order.

• “Press XXX (Windows/Linux) or YYY (Mac) ...” means that the option can be selected under a
different shortcut depending on the operating system.

• “Click ...” or “Click XXX ...” means that you should simply click an XXX button or tool with the
primary mouse button. A button may consist of a text (e.g., “OK”, “Cancel”, etc.) or a symbol.

• “Double-click ...” or “Double-click XXX ...” means that you should simply double-click an XXX
button or tool with the primary mouse button.

• “Confirm the entry ...” means that you can either click on the “OK” button in a dialog or alter-
natively press the “Enter” or Return key. In palettes, the Tab key may also be sufficient.

• “Open ...” means you should open a document, a folder, or a drive path.

• “This option is helpful ...” means that an example explains when the option can be set.

• “Please refer to the section XXX ...” or “Choose the options according to the information in the
section XXX”means an indication of additional options or information in another section of the
manual.

4



General Information | Services

Services

Program Help

If you need help for the application, the following resources are available:

1. The program‘s user manual:

• Choose Help > Manual.

2. The application website:

• Choose Help > Web page.

3. Send a message to VIVA:

• Choose Help > Send a message to VIVA.

• Fill out the fields in the Internet browser and describe your problem in as much detail as pos-
sible.

If you have problems with your operating system, please read the docu mentation supplied with your
computer. This particularly refers to problems with:

- access to discs and folders,

- saving files,

- usage of fonts or single characters in a font, and

- usage of printers and output devices.

The usage of additional applications which add to or extend the functions of the operating system
may limit the functionality of the pro gram or its usage completely. These may include:

 • Programs that change the display of windows, documents and dialogs

 • Programs that change the access to and management of fonts.

Therefore we cannot give any guarantees for program usage in conjunction with these programs.

Additional Services

VIVA offers many additional services on request. These include:

1. Service & Support:

• Training & Workshops

• Telephone Hotline in several languages

• Service & Support contracts

• Support for your developers (Support/example code)

2. Support and advice for publishing projects in

• Planning

• Development

• Automation
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• Implementation

3. Software development

• Extension of existing VIVA applications

• Programming individual applications

4. Provision

• Hosting VIVA products

• Renting VIVA products

Legal notices

VIVA Trademarks

Viva, the Viva logo, vivaMedia, Viva Network Publishing, Database Publishing, Intelligent Publishing,
Enterprise Publishing, Viva Creative Publishing and Viva Corporate Publishing are registered trade-
marks of Viva Vertrieb GmbH (formerly Viva Software GmbH) or Viva Technology GmbH. All further
registered trademarks are the property of the respective owners.

All rights reserved. © 1994, 2020 VIVA GmbH. All unauthorized copying of this manual or the software
will be subject to legal prosecution. Rights to the software programs are owned by Viva GmbH,
Koblenz, Germany. Rights to the documentation and rights to the object-oriented Alias concept are
owned by Andreas Krings. Legal purchase of the pro gram version and manual entitles the user to use
the product according to the conditions of the licensing agreement. Duplication, sale or other use of
the product not complying with the conditions of the licensing agreement is prohibited. Copies of the
programs may be made only for data backup purposes.

Trademarks of other manufacturers

Microsoft, OpenType, Internet Explorer, Edge, Windows, MS-Publisher, Microsoft Word, Microsoft
Access, Microsoft PowerPoint and Microsoft Excel are trademarks of Microsoft Corporation registered
in the U.S and/or other countries.

Mac, Mac OS, TrueType, Safari, Apple and Macintosh are trademarks or registered trademarks of
Apple, Inc. in the U.S.A. and other countries.

Adobe, the Adobe logo, Acrobat, Creative Suite, Flash, FreeHand, Illustrator, InCopy, InDesign, Page-
Maker, Photoshop, PostScript and PostScript 3 are either registered trademarks or trademarks of
Adobe Systems Incorporated in the United States and/or other countries.

Quark, the Quark logo, QuarkXPress, XTensions, QuarkXTensions other Quark related marks which
Quark may adopt from time to time are trademarks of Quark, Inc. and all applicable affiliated com-
panies.

The PANTONE® colors displayed in the software or in the user documentation may possibly not be
identical with the PANTONE color standards. Please check the exact colors in the current PANTONE
publications. PAN TONE and other trademarks of Pantone, Inc. are the property of Pantone, Inc.
©Pantone, Inc., 2007.

Color Data is manufactured under licence from Dainippon Ink and Chemicals, Inc.
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FOCOLTONE and FOCOLTONE Color System are registered trademarks of FOCOLTONE. Concept, structure
and form of the FOCOLTONE material and its intellectual property are protected by Patent and copy-
right. Reproduction in any form, in whole or in part, for private use or for sale, is strictly prohibited.
Further information on the patents is available from FOCOLTONE, Ltd.

Toyo Ink Mfg. Co., Ltd. is the owner of the copyrights of the TOYO INK COLOR FINDER™ SYSTEM AND
SOFTWARE. ©TOYO INK MFG. CO., LTD., 1991. COLOR FINDER have been registered as trademarks by the
Toyo Ink Mfg. Co., Ltd.

TRUMATCH, TRUMATCH Swatching System and TRUMATCH System are trademarks of TRUMATCH, Inc.

Unicode is a trademark of Unicode, Inc. Firefox is a trademark of the Mozilla Foundation. Google and
the Google Chrome logo are registered trademarks of Google Inc. The Opera Browser logo is the prop-
erty of Opera Software ASA, Oslo, Norway Java is a trademark or registered trademark of Oracle and/
or its affiliates. The names of actual companies and products mentioned herein may be the trade-
marks of their respective owners. All other trademarks are the property of their respective owners.
Errors and Omissions Excepted.

Duden - © 2016, Bibliographisches Institut GmbH, Berlin and EPC Consulting und Software GmbH,
Ketsch.
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Installation

Preparing the Installation
For the installation and subsequent problem-free operation of the program, the following conditions
are absolutely essential. These are explained below.

Step 1: Remove/delete previously installed program versions
If they exist, remove all previously installed program versions before the installation (see section
Uninstalling or deleting the program). In every case, delete existing installations of a Free Edition if
you have purchased a license for a full version. A Free Edition can not be unlocked with a license key
for a full version! You should always empty the Trash, as some operating systems (e.g. Mac OS X)
start programs that have already been deleted to the Trash.

Step 2: The correct installation program for your operating system
For the software installation VIVA has developed appropriate installation programs for different oper-
ating systems (Windows, Mac OS X and Linux). Please ensure when downloading the installer pro-
gram that you choose the correct one for your operating system.

For all operating systems since Version 9 a 64 Bit version is supplied. For some older Windows sys-
tems both a 32 bit and a 64 Bit version may be supplied. If you have a 64 Bit operating system, you
should also always install the 64 Bit version. If you don't possess a 64 Bit system, please use the 32
Bit version. Please note that the function ranges of the 32 Bit and 64 Bit versions may differ.

Step 3: Unpacking the installation program
The installation program may be packed in an archive (e.g. .zip or .rar file). A ZIP/RAR file may be
recognized by its suffix when these are displayed as default. In this case you must unpack the instal-
lation program so as to be able to start it. Programs for unpacking archives (e.g. ZIP files) are a part
of the operating system.

When using Windows, it may be that the operating system's own unpacking program displays an
empty archive. In this case please use a free of charge additional program (e.g. 7-Zip), to unpack
the ZIP.

Step 4: Installation rights
The installation may under certain circumstances only be possible with local administrator rights. If you
do not possess appropriate rights, please contact your administrator.

Step 5: Licensing the software (chargeable versions only)
1. Free Edition
Some programs are available as a free version. Free of charge versions (Free Edition) do not need a
License file. A suitable License file is included in the installation package.

A free of charge Free Edition cannot be updated with a License file for chargeable program ver-
sions. In this case you must use another installation program.

2. Demo Version
Some programs are available as a free demo version. Free of charge time-limited demo versions also do
not need a License file. A demo License file is included in the installation package. When the time limit

10



Installation | Licensing additional options and add-on modules

for using the demo version has expired, the demo version will automatically be converted to a Free
Edition so that you can continue to edit your documents.

3. Licensed full version
You must unlock the full version either with a License file or a License code that you will have
received from either VIVA or your product dealer. The License file or the License code can be used for
licensing a program on all platforms.

Some programs are already delivered with a temporary, time-limited licence file. To exchange a time
limited License file for a final License file for licensed program versions (i.e Personal Edition or Com-
mercial Edition), please see the section Update License Key.

 • Do NOT try to open the License file with another program (Text Editor, etc.) or in a browser.

 • Store the License file on your computer and note its location so that you have the License file for
a later installation.

Step 6: Hardware protection
Some special Desktop and Server applications are supplied by VIVA with a hardware protection key
(Dongle) as well as the License file. If you have received software with hardware protection (e.g. with
the purchase of server software), attach the hardware key to your computer's USB connection before
you install the software. The VIVA application should recognize the hardware key automatically after
installation, or at least after the computer is rebooted.

Licensing additional options and add-on modules
Various additional options or add-on modules are available for VivaDesigner. When you order these
additional options or add-on modules, you will receive a License code. To activate these additional
options or modules, please see the section Update License Key.
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Installation on Microsoft Windows
Program installation
Step 1: Unpack the installation program
The installation program may be packed in an archive (e.g. ZIP file). A ZIP file may be recognized by
the suffix .zip (see Step 2 Preparing the installation).

Step 2: Start the installation program
Click the installation program (Setup.exe) and choose Run as Administrator in the context menu. If
you are sure that you have administrator rights, you can also start the installation program (Set-
up.exe) with a double click on the program icon.

Step 3: Follow the installation instructions
Follow the instructions of the installation program.

 • By default, all the options are defined so that in most cases you only need to confirm the settings.

 • Use the option Standard or Complete.

 • In most cases you can go back a step if you think that you may have made a mistake.

 • You can cancel the installation at any time and if necessary restart from the beginning.

Step 4: Start the program
Start the program with a double click on the program icon.

 • If you have problems installing the program or starting the program after installation, please
check your user rights. It may be that you do not possess the right to install any software on
your computer. In this case please refer to your administrator.

Step 5: Choose License file/Enter License code
With chargeable licensed versions or after expiry of a time limited program version, the program will
ask for a License file or a License code at the start.

1. If you have received a License file, choose the appropriate License file with the suffix .vlk (see the
section Preparing the Installation).

2. If you have received a License code, enter the License code in the dialog (see the section Preparing
the Installation).

 • For Windows users, it may be that the installation program refuses the License file, although the
installation was carried out as an administrator. In this case it sometimes helps to reboot the
program several times. Alternatively, you can rename the License file as viva.vlk and replace the
existing file »viva.vlk« in the Resources sub-folder of your program folder. With server versions
you should always follow this procedure.

 • To exchange a time limited License file for an unlimited License file for licensed program ver-
sions (Personal Edition or Commercial Edition), please see the section Update License Key.

 • A free of charge Free Edition can NOT be updated with a License file for chargeable program
versions. In this case you must use a different installer.
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Uninstalling or deleting the program
On Windows you can uninstall with the operating system.

Uninstall with the operating system
• In the Windows Start menu, choose the Control Panel for Software or Programs.

• Select the program to be removed and follow the instructions.
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Installation on Mac OS X
Program Installation
Step 1: Unpack the installation program
Double-click the file icon with the suffix .dmg. The operating system will unpack the file and display
it as a disk drive on the Desktop.

Step 2: Copy the program
Double-click the disk drive icon. You can start the program directly with a double click on the icon.
We do however recommend that you move the program icon to the Applications folder. You can also
use a folder of your choice (e.g. Desktop).

Step 3: Start the program
Start the program with a double click on the program icon.

If you have problems installing the program or starting the program after installation, please check
your user rights. It may be that you do not possess the right to install software on your computer.
In this case please refer to your administrator.

If Mac OS gives a hint that only applications from the Apple App Store can be launched, choose
System Preferences > Security & Privacy > Allow Apps downloaded from > App Store and identified
developers under Mac OS.

Step 4: Choose License file/Enter License code
With chargeable licensed versions or after expiry of a time limited program version, the program asks
for a License file or a License code at the start.

1. If you have received a License file, select the appropriate License file with the suffix .vlk
(see the section Preparing the Installation).

2. If you have received a License code, enter the License code in the dialog (see the section Preparing
the Installation).

Update an installed program version
To update an existing program version on Mac OS X, you should always replace the complete pro-
gram folder.

If you are using a licensed version, you may need to select or update your License file or enter a
License code. If so, please refer to the section Update License Key.

Uninstalling/Deleting the program
On Mac OS X you can remove the program by simply deleting the program folder. Afterwards you
must always empty the Trash.

Please also delete the following additional files (if available):

Deleting on Mac OS X (10.6 or newer)
- Start the program Terminal, which is in the Dock or in Utilities.

- Open the folder /private/var/db/receipts (cd /private/var/db/receipts).

- Delete the files viva....bom and viva...plist with the command sudo rm.
(e.g. sudo rm com.viva.designer.bom and sudo rm com.viva.designer.plist)
Your user password will be required to delete these files.
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Installation on Linux
The program is available under Linux as a so-called “AppImage” version. AppImage is an Add-on
module for Linux, which simplifies the use of programs on Linux operating systems. It can be down-
loaded free of charge from https://appimage.org. With the help of AppImage the program runs on
almost all Linux distributions, because there are no dependencies on libraries of the operating sys-
tem. AppImage is installed by default on many Linux distributions, but is not a mandatory require-
ment to use the program. Nevertheless we recommend the installation of the additional module, so
that you can, for example, also start the program by double-clicking on the document icon. If the
additional module “AppImage” is installed on your computer you can skip Step 1.

Step 1: Preparation

1. Click on the AppImage file and choose Properties from the context menu.

2. -In the Access Rights tab, select Run the file as a program (Ubuntu) or Allow the file to run as a
program (Mint) and close the dialog.

The names of the options listed here correspond to those in the “Ubuntu” or “Mint” operating sys-
tem. In other operating systems, these options may have different names or be in different dialogs.
When using other distributions and/or versions, make sure that a file with the extension “.appi-
mage” can be executed as a program.

Step 2: Start the program
Start the program by double-clicking on the AppImage file.

If an error message appears, go back to Step 1.

Step 3: Choose License file/Enter License code
With chargeable licensed versions or after expiry of a time limited program version, the program asks
for a License file or a License code at the start.

1. If you have received a License file, choose the appropriate License file with the suffix .vlk (see the sec-
tion Preparing the Installation).

2. If you have received a License code, enter the License code in the dialog (see the section Preparing
the Installation).
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Program start (emergency mode)
When the program is started, the program loads a number of additional files. If these additional files
are defective or incompatible, the program may crash when started. In such cases, you can start the
program in Emergency Mode to solve the problem. To do this, proceed as follows:

1. Hold down the Shift key.

2. Start the program by double-clicking on the program icon.

3. Instead of the program, the Emergency Mode dialog opens. As the program language is not yet
known when the program is started, the options appear in English. Choose one of the following
options:

• Reset Preferences — This option skips loading the Preferences file. Choose this option if you
think that a defective preferences file could be the cause of the program crash. For example,
the Preferences file stores all the settings from the options in the Preferences. If you choose this
option and the program is subsequently started without errors, a new Preferences file is created
after you quit the program. All settings of the old defective file cannot be taken over.

• Reset Font Cache — This option skips loading the font cache that the program has created based
on the available fonts. Choose this option if you think that a defective font cache could be the
cause of the program crash or if not all fonts are displayed despite a correct program start. In
this case, all available fonts are reloaded after the program start and a new font cache is cre-
ated.

• Ignore Addins — This option skips the loading of AddIns. Choose this option if you think that a
defective or incompatible AddIn module could be the cause of the program crash. If you
choose this option and the program subsequently starts without errors, you must remove the
modules in the AddIns folder step by step if you do not know directly which AddIn module is
responsible.

• Reset Dialog Geometries — This option deletes all information about the position of the dia-
logues on the screen. Choose this option if you have been working with several screens that are
now no longer available. For example, if you have always opened the Open dialog on a second
monitor that is now unavailable, the dialog may no longer be displayed. This is because the
program is trying to display the dialog on this second monitor.

4. Confirm your entry. If you do not choose any option or click Cancel, all defaults are retained.

16



Installation | Update License Key

Update License Key
A license update is necessary when

• after placing your order you have received an email with the download links for the program
and also a License file or License code, or

• you want to exchange a temporary license with a final one after paying the invoice, or

• the License file supplied with the program has expired, or

• you have installed additional options or modules and/or want to activate existing modules.

For the update, you need a License file or a License code (see the section Preparing the Installation).

Step 1: Start the program
Start the program. If the program cannot be started due to the expiry of the License file, the dialog
for updating the license will open automatically. Continue with Step 3.

Step 2: Update License
Choose Help > Update License Key.

Step 3: Follow the instructions
Follow the instructions in the program.

It may be that the installation program refuses the License file, although the installation was car-
ried out as an administrator. In this case it sometimes helps to reboot the program several times.
Alternatively, you can rename the License file as viva.vlk and place it in the folder Resources of your
program folder and replace the existing file viva.vlk.
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Install third-party dictionaries
Depending on the program version, the software comes with a module for spell checking and hyphena-
tion for different languages. If you have installed modules of other manufacturers for hyphenation, they
can be selected for each individual language in the preferences.

For example, you can use the Hunspell spell checker and hyphenation used in programs like LibreOffice,
Mozilla Firefox or Mozilla Thunderbird (http://hunspell.github.io/).

Under Linux (AppImage) it is currently not possible to install third-party dictionaries.

Install Hunspell spell checker

1. Quit the program.

2. Look for Hunspell dictionaries in the Internet.
(e.g. https://cgit.freedesktop.org/libreoffice/dictionaries/tree/)

3. Download the spell checker file. The file name starts with a country code and ends with “.dic” (e.g.
“cs_CZ.dic”).

4. Download the appropriate additional file with the extension .aff (e.g. “cs_CZ.aff”).

5. Copy the files to the folder Dictionaries/hunspell in the program folder.

6. Start the program.

7. Choose Edit > Preferences > Language > Spelling & Hyphenation (Windows/Linux) or [Application
Name] > Preferences > Language > Spelling & Hyphenation (Mac) to let the module choose the appro-
priate language. If there is only one module for the language, it is automatically displayed. If the
module is not displayed, the module was not loaded. In this case, please check all previous steps.

Install Hunspell Hyphenation

1. Quit the program.

2. Look for Hunspell dictionaries in the Internet.
(e.g. https://cgit.freedesktop.org/libreoffice/dictionaries/tree/)

3. Download the hyphenation file. The file name starts with hyph and ends with .dic (e.g.
“hyph_cs_CZ.dic”).

4. Copy the files to the folder Dictionaries/libhnj in the program folder.

5. Start the program.

6. Choose Edit > Preferences > Language > Spelling & Hyphenation (Windows/Linux) or [Application
Name] > Preferences > Language > Spelling & Hyphenation (Mac) to let the module choose the appro-
priate language. If there is only one module for the language, it is automatically displayed. If the
module is not displayed, the module was not loaded. In this case, please check all previous steps.
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Automated Installation (for System Administrators only)
As an administrator you can carry out an automated installation, or share the program. Particularly on
Windows, there are many programs for an automated installation. As an administrator there are a few
aspects to which particular attention should be paid.

Preferences file

In this Preferences file are contained all of the settings that can be entered in the program's
Preferences dialog. If users need certain predefined settings, you will need this file for the automated
installation. This is particularly true if you need special program settings. The Preferences file is not
part of the installation, but is saved when the program quits for the first time, and is updated when fur-
ther changes are made. The Preferences file contains both preferences for the program and preferences
for documents.

To create a Preferences file for automatic installation, please proceed with the following steps:

Create Preferences file:

1. Install the program on a reference computer according to the installation instructions.

2. Start the program.

3. Choose Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences (Mac).

4. Set all the program and document preferences you require.

5. Quit the program.

6. Open the folder in which the program has saved the Preferences file. The paths are as follows:

Windows 7/8/10:

C:\User\[User Name]\AppData\Roaming\Viva\[VIVA Programname]\Build Number\Application.prefs

Mac OS X:

Users/[User Name]/Library/Preferences/Viva/[VIVA Programname]/Build Number/Application.prefs

Linux:

/home/[User Name]/.Viva/[VIVA Programname]/Build Number/Application.prefs

Please note that some folders may be hidden and are displayed gray in the example.
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Windows Registry

For technical reasons, NOT all program preferences are saved in the Preferences file. The Proxy Set-
tings for example are saved in the Windows Registry, so that the VivaFileSender can also access this
information. In this case you must extend the Windows Registry.

You must enter the Proxy Settings in KEY_LOCAL_MACHINE/Software/Viva/VivaApp/Proxy. The soft-
ware will then register the fact that at the time of the installation there is, as yet, no user in the sys-
tem. The deciding factor here is the value in SystemScopeStamp as well as the pure Proxy Settings.
The value format is a free choice (date, number or text) but must be UNIQUE.

The software checks the entry in KEY_LOCAL_MACHINE when it is started and enters these settings
automatically in KEY_CURRENT_USER. If the user changes the Proxy Settings, then the new settings
will take effect, as long as the value in the field SystemScopeStamp has not changed. If the value in
the field SystemScopeStamp changes, the Proxy Settings from KEY_CURRENT_USER will be overwritten
automatically with the Proxy Settings in KEY_LOCAL_MACHINE.

License file

If you carry out an automatic installation, you must ensure that there are individual serial numbers
for each computer, which are generally only allowed to be used on one computer. A general License
file for a corporation is only available on request.

In a manual installation the License file is saved to the user folder. The program automatically names
the file viva.vlk.

Paths for the License file in the user folder:
Windows 7/8/10:

C:\Users\[User Name]\AppData\Roaming\Viva\[VIVA Programname]\Build Number\viva.vlk

Mac OS X:

Users/[User Name]/Library/Preferences/Viva/[VIVA Programname]/Build Number/viva.vlk

Linux:

/home/[User Name]/.Viva/[VIVA Programname]/Build Number\viva.vlk

Please note that some folders may be hidden and are displayed gray in the example. You can, how-
ever, also place the License file directly into the program folder if no user has yet been created on the
computer, or if the computer is operated by several users. In this case the License file is just named
viva.vlk, independently of the version number.

Paths for the License file in the program folder:
Windows 7/8/10: C:\Program Files(x86)\[VIVA Programname]\Resources\viva.vlk

Mac OS X: Applications/[VIVA Programname]/Resources/viva.vlk

Linux: opt\viva\Resources\viva.vlk
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VCP file

If you work with service providers who supply you with a communication profile, this communication
profile should also be taken into account with an automated installation. With the help of the com-
munication profile, you can send documents with all fonts and images used to third parties fully
automatically. Please refer to the chapter in the manual entitled Package & Send.

To enable customers in need of support to transfer test files to VIVA, the default communication profile
Viva Support with the file VIVA_Support.vcp is supplied with the program. You can decide for your-
self whether you will remove this communication profile for an automated installation and/or install
other communication profiles supplied by your service provider. The communication profiles always
have the suffix .vcp and must be placed in the folder Resources/Services of the program folder.
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User Interface
For creating and editing documents, the program provides a variety of functions/
options that are available through document windows, menus, dialogs, and pal-
ettes. These elements are called “user interface”. This section explains the basics of
document windows, dialogs, palettes, and their options.

The Document Window
Documents are displayed in windows. The basic procedure for customizing windows is the same for
all documents. You can move document windows and resize them according to your needs.

On Windows/Linux, all document windows are displayed within a program window. In Mac OS X,
each document window can be displayed as a separate window.

When the Tabbed Document View (Preferences) is turned on, the document name is displayed in the
tab. When the Tabbed Document View is turned off, the document name is displayed in the title bar
of the program window (Windows/Linux) or in the title bar of the document window (Mac).

An asterisk after the document name indicates that the document has been modified and not yet
saved.

Use the Scroll Bar and Scroll Box to navigate very quickly within the document. The Scroll Bar is the
area over which the Scroll Box is dragged. The size of the vertical Scroll Box in the document window
is determined mainly by the number of pages and represents the ratio between the size of the crop
and the total height of the document. Therefore, the vertical Scroll Box in the document window hides
when all pages of the document are displayed vertically in the window. The size of the horizontal Scroll
Box in the document window is determined mainly by the width of all the pages of a sheet and the
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workspaces to the right and left of the document pages. Therefore, the horizontal Scroll Box in the
document window disappears when the section displays all the pages of an arc and the workspaces.

Move document window
• Click on the title bar of the program window (Windows/Linux) or the document window (Mac)

and drag the window to the desired position while holding down the mouse button.

Change the size of the document window
• Position the mouse on the edge or corner of the program window (Windows/Linux) or docu-

ment window (Mac) until an arrow pointer appears. With the mouse button pressed, drag the
window to the desired size.

• Click “Maximize” in the title bar of the program window (Windows/Linux) or document window
(Mac) to automatically adjust the document window to the size of the screen.

• Click “Minimize” in the title bar of the program window (Windows/Linux) or document window
(Mac) to hide the document window and make it disappear in the system tray (Windows/Linux)
or dock (Mac).

If Tabbed Document View is turned on in Preferences, the resizing options above apply to all open
documents. When the tab view is off, document windows can be resized individually.

Menus
We distinguish between program menus and context menus.

• Program menus are displayed in the program window (Windows/Linux) or at the top of the
screen (Mac).

• Context menus are displayed in the document window depending on the edit mode when the
secondary mouse button is held down.

The program has permanent program menus (e.g. File, Edit, etc.) that are available at all times, as
well as context sensitive program menus (e.g., Object, Text, etc.) that are displayed depending on
the editing mode.

In menus, groups of thematically related options are separated by a line.

In addition to some menu options, corresponding keyboard shortcuts are shown. This means that you
can select the option both via the menu and via the shortcut. The program has even more shortcuts in
addition to the keyboard shortcuts in the menu.

Menu options ending in three dots open a dialog box in which you can make additional settings.
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Menu options that are grayed may not be selected as long as their criteria are not met.

Commands followed by an arrow open up further submenus. To enter into the submenu, select the
option in the main menu and then drag the mouse to the desired option in the submenu.

A Checkmark in front of a menu option indicates that this option is activated. In order to switch off
the option, the menu option has to be selected again or a different menu option has to be selected
(e.g, the option Edit > Program Language).

Menus can also be individually extended to include scripts. Please refer to the section Working with
Scripts.

Dialogs & Palettes
To use different options individually or simultaneously, the program has includes dialogs and pal-
ettes. Dialogs and palettes differ as follows:

• With open palettes, you can always perform actions in the document window. With open dia-
logs, you can not perform any actions in the document window as long as you have not closed
the dialog.

• Palettes can be freely positioned, stacked and grouped. In many cases, dialogs can only be
freely positioned.

• The palettes are only applicable when a document is open. Dialogs can also be opened if no
document is open.

Dialog Construction and Behavior

We differentiate between program dialogs and the individual program and system dialogs provided
by the operating system. Some program dialogs affect global settings and can be invoked at any
time while others are only applicable when a document is open or when the mouse pointer is in a spe-
cific mode (eg text mode, image mode, etc.).

The dialogs provide information about the current settings. The program opens a dialog after you
have called up a menu item that ends with three dots (...) or pressed an associated key sequence. A
dialog contains various options for input. Dialogs are displayed by default in the middle of the cur-
rent screen. The name of the dialog is displayed in its title bar.

Move dialog window
Program dialogs can be moved frequently depending on the operating system,

• Position the mouse on the title bar and move the dialog while holding down the mouse button.

Change the size of the dialog window
Dialog boxes can be resized in some cases,

• Position the mouse on the title bar and move the dialog while holding down the mouse button.
When it is opened again, the dialog is once more displayed centered.

If dialog box areas are grayed, these functions cannot be selected as long as the conditions for their
selection do not exist.
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Palette Construction and Behavior

After launching the program and opening a document, the palettes are displayed according to the
settings in the Window menu. The position and grouping of the palettes is saved when the program is
properly closed or when the Workspace is saved using the Window menu.

The behavior and options of palettes regarding positioning and resizing may vary in the Web edi-
tion.

To close a palette, click in the close box or on the Window menu, call up the option corresponding to
the corresponding palette.

Positioning palettes
• To position a palette/palette group, click on the title bar and move the palette while holding

down the mouse button. For palettes with tab, you can alternatively click on the tab or the free
space next to the tab.

• Palettes are magnetically attracted when moved from the edge of the screen or from other pal-
ettes at a distance of less than 10 pixels.

• Palettes can be docked at the edge of the document window. This means that the palettes
change their position according to the size and position of the document window. To undock a
palette/palette group from the document window, drag a palette/palette group to the edge of
the document window. As soon as a blue area or blue line appears on the document border,
you can release the mouse button.

• The Tools palette can be docked on all sides of the document window.

• The Navigation and Quick Access palettes can be docked at the top and/or bottom of the docu-
ment window.

• The palettes Tools, Navigation and Quick Access can be arranged next to and/or below each
other at the top or bottom of the document window.

• All other palettes can be docked at all edges of the document window (Windows or Linux only).

• To undock a single palette/palette group from the document window, move the single palette/
palette group using the title bar.

It may not be possible to dock all the palettes on all sides.

Change palette size
• In many cases palettes can be changed in height and width. For palettes grouped on top of

each other, the change in width also affects all other palettes in the group.

• Palettes can be minimized or maximized by double-clicking the tab or the free space next to
the tab.

• Palettes can be minimized or maximized in height and width by clicking on the arrow icon in
the title bar . When minimized, the palette appears as a button with an icon and the name of
the palette. In addition, the width of the palette can be changed and reduced to the size of the
symbol. This also applies if the palettes are grouped.

Group palettes
• Tabbed palettes can be grouped together. This does not apply to the Tools, Navigation, and

Quick Access palettes.

• Any number of groups can be created.
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• A group of palettes can consist of stacked, side by side and individual palettes above one
other.

• Tabbed palettes can be stacked and grouped side by side and above one other.

• A group of palettes has a title bar that positions the entire group.

Stack palettes
• To stack palettes, drag one palette onto the tab of the other palette (target palette). Once the

target palette is blue, you can release the mouse button. This process can be repeated as often
as you like.

• To remove a palette from the stack, click on the tab and move the palette up or down while
holding down the mouse button. Once the palette is displayed with its own title bar, you can
release the mouse button.

• To change the order of the palettes within a stack, click on the tab and move the palette to the
right or left while holding down the mouse button. As soon as the tab appears at the desired
position, you can release the mouse button.

• If a palette within a stack is minimized or maximized by double-clicking the tab or the free
space next to the tab, all other palettes in the stack will be minimized or maximized.

Group palettes next to/above one another
• To group palettes side by side, drag one palette to the left or right edge (2) of the other palette

(target palette). As soon as a blue line appears in the target palette or the output palette is
barely visible, you can release the mouse button. This process can be repeated as often as you
like.

• To group palettes one above the other, drag a palette to the area between the tab of the title
bar or the bottom border of the other palette (target palette). As soon as a blue line appears in
the target palette or the output palette is barely visible, you can release the mouse button. This
process can be repeated as often as you like.

• To change the arrangement of a single palette within a palette group, drag the palette to the
desired horizontal or vertical position.

• To remove a palette from the group, click on the tab and move the palette up or down while
holding down the mouse button. Once the palette is displayed with its own title bar, you can
release the mouse button.

• Multiple palette groups, like individual palettes, can also be grouped into a palette group.

Save workspace
• The location and arrangement of the palettes is called a Workspace and is automatically

backed up when the program is quit properly.

• The workspace can be backed up at any time by choosing Window > Workspace > Save.

• The workspace can be saved under a special name by choosing Window > Workspace > Save As.
With this option you can save any number of workspaces.

• Select Window > Workspace to select a workspace.

• Select Window > Workspace > Delete to delete a saved workspace. The current arrangement on
the screen is not changed.
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Options in dialogs and palettes

Tabs
To increase clarity, tabs are used in some dialogs and palettes. Click the name of the tab to display
the tab options

Command areas
To increase clarity, command areas are used in some dialogs and palettes. In a command area, repre-
sented by a frame with an optional title, several options are summarized thematically.

Values for entry fields
Entry fields allow a numeric and/or alphanumeric input. Select the content of the input field and
overwrite the contents with your entries. Click in the field and delete the desired entry. Complete the
entry with the Return or the Tab key to jump to the next entry field.

Some entry fields have a popup menu from which predefined options can be selected. Click in the
field and select an option from the popup menu.

Some entry fields have spinner arrow symbols in a number selection field. Click in the field and click
the arrows to increase or decrease the value. Alternatively, you can use the scroll wheel on the mouse
to increase or decrease the value. The change is made in each case by one unit of measurement (one
degree, one millimeter, etc.).

Delete values in entry fields
You can not completely clear the value in most palette entry fields because the field or option always
expects a value. The field may therefore not be empty at any time, regardless of whether you have
confirmed the entry. In this case, you must select the entire value and then replace it with your entry.

If you delete the value in dialogs, the option will not be applied.

Display values in entry fields
If a single element (for example, an object or a character in the text) is selected, the displayed value
refers to that element.

If multiple elements are selected, the displayed value refers to all selected elements. If the entry field
is empty, the elements have different values. If you enter a value in this case, all the elements receive
the same value.

Some entry fields can only be selected if another option was previously selected.

Measurement units in entry fields
In all entry fields in which absolute units of measurement can be entered, the program supports the
following units: Point Pica (abbreviated to “pt”), Point Didot (abbreviated to “dd”), Millimeters
(abbreviated to “mm”), Centimeters (abbreviated with “cm”), Inches (abbreviated to in or "), Deci-
mal Inches (abbreviated to “dz”), Cicero (abbreviated to “c”), Quart (abbreviated to “q”), and
Degrees (abbreviated to “°”)

With the exception of the entry fields that require values in degrees, absolute dimensions can be
predefined using the option Edit > Preferences > Measurements (Windows/Linux) or {Application
name} > Preferences > Measurements (Mac).
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In all entry fields in which relative units of measurement can be entered, the program supports the
units: Percent (abbreviated to “%”) and Em (abbreviated to “g”).

When you are typing, it does not matter whether you enter these abbreviations in high or low case.

Calculations in entry fields
Calculations can be made in all entry fields. The program supports the basic operations Addition
(abbreviated to “+”), Subtraction (abbreviated to “-”), Multiplication (abbreviated to “*”), Division
(abbreviated to “/”) and Exponentiation (abbreviated to “^”).

All calculations can be combined with any measurement units. However, this possibility of combina-
tion refers only to values of the same type. Thus absolute values can only be calculated with absolute
values (e.g. “30 mm + 10 pt”) and relative values only with relative values (e.g. 120% - 30%). In addi-
tion, all bracket levels are supported.

Therefore the following entries are no problem:

• 200 + (34 - 12*3) + (4*5)

• (5 * 3mm) + (2c - 7dd)

• 7mm * (5pt / 3pt)

For multiplications and divisions, only one operand may have a measurement unit. Thus the follow-
ing entries are invalid:

• (34mm - 12" * 3dd) + (4pt * 5c)

• (5" * 3mm) + (2" * 5,7pt)

In addition to bracketed expressions, fractions can also be entered. Here are a few examples:

• 4/15mm (corresponds to 0,266 millimeters)

• 2/5" (corresponds to 0,4 inches)

If a palette contains several entry fields, they can be selected with the Tab key if the mouse has been
clicked inside one of the entry fields.

Checkboxes
Checkboxes indicate whether or not a command will be executed.

• Click on the checkbox to turn the option on. For checking purposes, a checkmark is displayed in
the checkbox.

• Click on the checkbox to turn the option on. For checking purposes, an empty checkbox is dis-
played.

The checkbox is displayed with a black rectangle if the selected elements have different values. If no
change is made, the different values of the elements are retained even if other options are changed in
the same dialog/palette.

Radio Buttons
Radio buttons determine which one of several possible commands is executed. Only one command
from a number of options may be applied.

• Click a radio button to turn it on. For checking purposes, a circle is displayed in the button.

Selecting another option automatically disables previously selected options.
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Popup Menus
Popup menus display a list of options, of which only one option can be selected. Then the menu
closes and the selected option is displayed and applied.

Some popup menus are available only when another selection is made in advance or when a control
box is activated.

Some popup menus include options such as Any or None. These options cause the current settings not to
be changed or removed.

To avoid making changes to an open popup menu, move the mouse outside the menu and release the
mouse button.

Lists
Lists show a list of options, one or more of which may be selected. Unlike the pop-up menu, the list
does not close after selecting an option. In some lists you can navigate using arrow keys and/or
scrollbars. (Example: Edit > Preferences > Embedded Fonts (Windows/Linux) or {Application name} >
Preferences > Embedded Fonts (Mac).

Scroll boxes
You can navigate very quickly within a dialog or a palette using Scroll Bars and Scroll Boxes. The
Scroll Bar is the area over which the Scroll Box is dragged.

Buttons
Buttons determine which action should be taken. One possible option is to accept settings (often
referred to as OK) or discard the inheritance of settings (often referred to as Cancel). However, but-
tons can also be represented as icons or represent any other actions. Buttons can be recognized by
the fact that they change their color slightly if you move the mouse pointer over the surface.

Program Palettes

The use and options of the program palettes are described in detail in the sections listed. Depending
on the program edition, program version number and access rights, there may be more or fewer pro-
gram palettes available. For the program editions, please note the information on the website. For
access rights, please refer to the section Preferences or Working with Access Rights.

Tools — Allows the creation and editing of objects. Please refer to the section Working with Objects.

Navigation — Allows quick selection of document pages and Alias pages as well as the selection of a
magnification factor using tools and input fields. Please refer to the section Working with Docu-
ments.

Quick Access — Allows quick selection of the most important options for objects, paths, text and
images. This palette represents a selection of the options that are also provided in the Module palette.
Please refer to the sections that also describe the Module palette.

Module — Serves as a general term for all module oriented palettes. The functions Object mode, Text
mode, possibly Table mode and Picture mode are considered as modules. Therefore, the Object mode
(default) includes an Object palette, the Text mode a Text palette, the Table mode a Table palette and
the Picture mode a Picture palette . The palette title Module remains unchanged when the mode
changes.
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- Object — Allows quick definition of object coordinates and attributes. Please refer to the section
Working with Objects.

- Text — Allows quick definition of text attributes for the current text string or Story. The palette
consists of the tabs Story, Chapter, Layout, Paragraph and Character with individual attributes.
The use and options of the palette are described in detail in the chapter Working with Text.

- Table — Allows quick definition of attributes for a table object and is divided into attributes for
the Table, Columns and Rows, Cells, Separators and Content. Please refer to the section Working
with Tables.

- Picture — Allows quick definition of attributes for a selected image. Please refer to the section
Working with Pictures.

Pages — Allows quick selection of document pages, assign Alias pages to document pages and move
or delete individual pages. Please refer to the section Working with Pages.

Style Sheets — Allows quick assignment of predefined style sheets to texts, objects, images and
tables. Please refer to the section Working with Style Sheets.

Layers — Allows quick selection of layers and objects as well as their order and visibility. Please refer
to the section Working with Layers.

Pictures — Allows quick image import via Drag & Drop as well as an overview of all used images.
Please refer to the section Working with Pictures.

Search & Replace — Allows you to search and replace text and/or text attributes. Please refer to the
section Working with Text.

Spell and Grammar Check — Allows the checking of the spelling and grammar in a text. Please refer to
the section Working with Text.

Change Tracking — Allows you to make changes and accept or reject these changes quickly. Please
refer to the section Working with Text.

Notes— Allows quick navigation through notes as well as the creation of new notes and also the modi-
fication of existing notes. Please refer to the section Working with Text.

Colors — Allows quick assignment of defined colors to objects, paths, text and tables, and of color
gradients to objects, paths, and tables. Please refer to the section Working with Colors.

Trapping — Determines the behavior of individual objects when printing in color. Please refer to the
section Working with Colors.

Character Map — Allows searching and inserting characters from the font selected. The option is simi-
lar to the feature available in your operating system, but is functionally more flexible. Please refer to
the section The Character Map.

OpenType — Allows quick selection and replacement of alternate characters. Please refer to the sec-
tion Working with Text.

Assignments — Allows the management of assignments/tasks. Please refer to the section Working in a
Team.
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Character Inspector — Allows the individual positioning of individual characters and the arrangement
of individual characters in connection with “diacritical marks” such as “accents”. The modification of
these so-called “Glyphs” is helpful in both Roman and especially Arabic texts. Please refer to the sec-
tion Working with Text.

Character Map — Allows a quick review of fonts and the available character set. Please refer to the
section The Character Map.

Scripts — Allows the running and management of scripts. Please refer to the section Working with
Scripts.

Book - Allows the compilation of a a book based on different documents. Please refer to the instruc-
tions in the section Working with Books.

Text Formatting Inspector - Allows you to find different formats. Please refer to the instructions in the
section Working with Typography.

Errors, Warnings and Queries
In addition to the standard dialogs and palettes, the program provides error boxes, alert boxes and
query boxes.

Errors — Appear when a command cannot be fulfilled for a specific reason.

Warnings — Appear when a command could lead to a result that the user under certain circumstances
does not want. The user has the option of continuing the potentially dangerous action or canceling.

Queries — Appear if there are several way of executing a command. The user must then decide how
the program should act.

33





Working with Documents

Version 10 — Wednesday, January 5, 2022



Working with Documents | Introduction

Working with Documents

Introduction

All layout work is carried out by the program in documents. Therefore, after the
application has started, you will always create a new document, or open an existing
document. This section describes how the application interacts with documents and
their options.

Open Document
Existing documents can be opened in various ways:

• With the program dialog Open.

• With the operating system dialog Open.

• With a double click on the document icon.

• By Drag and Drop.

• With the option Revert to Saved.

• With the option Open Backup Copy.

Regardless of which option you use to open a document, for larger documents the program will dis-
play a progress bar showing the current status of the option.

Whether the program dialog Open or the system dialog Open is displayed by default can be set using
the Preferences. Please refer to the section Preferences.

Open Document with the program dialog

1. Choose one of the following options:

• Press Ctrl + O (Windows/Linux) or Command + O (Mac).

• Choose File > Open.
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2. Optionally choose one of the following options to determine the document path:

• In the Search in option, enter a document path or select a recently used document path from
the pop-up menu.

• Click Forward or Back to view the contents of one of the most recently used document paths.

• Click Up to view the contents of the parent folder.

• Double-click a drive or folder in the list to view the contents of the drive or folder.

• In the Favorites tab, click the Computer to view all physical drives on the computer and all vir-
tual drives. The display of the drives can be expanded or restricted by using the Preferences.
Please refer to the section Preferences.

• In the Favorites tab, click User Folder to display all documents of the selected File Type and all
folders in the user folder.

• In the Favorites tab, click Desktop to display all documents of the selected File Type and all
folders on the computer desktop.

• In the Favorites tab, click Sample Documents to display all the templates of the selected file
type and all folders. This option requires an Internet connection.

• IIn the Favorites tab, click VivaCloud to display all documents of the selected File Type and all
folders. This option requires an Internet connection and registration in the VivaCloud.

3. Optionally choose one of the following options to define the document view:

• Click Details, List, Thumbnail, Large Icons or Film Strip to specify the appearance of the docu-
ments.

• In the Details or List view, click a column header to specify the sorting of the documents.

• In the Thumbnail, Large Icons or Film Strip view, click Small or Large or use the slider to set the
size of the document preview.

4. Optionally choose one of the following options to define the dialog view:
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• Click the separator between list and the Favorites tab. With the mouse button held down, move
the mouse to the right or left. When you move the mouse all the way to the left, the entire
Favorites tab disappears.

• In the Favorites tab, click the separator between the list and the Preview. Move the mouse up or
down while holding down the mouse button. When you move the mouse all the way up, the list
of Favorites disappears.

• In the Favorites tab, click the separator between Preview and Metadata. Move the mouse up or
down while holding down the mouse button. When you drag the mouse all the way down, the
list of metadata disappears.

5. By default, the File Type pop-up menu is set to the native documents option for each program.
There may be more file types available. If you choose a different file type, please refer to the corre-
sponding notes in the section Import/Export.

6. Choose a document from the list. Optionally click Next or Previous to view the document pages in
the Preview dialog box. These options are only available if the document has been saved with a
corresponding preview. Please refer to the section Preferences.

7. Optionally click OS Dialog to display the operating system dialog for opening documents. Please
refer to the Preferences section.

8. Click Open or double-click the document in the list.

The program saves the last selected document path while running and after the program has been
properly closed. It is irrelevant whether a document has been opened or not. If a previously
selected document path is no longer available, this can lead to a considerable delay in the display
of the dialog. This may be the case, for example, when a drive is no longer connected or the Inter-
net connection to an Internet drive is interrupted. In such cases, the program tries to connect to
the appropriate document path, which may take a while. This operation will be canceled after a
while.

Open Document with the operating system dialog

1. Choose one of the following options:

• Press Ctrl + O (Windows/Linux) or Command + O (Mac).

• Choose File > Open.

2. If the operating system dialog is not displayed directly, click OS Dialog. Please observe the
instructions in the Preferences section.

3. By default, the File Type pop-up menu is set to the native documents option for each program.
There may be more file types available. If you choose a different file type, please refer to the corre-
sponding notes in the section Import/Export.

4. Optionally define the document path with options provided by the respective operating system in
the dialog.

5. Optionally define the document view with options provided by the respective operating
system in the dialog.

6. Click Open or double-click the document in the list.

The operating system dialog does not display any favorites and does not allow you to open docu-
ments or files from virtual drives, such as the VivaCloud.
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Open Document with a double click

1. Choose a document in the operating system that corresponds to the program’s native file type.

2. Double click the document

The document is automatically opened in the program responsible for the native file type. If the pro-
gram has not been started yet, it will be started automatically and then the document will be
opened.

If you do not select a native document, either nothing happens or the operating system asks which
program it should open. Alternatively, it may be that the operating system automatically launches
another program that can open the document with this file type.

If you have several versions of the program installed on the computer, make sure that the correct
version of the program is started in this case. If this is not the case, you must start the required
program version manually.

If you have deleted an old version of the program on MacOS X, you should for safety’s sake also
empty the recycle bin, as otherwise the old program version may be launched (unnoticed)from the
recycle bin.

Open Document by Drag & Drop

1. Choose a document in the operating system that corresponds to the program’s native file type.

2. Choose one of the following options:

• While holding down the mouse button, drag the document to the program icon in a folder.

• While holding down the mouse button, drag the document to the program tray icon (Windows)
or Dock (Mac). Depending on the operating system, it may be necessary for the program to be
already running.

• While holding down the mouse button, drag the document to the program window. On Mac OS
systems, this is only possible if the option Tabbed Document View is selected in the Preferences.

3. Release the mouse button.

If you select a document whose file type is not supported by the program, nothing happens.

If you select a document whose file type is supported by the program but does not conform to the
native format (for example, IDML, etc.), please refer to the section Import/Export.

If you choose a document whose file type is supported by the program in different ways, it may
make a difference whether you drag the document onto the program window or the document
window (for example, PDF documents).

Open last saved version of a document

1. Choose one of the following options:

• Choose File > Revert to Saved.

• Press Ctrl + Alt + Shift + Z (Windows/Linux) or Command + Option + Shift + Z (Mac).

2. Choose one of the following options:

• Click Yes to discard all changes and open the most recently saved version.

• Click No to cancel the option.
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Opening automatic backup copies
The program is designed to prevent documents from being destroyed when backing them up, should
the program crash while saving or the power fail, for example. However, when backing up docu-
ments, errors may occur that can result in documents not being able to be opened afterwards. This
error may not be noticed by the user, because there is no error message and the document can be
processed normally in the opened state. The most common reason for backup failures is bad sectors
on the disk that are not noticed by the operating system. Therefore usually no error message appears.
Nevertheless, the documents in these cases are often irretrievably damaged.

To avoid this, you should create manual backup copies regularly and save these on other drives or
data media. If you extend the document name with a date or version number in the file name, you
can create as many copies as you like. You can achieve similar security with the option Create backup
copy when saving in the Preferences. If this option is selected, the program creates a backup each
time the document is backed up. The option costs no additional time but only storage space. Please
observe the instructions in the section Preferences.

Open backup copy automatically

1. The program automatically displays a selection of backup copies if it detects when opening that
the selected document is defective and can not be opened.

2. Choose a backup copy in the popup menu.

3. Confirm the entry.

Open backup copy manually

1. Choose a backup copy of the currently open document manually if you want to return to an older
version of the document.

2. Choose File > Open Backup.

3. Choose a backup copy.

In all cases the following rules apply:

• The backup copies created automatically are sorted by date and time.

• Backup copies are only created after the second time a document is saved. It does not matter
whether the backup is done manually or via the Background Save option in the Preferences.
Please refer to the section Preferences.

• If no automatically created backup copy is displayed for the current document, either no
backup copy is available or existing backup copies may have been deleted due to lack of
memory on the data medium. The number of available backup copies is based on the regular
backups, as well as the options for the maximum number of backup copies and the maximum
storage space selected in the Preferences. Please refer to the section Preferences.

• After selecting an automatically created backup copy, no backup copies are initially displayed
for the document. If you now save the selected backup copy, you can decide whether you want
to replace the previous document or save the backup copy under a different name. If you
replace the document, this version of the document becomes the current version. If you save
the document under a different name, all backup copies of the original document are retained.

• Backup copies created automatically can not prevent the problem of defective documents.
However, they often prevent a total loss if you can access older versions of the document.
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• Backup copies created automatically are not a complete replacement for manual backup cop-
ies. Therefore, regularly make backup copies on other data media.

Closing Documents
Documents can be closed in a number of different ways.

Close document
Choose one of the following options:

• Click the close symbol at the right of the document window or the tab.

• Press Ctrl + W (Windows/Linux) or Command + W (Mac).

• Choose File > Close.

If you made any changes since you last saved the document a dialog box will appear prompting you
to save the document or cancel the option.

Creating new documents
When you create a new document, you define the page size, the number of pages, and an optional
layout.

Create a new document

1. Choose one of the following options:

• Press Ctrl + N (Windows/Linux) or Command + N (Mac).

• Choose File > New or File > New > Document.

Once you have chosen the option the Document Setup dialog will open. On the left side of the dialog,
you can make all the settings that are displayed proportionally on the right side in the Page Preview
section.

2. Choose one of the following options in the Pages tab:

• Standard — List of predefined page formats. The dimensions of the standard sheet formats are
displayed in the input fields for your own custom formats after the pop-up menu has been
selected, and these can then also be edited if you select the option Custom.

• Custom — Definition of an individual page format. Enter the page size in the Width (W) and
Height (H) fields.

• Choose the Portrait or Landscape option from the popup menu Orientation. If you have chosen
a custom format, this setting should always be Portrait.

3. Page Type — Determines the layout of the document pages, as well as the page type of the first
Alias page. These settings can not be changed later.

• Single Page — The document pages are displayed one below the other and can not be arranged
side by side

• Facing Pages — The document pages are displayed side by side as facing pages and several
pages can also be arranged side by side.
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• Page Order — Determines the layout of the pages in the Facing Pages option and the writing
direction for text objects with multiple columns.

• Left/Right — Even pages are displayed on the left and odd pages on the right. The reading
direction for multi-column text objects is from left to right (for example for Roman texts).

• Right/Left — Even pages are shown on the right and odd pages on the left. The reading direc-
tion for multicolumn text objects is from right to left (eg for Arabic texts).

4. Automatic Text Object — Determines whether a text object should be created on the first Alias page
or on the first document page. This option is useful if you want to create a document that automatic-
ally links all the text objects on the document pages (for example, for books).

5. Grid — Determines whether a grid of Guide objects should be created on the first Alias page or on
the first document page. These guide objects are magnetic by default.

6. Top, Bottom, Left and Right or respectively Inner and Outer — Define the distance between the
Automatic Text Object and/or the Grid and the edges of the page for both single and facing pages.
The options are not selectable unless at least the options Automatic Text Object and/or Grid are
selected.

7. Page Layout — Defines the area of the page on which the text should appear. This includes the
actual body text as well as any headers and footers, margins or comments. If a page layout for
Facing Pages is to be generated, the type area can be mirrored automatically.

8. Columns — Number of columns for the Automatic Text Object and/or the Grid.

9. Gutter — Distance between the columns for the Automatic Text Object and/or the Grid.

10. Top, Bottom, Left and Right or Inner and Outer — Defines a magnetic frame around the outsides of
the document pages. The area between the frame and the side edge is called bleed. This option is
useful to compensate for tolerances when cropping the page after printing.

11. Number — Number of document pages that will be created automatically when the document is
created. The number of document pages can be changed manually at any time. Please refer to the
section Working with Pages.

12. Choose one of the following options in the Header & Footer tab:

• Header — Appearance and height of a header in the automatic text object. This option is useful
if you want to display recurring textual content (such as page numbers, chapter headings,
running titles or other variables) at the head of the automatic text object.

• Footer — Appearance and height of a footer in the automatic text object. This option is useful if
you want to display recurring textual content (such as page numbers, chapter headings, run-
ning titles or other variables) at the foot of the automatic text object.

13. Confirm the entry.

The application will now create a new document and automatically name it Untitled*. Documents cre-
ated subsequently are automatically numbered consecutively to prevent confusion. The asterisk (*) in
the name means that the document has not been saved.

The document name can be assigned or changed at any time through the options Save or Save As.

The page size and orientation of the document can be changed at any time through the option File >
Document Setup.
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Please note the relationship between Alias Pages, the Automatic Text Object and the Grid. Please refer
to the sections Working with Pages and Working with Objects.

Saving Documents
Open documents may be saved in different ways:

• Saving a new document.

• Saving a document under the same or another name.

• Saving a document with a preview of the pages

New documents are automatically named Untitled*. Those which are subsequently created are num-
bered consecutively. New documents are saved by selecting the Save and Save As options from the
File menu or by using the shortcut keys. In either case the application will display the same dialog
box in which you will be able to enter the document name and the location where you want to save
the document.

By default, the document is saved in the native file format of the program. The program often also
supports other format s. Please refer to the section Export.

You can specify in the Document Preferences whether a preview of the first document page or a pre-
view of all the document pages is to be saved with the document.

Existing documents are saved through the option File > Save or by pressing the appropriate shortcut
keys. The application will save the document without prompting you for a document name.

It may happen that you want to save a copy of your document. In this case you may use the option
File > Save As or press the corresponding shortcut keys. This option will save a copy of your current
document under a new document name of your choice. The newly saved document will remain open.

Save a new document

1. Choose one of the following options:

• Press Ctrl + S or Ctrl + Alt + S (Windows/Linux), or Command + S or Command + Option + S (Mac).

• Choose Save or Save As in the File menu .

2. Optionally, choose one of the following options to specify the document path:

• In the Search in option, enter a document path or choose a recently used document path from
the pop-up menu.

• Click Forwards or Back to view the contents of one of the recently used document paths.

• Click Up to view the contents of the parent folder.

• Double-click a drive or folder in the list to view the contents of the drive/folder.

• In the Favorites tab, click Computer to view all physical drives on the computer and all virtual
drives. The drives can be expanded or restricted by using the preferences. Please refer to the
section Preferences.

• In the Favorites tab, click User Folder to display all documents of the selected file type and all
folders in the user folder.

• In the Favorites tab, click Desktop to display all documents of the selected file type and all
folders on the computer desktop.
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• In the Favorites tab, click Sample Documents to display all sample documents of the selected
file type and all folders. This option requires an internet connection.

• In the Favorites tab, click VivaCloud to display all documents of the selected file type and all
folders. This option requires Internet connection and registration in the VivaCloud.

3. Choose one of the following options to define the document view:

• Click Details, List, Thumbnail, Large Icons or Filmstrip to specify the appearance of the docu-
ments.

• In the Details or List view, click a column header to specify the sorting of the documents.

• In the Thumbnail, Large Icons or Filmstrip views, click Small or Large, or use the slider to set the
size of the document preview.

4. Optionally choose one of the following options to define the view of the dialog:

• Click the separator between the list and the Favorites tab. With the mouse button pressed, move
the mouse to the right or left. When you move the mouse all the way to the left, the entire
Favorites tab disappears.

• In the Favorites tab, click the separator between the list and the preview. Move the mouse up or
down while holding down the mouse button. When you move the mouse all the way up, the
Favorites list disappears.

• In the Favorites tab, click the separator between Preview and Metadata. Move the mouse up or
down while holding down the mouse button. When you drag the mouse all the way down, the
list of meta data disappears.

5. By default, the File Type pop-up menu is set to the native document option for each program.
There may be more file types available. If you choose a different file type, please refer to the sec-
tion Import / Export.

6. Optionally, click OS Dialog to display the operating system dialog for opening documents. Please
refer to the section Preferences.

7. Enter the name of the new document.

8. Confirm the entry.

The program saves the last selected document path while the program is running and after the
program is quit. It is irrelevant whether a document has been opened or not. If a previously
selected document path is no longer available, this can lead to a considerable delay in the display
of the dialog. This can be the case, for example, when a drive is no longer connected or the Inter-
net connection to an Internet drive is interrupted. In such cases, the program tries to connect to
the appropriate document path, which may take a while. This operation will be canceled after a
while.

Save a new document with a preview

1. Choose Edit > Preferences (Windows/Linux) or [Application] > Preferences (Mac).

2. Choose Pages & Objects > Pages.

3. Choose Save small preview and/or Save large preview.

4. Choose All Pages or Manual. If you choose Manual, you must set the number of page
previews to be saved.
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5. Confirm the entry.

6. Save the document as described in the section Save new document.

Save document using OS dialog

1. Choose one of the following options:

• Press Ctrl + S (Windows/Linux) or Command + S (Mac).

• Choose File > Save.

2. If the OS dialog is not shown immediately, click OS Dialog. Please refer to the section Preferences.

3. By default, the File Type pop-up menu is set to the native document option for each program. There
may be more file types available. If you choose a different file type, please refer to the section
Import / Export.

4. Optionally define the document path with options provided by the operating system in the dialog.

5. Optionally define the document view with options provided by the operating system in the dialog.

6. Enter the name of the new document.

7. Confirm the entry.

The OS dialog does not display any favorites and does not allow backing up of documents / files
from virtual disks, such the VivaCloud.

Save an existing document
Choose one of the following options:

• Press Ctrl + S (Windows/Linux), or Command + S (Mac).

• Choose File > Save.

Save a document with a different name

1. Choose one of the following options:

• Press Ctrl + Alt + S (Windows/Linux) or Command + Option + S (Mac).

• Choose File > Save As.

2. Save the document as described in the section Save new document.

Document views
After starting the application and the creation of a new document a document window and several
application palettes will appear. These are described in the section User Interface and in following
sections. In this section, we will describe the display of document windows and document views.

Selecting Open documents

Open documents can be selected either interactively or through the menu command.
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To select a document interactively you click a document window or its tab. When you click outside
the document window or program window, you are automatically switched to the Explorer (Win-
dows/Linux) or the Finder (Mac) without quitting the application or closing any documents. To return
to the application it is usually sufficient to click the visible document or program window.

When you are editing several documents at a time it is easy to lose track of a specific document. For
this purpose the application allows you to select a specific document through the Window menu. All
open documents will be shown in the order in which they are opened. The current document will be
shown with a checkmark before its name.

Sort document windows

Document windows can be resized and arranged as you like.

• Stack Windows — All documents will be shown behind each other with a certain distance
between them.

• Tile Windows — Divides the documents as evenly as possible over the program window (Win-
dows/Linux) or the screen (Mac). If for example you have three documents open, one docu-
ment will take half the available space while the other two will share the other half, taking each
a quarter of the total space available.

Arrange Windows Horizontal — The document windows are stretched horizontally to the available
width and displayed above one another in a column. The heights of the windows are calculated
exactly according to the space available.

Arrange Windows Vertical — The document windows are stretched vertically to the vertical space
available, and displayed next to one another in a row. The widths of the windows are calculated
exactly according to the space available.
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Split document window

If the document you are working on has many pages, you may need to refer to different pages for
information while continuing to work on one page. One simple example is a manual with a drawing
or diagram on one page with numbered parts, while the text referring to those parts runs over several
pages.

Instead of constantly switching back and forth between pages, you can split the document window
with the options in the Window menu or in the context menu Window:

Split Document Window Horizontally — Splits the space available into two equal parts next to each
other.

Split Document Window Vertically — Splits the space available into two equal parts above one
another.

Synchronize View — Synchronizes the views of the window splitting so that any change in the view in
one split will automatically be applied to all the others. This option is useful if you are working with a
multilingual document, where each language is on a different layer and you want to see the same
document section for each language.

Please observe the following hints:

• When you have tiled your document window, you can adjust the tiling proportion manually by
moving the mouse pointer over the Window splitter until it changes to the sizing pointer. With
the mouse button held down drag the tiling barrier left/right or up/down to set the required
proportions.

• You can move about the document and scroll between pages in both viewing sections.

• You can apply different zoom factors to the different sections.
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• If you are working in a multi-language document where each language is on a different layer,
you can activate and deactivate the layer views for the different sections as required. Please
refer to the notes in the section Working with Layers.

• You can apply a splitting command to a section (sub-splitting).

• To cancel the splitting, choose Window > Cancel Window Splitting in the menu or in the context
menu.

• To cancel the synchronized view of the window splittings, choose Window > Synchronize View
in the menu or in the context menu.

Choose document zoom/views

Zoom factors/views may be applied in different ways:

• With the options in the Zoom menu.

• With the options in the context menu.

• With the measurement field in the Navigation palette.

• With the Zoom tool in the Navigation palette.

• With the mouse wheel.

• With shortcuts.

The zoom factor is applied to the current document or window splitting. The zoom factor of a docu-
ment will be saved with the document settings and is automatically applied when the document is
reopened.

Choose view with menu options
Choose one of the following options:

• Choose Zoom > Zoom In or press Ctrl + Plus (Windows/Linux) or Command + Plus (Mac) to zoom
in on the document page. The zoom follows in steps of 5%, 25% or 100%.

• Choose Zoom > Zoom Out or press Ctrl + Minus (Windows/Linux) or Command + Minus (Mac) to
zoom out from the document page. The zoom follows in steps of 5%, 25% or 100%.

• Choose Zoom > Original Size in the menu or Original Size in the context menu, or press Ctrl + 1
(Windows/Linux) or Command + 1 (Mac) to display the document pages in 100%.

• Choose Zoom > 50% or press Ctrl + 5 (Windows / Linux) or Command + 5 (Mac) to display the
document pages in 50%.

• Choose Zoom > 75% or press Ctrl + 7 (Windows / Linux) or Command + 7 (Mac) to display the
document pages in 75%.

• Choose Zoom > 200% or press Ctrl + 2 (Windows / Linux) or Command + 2 (Mac) to display the
document pages in 200%.

• Choose Zoom > 400% or press Ctrl + 4 (Windows/Linux) or Command + 4 (Mac) to display the
document pages in 400%.

• Choose Zoom > 1000% to display the document pages in 1000%.

• Choose Zoom > Fit Page in Window in the menu or Fit Page in Window in the context menu, or
press Ctrl + ‚ (Windows / Linux) or Command + ‚ (Mac) to fully view the current document
page in the document window. If the document window is resized, the scaling factor adapts
automatically.
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• Choose Zoom > Fit Spread in Window or press Ctrl + 8 (Windows / Linux) or Command + 8 (Mac)
to fully view the current spread in the document window. If the document window is resized,
the scaling factor adapts automatically.

• Choose Zoom > Page Width or press Ctrl + 3 (Windows / Linux) or Command + 3 (Mac) to fully
view the page width of the current page in the document window. If the document window is
resized, the scaling factor adapts automatically.

Zoom with the zoom field

1. Choose one of the following options:

• Click in the zoom field.

• Press Ctrl + Alt + V (Windows/Linux) or Command + Option + V (Mac).

2. Enter a scaling factor between 1% and 1000%. The option accepts whole numbers.

3. Confirm your entry.

4. Alternatively, choose an option from the popup menu on the right.

Zoom in with the zoom tool

1. Choose one of the following options:

• Choose the zoom tool for zooming in.

• Hold down the keys Ctrl + Alt (Windows/Linux) or Command + Option (Mac).

2. Choose one of the following options:

• Click on an area in the document you want to enlarge. The program decides independently
about the scaling factor. The selected position in the document is automatically displayed in
the center of the document window.

• With the mouse button held down, move the mouse in any direction to enlarge a specific area.
Release the mouse button when the area has the size you want. The selected area is displayed in
the center of the document window automatically.

Zoom out with the zoom tool

1. Choose one of the following options:

• Choose the zoom tool for zooming out.

• Hold down the keys Control + Alt+ Shift (Windows/Linux) or Command + Option+ Shift (Mac).

2. Click on a position in the document that you want to reduce. The program decides independently
about the scaling factor. The selected position in the document is automatically displayed in the
center of the document window.

Zoom in/zoom out with the mouse wheel

1. Hold down the keys Ctrl + Alt (Windows/Linux) or Command + Option (Mac).

2. Choose one of the following options:

• Turn the mouse wheel down (away from you) to zoom in.

• Turn the mouse wheel up (towards you) to zoom out.
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Zoom in/zoom out with shortcuts

1. Hold down the keys Ctrl + Alt (Windows/Linux) or Command + Option (Mac).

2. Choose one of the following options:

• Click to zoom in.

• Hold down the shift key and click to zoom out.

Presentation Mode

The Presentation Mode displays the document as a page on the screen without window, palettes or
menu. This option is very useful to get a picture of the optical effect of the document pages. At the
same time you can use the Presentation Mode to show presentations.

Activate Presentation Mode

1. Choose one of the following options:

• Press Ctrl + 9 (Windows/Linux) or Command + 9 (Mac).

• Choose View > Presentation Mode.

2. Optionally, press additional keys (e.g. Up arrow, Down arrow, Plus or Minus), or use the mouse
wheel to specify the selection and appearance of document pages. If the option Show Tooltips in
Document Window is selected in the preferences, the permitted keys are displayed in a tooltip, if
you move the mouse to the background and then release it. Please refer to the section Preferences.

The program will now center and display the current page on a gray background. You can use the
options in the Preferences to choose a different background color. In addition, you can use the
options in the Preferences to determine the page transitions for the presentation mode. Please refer to
the section Preferences. If there are overlaps over the edge of the page they are automatically cut
out, and Guides, but not Guide Objects, are temporarily switched off. In this page display the pro-
gram recognizes the modes Single Page or Facing Pages.

Leave Presentation Mode
Click once with the mouse or press the Esc (Escape) key.

Choose document section view

Document sections can be selected freely or page by page. Document sections always refer to the
current document or window distribution. The snippet is also saved when the document is saved and
is available when the document is reopened.

The document section views can be determined in various ways:

• With single keys or shortcuts.

• With the hand tool in the Tools palette.

• With the Scroll Bars in the document window.

• With the context menus in the area of the Scroll Bars.

• With keys.

• With the mouse wheel.

50



Working with Documents | Document views

Choose document section freely

1. Press Alt + mouse button and move the mouse in any direction.

2. Press spacebar + mouse button and move the mouse in any direction. This option is available only
when text mode is not selected.

3. Choose the Hand tool in the Tools palette and move the mouse in any direction.

4. Click on the lower or right Scroll Bar, hold down the mouse button and move the mouse to change
the document section horizontally or vertically.

5. Click with the secondary mouse button on the right Scroll Bar. Choose the options Scroll here, Page
up, Page down, Scroll up or Scroll down in the context menu.

6. Click with the secondary mouse button on the bottom Scroll Bar. Choose the options Scroll here,
Left edge, Right edge, Page left, Page right, Scroll left or Scroll right in the context menu.

7. Turn the mouse wheel up or down to change the document section view vertically.

8. Press an arrow key to change the document section view horizontally or vertically. This option is
available only when text mode is not selected. The increment of the arrow keys corresponds to the
options Scroll up and Scroll down.

9. Press Page up or Page down to change the document view vertically.

Choose document section page by page

1. Click with the secondary mouse button on the right Scroll Bar. Choose the options Top or Bottom in
the context menu.

2. Click First Page in the Navigation palette to show the first page.

3. Click Previous Page in the Navigation palette to show the previous page.

4. Click Next Page in the Navigation palette to show the next page.

5. Click Last Page in the Navigation palette to show the last page.

6. Double-click a page symbol in the Pages palette.
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Working with Pages

Working with document pages

Every document has one or more document pages. Objects can be placed on docu-
ment pages, and content (images, texts, etc.) can be imported into them. When cre-
ating a new document the program automatically creates at least one page. You
can of course create and manage multiple pages. In this chapter you will learn what
types of pages there are, how to create, Choose, delete, move and number pages
automatically.

For navigation and the selection of pages the program offers you the commands in
the Document menu, the Pages palette, the Navigation bar and the document win-
dow.

Create a new document page

Up to 8,000 document pages may be created in a document. New document pages can be
created with the command New Document Page(s) or interactively with the Pages palette.

Create new document pages using the dialog

1. Choose one of the following options:

• Choose Document > Create > New Document Page(s).

• Click on the Document Pages section of the Pages palette and choose New Document Page(s) in
the context menu.

2. Define the number of new document pages in the Number entry field.

3. In the dialog section Position, Choose where the document pages should appear.

4. Choose one of the following options:

• Click the checkbox Assign Alias Page to assign the default settings you defined in the Document
Setup dialog.

• Leave the checkbox unchecked to import a blank page with no settings or guides.

5. Confirm the entry.
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Create new (blank) document page(s) interactively

1. Click in the list section of the Page palette on the option [Blank Page] and hold down the mouse
button.

2. Keep the mouse button held down and move the mouse to the symbol section of the Pages palette.

3. Position the mouse pointer between, above, below or next to existing document pages and release
the mouse key at the desired position.

Create new (default) document page(s) interactively

1. Click in the list section of the Pages palette on the option A-Alias Page and hold down the mouse
button.

2. Keep the mouse button held down and move the mouse to the symbol section of the Pages palette.

3. Position the mouse pointer between, above, below or next to existing document pages and release
the mouse key at the desired position.

When creating new document pages with the dialog you can take over or copy objects from the cur-
rent page onto the new document pages.

Select document pages

The program offers different possibilities for selecting a document page:

Select a document page

1. Click on the required page in the document window. If the required document page is not visible,
use the scrolling arrows or the scroll bar of the document window or the scroll wheel of the mouse
to display the document page and then click on the document page.

2. Choose one of the following options:

• Double click the page icon of the document page you want to display in the Pages palette.

• Click in the page field of the Navigation bar. Enter the document page number and press the
Tab, Enter or Return key to display the document page.

• Use the commands First Page, Last Page, Previous Page and Next Page in the Document menu.

• Use the buttons First Page, Last Page, Previous Page and Next Page in the Navigation bar.
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Page Preview in the Pages palette

The Page Preview option in the Pages palette is often helpful when you are scrolling through larger
documents whose pages contain graphics or images, such as catalogs. Thumbnail previews are cre-
ated in the Pages palette to help you recognize your pages.

Activate/Deactivate Page View

1. Right click in the Document Pages section of the Page palette and choose Show Small Page Preview
or Show Small Page Preview in the context menu.

2. Click the activated option again to deactivate the Page Preview.

Deleting document pages

You can delete single or multiple document pages with a menu command or with the Pages palette.

Deleting document pages with the dialog

1. Choose Document > Delete document Page(s).

2. Choose one of the following options:

• Type a number in the Number entry field (e.g. 3) to delete a single page.

• Type a range in the Number entry field (e.g. 3-5) to delete several consecutive pages (in this
example pages 3, 4 and 5).

• Type an open range to the end of the document in the Number entry field (e.g. 10-) to delete
all pages from the named page (in this example from page 10).

• Type numbers and ranges in the Number entry field (e.g. 3, 5, 8-12, 15) to delete several non-
consecutive pages (in this example pages 3, 5, 8 to 12 and 15).

Deleting document pages interactively

1. 1. Choose a document page to be deleted in the Page palette.

• Use the Shift key to choose additional consecutive pages and/or the Ctrl key (Windows/Linux)
or the Command key (Mac) to choose nonconsecutive pages.

2. Choose one of the following options:

• Press the Del key.

• Choose the command Delete Document Page(s) in the context menu.

After deleting, the pages following those deleted will move up.

If Facing Pages was selected in the Document Setup, the pages following will be rear ranged. Depend-
ing on how many and which pages were deleted, previously left hand pages will become right hand
pages and vice versa.

When document pages are deleted, generally all objects and content on the pages will be deleted
too.

NOT deleted are:

- Objects that cover several pages in Facing Page mode. These objects will only be deleted when all
document pages are deleted on which the object is placed.
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- Texts that are linked with text objects on other pages in a text chain. The text will only be deleted
when all document pages in the current text chain are deleted.

- Objects on the clipboard area. These objects will only be deleted when all document pages in the
spread are deleted.

Move document pages

You can move single or several document pages using the Pages palette to change the page arrange-
ment.

Move document pages interactively

1. Click in the Pages palette on the symbol of the document page that you want to move and hold
down the mouse button.

2. Drag the mouse pointer between, above, below or next to existing document pages and release
the mouse key at the desired position.

Note: Moving pages cannot be reversed or undone with the Undo command. In this case you must
move the page back to its original position.
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Working with Alias pages

The program differs between document pages and Alias pages. When a new docu-
ment is created, a document page on which you can place your objects will then be
displayed in the document window. At the same time the default A-Alias Page was
automatically applied to the document page. An Alias page is a kind of page tem-
plate on which you can place objects that appear again and again, so that these
objects appear automatically on the document pages as required.

In this manual the chapter headers and page numbers were not recreated for each
page. Instead, these elements were placed on Alias pages.

Switch between Alias and document pages

You can switch between the display of Alias and document pages at any time.

Switch to an Alias page
Choose one of the following options to display an Alias page:

• Double-click on the name of the required Alias page in the Pages palette.

• Click in the Page field of the Navigation bar. Now enter the prefix for the Alias page and press
the Tab, Enter or Return key to display the Alias page.

Thanks to the striped clipboard area (default) or the view previously described in the Preferences, you
can recognize immediately that you are on an Alias page. The name of the Alias page will be dis-
played in the Page field. Additionally, the Alias page prefix is displayed before the page number in
the Pages palette.

To display a document page again, the program offers you several possibilities:

Switch to document pages
Choose one of the following options to switch from an Alias to a Document page:

• Double-click in the Pages palette on the required document page.

• Click in the Page field of the Navigation bar. Now enter the number of the document page
required and press the Tab, Enter or Return key.

Create new Alias page

In a document you can create as many Alias pages as you like. Every Alias page receives a unique
prefix and a name.

The prefix consists of a maximum of 3 characters and may only appear once in a document. When
creating a new document an Alias page with the prefix A will be created automatically. Therefore
when a new Alias page is created the program suggests the prefix B. For further Alias pages the letters
C, D, etc. will be suggested. You can choose another prefix as long as this is unique and is not used in
the document.
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The name consists of a maximum of 256 characters and may appear several times in a document. You
can change the suggested name for the Alias Page at any time.

The option fields Single Page and Facing Pages define which page type should be applied to the Alias
pages.

Choose Single Page if all objects on the new Alias page should always be displayed identically on left
and right hand document pages.

Choose Facing Pages as soon as one or more objects (e.g. header bars, page number, etc.) are to be
displayed differently on left and right hand document pages.

Create new Alias page

1. Choose one of the following options to create an Alias Page:

• Choose Document > Create > New Alias Page.

• Click the name of an Alias page section in the Pages palette and choose New Alias Page in the
context menu.

2. Enter an individual prefix and the name of the new Alias page or accept the suggestion made by
the program. (There must be a dash between the prefix and the name.)

3. Choose Single Page or Facing Page in the dialog area Page Type.

4. Confirm the entry.

The program will now show the new Alias page in the document window and in the Pages palette.

- If the Alias page type is Single Page, a single page symbol will be displayed in front of the Alias
page name in the Pages palette.

- If the Alias page type is Facing Pages, a facing page symbol will be displayed in front of the Alias
page name in the Pages palette.

Note: Think carefully about which page type you choose, as this setting cannot be changed later! If
it turns out later that you have chosen the wrong page type, you will have to create a new Alias
page, copy the objects from the old Alias page to the new one and delete the old Alias page. Then
you can assign the new Alias page to the required document pages.

Switch between Alias pages

The program offers different possibilities for switching between Alias pages:

Switch between Alias pages

1. Choose one of the following options to switch Alias pages in the alias Page mode:

• Double-click in the Pages palette on the name of the Alias page required.

• Click in the Page field of the Navigation bar. Now enter the prefix of the Alias page and press
the Tab, Enter or Return key.

2. Choose one of the following options to switch Alias pages:

• Use the commands First Page, Last Page, Previous Page and Next Page in the Document menu.

• Click the navigation buttons First Page, Last Page, Previous Page and Next Page in the Naviga-
tion bar.
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Thanks to the striped clipboard area (default) or the view previously described in the Preferences, you
can recognize immediately that you are on an Alias page. The name of the Alias page will be dis-
played in the Navigation bar.

Assign an Alias page to a document page

When a new document is created, the Alias page A-Alias Page is automatically assigned to the docu-
ment page. You can change this assignment for document pages at any time.

Assign an Alias page to a document page with the dialog

1. Select the document page to which you want to assign an Alias page.

2. Choose one of the following options:

• Choose Document > Document Page Settings.

• Click in the Pages palette on the symbol of the appropriate document page and choose Docu-
ment Page Settings in the context menu.

3. Choose the required Alias page from the dialog area Alias Page.

4. Confirm the entry.

Assign an Alias page to a document page interactively

1. Ensure that the symbol of the appropriate document page and the name of the Alias page are dis-
played in the Pages palette.

2. Click on the name of the Alias page and hold the mouse button down.

3. Keep the mouse button held down and move the mouse to the symbol of the appropriate docu-
ment page.

4. Release the mouse button as soon as the required document page is displayed in the chosen color.

Assign one Alias page to several document pages simultaneously

1. Use the mouse to choose several document pages in the Pages palette. Use the Shift key to choose
consecutive pages and/or the Ctrl key (Windows/Linux) or the Command key (Mac) to choose non-
consecutive pages.

2. Click with the right mouse button (Windows/Linux) or with the Command key held down (Mac) on
the name of the Alias page you want to assign and hold down the mouse button.

3. Choose Assign marked Alias to selected pages in the context menu.

The document page symbol in the Pages palette now shows the prefix of the assigned Alias page and
the objects of the Alias page will now appear on the document page. To assign another Alias page to
document pages, repeat the previous steps.

Deleting the assignment of Alias pages

If you want to remove the assignment of Alias pages to document pages, you can assign an empty
page to a document page. Proceed exactly as previously with the assignment of an Alias page, and
choose the option [Blank Page] in the Document Page Settings Dialog or in the Page palette.
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Create new document pages with Alias page

Instead of assigning an Alias page to an existing document page, you can assign the Alias page
automatically when new document pages are created.

The taking over of Alias pages into document pages is just as flexible as taking over objects.

You have already learned that in the creation of a new document an Alias page will be assigned auto-
matically. This Alias page is given the default name A-Alias Page. You have also learned how the
assignment of a document page and an Alias page is changed. Now you will create new document
pages and assign an Alias page of your choice to them automatically.

Create new document pages with Alias page using Dialog

1. Choose Document > Create > New Document Page(s).

2. Define the number of new pages in the Number field.

3. Choose an option in the Position area to choose where the new document pages will appear.

4. Choose the option Assign Alias Page and choose an Alias page from the popup menu.

5. Confirm the entry.

Create new document pages with Alias page interactively

1. Ensure that the name of the Alias page which will be assigned to the new document page is dis-
played in the Pages palette.

2. Click on the name of the Alias page (list area) and hold down the mouse button.

3. Keep the mouse button held down and move the mouse to the page symbol area of the Pages pal-
ette.

4. Position the mouse pointer between, above, below or next to existing document pages and release
the mouse key at the desired position.

Deleting Alias pages

When Alias pages are deleted, both the Alias page itself and also all assignments to document pages
will be deleted. Here all objects on document pages whose originals were on the Alias page will also
be deleted.

Delete Alias page

1. Select an Alias Page to be deleted in the Pages palette. Use the Shift key to choose consecutive
Alias Pages and/or the Ctrl key (Win dows/Linux) or the Command key (Mac) to choose nonconse-
cutive pages.

2. Choose an appropriate option to delete one or more Alias pages:

• Press the Del key.

• Choose Delete Alias Page(s) in the context menu.

• Double-click the Alias page symbol to switch to Alias page mode and choose Delete Alias
Page(s) in the context menu.

3. Confirm the Warning question.
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Note:

 • An Alias page cannot be deleted when it is the only Alias page in the document.

 • If an Alias page that is assigned to a document page is deleted, then a blank page is auto-
matically assigned to that document page. Objects that do not come from the Alias page are
retained.

Change Alias page name

The prefix and the name of the Alias page may be changed at any time as long as the naming con-
ventions are adhered to.

Change Alias page name

1. Choose an Alias page.

2. Choose one of the following options:

• Double-click the Alias page and choose Document > Alias Page Settings, change the Prefix and/
or the Name and confirm the entry.

• Click the Alias page in the Pages palette and choose Rename in the context menu. Change the
Prefix and/or the Name and confirm the entry.

Duplicate Alias Pages

For a manual or a small catalog you may want to have chapter or category-oriented Alias pages,
maybe with header bars of the same size, shape and position, but in different colors. Creating each
Alias Page from scratch and copying objects from one Alias page to the next is of course possible, but
not an ideal way of working. Therefore the program offers the function to duplicate an Alias page.

Duplicate Alias Page

1. Select an Alias page.

2. Click the Alias page in the Pages palette and choose Duplicate from the context menu.

A new Alias page will be created with the next available prefix. Any objects you have created on the
Alias page will be duplicated as well and can of course be edited on the new Alias page.

Note: Text objects created with the Duplicate command on new Alias pages do NOT have the Auto
Link special setting activated. If you want the text on the document pages to flow through these
objects, then you must enable the option manually.

Protect Alias Pages

If you want to give your document to someone else for editing and have put much effort into creating
an Alias page structure, you may want to protect your Alias pages against unintentional loss or dam-
age. In this case you can lock the Alias pages with a password so that they cannot be edited.

Protect Alias Page

1. Choose an Alias page.

2. Click the Alias page in the Pages palette and choose Protection in the context menu.
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3. Enter a password in the Password entry field and repeat the entry in the next entry field. Choose
the option Make visible to display the password in clear text on the screen.

4. Confirm the entry.

Now a lock symbol will appear for the Alias page on the right hand side of the palette.

Note: Store the password in a safe place!

Unlock Alias Page

1. Choose the Alias page in the Pages palette.

2. Right click the Alias page in the Pages palette and choose Cancel Protection in the context menu.

3. Enter the password and confirm the entry.

Working with page numbers

Define page numbering

One document page is created automatically in the creation of a new document. This document page
receives the page number 1. All following pages are then numbered automatically.

This page numbering controlled by the program may be extended by the user with the help of a pre-
fix, or changed individually through a new numbering for every document page. In this book a new
page numbering has been used for every chapter. All pages are numbered starting with page number
1, and have been given a prefix.

The chapter Working with Text describes how to insert page numbers in the text.

The program provides different possibilities for changing the page numbering:

Change page numbering

1. Choose the document page whose page numbering you want to change:

• Choose Document > Document Page Settings.

• Click on the document page in the Pages palette and choose Document Page Settings in the
context menu.

2. Click the option New Numbering.

3. If you want to define a Prefix, enter a combination of max. 3 characters in the Prefix entry field
(e.g. A-).

4. Enter a number between 1 and 9999 (e.g. 1234) in the entry field New Page Number.

5. If you want to choose a different numbering format, Choose an option from the popup menu For-
mat. The program provides the option of Arabic numbers, Roman numbers in upper or lower case
and also the Roman alphabet in upper or lower case.

6. Confirm the entry.

The document will now be recalculated. Starting from the current page, all following document
pages will receive the prefix and the page numbering assigned until a new page numbering is
applied. The page number of the following pages is also increased each time by 1.
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The start of a new page numbering is shown in the Pages palette and in the Page field of the Naviga-
tion bar with an asterisk before the page number.

If a page with an even page number that is positioned on the left is given an odd number through the
new page numbering, this page will automatically be displayed on the right when in the Preferences
the option Position Chapter Page automatically is activated. This option is activated as default for the
creation of new documents.

Use variables for page numbers

If you want to output page numbers in text objects, you should not enter these page numbers indi-
vidually with the keyboard, but use variables that are automatically updated when the page number
is changed through insertion, deletion or alteration of document pages.

The program offers a series of variables to display page numbers in text.

Inserting variables for page numbers in text

1. Choose an appropriate option:

• Click in an existing text object.

• Create a text object on a document page and activate the text mode.

2. Choose Text > Insert Variable. in the menu or Insert Variable in the context menu.

3. Choose one of the following options in the popup menu:

• Page Number – outputs the cur rent page number.

• Number of Pages – outputs the total number of pages.

• Next Page Number – outputs the page number of the following page. If no following page
exists, nothing will be displayed.

• Previous Page Number – outputs the page number of the previous page. If no previous page
exists, nothing will be displayed.

• Continued from – outputs the page number of the page from which the text has been contin-
ued. If no document page exists from which the text was continued, nothing will be displayed.

• Continued on – outputs the page number of the page on which the text is continued. If no doc-
ument page exists on which the text could be continued, nothing will be displayed.

When the page number is placed in a separate text object, you should place all page numbers on
Alias pages. Proceed exactly as described in the previous example. After importing the page number
into the text object on the Alias page, not the page number but a variable appears. This variable will
be converted to a page number automatically when the document page is displayed.

Logical and physical page numbers

In working with pages, the program differs between physical and logical page numbers. Insofar as
the user makes no changes in the Page Numbering in the document using the command Document
Page Settings, the physical and logical page numbering is identical. This means that the last page
number will match the total number of document pages.
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When a document has pages whose page number is not the same as the physical document page, the
page field automatically displays first the logical page number and then in brackets the physical
page number and the total number of pages.

If you have entered a page number in a document manually, and enter a page number in the page
field of the navigation bar, the program will always show the first page that corresponds to the page
number, whether it is a physical or logical page number.

If you have used page numbers in text objects, these always take on the logical page numbers, irrele-
vant of which settings you have made in the Program Preferences.

Define the page number display in the Preferences

1. Choose Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences (Mac).

2. Choose Physical or Logical in the Program/General/Page Numbers area.

The option is only relevant to the display of the page numbers in the Pages palette and in the Page
field of the Navigation bar.
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Working with Objects

Introduction

Whenever you need to enter text, to place pictures or create graphic elements you
will need to create objects. Objects may be modified after they are created, their
form, position, type, color and other object properties can all be modified.

This chapter will show you how to create and modify objects. Even if you are famil-
iar with other illustration or layout pro grams we advise you to read this chapter
carefully since it will give you in-depth information on the sometimes unique pos-
sibilities of Viva products.

The Toolbar
Through the Toolbar you are able to create new or modify existing objects. The fol-
lowing tools are available from the Toolbar:

- Rectangle tool (Text, Picture and Graphic Objects)

- Ellipse tool (Text, Picture and Graphic Objects)

- Polygon/Bézier Object tool (Text, Picture and Graphic Objects)

- Table objects

- Line tool

- Orthogonal Line tool

- Path/Multiple line tool

Other objects like for instance open or closed Bézier curves, circle segments, etc.
can also be created through the modification of other objects.

All objects can either be modified interactively or by means of the available menu
or keyboard commands. How this is done is described in the following sections.
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Creating objects
To create an object, select the appropriate Object Tool from the Toolbar or where appropriate, use the
shortcut keys to create closed rectangular objects in a default size. We see a difference between
closed objects (rectangle, oval or polygon/bézier objects) and line/path objects as well as between
original and Alias objects. Please refer to the section Working with Alias Objects.

Objects can be created on the document page or on the pasteboard beside the page. Objects can also
be created over several pages in Facing Page Mode. Several pages (i.e. more than two) may also be
placed on a spread next to one another.

While creating an object the application gives you feedback about the size and form of the object
through an imaginary line, which shows you the object’s appearance when you release the mouse
button. The Ruler, the Module Palette and the Quick Access Palette also give information about the
size and position of the object created.

 • Objects that touch the edge of the page should run over between 3 and 5 mm into the clip-
board area (bleed). Please refer to the section Working with Documents.

 • When creating objects, check the information in the Ruler and in the Module Palette.

 • Refer to the sections Objects with predefined settings and Create Alias Objects.

Creating closed objects

To create closed objects, several tools are available for each object type (graphic, text, image). To
open the list, click on the tool and hold the mouse button down until the list appears.

Create a rectangle or square interactively

1. Choose a tool for a rectangular object from the Toolbar:

• Choose Rectangular Graphic Object to create a rectangular graphic object.

• Choose Rectangular Text Object (LTR) to create a rectangular text object with text running from
left to right.

• Choose Rectangular Text Object (RTL) to create a rectangular text object with text running from
right to left (e.g. for Arabic, Hebrew, etc.).

• Choose Rectangular Text Object (TTB) to create a rectangular text object with text running from
top to bottom (e.g. for Chinese, etc.).

• Choose Rectangular Picture Object to create a rectangular picture object.

• Choose the Table tool to create a table object. This tool is not available in the Free Edition and is
an optional extra in the Personal Edition. Please refer to our Website www.viva.de and the sec-
tion Working with Tables.

2. Click in the document window on the position where the object should be created and hold down
the mouse button.

3. Keep the mouse button held down and move the mouse in any direction.

• Hold down the Shift key as well if you want to create a square with a rectangle tool or a circle
with the oval/ellipse tool.

4. Release the mouse button when the object has the desired size.
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As well as the interactive creation of a rectangle or square with the mouse, a rectangle or square may
be created automatically. No object should already be selected since it would be modified.

Create a rectangle/square automatically

1. Choose one of the following options to create a graphic object:

• Press Ctrl + Shift + G (Windows/Linux) or Command-Shift + G (Mac).

• Choose Object > Content > Graphic.

2. Choose one of the following options to create a text object:

• Press Ctrl + Shift + T (Windows/Linux) or Command-Shift + T (Mac).

• Choose Object > Content > Text.

3. Select one of the following options to create a picture object:

• Press Ctrl + Shift + B (Windows/Linux) or Command-Shift + B (Mac).

• Choose Object > Content > Picture.

The object will now be created at the upper left sector of the document page and selected. With an
additional option you can modify the radius of the angle.

Create a curved rectangle

1. Create a rectangle.

2. Enter a value in the Radius field of the Module palette or the Quick Access palette, or choose a
value from the popup menu.

With the rectangle tool you can also create derivative forms such as parallelograms. Please refer to
the section Skew objects.

Create an oval/circle interactively

1. Choose a tool for an oval object from the Toolbar:

• Choose Oval Graphic Object to create a oval graphic object.

• Choose Oval Text Object (LTR) to create a oval text object with text running from left to right.

• Choose Oval Text Object (RTL) to create a oval text object with text running from right to left
(e.g. for Arabic, Hebrew, etc.).

• Choose Oval Text Object (TTB) to create a oval text object with text running from top to bottom
(e.g. for Chinese, etc.).

• Choose Oval Picture Object to create a oval picture object.

2. Click in the document window on the position where the object should be created and hold down
the mouse button.

3. Keep the mouse button held down and move the mouse in any direction.

• Hold down the Shift key as well if you want to create a circle.

4. Release the mouse button when the object has the desired size.

With the oval tool you can also create derivative forms such as half circles. Please refer to the sec-
tion Delete handles.
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Create a polygon/Bézier object

1. Choose a tool for an polygon object from the Toolbar:

• Choose Polygonal Graphic Object to create a polygonal graphic object.

• Choose Polygonal Text Object (LTR) to create a polygonal text object with text running from left
to right.

• Choose Polygonal Text Object (RTL) to create a polygonal text object with text running from
right to left (e.g. for Arabic, Hebrew, etc.).

• Choose Polygonal Text Object (TTB) to create a polygonal text object with text running from
top to bottom (e.g. for Chinese, etc.).

• Choose Polygonal Picture Object to create a polygonal picture object.

2. Click on the position where the first selection point of the object should be created.

3. Move the mouse in any direction.

• Hold down the Shift key as well if you want to draw a line segment at an angle of 0 (zero) or 90
degrees.

4. Click the mouse button once to complete a line segment and move the graphic object pointer in
any direction to create the next line segment.

• Hold down the Ctrl key (Windows/Linux) or the Command key (Mac) and move the mouse in
any direction to draw a tangent and thus create a curve.

5. Repeat this for every line segment.

6. Double-click to complete and close the drawing process. The line segments will be connected auto-
matically.

Bézier objects may also be created from polygons. Please refer to the section Object Size & Form.
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Create line objects/paths

The program makes three tools available to you which allow you to draw lines. The application differs
between the tools for drawing a

- straight line with any angle,

- an orthogonal straight line and

- a multiple line/path consisting of several line segments and/or curves.

Create a simple straight line

1. Select the Line tool (diagonal line symbol) from the Toolbar. If the Orthogonal Line tool (cross
symbol) is visible, click the icon and hold down the mouse button to open the popup menu.

2. Click on the position where the object should be created and hold down the mouse but ton.

3. Move the mouse in any direction while holding down the mouse but ton.

• Hold down the Shift key to draw an orthogonal straight line with an angle of 0 (zero), 45 or 90
degrees.

4. Release the mouse button when your line is of the required length and angle.

Create an orthogonal line

1. Choose the Orthogonal Line tool (cross symbol) from the Toolbar. If the Line tool is visible, click the
icon and hold down the mouse button to open the popup menu.

2. Click on the position where the object should be created and hold down the mouse but ton.

3. Move the mouse in any direction while holding down the mouse but ton. The orthogonal line fol-
lows the horizontal or vertical position of the mouse pointer. The orthogonal line will however
change its direction by 45 degrees when the angle between the line and the mouse pointer is
greater than 22,5 degrees.

• Hold down the Shift key to draw a straight line with any angle.

4. Release the mouse button when your line is of the required length.

To make an angled line from an orthogonal line and vice versa, hold down the Shift key when edit-
ing or drawing.

Create a multiple line/path

1. Choose the Path tool from the Toolbar.

2. Click in the document window on the position where the object should be created.

3. Move the mouse in any direction.

• Hold down the Shift key when a line segment with an angle of 0 (zero) or 90 degrees should be
drawn.

4. Click once to complete a line segment and move the mouse pointer in any direction to create the
next line segment.

• Hold down the mouse button and move the mouse in any direction to draw a tangent and thus
create a curve.

5. Repeat this for every additional line segment.
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6. Double-click to complete and close the drawing process.

Bézier curves may also be created from multiple lines. Please refer to the section Object Size &
Form.

Summary Creating Objects
- Rectangles are created with a Rectangle tool in the Toolbar. By holding down the Shift key a

square will be created.

- To create a rectangle automatically, choose the appropriate object type in the Object menu or
press the following shortcut keys:

• Graphic object: Ctrl + Shift + G (Windows/Linux) or Command + Shift + G (Mac)

• Text object: Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac)

• Picture object: Ctrl + Shift + B (Windows/Linux) or Command + Shift + B (Mac)

- Make sure no object is already selected before using the command.

- Rectangles with rounded corners can be created with the help of the Radius option in the Quick
Access palette or the Module palette.

- Ellipses/Ovals are created with an Oval tool in the Toolbar. Holding down the Shift key while
drawing automatically creates circles.

- Simple straight lines are created through the Line tool in the Toolbar. Holding down the Shift key
while drawing automatically creates vertical or horizontal orthogonal lines.

- Orthogonal lines are drawn with the Orthogonal Line tool in the Toolbar. Holding down the Shift
key while drawing automatically creates diagonal lines.

- Multiple lines/paths are drawn with the Path tool in the Toolbar. Holding down the Shift key while
drawing automatically creates only horizontal or vertical line segments. A double-click com-
pletes the creation of a multiple line.

- Polygons/Bézier objects are drawn with the Polygon tool in the Toolbar. Holding down the Shift
key while drawing automatically creates only horizontal or vertical line segments. A double-click
completes the creation of a polygon and the first and last line segments will be connected. You
can also convert an open path to a polygon by selecting it and choosing the command Object >
Shape > Close Polygon.

- Open curves can also be created by converting multiple lines/paths. Position the mouse pointer
on the sizing handle of a path, hold the Ctrl key (Windows/Linux) or the Command key (Mac) and
the mouse button down and stretch the handle by moving the mouse. The corresponding mouse
pointer will be displayed. You can also convert a polygon to an open path by selecting it and
choosing the command Object > Shape > Open Polygon.

- Closed curves/Bézier objects can also created by converting existing polygons. Position the
mouse pointer on a sizing handle of the polygon, hold the Ctrl key (Win dows/Linux) and the
mouse button down and stretch the handle by moving the mouse. The corresponding mouse
pointer will be displayed.
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- A newly created object will have the same graphic properties as a previously created object if the
previously created object is selected before the appropriate object tool is activated in the Tool-
bar.

- For information about table objects please refer to the section Working with Tables.

- One or more Alias objects can be created from any original object.

- One or more Alias objects can also be created from any Alias object.

Selecting objects
As soon as the mouse pointer is positioned on top of a graphic object or its frame the Object pointer
or Graphic pointer is displayed. This mouse pointer shows you that the object can be selected by
means of a mouse-click. The same is true if you move the mouse pointer to the frame of a text or pic-
ture object, and here there is an additional feature: As soon as you move the mouse over the surface of
a text or picture object, the mouse pointer will change into an I-beam (text) or grabber hand (pic-
ture), while a gray selection button appears in the middle of the object. If you move the mouse over
the button, the mouse pointer will change into the Object pointer.

After the mouse-click the selection handles are shown. The term selection handles describes the sizing
handles and control handles of an object. Lines and polygons have selection handles at every corner
point. Ellipses/ovals and rectangles always have eight selection points. As well as the display of the
selection handles, the attributes applied to the object appear in the Object Palette (Module Palette in
Object mode). If the Object Palette is visible, its co-ordinates are displayed.

Select objects with a mouse-click

1. Choose one of the following options:

• Position the mouse pointer on a closed graphic object or a line.

• Position the mouse pointer on the object frame of a picture or text object.

• Position the mouse pointer on the picture or text object and hold down the Ctrl key
(Windows/Linux) or the Command key (Mac).

• Position the mouse pointer on the gray selection button in the middle of the picture or text
object.

2. Click as soon as the Object pointer is shown.

3. To select several objects, repeat points 1 and 2 while holding down the Ctrl and Shift keys.

Objects can also be selected by dragging an imaginary rectangle over them.

Select objects through dragging

1. Position the mouse pointer somewhere on the page where there is no object.

2. Hold down the mouse button and drag the selection rectangle in the direction of the objects you
want to select.

3. Release the mouse button when the selection rectangle covers all the objects you wanted to select.
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Select objects in content mode (menu) or Esc

Select objects with tools

Select all objects
Choose one of the following options:

• Choose Edit > Select All.

• Press Ctrl + A (Windows/Linux) or Command + A (Mac).

In single page documents, all objects on the page and on the pasteboard area will be selected. In
facing page documents, all the objects on the left and right hand page and also on the pasteboard
area will be selected.

The program offers the possibility of steering the selection of certain objects (e.g. Guide objects,
Alias objects, etc.). If one or more objects cannot be selected, please refer to the sections Working
with Guide Objects and Working with Alias Objects.

The program offers several possibilities for deselecting an object:

Deselect all selected objects
Choose one of the following options:

• Position the mouse pointer somewhere on the page where there is no object and click.

• Hold down the Shift key and click the frame of the object to be deselected or use the dragging
method.

• Hold down the Shift key and click the gray selection button in the middle of a picture or text
object.

• Select another object.
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Summary Selecting objects
- Objects are selected through the Object pointer.

- For single pages, only objects on the current page and the Paste board area are selectable.

- For facing pages, all objects on both left and right hand pages as well as on the Pasteboard area
are selectable.

- All objects on the current page or spread can be selected with the command Edit > Select All or
with the shortcut keys Ctrl + A (Windows/Linux) or Command + A (Mac).

- When the mouse pointer is over a text or picture object the Ctrl key (Windows/Linux) or Com-
mand key (Mac) must be pressed to select the object if you do not want to position the mouse
pointer exactly on the frames or the gray selection buttons of these objects.

- Selection handles of original objects are filled square points (sizing handles) and round points
(control handles).

- Selection handles of Alias objects are filled light-colored points and their control handles are
filled light-colored round points.

- Multiple objects can be selected by dragging the selection rectangle in the direction of the
objects you want to select or by holding down the the Shift key and clicking each object with the
mouse. If the objects are text or picture objects, then the Ctrl key (Windows/Linux) or Command
key (Mac) must also be held down.

- To select hidden objects, the Ctrl + Alt + Windows-Shift (Win dows/Linux) or Ctrl + Option + Com-
mand + Shift (Mac) shortcut keys and the mouse button must be pressed until the selection han-
dles of the object are shown.

Editing Objects
The application offers a variety of options for positioning and displaying objects. These options are
included in the program both in the Quick Access palette and the Module palette. Therefore, in the
following description, reference will only be made several times to these palettes and dialogs. The
text below describes how to achieve these options.

Quick Access palette
Choose Window > Quick Access.

Module palette
Choose Window > Module.

Positioning objects
The program provides many options for the positioning of objects. You can position objects using the
mouse, keyboard, and options in the Quick Access and Module palettes.
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Move objects

In selecting objects you have already met the graphic mouse pointer whose arrowheads point in all
four directions. This pointer is also used for moving objects.

Move an object interactively with the mouse

1. Select one or more objects.

2. Hold down the mouse button and move the mouse in any direction.

3. Hold down the Shift key as well to move the objects only horizontally or vertically.

If the Module palette (object mode) and/or the Quick Access palette (object mode) is visible, the cur-
rent position of the object is shown exactly as soon as you release the mouse button.

Move/nudge object(s) with the keyboard

1. Select at least one object.

2. Use the arrow keys on the keyboard to move or nudge objects one screen pixel at a time in the
appropriate zoom factor:

• Press the Arrow-Right key or the Arrow-Left key to move/nudge objects horizontally.

• Press the Arrow-Up key or the Arrow-Down key to move/nudge objects vertically.

During object nudging the outer dimension of the object is shown. You can now move the object
around on the current page or to other pages. When the ruler is active the position of the active
object is shown.

If the Module palette (object mode) and/or the Quick Access palette (object mode) is visible, the cur-
rent position of the object is shown exactly.

Apart from the interactive positioning of objects it is also possible to do this in a precise manner through
various commands. We will differentiate between absolute and relative positioning.

- Absolute positioning means the selected objects are moved to a specific position. The application
offers you three ways to do this: through the Object Settings dialog or through the Module pal-
ette or the Quick Access palette.

- Relative moving means the selected objects will be moved with a specified factor.

Move an object with the Module palette/Quick Access palette

1. Select one or more objects.

2. Enter the required co-ordinates in the entry field X or Y of the Module palette or the Quick Access
palette:

• Replace the values manually in the entry fields to position the objects absolutely.

• Alternatively, click the arrows on the right of each entry field to decrease or increase the co-
ordinates in steps of one measurement unit. You can define the units to be used in the Prefer-
ences (Measurements). Please refer to the section Working with Preferences.

• Enter a factor (e.g. +10) to move the objects relatively. Positive values move the objects to the
right or downwards. Negative values move the objects to the left or upwards.
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3. As an extra option, choose the reference point for the X and Y co-ordinates. The default reference
point for closed objects and multiple lines/paths is Top Left. The default reference point for lines
and orthogonal lines is Start.

Changing object hierarchy

Objects are drawn on top of each other in the order in which they are created. Each object virtually
represents a card in a deck of cards. In practice, however, it is rare for you to create all the objects in
the order in which you want them to appear later. The program offers several options to change the
order of objects within a batch. The following options affect the order within a layer. Please refer to
the section Working with Layers.

Change object hierarchy

1. Select at least one object.

2. Choose one of the following options in the Object menu or in the context menu Order, or press the
appropriate shortcut keys:

• Send to Front — Sends the selected objects in the hierarchy to the front, similar to the top card
in the pack. Alternatively, press Ctrl + Shift + Plus (Windows/Linux) or Command + Shift + Plus
(Mac).

• Send to Back — Sends the selected objects in the hierarchy to the back, similar to the bottom
card in the pack. Alternatively, press Ctrl + Shift + Minus (Windows/Linux) or Com mand + Shift +
Minus (Mac).

• Send Forward — Sends the selected objects in the hierarchy in front of the object above, similar
to the next card up in the pack. Alternatively, press Ctrl + Alt + Plus (Windows/Linux) or Com -
mand + Alt + Plus (Mac).

• Send Backward — Sends the selected objects in the hierarchy underneath the object below, sim-
ilar to the next card down in the pack. Alternatively, press Ctrl + Alt + Minus (Windows/Linux) or
Command + Alt + Minus (Mac).

You can also change the object hierarchy in the Objects section of the Layer palette. Please refer to the
section Working with Layers for further information.

Object alignment

Another option to change the position of objects is through the Alignment or Align/Distribute com-
mand, with the help of the Smart Guides, with the Module palette or the Object Settings dialog. This is
especially useful if several objects have to be positioned in a certain way relative to another.

Align objects with menu commands

1. Select at least two objects.

2. Choose Object > Alignment in the menu or one of the following options in the context menu Align-
ment:

• Left Edge — All selected objects are aligned on the left edge of the selected object whose left
edge is furthest to the left.

• Center horizontally — All selected objects are aligned on the horizontal center axis of the object
selection.
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• Right Edge — All selected objects are aligned on the right edge of the selected object whose
right edge is furthest to the right.

• Center — All selected objects are aligned on both the horizontal and vertical center axes of the
object selection.

• Top Edge — All selected objects are aligned on the top edge of the selected object whose top
edge is the furthest up the page.

• Center vertically — All selected objects are aligned on the vertical center axis of the object
selection.

• Bottom Edge — All selected objects are aligned on the bottom edge of the selected object whose
bottom edge is the furthest down the page.

Align objects with the Align/Distribute dialog

1. Select at least two objects.

2. Choose one of the following options:

• Press Ctrl + Comma (Windows/Linux) or Command + Comma (Mac).

• Choose Object > Alignment > Align/Distribute in the menu or Alignment > Align/Distribute in the
context menu.

3. Choose one or more of the following options:

• Horizontal > Spacing > Between > Left Edge — All selected objects are aligned on the left edge of
the selected object whose left edge is furthest to the left.

• Horizontal > Spacing > Between > Center — All selected objects are aligned on the horizontal
center axis of the object selection.

• Horizontal > Spacing > Between > Right Edge — All selected objects are aligned on the right edge
of the selected object whose right edge is furthest to the right.

• Vertical > Spacing > Between > Top Edge — All selected objects are aligned on the top edge of
the selected object whose top edge is the furthest up the page.

• Vertical > Spacing > Between > Center — All selected objects are aligned on the horizontal center
axis of the object selection.

• Vertical > Spacing > Between > Bottom Edge — All selected objects are aligned on the bottom
edge of the selected object whose bottom edge is the furthest up the page.

4. Confirm the entry.

Align objects automatically on the page

1. Select at least one object.

2. Choose View > Smart Guides.

3. Choose one of the following options:

• Move the objects toward the center of the page to align them horizontally and / or vertically at
the center of the page.

• Move the objects toward the edge of the page margin to align them horizontally and/or verti-
cally with the page edge.

4. Release the mouse button when a red, horizontal, and/or vertical guide appears. The red line is
displayed when the page center or the page edge
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• intersects with the edge of one of the selected objects or

• intersects with the center of one of the selected objects or

• intersects with the center of all selected objects.

Align object to each other automatically

1. Select at least one object.

2. Choose View > Smart Guides.

3. Move the objects in the direction of the objects to which you want to align.

4. Release the mouse button when a green, horizontal, and/or vertical guide appears. The green line
is displayed when the object center or edge

• intersects with the edge of one of the selected objects or

• intersects with the center of one of the selected objects or

• intersects with the center of all selected objects.

Align objects numerically

1. Select at least one object.

2. Enter a value in the entry field X and/or Y in the Module palette or the Quick Access palette to assign
a communal X and/or Y coordinate to the objects. The positioning is dependant on the reference
point.

Rotate

You can rotate individual or multiple objects or groups interactively using a tool in the toolbar or
numerically using the dialogs and palettes. Multiple objects selected together behave like a group.

Rotate an object Interactively

1. Select at least one object.

2. Position the mouse pointer near a selection point of the object or group so that the rotation pointer
is displayed.

3. Hold the mouse button down and drag the mouse in the desired direction. The rotation always
occurs around the center of the object or group of objects.

4. Release the mouse button when the desired rotation angle has been reached. It is displayed tem-
porarily in the middle of the object or in the group.

In borderline cases, the value displayed during interactive rotation may differ from the numeric
value in the dialogs and palettes. If in doubt, the value in the dialogs and palettes always applies
here.

Rotate numerically

1. Select at least one object.

2. In the Quick Access palette or the Module palette, or in the Object Settings dialog, enter a value for
the rotation. With the Quick Access palette or Module palette the rotation is made around the
selected reference point. In the Object Settings dialog the rotation is made around the center of
the object or the object group.
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3. Confirm the entry.

Mirror

You can mirror individual or multiple objects or entire groups vertically using the dialogs and pal-
ettes. Multiple objects selected together behave as individual objects and not as a group.

1. Select at least one object.

2. Choose one of the following options:

• In the Quick Access palette or in the Module palette, click the Mirrored option. Mirroring is per-
formed vertically and depends on the reference point.

• -Choose the option Mirrored in the Object Settings dialog. The mirror axis corresponds to the
center of the object.

3. Optionally, choose a rotation angle (for example “180”) if the object or group should also be mir-
rored horizontally.

Skew objects

You can skew closed objects and paths by entering a negative or positive angle.

When skewing text and picture objects, the content of these objects is also skewed. Please note that
there are additional options for skewing text passages and images, which are described in the
respective chapters and have an additive effect.

1. Select at least one object.

2. Enter a value in the Skew Angle field in the Quick Access Palette or the Module palette, or in the
Object Settings dialog, or click the arrow keys or use the mouse wheel. Values between +1 and +75
give a skew to the left, values between -1 and -75 give a skew to the right.

Basic commands

Delete objects

Selected objects can deleted by using the Delete command.

Delete objects

1. Select at least one object.

2. Choose one of the following options:

• Press Del.

• Press Backspace

• Choose Edit > Delete.

• Select the object in the Layers palette and choose Remove Object(s) in the context menu.

If an original object is deleted that possesses Alias Objects that are not selected, a warning will
appear that allows the user to cancel his command.
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Section Pasting objects
Section Undo
Section Working with Alias Objects

Section Working with Layers

Cut objects

Cutting objects is similar in its function to deleting objects. Objects which are cut disappear, but they
are copied to the clipboard and reappear again with the command Paste.

Cut objects

1. Select one or more objects.

2. Choose one of the following options:

• Press Ctrl + X (Windows/Linux) or Command + X (Mac).

• Choose Edit > Cut in the menu or Cut in the context menu.

When an object which has connected Alias objects is cut, a dialog will prompt you to confirm or
cancel the operation.

Sections Pasting Objects and Working with Alias Objects

Copying objects

When you need the same object more than once you can create a copy of one or more existing objects. The
selected objects are copied to the clipboard, and can be pasted back in the document with the command
Paste.

Copy objects

1. Select one or more objects.

2. Choose one of the following options:

• Press Ctrl + C (Windows/Linux) or Command + C (Mac).

• Choose Edit > Copy in the menu or Copy in the context menu.

When the original object should be copied that has unselected Alias objects a warning dialog will
appear prompting the user to reverse his decision.

Section Pasting Objects
Section Duplicating Objects
Section Working with Alias Objects

Pasting Objects

When you have cut or copied objects to the clipboard these can be pasted through the Paste com-
mand. You can choose whether the objects should be inserted with an offset (default) or at the same
position. The offset can be predefined with the option Edit > Preferences (Windows/Linux) or {Appli-
cation Name} > Preferences (Mac). Pasting takes place across documents, that is, you can cut or copy
objects in another document and paste them into the current document. With the insertion of the
objects also all possible attributes (e.g. style sheets) are taken over.
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Paste objects

1. Select the document page on which the cut or copied objects are to be pasted.

2. Choose one of the following options:

• Press Ctrl + V (Windows/Linux) or Command + V (Mac).

• Choose Edit > Paste or Edit > Paste (without Offset) in the menu, or Paste or Paste (without Off-
set) in the context menu.

When the objects have connected Alias objects these will automatically also be pasted. If there are
insufficient pages available in the document to paste the Alias objects to they will only be pasted
to the pages which are available in the document.

Section Working with Alias Objects

Duplicate objects

The Duplicate command is similar to the Copy command. The main difference is that the Copy com-
mand makes only one copy of the object, which can be pasted into the document with a predefined
offset. The Duplicate command allows you to make multiple copies of objects. Objects can also be
copied automatically to following pages with this command.

Duplicate objects

1. Select one or more objects.

2. Choose one of the following options:

• Press Ctrl + D (Windows/Linux) or Command + D (Mac).

• Choose Object > Duplicate.

3. Enter a value in the field Duplicates in the Number section.

4. Enter in the fields Horizontal Offset and/or Vertical Offset the offset that should be applied to each
duplicate. If you enter the value 0 in both cases, all duplicates will be placed on top of each other.

5. Define the object type:

• Copy — Independent duplicates will be created.

• Alias — Dependant duplicates will be created.

6. Define the page:

• Current Page — The duplicates will be placed on the current page.

• Duplicate on Following Page(s) — The duplicates will be placed on following pages, whereby
you can choose Left Pages, Right Pages or Left and Right Pages. In this case one duplicate will
be placed on each following page.

7. Select the option Link to Text Chain when the original object is a text object and you want the text
to flow into the duplicate objects.

8. Confirm the entry.
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Split objects

Another elegant way to create new objects is with the Split command. All Graphic, Picture or Text
objects can be split. However the following objects can not be split: Objects which are part of a text
chain/story, locked or protected objects, Alias objects and original objects that have connected Alias
objects.

Split objects

1. Select one or more objects.

2. Select one of the following options:

• Press Ctrl + Alt + Shift + T (Windows/Linux) or Command + Option + Shift + T (Mac).

• Choose Object > Split.

3. Enter the number of sections in the fields Horizontal and/or Vertical. As an option, you can also enter
a horizontal and/or a vertical offset in the fields on the right hand side of the dialog.

4. Define the object type in the Create section:

• Copy — Independent duplicates will be created.

• Alias — Dependant duplicates will be created. In this case the original object will be located in
the top left corner. All other objects will be Alias objects derived from it.

5. Select the option Link to Text Chain when the original object is a text object and the new objects
shall be part of the text chain.

6. Confirm the entry.

Lock objects

With the command Lock you prevent the interactive repositioning and resizing of objects (by mis-
take).

If the mouse pointer is moved over the frame of a locked object the lock pointer will be displayed. The
lock pointer for objects, consisting of a lock and an object pointer, shows that the object concerned is
locked and therefore cannot be moved.

Lock objects

1. Select one or more objects.

2. Choose one of the following options:

• Press Ctrl + Shift + L (Windows/Linux) or Command + Shift + L (Mac).

• Choose Object > Lock.

• Click the space next to the object in the Layers palette. A lock icon will appear.

Unlock objects

1. Select one or more locked objects.

2. Choose one of the following options:

• Press Ctrl + Alt + Shift + L (Windows/Linux) or Command- Option + Shift + L (Mac).

• Choose Object > Unlock.
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• Click the Lock icon next to the object symbol in the Layers palette.

As well as original objects, it is also possible to lock Alias objects. Please note, however, that the
locking of Alias objects is under certain circumstances only of a temporary nature. This is the case
when the original object is resized - the Alias object will change accordingly. In this case the locked
Alias objects must be unlocked automatically, because the connection between original and Alias
Objects is absolute. Locked Objects can still be deleted!

Section Paste objects
Section Duplicate Objects
Section Working with Alias Objects

Section Working with Layers

Protect objects

With the command Protection you prevent the content of certain objects from being altered and at
the same time prevent the object from being deleted.

If the mouse pointer is moved over a protected object, the content lock pointer will be displayed. The
lock pointer for both picture and text objects consists of a lock and a pencil and shows that the con-
tent of the object is protected and can therefore not be edited.

Protect objects

1. Select one or more objects.

2. Choose one of the following options:

• Press Ctrl + Shift + H (Windows/Linux) or Command + Shift + H (Mac).

• Choose Object > Protection.

Cancel protection

1. Select one or more protected objects.

2. Choose one of the following options:

• Press Ctrl + Shift + H (Windows/Linux) or Command + Shift + H (Mac).

• Choose Object > Cancel Protection.

Modifying object properties

Resizing objects interactively

The program provides many options to define the size and form of objects interactively or with the
help of palettes and dialogs.

When an object is selected, its selection handles will appear as described in the section Selecting
Objects. The selection handles show that the object may be modified. The selection handles are dis -
played in the selection color and are not printed.
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Selection handles are either sizing handles or control handles. Rectangles, ovals, polygons, lines and
orthogonal lines all have sizing handles that are displayed as a rectangle. Bézier curves and closed
Bézier objects also have control handles, which are displayed as points. A sizing handle may have one
or two tangents at whose end points control handles are displayed.

To resize an object, position the mouse pointer exactly on one of the sizing handles. The mouse
pointer will be positioned exactly on a sizing handle when the sizing pointer is displayed. If you now
hold down the mouse button and drag the mouse in the required direction, the object will be resized.

During the resizing operation, you will see the same imaginary frame or the same imaginary line that
you already know from the creation of a new object.

Resize/scale rectangle and oval interactively

1. Create a rectangle or an oval.

2. Change the size and form of the rectangle or oval using the nine sizing handles:

• Position the mouse pointer on one of the four middle sizing handles if you only want to resize
the object’s height or width.

• Position the mouse pointer on one of the four sizing handles at the object corners if you want to
resize the object‘s height and width simultaneously.

• Position the mouse pointer on the scaling handle next to the bottom right hand corner of a text
or picture object to scale the object and its content proportionally at the same time.

3. Hold down the mouse button.

4. Keeping the mouse button held down, move the mouse in any direction.

• Hold down the Shift key as well if you want to resize the object proportionally.

• Hold down the Ctrl key as well as the Shift key if you have selected a corner sizing handle and
also want to resize the text or image content proportionally with the object.

• Hold down just the Ctrl key if you have selected a corner sizing handle and also want to resize
the text or image content unproportionally with the object.

5. Release the mouse button when the object has the desired form and size.

Resize polygons and lines interactively

1. Create a polygon, a line, an orthogonal line or a path.

2. Position the mouse pointer on a sizing handle and hold down the mouse button.

3. Keeping the mouse button held down, move the mouse in any direction.

• When resizing a polygon or a multiple line, hold down the Shift key if a line segment should be
displayed as an orthogonal line.

• When resizing a line, hold down the Shift key if the line should be displayed as an orthogonal
line.

• When resizing an orthogonal line, hold down the Shift key if the orthogonal line should be dis-
played as a line with any angle.

4. Release the mouse button when the object has the desired form and size.
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Resize curves and Bézier objects

1. Create a curve or a Bézier object.

2. Position the mouse pointer on a sizing handle if the curve is to be resized symmetrically and hold
down the mouse button.

3. Position the mouse pointer on a control handle if the curve is to be resized asymmetrically and
hold down the mouse button:

• Keeping the mouse button held down, move the mouse in any direction to lengthen the tan-
gent.

• When resizing the curve, hold down the Ctrl key as well if you want to keep both tangents the
same size.

• Keeping the mouse button held down, move the mouse in any direction and hold down the
Shift and Ctrl keys as well to break the tangent.

4. Release the mouse button when the object has the desired form and size.

Delete sizing handles

With multiple lines, polygons, open and closed curves the application allows you to delete one of the
object’s selection handles. Move the mouse pointer over the sizing or control handle which is to be
deleted.

The sizing pointer will now appear. If you now press the Alt + Shift (Win dows/Linux) or the Option +
Shift shortcut keys (Mac), the sizing pointer will be displayed with a minus sign. Now you can delete
the point by clicking the mouse button. When a sizing handle is deleted, its control handles will auto-
matically be deleted with it.

Delete sizing and control handles

1. Position the mouse on a sizing handle or control handle, hold down the Alt + Shift (Windows/
Linux) or Option + Shift shortcut keys (Mac).

2. When the sizing pointer with the minus sign appears, click once.

Create a half-circle

1. Create a circular object.

2. Choose Object > Form > Convert to Polygon.

3. Delete the central sizing handle from the bottom edge of the object by holding down the Alt + Shift
(Windows/Linux) or Option + Shift shortcut keys (Mac) and clicking the mouse button.

4. Delete the bottom two control handles from the left and right sides of the object holding down the
Alt + Shift (Windows/Linux) or Option + Shift shortcut keys (Mac) and clicking the mouse button,
so that the bottom sizing points of the object left and right only possess one tangent.

Add sizing handles

As well as the deleting of both sizing handles and control handles, the application also allows you to
add sizing handles. The new sizing handle will appear on top of the original sizing handle you were
modifying and will still have to be positioned.
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Add a sizing handle

1. Select a polygon/bézier object or a path.

2. Position the mouse pointer on one of the sizing handles. The sizing pointer will now appear.

3. Hold down the Alt key (Windows/Linux) or the Option key (Mac). The sizing pointer will be dis-
played with a plus sign. Now click with the mouse to create the new handle.

4. Release the Alt key (Windows/Linux) or the Option key (Mac), but hold down the mouse button
again and move the sizing pointer in any direction to position the new sizing handle.

5. Release the mouse button once you have achieved the desired shape.

Automatic Scaling

As you have already learned in the section Sizing objects interactively, the image content of rectan-
gles and ovals may also be scaled interactively with the object.

In practice it often occurs that not just one object but a whole group of objects should be displayed
in a smaller or larger form. For example, when you need to scale down a page from A4 paper size to
A5 paper size you would normally have to change all the objects interactively or numerically with the
help of the object measurement settings. This would only change the frame size but not the content of
the frame, which you would have to scale down separately.

To solve this problem quickly and elegantly the application offers you the Scaling command in the
Object menu.

Scale objects and groups proportionally with the dialog

1. Select a single object or a group of objects. Please refer to the section Working with groups.

2. Choose Object > Scaling.

3. In the section New Size, define the scaling or the new size of the object or group:

• Enter a value between 1% and 1000% in the Scaling field to make a relative scaling. While with
the entry 100% nothing will change in the object measurements, the entry 120% will mean that
the object is enlarged by a factor of 1.20. The value 50% will reduce the object to half its origi-
nal size. After the scale factor is entered, the new width and height settings will be computed
automatically.

• Alternatively, enter values in the Width and Height entry fields to give an absolute scaling.
Since the Scaling command only scales objects and object groups proportionally, the values in
the field Width change whenever the values in the Height field are changed. This is also true the
other way around.

4. Define in the section Scaling Attributes whether and which object and content attributes should be
scaled:

• Line Width — The line or frame width will be scaled proportionally.

• Picture Attributes — The scaling of the image content and its positioning in the object will be
scaled proportionally.

• Text Attributes — Text attributes such as font size, text indents or line spacing will be scaled
proportionally.

• Text Object Indent — The special indent settings of the text object will be scaled proportionally.
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• Column Gutter — The gutter in a text object with several columns will be scaled proportionally.

5. Confirm the entry.

Summary Resizing objects
- Sizing handles control object size.

- Control handles control the curvature of a line.

- Sizing handles and control handles can be moved in any direction.

- The two control handles of a sizing handle can be at different distances from it.

- The slope control of one tangent line can be split into two tangent lines by holding down the Ctrl
+ Shift (Windows/Linux) or the Command + Shift shortcut keys (Mac).

- Sizing handles and control handles can be deleted by holding down the Alt + Shift (Windows/
Linux) or Option + Shift shortcut keys (Mac), and clicking the points to be deleted.

- The deletion of a sizing handle will automatically delete its control handles.

- Sizing handles can be added by pressing the Alt key (Windows/Linux) or Option key (Mac) and
clicking the mouse with the sizing pointer over an existing sizing handle.

- Multiple objects can be resized proportionally using the command Scale.

- Object scaling can be relative or absolute.

- As well as the object size, its content can be scaled.

Object fill

Fill Color, Density, Transparency

The following properties may be changed either with the Quick Access palette or the Module palette.
With new documents the program provides a set of standard colors.Please refer to the chapter Work-
ing with Colors.

Change fill color with the Module or Quick Access palette

1. Create or select a closed object.

2. Select a color or blend from the popup menu Color in the Fill section in the Module palette or the
Quick Access palette.

3. Define the color shade in the Shade field:

• Enter a value between 0% and 100%, or select an entry from the popup menu to define the fill
color shade. The value 0% means that the object fill will be displayed as white.

• Enter the value -1 or Transparent, or select the entry Transparent from the popup menu to
switch off the fill color. This function is the same as the option None for the fill color in other
programs.

4. Define the opacity/transparency of the fill color in the Opacity field:
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• Enter a value between 0% and 100%, or select an entry from the popup menu.

5. Enter a value in the field Color Blend Angle if the fill color is a blend.

Change fill color

1. Select a closed object.

2. Choose a color or blend from the popup menu Color in the Fill Color section.

3. In the Shade field of the Fill Color section, define the density or transparency of the color:

• Enter a value between 0% and 100%, or select an entry from the popup menu to define the fill
color shade. The value 0% means that the object fill will be displayed as white.

• Choose the option [None] from the popup menu to switch off the fill color and make the object
transparent.

4. Enter a value in the field Blend Angle of the Module palette if the fill color is a blend.

5. Define the opacity/transparency of the Fill Color:

• Enter a value between 0% and 100% or select an entry from the popup menu Opacity in the
Module palette and confirm the entry.

• Use the Opacity slider in the Quick Access palette.

Lines and Frames

Line Color, Shade, Transparency

With new documents the program provides a set of standard colors. Please refer to the section Work-
ing with Colors.

Change Line color with the Module/Quick Access palette

1. Create or select an object.

2. Choose one of the following options:

• Choose a color from the popup menu Line Color in the Line/Frame section of the Module palette.

• Move the mouse over the Line/Frame Color symbol in the Quick Access palette and choose a
color.

3. Define the line color shade or transparency:

• Enter a value between 0% and 100% in the Line Shade field in the Module palette, or select an
entry from the popup menu to define the color shade.

• Use the Opacity slider in the Quick Access palette.

The value 0% means that the object frame will be displayed as white if the frame width is
greater than zero.

• Choose the option [None] from the popup menu to switch off the line/frame color and make the
line or frame color transparent.

4. Define the opacity/transparency of the frame or line:
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• Enter a value between 0% and 100% in the field Opacity (Line/Frame) in the Line/Frame section of
the Module palette or select an entry from the popup menu and confirm your entry.

• Use the Opacity slider in the Quick Access palette.

Change Line/Frame Width

The line width of a line object or object frame can be modified through the Module palette or the
Quick Access palette (Object mode). When using the line width there are several aspects to be noted:

- Because object coordinates are absolute the line widths of closed objects will always be drawn on
the inside of an object as default. With line objects the line width will be equally applied to both
sides of the object. This setting may be changed manually.

- When a graphic object is converted to a text object the line/frame width is reset to 0 (zero) auto-
matically.

- When a line width is applied to a text object, the text in this object will be indented automatic-
ally by the line width value.

- When a line width is applied to criss-cross polygons, this can for mathematical reasons lead to
incorrect results.

Change Line Width with the Module/Quick Access palette

1. Create or select several objects.

2. Choose one of the following options in the Module palette or Quick Access palette to define the line
or frame width:

• Enter a value in the Line Width field.

• Choose an entry from the popup menu.

Change Frame type (line style)

A frame type can be defined in the Module palette or the Quick Access palette (Object mode). When
using line styles there are several aspects to be noted:

- When applying frame types, the program always applies the frame in relation to the line width,
so that the frame always meets at closed object corners and that line objects always have neat
ends.

- The spaces between line segments remain transparent, irrelevant of which color and shade has
been selected for the frame.

Change Line Style

1. Create or select an object.

2. Choose one of the following options:

• Choose an entry from the popup menu Line Style in the Module palette.

• Move the mouse over the line style in the Quick Access palette and choose an entry from the
popup menu Style.

• If you have chosen a line style other than Solid, you can optionally choose a Line Gap Color and
a Line Gap Shade.
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Change Line ends

The line ends of a line object can be modified through the Module or Quick Access palette (Object
Mode) or the Object Settings. When using the line ends please note:

- When applying line ends you should be aware that the program always applies the end form in
relation to the line width.

- It is also important to note that lines with differing ends may be printed differently, although
they posses the same co-ordinates.

Change Line ends

1. Create or select a line/path.

2. Choose an entry from the popup menu Line Start and/or Line End for one or both ends of the line.

Change Line Join

1. Create or select a closed object.

2. Choose an entry from the popup menu Line Join.

• If required, modify the entry Miter Limit.

Change Line Cap

1. Create or select a line/path.

2. Choose an entry from the popup menu Line Cap.

Change Radius

The corner radius of a rectangular object can be modified through the Module or Quick Access palette
(Object Mode). When using the radius please note:

- The radius is only applied to rectangles or squares. It has no effect on other objects.

- When a radius is applied to text objects the text at the object corners is automatically indented
according to these settings.

Change radius with the Module/Quick Access palette

1. Create or select a rectangle or square.

2. Choose one of the following options:

• Enter a value in the Corner Radius field of the Module palette or the Quick Access palette.

• Choose an entry from the popup menu Radius.

Objects with predefined settings

Create object with predefined settings

1. Create a closed object (graphic, text or picture object) and apply a fill color, frame attribute and a
radius to it.

2. Keeping the object active, choose another closed object tool and create the new object.
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Object Grouping
The application allows you to group a number of objects on one page. This is particularly helpful if a
group of several different objects are to be treated as one object.

Create and recognize a Group

You can use the Group command whenever there are more than two objects selected. The application
also supports hierarchical grouping. This means a group may be part of another group. There is no
upper limit to the number of groups.

Create a Group

1. Select at least two objects.

2. Choose one of the following options:

• Press Ctrl + G (Windows/Linux) or Command + G (Mac).

• Choose Object > Group.

A group has been created successfully when the selected objects are deselected and a rectangular
frame is shown around these objects.

Creating a Group Hierarchy

1. Select both the group you created in the previous example and an additional object.

2. Choose one of the following options:

• Press Ctrl + G (Windows/Linux) or Command + G (Mac).

• Choose Object > Group.

An Alias object can also be part of a group. Changes made to the original object will still be inherited
by the Alias object.

Create a Group with an Alias object

1. Select at least two objects.

2. Create Alias objects of both objects and place them on the page below their original objects.

3. Select the first original object and the second Alias object.

4. Choose one of the following options:

• Press Ctrl + G (Windows/Linux) or Command + G (Mac).

• Choose Object > Group.

If the second original object in the upper row is selected and modified, the changes will of course be
reflected in the Alias object in the group. You can also create an Alias of a group.

Create Alias of a Group

1. Select the group from the previous example.

2. Choose one of the following options:

• Press Ctrl + x (multiplication) or Ctrl + Shift + * (Windows/Linux) or Command + * (Mac).

• Choose Object > Alias > Create Alias.
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Section Working with Alias Objects

Select objects in a group

It frequently happens that you need to modify an object which is part of a group. You do not need to
ungroup the whole group first; you can select and edit single objects in the group directly.

Select object in a group

1. Select an object group.

2. Choose one of the following options to deactivate the group mode:

• Press Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

• Choose Object > Group Mode Active.

3. Select the desired object in the group and make some modifications to the attributes (e.g. object
size/position, fill color/density or frame color/density) as already described.

4. Choose one of the following options to reactivate the group mode:

• Press Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac).

• Choose Object > Group Mode Active.

Ungroup

This command enables you to disable the group feature and display the elements in their original
state. Since the program works with hierarchic groups, there may be groups within groups. This hier-
archy is retained when ungrouping. Therefore you may need to repeat the Ungroup command several
times to ungroup the group completely.

Ungroup

1. Select the group.

2. Choose one of the following options to deactivate the group mode:

• Press Ctrl + U (Windows/Linux) or Command + U (Mac).

• Choose Object > Ungroup.

Please note that Alias objects are virtual copies of their original objects. If a group of grouped
objects which has a corresponding Alias group is ungrouped, the Alias group will completely dis-
appear since it can not be broken down into singular objects.

Resize a group

You can resize a group interactively. The group may be resized proportionally or disproportionally.

Resize a group proportionally

1. Select the group.

2. Click the scaling handle (bottom right of the group to the left of the bottom right sizing handle)
and drag the mouse in any direction.
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Resize a group disproportionally

1. Select the group.

2. Click a sizing handle and drag the mouse in any direction.

Summary Object Grouping
- Objects can be grouped with the menu command Object > Group or by using the shortcut keys

Ctrl + G (Windows/Linux) or Command + G (Mac).

- Alias objects can be part of a group. The original object does not have to be part of that group.

- Objects in a group may be edited individually without the group being ungrouped by pressing
the shortcut keys Ctrl + Alt + U (Win dows/Linux) or Command + Option + U (Mac).

- The content of grouped objects can only be edited when the group mode is deactivated.

- Pressing the shortcut keys Ctrl + Alt + U (Windows/Linux) or Command + Option + U (Mac) again
reactivates the group mode.

- Groups are ungrouped with the menu command Object > Ungroup or by using the shortcut keys
Ctrl + U (Windows/Linux) or Command + U (Mac).

- An Alias object of a group of original objects will completely disappear if the original objects are
ungrouped. A warning dialog will be displayed in this case.

Combine Objects with the Pathfinder
The program provides the function of combining objects to create special object forms and special
effects. We will illustrate the different functions available in a series of exercises. First you need to
prepare the objects you want to combine.

Preparing objects

1. Create two circular objects.

2. Give each object a different fill color.

3. Move the second object so that it overlaps but does not cover the first object.

Unite Paths

1. Mark both objects.

2. Choose Object > Shape > Unite Paths.

3. In the Smoothing dialog, choose the degree of smoothing you require for the new object.

The two objects will be combined into one object consisting of the outer edges of both objects. In the
case of two circles with an overlap, the new object will resemble a figure 8.

Subtract Paths

1. Mark both objects.

2. Choose Object > Shape > Subtract Paths.
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3. In the Smoothing dialog, choose the degree of smoothing you require for the new object.

The two objects will be combined into one object consisting of the outer edge of the first object and
the overlapping part of the second object. In the case of two circles with an overlap, the new object
may resemble a moon that is not full.

Intersect Paths

1. Mark both objects.

2. Choose Object > Shape > Intersect Paths.

3. In the Smoothing dialog, choose the degree of smoothing you require for the new object.

The two objects will be combined into one object consisting only of the overlapping part. In the case
of two circles with an overlap, the new object will resemble an oval with two end points.

Exclude overlap

1. Mark both objects.

2. Choose Object > Shape > Exclude Overlap.

3. In the Smoothing dialog, choose the degree of smoothing you require for the new object.

The two objects will be combined into one object consisting of the outer edges of both objects. The
overlapping part of both objects is cut out and therefore transparent.

In all object combinations, the new object will take on the fill color of the first object created (or the
object on the lowest level). You can check this by marking the second object and applying the menu
command Send to Back and repeating the above action. You can of course also alter the fill color of
the new object in the usual way.

- Now try combining two differently shaped objects. For example, a circle and a triangle may be
combined to make a keyhole shape, a series of circles may be combined to make a cloud shape,
and so on.

Text may also be converted into “paths” (objects) for special effects. Using the command Unite Paths
combines the individual letter objects into one single object.

Convert text to paths

1. Create a text object.

2. Type a word such as BEACH.

3. Mark the text and format it so that the word almost fills the object and the letters are quite strong.

4. Mark the object (object mode).

5. Choose Object > Shape > Convert Text to Paths.

6. You will see that your word is now a group of graphic objects. Ungroup the objects as previously
described.

• You can now give each letter in the word an individual fill color or blend and a frame color.

Combine the paths of the objects/letters of the word

1. Mark all the objects in the word.
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2. Choose Object > Shape > Unite Paths.

3. Choose a Smoothing factor as described above.

Now that your word has been converted into a single object, you can decide which attributes it
should have. Create a color blend and apply it to the object as a fill color, and try changing the blend
angle to see the effect. Give the object a shadow in a color of your choice. Change the object from a
graphic object into a picture object and import a picture/photo of your choice, such as a beach
scene.

Special object properties and commands

Printable/non-printable

When creating a document, you may want to create certain objects that are not to be printed, but are
needed as assistance or information for you as the editor. Some objects, such as the guide lines you
drag onto the page with the ruler, or those you define in the Grid section of the Document Setup dia-
log, are non-printable by default. Normally all closed objects and lines created using the object tools
have the default setting Print. However, a potential problem would arise if you make one object non-
printable, and, leaving this object active, create a new object, which is also non-printable, having
the same attributes as the first object. Taken to its logical extreme, this simple error could mean that
a whole series of non-printable objects is scattered through the entire document with the resulting
high costs of reprinting.

To solve this problem and in co-operation with customers, VIVA has inserted a red button with a
white cross, which appears on the center of the object as soon as it is designated “non-printable”.
This button appears for all closed objects, line and multiple line objects. The only exceptions are the
orthogonal line and the guide lines drawn from the Ruler. When checking your document before
printing, you can see at a glance if there are non-printable objects on the page.

Make objects non-printable

1. Create a closed object, a line and a multiple line and select them.

2. Choose one of the following options:

• Double-click one of the selected objects (graphic objects).

• Double-click the frame of one of the selected text or picture objects.

• Double-click the gray selection button in the middle of one of the selected text or picture
objects.

• Press Ctrl + M (Windows/Linux) or Command + M (Mac).

• Choose Object > General in the menu or General in the context menu.

3. In the Object Settings dialog or in the Module palette (Object mode), click the checkbox Print, so
that the checkmark disappears.

4. Confirm the entry.

You will see that the red button appears for all objects.

Please refer to the section Objects with predefined settings.
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Effects

Shadow/Drop Shadow

You can apply a so-called “Drop Shadow” to all closed objects, text or picture content. Here specific
criteria must be fulfilled to achieve the desired effect(s). We will illustrate this in a number of exer-
cises.

Create closed objects with Drop Shadow

1. Create a graphic rectangle.

2. Click away from the object to ensure that the default values for objects are set and create a text
rectangle and a picture rectangle.

3. Mark all three objects.

4. Choose Object > Effects in the menu or Effects in the context menu.

The dialog with the default settings appears.

5. Click the checkbox Drop Shadow. Confirm the entry.

You will see that the graphic object now has a Drop Shadow while the text and picture object do not.
This is because, with their default settings, they are transparent and have no content (are empty).

6. Now select just the text and/or picture object. Change the Fill Color Shade from Transparent to
100%.

Create text content with Drop Shadow

1. Select the text object from the previous exercise.

2. Change the Fill Color Shade back from 100% to Transparent.

3. Click in the object to activate Text Mode and type the word TEXT.

4. Increase the object size and/or font size in order to see the effect clearly.

Create picture content with Drop Shadow

1. Select the picture object from the first exercise.

2. Change the Fill Color Shade back from 100% to Transparent.

3. Click in the object to activate Picture Mode and import an image with a transparent background.
The image may be a bitmap in TIFF, PNG or PDF format created in/exported from an image editing
program or a vector graphic image created in an illustration program and saved as a PDF file. The
JPEG format does not support transparency and should not be used here!

4. Increase the object size and/or image size in order to see the effect clearly.

Section Working with Text, section Working with Pictures

Now you can experiment with the Drop Shadow settings to see the different effects.

Change Drop Shadow settings

1. Select an object and open the Effects dialog.
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2. Choose the options you want to change:

• Change the Color, Shade or Opacity of the Drop Shadow.

• Change the Mode of the Drop shadow to see which mode suits best. Some modes will show no
shadow.

• Change the Angle, Offset, Blur or Scaling of the Drop Shadow.

3. Confirm the entry.

You can also change the opacity of the object itself to change Drop Shadow effects.

Inner Shadow
Outer Glow
Inner Glow
Color Overlay
Reflection
Transparency incl. new tool

Run Around

When you create a layout on the page, you may wish to have an object or objects fixed on the page
with the text flowing around them. The program offers a special dialog for this function. We will illus-
trate this with some simple exercises.

Create and use an object with Run Around features

1. Create a graphic, text or picture object.

2. Select the object and choose one of the following options:

• Press Ctrl + T (Windows/Linux) or Command + T (Mac).

• Choose Object > Run Around in the menu or Run Around in the context menu.

3. Choose the run around Method from the popup menu:

• Left — The run around will only be on the left side of the object. This is a suitable option for
objects positioned on the right hand side of the layout.

• Right — The run around will only be on the right side of the object. This is a suitable option for
objects positioned on the left hand side of the layout.

• Both sides — The run around will be on both sides of the object. This is a suitable option for
objects positioned in the middle of the layout.

4. Choose the runaround Form from the popup menu:

• Block, if you want to have different distances from different sides of the object to the text.

• Object contours, if the object is a polygon or has a bézier shape. In this case only a total dis-
tance from the object contours to the text may be defined.

• Image boundaries, if the image is smaller than the picture object. In this case only a total dis-
tance from the image boundaries to the text may be defined.

• Clipping path, if the image has a clipping path. In this case only a total distance from the clip-
ping path to the text may be defined. For information regarding the creation of clipping paths
for images, please refer to your image editing program to check if it is capable of creating
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these. You will find an example of this option in the example file “Brochure 02.desd” in the
folder “Examples”.

• Click the checkbox Run around empty Picture Objects for the options Clipping Path or Image
boundaries to ensure that if the picture object is empty the text will run around the object. This
gives you a visual control and enables you to fill, delete or move the object as necessary before
printing the document.

5. Confirm the entry.

Special object settings for images

In addition to the General object settings, the Run Around and the Effects settings, there are a number
of special settings for picture objects that are made in the Special Settings dialog. Some of these set-
tings are duplicated in the Module palette in Picture Mode and may also be entered in the palette.

Special settings for images

1. Create a picture object and import an image.

2. Activate Object mode and select the object.

3. Choose one of the following options to open the Special Settings dialog:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or Special in the Context menu.

4. Enter your special settings as required:

• Values for horizontal and/or vertical image Scaling.

• Values for horizontal and/or vertical image Offset.

• Click the checkboxes for horizontal and/or vertical Mirroring.

• Values for Rotation and/or Skew.

5. Confirm the entry.

Section Working with Pictures

We have already mentioned images which possess a clipping path, that is, the image background,
whether colored or transparent, is ignored. This enables such images to be laid on a colored back-
ground in the document for a “clean” output. In many cases, however, images are used that do not
have a clipping path or whose format does not allow clipping or a transparent background. One
example of such images is the JPEG format. JPEG images usually have a white background as default,
but may of course have a background in another solid color. For images like this the program pro-
vides the Automatic Clipping function.

Apply Automatic Clipping to an image

1. Create a picture object with a fill color and import an image with a solid background (white or any
other color).

2. Open the Special Settings dialog as described above.

3. Use the scroll buttons to set the Automatic Clipping or type a value, such as 10.

4. Confirm the entry.
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Section Working with Pictures

Another function in the Special Settings dialog is the checkbox Individual Alias Content in the Content
Option section. This command is activated when

- You have created Alias objects of a picture object, either on the same page or on following
pages. These have the same graphic attributes as the original, and the command enables each
Alias object to contain a different image.

- You have created picture objects on an Alias page (such as for a photo book) which will be filled
individually.

References:

Section Working with Alias objects

Section Working with Pictures

Section Working with Pages

Special object settings for text

In addition to the General object settings, the Run Around and the Effects settings, there are a number
of special settings for text objects that are made in the Special Settings dialog. Some of these settings
are duplicated in the Module palette in Text Mode and may also be entered in the palette.

Enter special settings for text

1. Create a text object and enter some text.

2. Choose one of the following options to open the Special Settings dialog:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Enter your settings in the Main Text tab:

• Enter values for Text Indent. These are values for the object and bear no relation to the Para-
graph Indent, Left Indent or Right Indent, which are text (paragraph) attributes.

• Click the checkboxes Linkable with Original and Individual Alias Content. if you will make Alias
copies of the object that have the same graphic attributes but different content, or if you will
copy the object to an Alias page. Please refer here to the section Working with Alias objects >
Flexible Alias Content.

• Choose an option for First Baseline.

• Ascent Height means that the distance between the object frame and the baseline of the first
line of text corresponds to the Ascent Height of the font.

• Cap Height (standard setting) means that the distance between the object frame and the base-
line of the first line of text corresponds to the height of the letter “M” of a font. (14.9.2015)

• Largest Character means that the distance between the object frame and the baseline of the
first line of text corresponds to the height of the letter “d” of a font.

• x-Height means that the distance between the object frame and the baseline of the first line of
text corresponds to the height of the letter “x” of a font.

• Baseline means that the baseline of the first line of text will be placed on the object frame.
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• Line Spacing means that the distance between the object frame and the baseline of the first line
of text corresponds to the height of the line spacing. (This option only works when the line
spacing is set to Auto!!)

• Fixed means that a fixed value will always be added to the distance set (Option First Baseline)
between the object frame and the first baseline.

• Minimum means that the value will only be applied when it is larger than the baseline position
that has already been calculated.

• Minimum means that a value will be added to the distance set (Option First Baseline) between
the object frame and the first baseline if this is larger than the set value. If for example the
minimum value is 2 mm, the setting for the first baseline is Cap Height and the font size is 18 pt,
the value will not be applied, because the distance between the object frame and the first
baseline is already more than 2 mm. If the value 5 mm is entered, this will be applied accord-
ingly.

4. Make your settings in the Text Columns tab:

• Enter the number of columns in the Number field.

• Enter the gutter value in the Offset field.

• If required, activate the Column Lines and choose the settings as needed.

• If required, activate the individual object Baseline Grid and apply settings as needed. This grid
is only applied to the object in question and is independent from the main Baseline Grid in the
document.

5. Make your settings in the Header & Footer tab:

• Activate the checkboxes Header and/or Footer and enter an appropriate value (the default
value is 10 mm).

• Choose appropriate settings for Footnotes as required.

6. Confirm the entry.

Section Working with Alias objects

Section Working with Text

Section Working with Typography

Section Working with Footnotes

Section Working with Pages

Notes

With the Notes function you can apply non-printable information and tips for other users to text and
objects. This option is suited for users who work in a team or for users who only want to create a
report of their work.

Section Working in a Team
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Using Guide Objects
Guide objects are objects which have “magnetic” properties. Guide objects will “attract” other objects
during creation, moving and resizing in a magnet-like way. Guide objects simplify the positioning of
objects in your document since they will automatically align objects for you with their magnetic
characteristics.

Any object regardless of the form and type can be a Guide object which “attracts” other objects.
Therefore all Guide objects may be assigned the same commands as objects that are not Guide
objects. Among these are the exact positioning as well as the changing of the display.

Guide objects can be created automatically and manually, and shown or hidden with a keystroke.

There are seven ways to specify Guide object settings :

- The option Guide Object in the Object Settings dialog in the menu Object > General.

- The option Guide Object in the Object section in the Module palette (Object mode).

- The Snap to Distance option in the Preferences dialog (Tab Pages & Objects).

- The menu command View > Guide Objects selectable.

- The menu command View > Show/Hide Guide Objects.

- The option Grid: Behind/Front in the Preferences dialog (Tab Program > General, Options section).

Section Align Objects
Section Working with Documents, Document Setup (Grid)

Create Guide Objects automatically

The program offers two options to create Guide objects automatically:

- The automatic creation of Guide objects with the Grid option in the Document Setup dialog.

- The creation of Guide objects with the Ruler.

In the first case the program creates horizontal and vertical Guide objects on the first Alias page.

In the second case the user creates Guide objects interactively by dragging lines from the Ruler.

Create Guide object with Ruler

1. Ensure that the Ruler is shown. If this is not the case,

• press Ctrl + R (Windows/Linux) or Command + R (Mac).

• choose View > Show Ruler.

2. Ensure that the Guide objects are visible. If this is not the case,

• press Ctrl + Alt + G (Windows/Linux) or Command-Option + G (Mac).

• choose View > Show Guide Objects.

3. Ensure that the Guide objects are selectable so that you can position your Guide objects later. If
this is not the case,

• press Ctrl + Alt + Shift + G (Windows/Linux) or Command + Option + Shift + G (Mac).

• choose the menu command View > Guide Objects Selectable.
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4. Position the mouse pointer in the horizontal or vertical ruler to create a horizontal or vertical line
with the Guide object property.

5. Hold down the mouse button and drag a line onto the document page. An imaginary line will be
shown.

6. Release the mouse button at the position of your choice.

The object stays selected and it can be positioned exactly with the Object palette or the Object Set-
tings.

If you now select the Object Settings dialog, you will see that the Guide object option is activated. At
the same time the program assumes that you need the automatically created Guide objects to posi-
tion other objects. therefore the option Print is de-activated, but you can change this at any time.
further, the object is automatically assigned the default color [Guide Objects]. The color [Guide
Objects] is predefined in the program as fluorescent green, but may be changed at any time. For fur-
ther information on this subject please refer to the chapter Working with Colors.

Create Guide Objects manually

Any object regardless of the form and type can be a Guide object which “attracts” other objects mag-
netically.

Create Guide object manually

1. Ensure that the Guide objects are visible. If this is not the case,

• press Ctrl + Alt + G (Windows/Linux) or Command + Option + G (Mac).

• choose View > Show Guide Objects.

2. Select one or more objects.

3. Choose one of the following options:

• Open the Object Settings and choose the option Guide Object.

• Choose the option Guide Object in the Object section of the Module palette.

4. If the Guide object is not to be output, as with the automatically created Guide objects, . deacti-
vate the option Printable in the Object section of the Module palette.

Select Guide Objects

Guide objects generally serve as position guides for other objects. This is particularly true of those
Guide objects that are created automatically with the Ruler and are not printed. So that Guide objects
are not selected by mistake, their selectability may be switched on or off for the whole document.

Guide Objects Selectable On/Off
Choose one of the following options:

• Press Ctrl + Alt + Shift + G (Windows/Linux) or Command + Option + Shift + G (Mac).

• Choose View > Guide Objects Selectable.

If in front of the command a tick or checkmark is shown, Guide objects are selectable. If no checkmark
is shown they are not selectable. The command is similar to the commands Lock and Protection in
practice, but is much quicker to use.
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Show Guide objects

The Grid of Guide objects created through the Document Setup dialog is helpful for exact positioning.
The grid lines themselves are not part of the document layout. In fact in practice most Guide objects
displayed as lines are only useful in positioning.

In order to view the layout of your document you may want to hide all Guide objects which are not
really a part of the basic layout.

Hide/Show Guide objects
Choose one of the following options:

• Press Ctrl + Alt + G (Windows/Linux) or Command + Option + G (Mac).

• Select View > Show Guide Objects.

Please note that Guide objects still possess their “magnetic” properties also when they are hidden.
Guide objects which are hidden can not be selected.

The display and hiding of help objects can also be used in a meaningful way. For example, when
designing, you can assign large image objects with the attribute Guide object. If the scaling factor is
now greatly increased, you will first hide the Guide objects. This speeds up the workflow enormously,
because the images do not have to be extremely enlarged. If you then return to the original scaling
factor, you can show the Guide objects again.

Magnetism

If objects are moved or stretched in the direction of a Guide Object they will automatically snap to
that Guide Object like a magnet. Whether and at which distance objects are attracted depends on the
setting for the Snap to distance.

Guide objects are magnetic as default.

The distance from which an object is attracted magnetically depends on the Snap to distance. The
value for the Snap to distance is entered in screen pixels and as a default is entered as 10 pixels. This
value is independent of the scaling factor in which the document is displayed.

This means that Guide objects will apply their magnetic attraction already at quite a small distance
when the zoom factor is below 100%. By contrast, Guide objects attract other objects at a relatively
great distance when for example the zoom factor is above 200%. The standard value for the Snap to
distance may be changed at any time.

Change Snap to Distance for Guide objects

1. Choose Edit > Preferences > Pages & Objects (Windows/Linux) or [Program nameApplication Name] >
Preferences > Pages & Objects (Mac).

2. Enter the value 20 in the field Snap to Distance. This means that magnetic objects will already
attract other objects when they are resized or moved and the distance between the objects is less
than 21 screen pixels.

Summary Using Guide Objects
- Any object, regardless of its type or form, can be a Guide object.
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- Guide objects can be created with the option Guide Object in the Object Settings dialog.

- Guide objects can be created as Guides by dragging them from the Ruler.

- Guide objects can be created automatically through the Grid option in the Document Setup dia-
log in the menu File > Document Setup.

- Guide objects created through the Ruler or through the Grid option in the Document Setup dialog
are by default non-printable. This can however be modified by the user at any time.

- Guide objects will be drawn like normal objects in front of other objects if the Grid option in the
Program Preferences dialog opened with the menu command Edit > Preferences (Windows/Linux)
or [Program nameApplication Name] > Preferences (Mac) was not changed to Behind.

- Any change in the hierarchy of Guide objects using the option Behind in the dialog
Preferences > Program will only be applied to newly created Guide objects and not to
existing ones.

- The Snap to Distance setting specifies the screen pixel range in which the Guide object will
“attract” objects.

- The Snap to Distance setting is defined in the Objects tab in the Preferences > Pages & Objects dia-
log, menu command Edit > Preferences (Windows/Linux) or [Program nameApplication Name] >
Preferences (Mac). This setting is independent of the magnification factor chosen.

- Guide objects can either be selectable or non-selectable. This can be specified with the menu
command View > Guide Objects selectable. The shortcut keys for this command are Ctrl + Alt +
Shift + G (Windows/Linux) or Command + Alt + Shift + G (Mac).

- Guide objects can be hidden or shown with the menu command View > Show Guide Objects. The
shortcut keys for this command are Ctrl + Alt + G (Windows/Linux) or Command + Option + G
(Mac).

Working with Alias Objects

Creating Alias objects

In the section Create objects, we noted that is a difference between original and Alias objects. Since
an Alias object is a copy of an original object, there is no Alias without an original. To create an Alias
object, select an object on your document page and choose the menu command Object > Alias > Cre-
ate Alias or use the appropriate shortcut keys. The object you select may be an Alias object itself,
which saves you time trying to find the original object, which could well be on another page.

Create an Alias object

1. Choose one of the following options:

• Create a new object of any type.

• Select an existing object.

2. Choose one of the following options:

• Press Ctrl + x (multiplication) or Ctrl + Shift + * (Windows/Linux) or Command + * (Mac).

• Choose Object > Alias > Create Alias.
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An Alias object will now appear below and to the right of the original object. The original object will
be deselected and the newly created Alias object will be selected. The settings for the horizontal and
vertical offset from the original object are defined in the Pages & Objects section of the Preferences
and are the same as those used for pasting objects.

3. Now select the original object and make some changes to it, such as fill or frame color/shade/
opacity. The Alias object you have created takes over the changes automatically.

Another way to create Alias objects is to use the options with the Duplicate and New Document
Page(s) commands. These commands not only allow you to create Alias objects on the same page but
also on other pages.

Duplicate objects as Alias objects onto following pages

1. Create a document with two or more pages.

2. Create an object of your choice on the first page of the document.

3. Duplicate the object using the command Duplicate as described in the section Duplicate objects:

• Choose the number of duplicates according to the number of following pages in the document,
i.e. if your document has two pages, create only one duplicate.

• Choose Alias.

• Choose Duplicate on Following Page(s) and Left and Right Pages. One duplicate will be placed
on each following page.

4. Confirm the entry.

Duplicate objects as Alias objects on new pages

1. Create a document with one page.

2. Create an object of your choice on the (first) page of the document.

3. Add one or more document pages to the document:

• Choose Document > Create > New Document Page(s) or click the page in the Pages palette and
choose New Document Page(s) in the context menu.

4. Click the checkbox Take over Objects at the top right of the dialog.

5. Choose the option Take over as an Alias:

• Choose the default option All Objects on Page if you want to create Alias objects of all the
objects on the first page.

• If you have several objects on the first page and only want to create Alias objects from one
object, select this object first and then in the dialog choose the option All Selected Objects.

6. Confirm the entry.

A further method of creating Alias objects is to split a single object into identical sections using the
command Object > Split as described in the section Split objects.

In this section you have already been introduced to the features and behavior of objects. Many com-
mands can be applied to both original and Alias objects. There are also commands which are exclu-
sively applied to Alias objects and their connection with original objects. Through these commands
you are able to accomplish very complicated tasks.
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Find Original

The original object has to be selected before any modification can take place. When there are many
Alias objects on different pages in a document, finding the original object may be hard.

This is where the Find Original command comes in.

Find Original

1. Create a document with at least two pages.

2. Create an object of your choice.

3. Use the Duplicate command to create an Alias object on the following page(s).

4. Go to the following page. Select the Alias object and choose Object > Alias > Find Original.

The program jumps to the original object and selects it automatically.

Obviously this function works just as well if all your objects are on one page, overlay one another,
and so on.

Change Alias into a Copy

When using many objects you may feel the need to modify the content or appearance of an Alias
object directly, which can normally only be done through modifying the original object. This can be
done by converting the Alias to a copy of the original object, and then modifying it. After the object
is converted from an Alias to a copy it is not connected any more to the original object, so it will not
inherit any changes to the original object.

Change Alias into a Copy

1. Create an object of your choice, and then create an Alias Object from it as described above.

2. Select the Alias object.

3. Choose Object > Alias > Change into a Copy. The appearance of the sizing handles will change to
show you that the object is now an original and can be modified accordingly.

Flexible Alias Content

In the previous section the link between the original object and the Alias object was deleted by
changing the Alias into a copy of the object so as to be able to modify the content or the appearance
of this copy. When only the object content has to be modified and not the graphic properties such as
frame, fill, shade etc. there is an alternative to the Change into a Copy command.

Especially for this purpose the program allows you to define that the original text or picture object
has a flexible content. If you then create an Alias of this object, the Alias object will still inherit the
graphic properties from the original object but unlike standard Alias objects it will allow you to mod-
ify its content.

Create a Flexible Alias Text and/or Picture Object

1. Create a text object and/or a picture object.

2. Choose one of the following options to open the Special Settings Object dialog:

108



Working with Objects | Summary Alias Objects

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special. in the menu or Special in the context menu.

3. Click the checkbox Individual Alias Content and confirm the entry.

4. Create an Alias Object from each of the objects as previously described.

5. Check the success of your command by typing some text into the original OR the Alias text object
or by importing an image into the original OR the Alias picture object. If you now change the
graphic attributes of the original objects, these changes will still be taken over in their respective
Alias objects.

The same principle applies if you want to use the commands Duplicate or Split to create your objects.

Cancel the flexible content of an Alias Object

1. Select an original object that has a Flexible Alias Object.

2. Choose one of the following options to open the Special Settings Object dialog:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Click the checkbox Individual Alias Content off.

4. Confirm the entry.

You will now see that the Alias Object has taken over the properties of the original and that its content
cannot be changed. You can change the setting back to individual content again at any time, and
then make content changes in the Alias object.

Summary Alias Objects
- Alias objects are virtual copies of their originals. All attributes including content (for text and

picture objects) are taken over in the Alias Objects.

- Alias Objects of Text or Picture Objects may have an individual content if the original object has
the option Individual Alias Content activated in the Special Settings dialog.

- Alias objects may be created

• manually using shortcut keys, menu or context menu commands

• automatically with the Duplicate command

• automatically using the Split command

• automatically using the command New Document Page(s)

- Individual Alias Objects can be changed into a copy and thereafter edited.

- An Alias object can be a Guide object independently of the original object. Alias objects inherit
the Guide object status automatically if the original object is a Guide object. If an original object
with connected Alias objects is transformed into a Guide object, the Alias objects will not inherit
this property automatically.

- The command Find Original can be used to find the original object in larger documents.
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Working with Text
Text plays a central part in nearly all documents and publications. For centuries the
written word has been the bearer of information of all types. To create text safely
and quickly and to select and edit it, the program offers you a huge array of options.

Basics

Creating text objects

Text objects may be created using the Tools palette, the menu or shortcut keys, or by converting
other objects.

Create a text object interactively

1. In the Tools palette, click the tool for text objects.

2. Click on the document page and create the text object.

Create a text object with another shape and writing direction

1. In the Tools palette, click the tool for text objects and hold down the mouse button.

2. Choose one of the following options:

• Choose a tool of the type LTR (Left To Right) to create a text object with the text running from
left to right.

• Choose a tool of the type RTL (Right To Left) to create a text object with the text running from
right to left. This option is helpful for creating text objects for Arabic or Hebrew text.

• Choose a tool of the type TTB to create a text object with the text running from top to bottom.
This option is helpful for creating text objects for Chinese or Japanese text.

3. Click on the document page and create your text object.

The writing direction may be changed for every layout afterwards.

Create rectangular text object with menu/shortcut keys
Choose one of the following options:

• Press Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac).

• Choose Object > Content > Text.

You can also create a text object by converting another closed object into a text object. If you change
a graphic object into a text object the conversion will be immediate. However if a picture object is
changed into a text object an alert message may appear warning you that the picture’s content will
be lost.

Convert an existing object into a text object

1. Select an existing closed object.

2. Choose one of the following options:
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• Press Ctrl + Shift + T (Windows/Linux) or Command + Shift + T (Mac).

• Choose Object >Content > Text in the menu or Content > Text in the context menu.

Text mode

To enter or import text into a text object you will need to enable the text mode. When the mouse
pointer is positioned over a text object it will change into an I-beam (text) pointer.

Choose Text mode
Choose one of the following options:

• Click the mouse on the surface of the text object.

• Select the text object and choose Edit > Select Content,

The text mode has been selected successfully when the blinking cursor is displayed, Please refer to the
section Insertion point (cursor). Possibly some further palettes may appear.

If you position the mouse pointer over a text object and the I-beam (text) pointer is not shown, it
may be a protected text object, an Alias object or a group object. Please refer to the section Working
with Objects.

Leave Text mode
Choose one of the following options:

• Press Esc or choose Edit > Select Object.

• Click anywhere in the document window where there is no object positioned.

• Select another object.

Insertion point (cursor)

The blinking insertion point indicates where you can enter or mark text. It has the shape of a flag,
consisting of a vertical line and a triangle. The direction of the triangle determines the writing direc-
tion of the text. The insertion point can be positioned with a mouse click or the arrow keys.

If you click the mouse on a free area in the text object, the insertion point will be positioned at the
location closest to that point. This may be at the beginning/end of a line or at the end of the text.

As well as interactive positioning, the application also allows you to position the insertion point using
key board commands. Please refer to the notes in the section Keyboard and mouse commands.

Entering and importing text
The application offers you many different possibilities for entering/importing single characters or a
complete text:

Keyboard — Enter characters using the keyboard.

Special characters — Insert special characters or spaces using menus and shortcuts.

Breaks — Insert breaks or spaces using menus and shortcuts.
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Character Map — Insert characters using the Character Map palette, where you can search for specific
characters.

OpenType — Alternatively, insert characters using the OpenType menu or specify alternative charac-
ters using the OpenType palette. Please note the information in the section OpenType.

Text import — Insert text by importing text files in different formats.

Variables — Insert Variables for page numbers, dates and running titles.

Placeholder text — Insert placeholder text to get an impression of the layout.

Objects — Insert graphic objects or images that flow with the text.

Paste — Paste texts from the same or other documents and applications using menus and shortcuts.
Please note the instructions in the section Editing text.

In all cases, you must set the cursor at the required position.

Keyboard

In most cases, you enter text using the keyboard. The application of your keyboard can be found in
the hardware description.

Keyboard layout — The keyboard layout is controlled by the operating system. It determines the
association between the characters shown on the keys and the characters that appear in the text when
the key is pressed. If both characters do not match, an incorrect keyboard layout was probably cho-
sen. In this case please check these settings in the operating system.

On-screen keyboard — Some operating systems (such as Mac OS or Windows) also provide an on-
screen keyboard. The on-screen keyboard allows input via a mouse click or optionally via gestures
when a touch screen is present. This option is helpful for finding characters on the keyboard that are
accessible only by keystrokes without trying all key sequences. The option is also helpful if you want
to enter characters when no physical keyboard is connected.

Special characters

Special characters are generally characters that are neither a letter nor a number. These include punc-
tuation marks, symbols or scientific/technical symbols. Diacritics are also classed as special charac-
ters, e.g. Acute or Breve (é, ă)

Insert special characters
Choose Text > Insert > Insert Special Character in the menu or Insert Special Character in the context
menu to insert a special character (e.g. for currencies). The selected special character is displayed
correctly only if the font in question has the character and the position of the character in the font
conforms to the Unicode specification. Therefore, for example, symbol fonts will usually not be able
to represent these special characters.

Insert spaces

1. Choose Text > Insert > Insert Space in the menu or Insert Space in the context menu, or alternatively
press the appropriate shortcut keys, insofar as they are available.

2. Choose one of the following options:
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• Tab — Inserts a tab character. A tab character causes a predefined distance between two char-
acters. Please refer to the notes in the Tabs section.

• Border tab — A border tab shifts all characters following the tab character in the writing direc-
tion to the edge of the text object. Please refer to the notes in the Tabs section.

• Indent here — The character indents all subsequent lines of the paragraph.

• Em Space — Space relating to the font width. An En Space, a Three-per-Em Space, a Four-per-
Em Space, a Six-per-Em Space, a Thin Space and a Hair Space correspond to a fraction of the
width of an Em Space. Choose the alternative option Em Space (non-breaking) if the characters
before and after the Em Space should be invisibly linked. This option is helpful for connecting
character strings that should not be separated by a break at the end of a line (e.g. “10 mm”).
The options En Space (non-breaking), Three-per-Em Space (non-breaking), Four-per-Em Space
(non-breaking), Six-per-Em Space (non-breaking), Thin Space (non-breaking) and Hair Space
(non-breaking) correspond to a fraction of the width of a non-breaking Em Space.

• Punctuation Space — Space with the width of a punctuation mark, such as an exclamation
mark, period or semicolon in the respective font. Alternatively, select the option Punctuation
Space (non-breaking) if you want the characters in front to be invisibly joined to the punctua-
tion mark. This option is helpful for connecting strings that should not be separated by a break
at the end of a line (e.g. “10 mm”).

• Space (non-breaking) — Space with the width of a space of the respective font. The width of
the space may change during alignment justification. Alternatively, choose the option Space
with fixed width (non-breaking) if you want the space to be retained when the text alignment
Justified is applied.

• Figure Space (non-breaking) — Space with the width of a number of the respective font.

Insert Hyphen/Em Dash

1. Choose Text > Insert > Insert Hyphen/Dash in the menu or Insert Hyphen/Dash in the context menu,
or alternatively press the appropriate shortcut keys, insofar as they are available.

2. Choose one of the following options:

• Em Dash — Horizontal Dash with the width of an Em Space of the respective font. An En Dash has
half the width of the Em Dash. Choose the alternative option Em Dash (non-breaking) if the
characters before and after the Em Dash should be invisibly linked. This option is helpful for
connecting character strings that should not be separated by a break at the end of a line (e.g.
“FC Bayern — FC Liverpool). The option En Dash (non-breaking) has half the width of a non-
breaking Em Dash.

• Hyphen — Horizontal dash with the width of a minus sign in the respective font. Choose the
alternative option Hyphen (non-breaking) if the characters before and after the Hyphen should
be invisibly linked. This option is helpful for connecting character strings that should not be
separated by a break at the end of a line (e.g. “21-inch”).

• Discretionary Hyphen — Horizontal dash with the width of a Hyphen in the respective font. The
discretionary hyphen only takes effect in the case of an end-of-line hyphenation. The character
string/word is then automatically hyphenated at the position where the discretionary hyphen
was inserted. This option is helpful for hyphenating character strings/words at specific posi-
tions not known by the dictionary. However, if the discretionary hyphen is inserted immedi-
ately before the string/word, this is equivalent to a hyphenation ban. This option is helpful for
preventing the hyphenation of a string. Please refer to the section Hyphenation.
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Breaks

Break characters affect the break of individual lines and paragraphs.

Insert break

1. Choose Text > Insert > Insert Break in the menu or Insert Break in the context menu, or alternatively
press the appropriate shortcut keys.

2. Optionally choose View > Text Invisibles in the menu or Text Invisibles in the context menu, or
alternatively press Ctrl + I (Windows/Linux) or Command + I (Mac) to display the break characters.

3. Choose one of the following options:

• Paragraph Break — Wraps the current line and finishes the paragraph.

• Forced Line Break — Wraps the current line without finishing the paragraph. This means that
paragraph attributes (e.g. Space to previous paragraph or Space to next paragraph, etc.) are
not applied. . This option is helpful for manually intervening to wrap the paragraph lines, but
should only be used as an exception.

• Text Column Break — Wraps all following text into the next physical text column of the text
object. If the text object has only one physical column, the text will be wrapped into the next
linked text object. In this case, the option is the same as the option Text Object Break.

• Text Object Break — Wraps all following text to the next linked text object, irrelevant of how
many physical text columns an object has.

• Layout Column Break — Wraps all following text to the next Layout column. If the text object
only has one Layout column, the text will be wrapped to the next linked text object. In this
case, the option is the same as the option Text Object Break.

• Layout Break — Breaks the current line and finishes the current Layout. Please refer to the sec-
tion Text layout.

Character Map

The Character Map Palette (Glyphs) gives an overview of all fonts, font weights and their characters.
With the help of this palette you can:

• Insert single characters of a font into the text.

• Display variations of a character in all fonts.

• Display an overview of all characters of a font or font face.

• Search for single characters in a font.

• Display all the characters of a Unicode range.

• Check the Unicode value, the Unicode name and the Unicode range of a character.

• Save frequently used characters as favorites.

The Character Map Palette is helpful if for example you do not know which characters a font contains
or if you frequently work with non-Latin font systems (e.g. Arabic, Hebrew, Chinese, Japanese, etc.).
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Insert characters of a font into the text

1. Choose Window > Character Map.

2. In the popup menu, choose the font and font weight required.

3. Choose one of the following options to change the display of the palette:

• Use the slider to increase or reduce the display of the single characters in the palette.

• Choose Show Font Variations or Hide Font Variations in the context menu to display the selected
character in different fonts or to hide this display.

• Choose Hide Font Variations in the context menu to have more space for the characters in the
font selected.

• Click List to show the characters as a list.

4. Choose one of the following options to select characters:

• Scroll through the palette until the required character is displayed.

• In the popup menu Code Charts, choose Favorites to display the Favorites.

• In the popup menu Code Charts, choose Any to display all the characters of a font again.

• In the popup menu Code Charts, choose an option to display all the characters of a Unicode
area (e.g. “Arrows”).

• Enter a Unicode number (e.g. “0041”) or a Unicode name (e.g. “ACUTE”) in Roman characters in
the entry field to display only specified characters. Pleaser refer to the Unicode description in
the Internet for the meaning of the individual options. Confirm your entry to start the search.
Klick Delete to cancel the search.

5. Choose one of the following options to insert a character into the text:

• Double click in the palette on the character. Alternatively, choose Insert Character in Selected
Font in the context menu to import the character in the selected font in both cases.

• Choose Insert Character in Text Font to import the character in the font that is selected at the
cursor position.
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Notes:

 • Place the mouse over the information symbol to establish which font system is supported by
the selected font.

 • Place the mouse over the required character to establish which UTF-8 or Unicode value or Uni-
code name a character possesses and to which Unicode range a character belongs.

 • Choose Hide Font Variations to switch off the calculation of all the available font variations and
accelerate the display of the characters in the character Map.

 • The option Insert Character in Text Font is not available in the font variations.

You can save frequently used characters as Favorites. In the program a number of characters have
been defined as Favorites (e.g. quotation marks, Copyright symbol, etc.). You can extend the Favor-
ites list at any time and also remove characters from the Favorites list.

Show Favorites list

1. In the popup menu Code Charts, choose Favorites to show the Favorites.

2. In the popup menu Code Charts, choose Any to show all the characters of a font again.

Note: In the Favorites list, only those characters will be shown that are available in the font
selected. Therefore it may occur that additional or fewer Favorites will be shown when you change
the font.

Save single characters of a font as Favorites

1. In the popup menu Code Charts, choose Any to show all the characters of a font again or select
another option to limit the list.

2. Scroll through the palette until the required character is displayed.

3. Choose the character required.

4. Choose Add to Favorites in the context menu.

Remove characters from the Favorites list

1. In the popup menu Code Charts, choose Favorites to show just the Favorites.

2. Choose the character required.

3. Choose Remove from Favorites in the context menu.

OpenType Menu

OpenType is a standard font file format. The special features of this file format for fonts are the typo-
graphic options. This standard characters can be replaced by variations of the same character in the
same font. For example, the number “5” in an OpenType font may be in various variations that are
not accessible from the keyboard. For this purpose, the program offers either the OpenType palette
and the OpenType menu. The OpenType menu appears automatically when a single character of an
OpenType font has been selected and alternate characters exist. The menu shows a selection of all
alternatives for a character. This option is useful for quickly selecting and replacing a character with-
out searching for the option in the OpenType palette. Please refer to the section Working with
Typography.
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Insert OpenType character

1. Select/mark a single character in the text.

2. Place the mouse pointer over the selected character in the text.

3. Choose an alternative character in the OpenType menu.

4. Click to insert the chosen character in the text.

5. Click outside the menu to close it.

Variables

The program has a number of text variables for page numbers, document names, document paths,
running titles, creation date or creation date.

Insert variables for page numbers

1. Choose Text > Insert > Insert Variable in the menu or Insert Variable in the context menu, or alter-
natively press the appropriate shortcut keys.

2. Choose one of the following options:

• Page Number — Displays the current page number including an optional prefix in the selected
number format. If the page number is inserted in a text object on an Alias page, the wildcard
“#” appears. The page number is the number set using the option Document > Document Page
Settings. By default, the program allocates the number 1 for the first page.

• Previous Page Number — Displays the current page number including an optional prefix in the
selected number format. If the page number is inserted in a text object on an Alias page, the
wildcard “#-1” appears. If there is no previous page, the variable still has the width of a space.

• Next Page Number — Displays the current page number including an optional prefix in the
selected number format. If the page number is inserted in a text object on an Alias page, the
wildcard “#-1” appears. If there is no following page, the variable still has the width of a space.

• Continued from — Displays the page number of the page containing the previous text object of
the current story. If there is no previous text object in the current story, nothing is displayed,
but the variable still has the width of a space.

• Continued on — Displays the page number of the page containing the next text object of the
current story. If there is no further text object in the current story, nothing is displayed, but the
variable still has the width of a space.

Insert Variables for Document name and path

1. Choose Text > Insert > Insert Variable in the menu or Insert Variable in the context menu.

2. Choose one of the following options:

• Document Name — Displays the current document name including a file suffix.

• Document Path — Displays the current document path.

Insert Variables for Running Titles

1. Choose Text > Insert > Insert Variable in the menu or Insert Variable in the context menu.

2. Choose Running Title.
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3. Choose which Level should be displayed.

4. Choose one of the following options to define the procedure:

• First — Displays the first occurrence of the Running Title in the current text object.

• Last — Displays the last occurrence of the Running Title in the current text object.

• Previous — Displays the last occurrence of the Running Title in the previous text object.

5. Choose one of the following options to define the Maximum Length:

• Any — Displays the Running Title in the defined length (max. 256 characters).

• Limited — Limits the display of the Running Title to a certain number of characters.

The variable Running Title is only evaluated if it is used in a header and footer of a text object and if
the variable was used in the text. Please refer to the section Text layout.

Insert Variables for Footnotes and Endnotes

1. Make sure that you have made all preparations according to the instructions in the footnotes and
endnotes section.

2. Choose Text > Insert > Insert Variable in the menu or Insert Variable in the context menu, or alter-
natively press the appropriate shortcut keys.

3. Choose one of the following options:

• Footnote — Inserts a Footnote.

• Endnote — Inserts an Endnote.

At the cursor position, the reference number for the footnote or endnote is automatically inserted and
marked with the style sheet defined in the Preferences. At the same time, the footnote or endnote
number, followed by a footnote or endnote text, is inserted and also marked with the style sheets
defined in the Preferences. You can now overwrite the footnote or endnote text and replace it with
your own text.

Please refer to the section Footnotes and Endnotes.

Insert Variable for Dates

1. Choose one of the following options for a creation date:

• Choose Text > Insert > Insert Variable > Creation Date in the menu.

• Choose Insert Variable > Creation Date in the context menu.

2. Choose one of the following options for a modification date:

• Choose Text > Insert > Insert Variable > Modification Date in the menu.

• Choose Insert Variable > Modification Date in the context menu.

3. Choose one of the following options for the date format:

• Click OK if the date is to be displayed language-independently in the so-called “DATE_FULL”
format without any changes. This format displays the day of the week as text, the day as a
digit, the month as text, and the year as a number depending on the language. Example: The
date “20.07.2015” will be displayed as “2, 2015 7 20” if no language has been assigned. The
same date will be displayed as “Montag, 20. Juli 2015” if the language German has been
assigned, as “Monday, July 20, 2015” if the text language English has been assigned, or as “2015
年 7月 20日星期一” if the text language Chinese has been assigned.
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• Click the date icon and choose one of the 12 predefined date formats in the menu, which are
automatically translated to the text language.

• Enter an individual date format in the Format entry field using the 31 predefined abbreviations.
The abbreviations are based on the globally recognized Unicode Standard:
http://www.unicode.org/reports/tr35/tr35-dates.html#Date_Field_Symbol_Table

• Choose the options in the menu or optionally enter the abbreviations in the Format entry field:
Time — Hour (0-23, 00-23), Minute (0-59, 00-59), Second (0-59, 00-59), Period (AM or PM),
Zone
Day — Day (1-31, 01-31), Day of year (1-365), Day of week (1-7), Day of week (Tue), Day of week
(Tuesday).
Week — Week (1-53 or 01-53).
Month — Month (1-12 or 01-12), Month (short), Month (long).
Quarter — Quarter (1-4 or 01-04), Quarter (short), Quarter (long).
Year — Year, Year (00-99), Era (AD), Era (Anno Domini).

Any number of abbreviations can be combined to a date. The abbreviations can optionally be
separated by entering empty steps and periods. The preview evaluates the input field and dis-
plays the calculated variable in the selected format (in English). If the entries in the Number
Format input field are completely deleted, the variable is again displayed in the “DATE_FULL”
format by default.

4. Optionally, choose an Offset for the date. This option is useful if you want to output a date in the
past or in the future that refers to the modification date or creation date. For example, if you are
designing a package, you can use the Offset option to define a “best before” date. Choose one of
the following options for the offset:

• Choose the value “0” in all input fields if you do not want a time offset.

• In the input field Years, Months, Weeks, Days, Hours, Minutes and/or Seconds, choose a value
greater than “0” if you want to define a time offset for the future. Alternatively, choose a value
less than “0” if you want to define a time offset for the past.
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Notes:

1. For individual date formats based on pre-defined abbreviations, there is NO language-depen-
dent translation of the data for weekdays and months. Additional language-dependent format-
ting is only possible with the predefined date formats.

2.When calculating the offset, the program adds the information in the order year, month, day,
hour, minute, second. If you add a month to the date “31st January “, the result will be the last
day of February. Depending on whether it is a leap year, this may be February 28th or 29th. If you
add a month and two days to the date “30th April “, the result will be ”1st June”. If the program
first added the days and then the month, the result would be “2nd June “, since April has only 30
days and May 31 days.

Change settings for date variables

1. Select the variable in the text or place the insertion point in front of the text variable.

2. Choose the option Edit Variable in the context menu.

3. Make the desired changes and confirm the setting.

Importing text files
You can import text files, which may be available in various formats.

Import text file with the Import dialog

1. Choose one of the following options:

• Press Ctrl + E (Windows/Linux) or Command + E (Mac).

• Choose File > Import.

2. The options in the dialog are identical with the options for opening documents. Please refer to the
section Working with documents.

3. Choose one of the following options in the popup menu File Type:

• Choose Text (* .txt) if you want to import a text file without any formatting instructions. The
formatting of the text file in this case depends on the options selected at the position of the
insertion point.

• Choose another option if you want to import a text file with formatting instructions. Please
refer to the section Import/Export. The formatting of the text file in this case depends on the
formatting that is used in the text file and supported by the application.

4. Click Open or double-click the document in the list.

Import text file by Drag & Drop

1. Choose a text file in the operating system whose file type is supported by the program.

2. Drag the file over the text object with the mouse button held down.

3. Release the mouse button.

Note:

If you choose a file whose file type is not supported by the application, nothing happens.
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If you choose a file whose file type is supported by the application, an additional dialog may open.
Please refer to the section Import/Export.

Insert Placeholder Text

You can fill text objects with so-called placeholder text, which is available in several languages. The
placeholder texts are saved as a text file in the program folder with language-related names and can
be adapted if necessary. This option is useful if the texts for a layout are not yet available, but you
want to get an idea of what the pages would look like if the text were available.

Insert Placeholder Text
Choose Text > Fill with Placeholder Text.

If there is no file for the language chosen, or if the text language is set to None, then a Latin text will
appear automatically.

Objects

Anchored objects

You can anchor any objects such as graphic, picture or table objects as well as whole groups in the
text. Anchored objects “flow” automatically with the text and change their position according to the
position of the text.

Anchor image in text

1. Place the insertion point at the text location where you want to insert the image.

2. Choose Text > Insert > Insert Object > Image in the menu or Insert Object > Image from the context
menu.

3. Choose the options for the image according to the instructions in the section Working with Pictures.

The width of the inserted image object is no wider than the width of the text object. The size and sec-
tion of the image can be defined individually. If the image is not visible after insertion, check
whether the image has caused an overset. If this is the case, you may have to enlarge the text object.
Please refer to the notes in the section Working with Objects and Working with Pictures.

You can change the anchor settings for the image at any time. Please refer to the notes in the section
Editing Anchor Objects. You can also anchor existing image objects in the text. Please refer to the
notes in the section Anchoring Objects and Groups.

Anchor table in text

1. Place the insertion point at the text location where you want to insert the table.

2. Choose Text > Insert > Insert Object > Table from the menu or Insert Object > Table from the context
menu.

3. Select the options for the table according to the instructions in the section Working with Tables.
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The table is inserted into the text. The width of the table is at the most equal to the width of the text
object. The size of the table can be determined individually. If the table is not visible after insertion,
check whether the table has caused a text overset. If this is the case, you may have to enlarge the text
object.

You can change the anchor settings for the image at any time. Please refer to the notes in the section
Editing Anchor Objects. You can also anchor existing table objects in the text. Please refer to the
notes in the section Anchoring Objects and Groups.

Anchor formula in text

1. Place the insertion point at the text location where you want to insert the formula.

2. Choose Text > Insert > Insert Object > MathML Object from the menu or Insert Object > MathML Object
from the context menu.

3. Choose the options for the formula and confirm your entries.

The formula must be in MathML (Mathematical Markup Language) format. The Mathematical Markup
Language is a format for representing mathematical formulas and complex expressions. This stan-
dard was developed by the “World Wide Web Consortium” (W3C), a committee for the standardiza-
tion of techniques on the World Wide Web. A description of the MathML format as well as numerous
examples of formulas in MathML format can be found on the Internet.

Anchoring objects and groups in the text

You can anchor one object or group at a time in the text. In both cases, we refer to the objects as
anchored objects. If you want to anchor several objects or groups, repeat the process as often as is
necessary. In the anchoring process, possible rotations are retained. You can select anchored objects
or groups at any time and edit them in the usual way. This way you can also anchor existing image
and table objects in the text.

Anchor Objects

1. Copy the object or group that you want to anchor in the text.

2. Set the cursor at the point in the text where you want to insert the object.

3. Choose one of the following options:

• Choose Edit > Paste in the menu or Paste in the context menu

• Press Ctrl + V (Windows/Linux) or Command + V (Mac).

4. Choose one of the following options:

• In the Line — The object appears in the same line as the line in which the cursor is positioned.
With this option, the object will be treated like a text character, i.e. the width of the object
influences the position of the following text. The character height defines the height of the line
with automatic line spacing (leading). If the width/height of the object is greater than the col-
umn width/height, the anchored object may be broken to the following columns or text
objects, or a text overflow will be displayed.

• Above the Line — The object appears in its own line above the line in which the cursor is posi-
tioned. With this option, just the height of the object determines the position of the following
text, the width will be ignored. If the width/height of the object is greater than the column
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width/height, the anchored object may be broken to the following columns or text objects, or a
text overflow will be displayed. A control character in the form of an anchor will be displayed
at the anchor position in the text when the command View > Show Text Invisibles is activated.

• Anchored — The object appears with an individual offset to the text. This option does not influ-
ence the position of the following text unless special options for text runaround are selected.

Anchor objects in the line

1. Choose an offset relative to the baseline to move the object vertically up or down.

2. Choose a runaround for the object in the Anchor Settings dialog.

In the Runaround dialog for objects, certain settings will have no effect on anchored objects.

3. Choose an option for the Line spacing:

• Object settings — The height of the object influences the line spacing. In this case the program
ignores the settings for line spacing in the paragraph.

• Story — The height of the object does not influence the line spacing. In this case the object is
laid over the previous lines, insofar as the object height is greater than the line spacing in the
paragraph.

Anchor objects above the line

1. If required, choose a value for the Spacing before the Object and Spacing after the Object. Within
the paragraph, this option behaves in the same way as the paragraph option Space to previous
and Space to next.

2. Choose an Alignment:

• Centered relative to Anchor — The object is centered above the anchor. If the anchor is at the
beginning or end of a line, the object may possibly extend outside the column.

• Left/Center/Right — The object is displayed on the left, in the middle or on the right of the text
column . In the object is always displayed horizontally within the column.

If the anchor is in the first line of a text object or column, it may be that the anchor object will be dis-
played outside the text frame.

Anchor objects individually

1. In the popup menu Reference point horizontal, choose the co-ordinate on which the anchor object
should be aligned:

• Character position — The object is aligned on the current cursor position.

• Left text object border/Right text object border — The object is aligned on the left or right co-
ordinate of the text object.

• Left layout column border/Right layout column border — The object should be aligned on the
left or right edge of the layout column (multiple layout columns).

2. Choose the Horizontal Offset if required.

3. In the popup menu Reference point vertical, choose the co-ordinate on which the anchor object
should be aligned.

• Baseline — The anchor object is aligned on the baseline of the current line in which the cursor is
positioned.

125



Working with Text | Selecting text

• Upper text object border/Lower text object border — The anchor object is aligned on the upper
or lower edge of the text object.

• Upper layout column border/Lower layout column border — The anchor object should be
aligned on the upper or lower edge of the layout column (multiple layout columns).

4. Choose the Vertical Offset if required.

5. Choose the Object reference point.

6. As a further option, choose a Runaround for the object.

Edit anchor objects

Anchor objects with the option Above the Line and Anchored are indicated in the text by an anchor
symbol. For anchor objects with the option In the Line an anchor symbol is unnecessary. Choose the
option Show Text Invisibles to display the anchor symbol. The anchor is a character in the test, but it
has a zero width. Therefore you can use the left or right arrow keys once without having a recognisa-
ble effect. In fact you are setting the cursor before or after the anchor.

Edit the position of anchor objects

1. Set the cursor IN FRONT OF the object in the line or IN FRONT OF the anchor symbol. The cursor is
standing IN FRONT OF the object in the line or IN FRONT OF the anchor symbol if in the Text menu
the option Anchor Settings is displayed or if in the Charactor Inspector window an object symbol
(rectangle with the text “OBJ” as a grapheme) is displayed.

2. Choose Text > Anchor Settings in the menu or Anchor Settings in the context menu and make the
changes you need.

Select, cut, copy or delete anchor objects

1. Set the cursor IN FRONT OF the object in the line or IN FRONT OF the anchor symbol.

2. Hold down the Shift key.

3. Press the Arrow-right key to mark the object in the line or to mark the anchor.

4. Choose one of the following options:

• Choose Edit > Cut in the menu or Cut in the context menu, or press Ctrl + X (Windows/Linux) or
Command + X (Mac) to cut the anchor object.

• Choose Edit > Copy in the menu or Copy in the context menu, or press the shortcut keys Ctrl + C
(Windows/Linux) or Command + C (Mac) to cut the anchor object.

• Choose Edit > Delete in the menu or press the Del key to delete the anchor object.

Selecting text
To edit a text, you must select the text. You can select a text with the mouse and/or shortcut key s.
Please refer to the Keyboard and Mouse Commands.

Select Text

1. Click twice (double-click), three times, four times, five times, or six times quickly to select a word,
a line, a sentence, a paragraph, or all the text.
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2. Position the insertion point, hold down the mouse button and move the mouse in the desired
direction to select the text.

3. Position the insertion point and press Shift. Use the arrow keys to select the text character by char-
acter or by line.

4. Position the insertion point and press Ctrl + Shift (Windows/Linux) or Command + Shift (Mac). Use
the arrow keys to select the text word by word or by paragraph.

5. Press Shift and position the insertion point to change an existing selection.

6. Choose one of the following options to select the whole text:

• Quickly click the mouse button six times in a row.

• Press Ctrl + A (Windows/Linux) or Command + A (Mac).

• Choose Edit > Select All.

Deselect a text selection
Choose one of the following options to deselect the selection:

• Click.

• Choose Edit > Deselect All.

Editing text

Delete/replace text

You can delete individual characters or a selected text, or delete a selected text by replacing it with
another text.

Delete single character

1. Position the insertion point in the text.

2. Choose one of the following options:

• Press Backspace to delete the character BEFORE the insertion point.

• Press the Delete key to delete the character AFTER the insertion point.

Delete text selection

1. Select some text.

2. Choose one of the following options:

• Press the Backspace key

• Press the Delete key

• Choose Edit > Delete.

Delete text selection by replacing it

1. Select a text.

2. Choose one of the following options:
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• Enter characters using the keyboard or choose any option to insert text. Please refer to the section
Entering and importing text.

• Choose Edit > Paste to insert copied or cut text from the clipboard.

Cut text

You can cut a text selection. The text will be removed from the document and copied to an invisible
clipboard. The difference between deleting and cutting is that cut text can be pasted back into any
point in the document, so long as no other text has been cut or copied.

Cut text

1. Select some text.

2. Choose one of the following options:

• Press Ctrl + X (Windows/Linux) or Command + X (Mac).

• Choose Edit > Cut in the menu or Cut in the context menu.

Note: When you cut, both the text and all text formatting and floating objects will be copied to the
clipboard. This applies to font formatting as well as style sheets and colors. This ensures that the
text does not lose its formatting when pasted, even if the definitions used such as colors or style
sheets do not exist in the destination document. As a result, this option makes it easy to copy col-
ors and style sheets to other documents. However, if there are colors or style sheets in the destina-
tion document that have the same name but a different definition, the definition in the target doc-
ument will be used.

Copy text

You can copy a selected text and paste it later using the Paste option, if no other text has been cut or
copied in the meantime. The text is copied to an invisible clipboard.

Copy text

1. Select some text.

2. Choose one of the following options:

• Press Ctrl + C (Windows/Linux) or Command + C (Mac).

• Choose Edit > Copy in the menu or Copy in the context menu.

Note: When you copy, both the text and all text formatting and floating objects will be copied to
the clipboard. This applies to font formatting as well as style sheets and colors. This ensures that
the text does not lose its formatting when pasted, even if the definitions used such as colors or
style sheets do not exist in the destination document. As a result, this option makes it easy to copy
colors and style sheets to other documents. However, if there are colors or style sheets in the desti-
nation document that have the same name but a different definition, the definition in the target
document will be used.

In the Web Edition, there may be deviations from the functionality described. Please refer to the
section Information on the Web Edition.
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Paste copied/cut text

You can copy a selected text and paste it later using one of the Paste options, if no other text has
been cut or copied in the meantime. The text is copied to an invisible clipboard.

Paste text

1. Copy or cut a selected text in the document or in another application.

2. Position the insertion point in the text.

3. Choose one of the following options:

• Press Ctrl + V (Windows/Linux) or Command + V (Mac).

• Choose Edit > Paste in the menu or Paste in the context menu.

• Press Ctrl + Shift +V (Windows/Linux) or Command + Shift + V (Mac).

• Choose Edit > Paste WITHOUT Formatting in the menu or Paste WITHOUT Formatting in the con-
text menu. This option is only available when the option Paste Text Formatting in the Prefer-
ences has ben set to either Always (from all known applications) or Only within the application.
Please refer to the section Preferences.

• Choose Edit > Paste WITH Formatting in the menu or Paste WITH Formatting in the context menu.
This option is only available when the option Paste Text Formatting in the Preferences has ben
set to Never. Please refer to the section Preferences.

 • You can repeat the insertion as many times as you like, unless you cut or copy something
again.

Text layout
As “text layout” we mean the arrangement of texts within a text object or a text string. The layout of
a text is determined both by the options of the text object and by the options of the text itself. The
text layout is determined, for example, by text columns, text object entries or headers and footers.

The options are in some cases redundant. For example, you can define an indent or columns for both
the text object and the text. The options are additive in this case:

• If you set a 5 mm indent for the text object and format the text with a 7mm indent, the total
indent between the text and the object edge is 12mm.

• If you set two text object columns and two layout column text for the text object, the text will
be displayed with four columns.

Text object layout options

Indents for text objects

1. Select a text object.

2. Choose one of the following options:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Alt + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Click the tab Main Text.
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4. Enter a value in the entry fields top, Bottom, Left and/or Right. The value determines the distance
from the edge of the object. For polygonal or oval text objects, the indent correspond to the dis-
tance from the enclosing rectangle.

Define the position of the first baseline

1. Select a text object.

2. Choose one of the following options:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Alt + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Click the tab Main Text.

4. Choose one of the following options to define the position of the first baseline:

• Ascent Height — The distance between the object edge and the baseline of the first line, corre-
sponds to the ascent height of the font in which the line was formatted.

• Cap Height — (default setting) The distance between the object edge and the baseline of the
first line, corresponds to the height of the character “M” of the font in which the line was for-
matted.

• Largest character — The distance between the object edge and the baseline of the first line, cor-
responds to the height of the character “d” of the font in which the line was formatted.

• x-Height — The distance between the object edge and the baseline of the first line, corresponds
to the height of the character “x” of the font in which the line was formatted.

• Baseline — The baseline of the first line is set to the object edge.

• Line Spacing — The distance between the object edge and the baseline of the first line, corre-
sponds to the height of the line spacing. This option is only used if the line spacing has the
value “Auto”.

5. Choose one of the following options to add a value to the option First Baseline:

• Fixed — The value entered is always added to the first baseline.

• Minimum — The value entered is only added to the first baseline if it is greater than the posi-
tion already calculated. For example, if the minimum value is 2 mm, the first baseline has the
setting Cap Height and the font size is 18 pt, the value is not applied because the distance
between the object edge and the first baseline is already more than 2 mm. If the value were 5
mm, it would be added accordingly.

Text object columns

1. Select a text object.

2. Choose one of the following options:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Alt + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Click the tab Text Columns.

• Number — Defines the number of text object columns.

• Gutter — Defines the gutter between the text object columns.
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4. Choose Activate to show column lines. This option is only available when more than one column
has been defined for the text object.

• Color — Defines the color of the column line.

• Shade — Defines the shade of the column line.

• Width — Defines the width of the column line.

• Line Style — Defines the style of the column line.

• Indent Top — Defines the top indent of the column line. Choose whether the column line should
start at the Object Frame or the Baseline of the first line.

• Indent Bottom — Defines the bottom indent of the column line. Choose whether the column line
should end at the Object Frame or the Baseline of the last line. The option Baseline is deter-
mined by the options for the Baseline Grid in the text object and not by the text itself.

Header & Footer

1. Select a text object.

2. Choose one of the following options:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Alt + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Click the tab Header & Footer.

4. Choose Header and enter a value to create a header.

5. Choose Footer and enter a value to create a footer.

Creating a header or footer is mandatory if you want to use the variable Running Title in the docu-
ment. The variable can only be calculated within a footer and header.

For other variables, the header or footer is also helpful but not mandatory.

Please refer to the section Variables.

Text layout options

The program distinguishes between options for single characters, paragraphs and layouts. A “layout”
can consist of a number of paragraphs. Within a text object or a text string, there can be several lay-
outs. Layouts are helpful, for example, to format text within a text object alternately in one or more
columns or to determine the vertical alignment of lines and paragraphs.

Create several Layouts
Basically, each text object has settings for the current layout. Use the following options for the current
layout. To create more layouts, insert a layout break. Please refer to the section Insert special charac-
ters.

Change Layout options
1. Position the insertion point anywhere in the relevant Layout.

2. Choose one of the following options:

• Choose Window > Module > Layout.

• Choose Text > Layout.
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Line Orientation
The option Line Orientation determines the direction in which the lines are arranged. For most writing
systems, lines are read from top to bottom. Because the option can be set separately for each layout,
you can set the option differently for multiple layouts.

Choose one of the following options to define the Line Orientation:

• Top to Bottom — The lines are constructed from top to bottom. This option is helpful for all
texts that are read from top to bottom (for example, Roman, Hebrew or Arabic texts).

• Left to Right — The lines are constructed horizontally from left to right. This option is helpful for
all texts that are read from left to right (for example, Chinese or Japanese texts).

• Right to Left — The lines are constructed horizontally from right to left. This option is helpful for
all texts that are read from right to left.

Line Justification
The option Line Justification determines whether the space within a column should be distributed after,
before, or before and after a text. In most cases, the free space is displayed after the text.

Choose one of the following options to define the Line Justification:

• Beginning — The lines are aligned at the beginning of the line orientation. For a text with the
line orientation Top to Bottom, Beginning corresponds to the justification Top. For a text with
the line orientation Left to Right Beginning corresponds to the justification Left.

• Middle — The lines are centered vertically.

• End — The lines are aligned at the end of the line orientation. For a text with the line orientation
Top to Bottom, End corresponds to the justification Bottom. For a text with the line orientation
Left to Right End corresponds to the justification Right.

Since the option can be set separately for each layout, you can set the option differently for multiple
layouts. For example, to distribute the space between the first and second paragraphs for three para-
graphs, insert a layout break after the first paragraph. For the first layout, choose Beginning and for
the second layout (consisting of the second and third paragraphs) choose End.

Justified space between lines and paragraphs
You can distribute free space dynamically within a column between lines and/or paragraphs up to a
maximum value. Dynamic means that the free space can change if you change the size of the text
object. Since the option can be set separately for each layout, you can set the option differently for
multiple layouts.

• Choose Justified space between lines and enter a value for Maximum. The value “0” switches
the option “Off”. The option only works if the option Paragraph Spacing does not yet exhaust
the free space and there is also free space to distribute.

• Choose Paragraph Spacing and enter a value for Maximum. The value “0” switches the option
“Off”. The option only works if there is also free space to distribute.

Layout offsets
Like paragraph offsets, Layout offsets determine the distance between the previous and the next Lay-
out.

• Choose Space to previous Layout and enter a value.

• Choose Space to next Layout and enter a value.
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Layout Columns
Layout columns divide the text into multiple columns. Unlike text object columns, where each column
automatically has the same width, layout columns can have different column widths.

Choose one of the following options to specify the column layout:

• Automatic — All columns automatically receive the same width.

• Manual — The column width can be defined individually for each column.

Automatic and Manual Layout columns
Choose one of the following options to define the column layout:

• Choose Column Layout > Automatic to define the same width for all columns.

• Choose Column Layout > Manual to define an individual width for each column.

• Enter a Number.

• With manual Layout columns, enter a Width for each column. The width may have an absolute
value (e.g. “50 mm”) or a relative value (e.g. “100 %”).

• Enter a Gutter.

Exporting text
You can optionally export a selected text or the entire text of the current text string as a text file in
various formats,

Export Text

1. Choose one of the following options:

• Position the insertion point in the Text object to export the whole text of the current text chain
(Story).

• Select a text to export just the selected text.

2. Choose File > Export > As a Text file.

3. The options in the dialog are identical with the options for saving documents. Please refer to the
section Working with Documents.

4. Choose one of the following options in the popup menu File Type:

• Choose Text (* .txt) if you want to export a text file without any formatting instructions.

• Choose another option if you want to export a text file with formatting instructions. Please refer
to the section Import/Export.

5. Enter a name for the text file

6. Confirm the entry.

7. Depending on the selected File Type, additional dialogs may open with further options (for
example, Encoding). Choose the appropriate options and confirm your entry again.
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Language, Spelling and Hyphenation
Depending on the program version, you can manage text in different languages in one document.
Options for language-specific hyphenation, spelling correction and grammar check are available.
Please refer to the section Preferences, where you can make a number of settings.

Language

When you launch your program version for the first time, an initial dialog it will ask you to define/
confirm the program interface language and the default text language for all new text objects. Which
language will be automatically displayed as the initial default by the program depends on the lan-
guage of your operating system.

If for example you have an English operating system, the initial default language will be English, and a
German operating system will have German assigned to it. Operating systems whose language the
program cannot recognize will automatically receive the default language English. These initial set-
tings will be stored in the Viva program preferences file on your system.

You can redefine the language assigned to a text as well as the default language for new text objects
at any time. Please refer to the section Preferences.

Assign language to a text passage

1. Mark a text passage or place the insertion point in the text at the point from which the setting
should take effect.

2. Choose one of the following options to assign the language required:

• Choose Window > Module > Character > Font & Language > Language.

• Choose Window > Quick Access > Language.

• Choose Text > Language.

• Choose None if the text does not correspond to any of the languages offered by the pro gram or
if it simply does not require any language assigned to it. In this way you will ensure that no
hyphenation will take place. Furthermore, your text will not be affected by the Spell and Gram-
mar Check functions or by the replacement of quotation marks with typographic quotation
marks. This option is also relevant if you are using symbol fonts where the checking and
replacement functions are not needed.

When a language is used in a document for the first time, assigning the language may take a few
seconds. If the language is assigned again, you don’t have to wait – the language will be assigned
immediately.

The assignment of the correct language is very important for the correct structure of the document,
because the program determines the modules for hyphenation and spelling correction on the basis of
the language settings.

Note: You can still assign a language to a text or to all new text objects even if you do bot possess
the appropriate dictionaries or hyphenation modules.

Assign a new language to be applied to all new text objects

1. Choose Edit > Preferences (Windows/Linux) or VivaDesigner > Preferences (Mac).

2. Choose the new language from the popup menu Language in the Text section:
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• Choose None if you work with more than one language in your documents and want to apply
the different languages to the text manually or with the help of Style Sheets. Please refer to the
chapter Working with Style Sheets.

3. Confirm the entry and close the program to ensure that the settings are saved.

Hyphenation

The application offers extensive options for hyphenation of an excellent quality.

All determined hyphenation points are saved in the document. This allows a document to be passed
on even if the recipient does not have the hyphenation modules used, as long as he or she does not
edit the text in the relevant places, and a new page break occurs as a result.

Activate Automatic Hyphenation

1. Position the insertion point or select several paragraphs if the following settings are to apply not only
to the current paragraph but also to several paragraphs.

2. Choose one of the following options:

• Choose Window > Module > Paragraph > Hyphenation.

• Choose Text > Hyphenation.

3. Choose Hyphenation > Yes to activate the hyphenation using the modules and user dictionaries
installed. After the option has been activated, further settings may be made:

• Smallest Word — Defines the minimum number of characters allowed in a string before a
hyphenation. Strings with less cha racters will be ignored automatically by the Hyphenation
module.

• Hyphens in a Row — Defines the number of lines that may have a hyphen at the end of a line. If
a value of 3 is entered, no hyphenation will occur on the fourth line, even if a hyphenation is
possible.

• Minimum before — Defines the minimum number of characters for the beginning of a word
before the hyphenation. If a string of 10 characters is hyphenated after the second, fifth and
eighth character, the value 3, will mean that the first hyphenation after the second character
will not be made. In this case the first hyphenation will be after the fifth character.

• Minimum after — Defines the minimum number of characters for the end of a word after the
hyphenation. If a string of 10 characters is hyphenated after the second, fifth and eighth char-
acter, the value 3, will mean that the last hyphenation after the eighth character will not be
made. In this case the hyphenation will be after the fifth character.

4. Choose one of the following options to define the hyphenation quality:

• No quality — All the hyphenations in a word are made by the automatic hyphenation.

• Only good quality or better — Only the hyphenations that are of a good or very good quality
are made by the automatic hyphenation. If the word has no quality hyphenation, none will be
made.

• Only best quality — Only the hyphenations that are of a very good quality are made by the
automatic hyphenation. If the word has no quality hyphenation, none will be made.
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• Best possible quality Only the hyphenations that are of a good or very good quality are
made by the automatic hyphenation. If this quality is not available for the string, the applica-
tion will automatically use the option No quality.

Please note:

 • A character string can only be hyphenated when all conditions are fulfilled.

 • The automatic hyphenation options may be made for any character strings or whole para-
graphs.

 • The hyphenation quality settings are made independently of the actual possibilities of the
hyphenation module or the language. This can mean that the hyphenation will be made, but
that the settings for the quality will have no effect (e.g. in Spanish).

Deactivate Automatic Hyphenation

1. Choose Text > Hyphenation.

2. Choose Hyphenation > No to deactivate the hyphenation. After the option has been deactivated,
the other options in the dialog will be grayed out, but may still contain settings.

Show Automatic Hyphenation Suggestion
If you are not sure if the automatic hyphenation has hyphenated a string correctly, you can check this
using the command Hyphenation Suggestions. Please note that the suggested hyphenation only
shows possible hyphenations and their quality. The suggested hyphenation does not show how and
why a string will be hyphenated in special cases or not. Thus for example the settings for the selected
language, possible left and right indents, Aesthetic Rag settings and all the settings for the Hyphenation
option define if and how a string may be hyphenated at a specific point.

1. Select a single word in the text.

2. Choose Text > Hyphenation Suggestions.

• The first line shows all the hyphenations that the application has found based on the hyphena-
tion module(s) and user dictionaries. A single dash between the syllables shows a hyphenation
without qualitative value. Two dashes show a qualitatively good value, three dashes a high
quality hyphenation.

• The second line shows the selected language. Here you can see at once if the hyphenation is
wrong because the wrong language was assigned to the text.

• The third line shows the hyphenation module that was selected for this language. If you have
installed hyphenation modules from different manufacturers, you can select these in the Pref-
erences.

Discretionary hyphenation
With discretionary hyphenation, you can determine the hyphenation for a single word. With this
function the automatic hyphenation for the word is deactivated. This option is helpful if you want a
single word not to be hyphenated, or just want to separate it at a specific location, without changing
the hyphenation settings for the paragraph.

1. Choose one of the following options to define the hyphenation:

• Position the insertion point immediately BEFORE the word to set a No Hyphenation.

• Position the insertion point WITHIN the word to set an individual hyphenation.
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2. Choose Text > Insert > Insert Hyphen/Dash > Discretionary Hyphen in the menu or Insert Hyphen/
Dash > Discretionary Hyphen in the context menu, or alternatively press the appropriate shortcut
keys.

The discretionary hyphen is a special character that has no width. Using the option View> Text Invis-
ibles in the text, the discretionary hyphen point can be displayed. The separation point is only used if
the word at the end of the line should also be separated. Please refer to the notes in the section Vari-
ables.

Delete discretionary hyphen
To reactivate the automatic hyphenation, you must delete the discretionary hyphen. Position the
insertion point at the corresponding position in the word and delete the special character with the
Backspace key. Optionally choose View > Text Invisibles to check if the discretionary hyphen has really
been deleted.

Manual hyphenation
You can also make a manual hyphenation of the word by entering a hyphen.

Choose Text > Insert > Insert Hyphen/Dash > Hyphen in the menu or Insert Hyphen/Dash > Hyphen in the
context menu, or alternatively press the appropriate shortcut keys.

However, it is not advisable to do this because the hyphenation is part of the text and does not disap-
pear if the word is not to be separated.

User dictionaries for hyphenation exceptions
Automatic hyphenation can be enhanced by user dictionaries if the modules do not know or may
hyphenate a word or string incorrectly.

The user dictionaries also support automatic substitution of strings in case of hyphenation. Such sub-
stitutions are indispensable in some languages for high quality hyphenation.

Please refer to the section Preferences.

Spell Check

With the Spelling and Grammar Checkers you can check a document for spelling errors and according
to the program module supplied also check for grammatical correctness. To carry out the Spell and
Grammar Checks correctly, it is necessary for the appropriate modules to be loaded when starting the
program.

Depending on the program version supplied, the software comes with a module for Spell Check and
Hyphenation for different languages. If you have installed hyphenation modules from other manu-
facturers, these may be selected for every single language in the Preferences.

You can also carry out a spell check of selected text passages or the current text chain (story). When
checking the current text chain, the check is made from the position of the insertion point to the end
of the text. It does not matter if the end of the text is visible in the screen or not.

Start manual Spell Check

1. Select a text passage or place the insertion point at the point in the text from which the Spell Check
should start.
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2. Choose Text > Spell Check or Window > Spell Check. If the Spell Check palette is already displayed,
click Start.

3. If the application finds an unknown character sequence, the dialog Spell and Grammar Check will
open. In the upper dialog section, the unknown character sequence will be shown in red in the
context of the current sentence or paragraph. Choose one of the following options:

• Double-click an entry in the list to replace the unknown character sequence with one of the
suggestions.

• Alternatively, choose an entry in the list and click Change.

• Change the unknown character sequence in the entry field Change to and click Change.

• Click Change Always if you assume that the error will occur again.

• Click Ignore if the unknown character sequence is correct but you do not want to take over the
unknown character sequence in your dictionary.

• Click Ignore Always if you assume that the unknown character sequence will appear in the text
several times.

• Click the Learn button if the unknown character sequence is correct and you want to take over
the character sequence in your personal language dictionary. The new sequence will be
imported into the dictionary displayed in the popup menu Language.

• Click Language if the character sequence is assigned the wrong language and you want to
assign another language. After this it is possible that new suggestions will appear in the list.

Automatic Spell and Grammar Check
You can run the Spell and Grammar Checks in the background fully automatically. In this instance
spelling errors will be displayed with a red wavy underline. and grammatical errors with a green
wavy underline.

1. Choose one of the following options:

• View > Automatic Spell Check — Switches the automatic Spell Check function on or off. Please
also refer to the section Preferences.

• View > Automatic Grammar Check — Switches the automatic Grammar Check function on or off.
Please also refer to the section Preferences.

2. Position the insertion point anywhere in the unknown character sequence.

3. Choose a correction suggestion in the context menu.

4. For grammatical errors (for example, commas) the correction suggestion can not be selected. In
that case, compare the proposal with the text and correct the text accordingly.

The wavy lines disappear as soon as the module in question no longer considers the character string
to be incorrect.
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Search and Replace

Simple Search and Replace

A basic function in any word processor or layout program is a powerful Search and Replace com-
mand. The application allows you to search for character strings, invisibles, style sheets or text prop-
erties which can then be replaced by other characters, invisibles, style sheets or text properties.

Search and Replace

1. Choose an appropriate option:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).

• Choose Edit > Search & Replace in the menu or Search & Replace in the context menu.

2. Choose one of the following options in the popup menu Search:

• Text — Searches for a character string. Enter the string in the entry field. A character string may
consist of any combination of characters, invisibles (control characters) and regular expres-
sions. Searching for invisibles and regular expressions will be described in a separate section.

• Font — Searches for a character string with a font/font face. Choose a font and a font face.

• Font Size — Searches for a character string with a font size. Enter a size and choose a relation
option.

• Text Color — Searches for a character string with a text color. Choose a color.

• Language — Searches for a character string with a language. Choose a language.

• Character Style Sheet — Searches for a character string with a character style sheet. Choose a
character style sheet.

• Paragraph Style Sheet — Searches for a character string with a paragraph style sheet. Choose a
paragraph style sheet.

• Layout Style Sheet — Searches for a character string with a layout style sheet. Choose a layout
style sheet.

3. Click on the arrow icons to add or remove additional search definitions. Example: Search for the
character string “Sam” and then the color [Red]. The program will only find the strings to which
the appropriate color is assigned.

4. Optionally choose Replace if you want to replace the character strings found. The options work in
exactly the same way as the search options. Example: Search for the character string “Sam” and
replace with the color [Red]. The program will assign the color to all the strings found.

5. Choose one of the following options:

• Forwards/Backwards — Searches the text of the current text chain (story) after /before the posi-
tion of the insertion point. The options are only available if the insertion point is set in a text
object and the Document option is not selected.

• Document — Searches all the text chains (stories) in the document.

• Whole Word — The character string corresponds to a whole word or a word fragment. Example:
Choose the option if you only want to find the name “Sam” but not the word “Sample”.

• Ignore Case — Ignores the case for the search. Example: Choose the option if you want to find
the name “Sam” but also written as “sam” or “saM”.
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6. Click the Search button to start the search.

7. The character strings found will be marked automatically and displayed in the document window.
Click one of the following buttons:

• Search — Searches for further character strings.

• Replace & Search — Replaces the character string found and searches for further character
strings. The program will show a message in the palette when no further strings are found.

• Replace — Replaces the character string found without continuing the search for further
strings.

• Replace All — Replaces all further character strings automatically. Choose this option if you do
not need to show the strings found in the text and confirm them individually. When the process
is completed the program may show the number of replacements made.

Search and Replace invisibles

1. Choose an appropriate option:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).

• Choose Edit > Search & Replace in the menu or Search & Replace in the context menu.

2. Choose Search > Text.

3. Click the Invisibles icon on the right of the entry field and choose an option from the popup menu
or enter the control character manually in the entry field (e.g. “\p” for a Return). Enter as many
invisibles/control characters as you like or combine them with normal text. Example: the character
string “.\p\p” looks for a full stop/point followed by two Returns.

4. If required, choose the option Replace to replace the strings found. The options work in exactly the
same way as in the search. Example: The string “.\p” would remove the second Return in the above
search.

Complex Search and Replace

If you want to search for several variations of a character string (e.g. “Car” and also “Cars”, you must
extend and repeat this search.

With a complex search you can define several variations of a character string in a search. Here the
program uses the so-called “Regular Expressions”. This is a special syntax with which you create a
sort of text example for a complex search query. This syntax is broadly standardized and is also used
in other programs, mainly in text editors. Since this technology was used for the first time in the Unix
program “GREP” (Global Regular Expressions Program), these regular expressions are often referred to
in other programs as “GREPS”.

Regular expressions consist of meta characters (e.g. “\r” for a Paragraph Break or Return, or „()“ for
areas) and Operators (z.B. “|” for “or”).

Examples:

“Ca(r|rs)” will find “Car” or “Cars”.

“(Mr.|Mrs.) Doe“ will find “Mr. Doe“ or “Mrs. Doe”.

“(Mr.|Mrs.|Miss) (\w+)” will find “Mr. Doe”, “Mrs. Smith“, “Miss Jones“.

“[\.\-\w\d.]+@[\.\+\w\d.]+” will find all Email addresses.
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“(D|d)rag( ?|-?)(and|&|‘n‘)( ?|-?|)((D|d)rop)” will find “Drag and drop”, “Drag and Drop”, “Drag-
and-drop”, “Drag-and-Drop”, “Drag & drop”, “Drag & Drop”, “Drag‘n‘Drop”,
“Draganddrop”

You can find a complete description of the regular expressions in the Internet:
http://userguide.icu-project.org/strings/regexp

Search and Replace Regular Expressions

1. Choose an appropriate option:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).

• Choose Edit > Search & Replace in the menu or Search & Replace in the context menu.

2. Choose Search > Text.

3. Enter the regular expression. Example: the character string “.\p\p” looks for a full stop/point fol-
lowed by two Returns.

4. If required, choose the option Replace to replace the strings found. The options work in exactly the
same way as in the search.

5. Choose the option Regular Expressions to tell the program that the text should not be interpreted
as a character string but as a regular expression.

Index and Tables
The application has different internal memories for managing the index and tables. There are altogether
six different lists with the names Index, Contents Entry, Bibliography Entry, Abbreviation, Picture
Entry and Chapter. The naming of these indexes is for your convenience only, since technically you
could generate a Table of Pictures for all bibliography entries or for example for a list of authors.

The index generation facilities make the compilation of indexes a lot easier. The automatic generation
of an index allows for an up-to-date index with a high degree of accuracy.

An index may contain any character strings of up to 256 characters in length. A character string con-
taining a return will only be indexed up to the return.

Create an index entry for a text string

1. Select a word or character string.

2. Choose Text > Mark as > Index Entry.

3. Repeat the last two steps for every word or character string that you wish to include in the index.

To check the index, an index must first be created.

Generate an index

1. Position the insertion point.

2. Choose Text > Create > Index.

Indexes always refer to all entries marked in the current document.
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Footnotes and Endnotes
Footnotes and Endnotes are notes relating to a text, but which are not placed in the body text in
order to increase its legibility. The Footnote or Endnote contains additional explanations of the main
text, such as legends, notes, sources for quotes etc., which can be quite extensive. Footnotes and
Endnotes consist of a reference character in the body text and the Footnote or Endnote text. The Foot-
note text generally appears at the end of the text area or the chapter, Endnotes at the end of the
chapter or the main text, whereby the Footnote/Endnote Label (character or number) is repeated
before the appropriate text.

The program offers extensive functions for the entry, management and display of Footnotes and End-
notes. Below is a short overview:

• An unlimited number of Footnotes and Endnotes can be applied in a document.

• Footnotes and Endnotes are numbered automatically by the program. The numbering changes
automatically as soon as Footnotes or Endnotes are inserted or deleted.

• The numbering of Footnotes and Endnotes can follow per document or chapter.

• Style Sheets can be assigned to Footnotes and Endnotes both manually and automatically.

• Endnotes can be output at the end of the body text or at the end of the chapter.

• Footnotes can be displayed at the foot of the text object, the text column or at the end of the lay-
out.

• Footnotes and Endnotes can be displayed independently of the body text in several columns
and with a separator line.

• Footnote labels can be extended with a text that is displayed in front of and/or after the Foot-
note label (Prefix and Postfix).

Preparations for Footnotes and Endnotes

Preferences for Footnotes and Endnotes
Before you start creating Footnotes and Endnotes, you should make a few preparations:

1. Create Paragraph Style Sheets for the Footnote Text or Endnote Text as well as Character Style
Sheets for the Footnote Reference or Endnote Reference and the Footnote Label or Endnote Label.
When creating the Style Sheets, please apply the following rules:

• Footnotes or Endnotes are ideally displayed in a font size that is one or two points smaller than
the body text.

• So as not to change the type color of the page, the Line Spacing of the body text and the Foot-
note Text or Endnote Text should be identical.

• The Footnote Reference or Endnote Reference in the body text should be displayed in Super-
script. In the Footnote Text or Endnote Text however, the Footnote Label or Endnote Label char-
acter should not be in Superscript, because otherwise the legibility will be lost due to the
smaller type.

2. Define the layout of the Footnotes and Endnotes in the Preferences. Subsequent changes in the
Preferences only take effect on new text chains or new footnotes and endnotes. Changes for exist-
ing text objects and their text chains can be made using the Module palette.
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3. Define the Position of the Footnotes and the number of columns for them in the text object set-
tings.

Define Preferences for Footnotes and Endnotes

1. Choose Edit > Preferences > Text (Windows/Linux) or VivaDesigner > Preferences > Text (Mac OS).

2. Choose the following options in the dialog section Footnote Style Sheets:

• Choose the Character Style Sheets for the Footnote Reference and the Footnote Label and the
Paragraph Style Sheet for the Footnote Text.

3. Choose the following options in the dialog section Endnote Style Sheets:

• choose the Character Style Sheets for the Endnote Reference and the Endnote Label and the Par-
agraph Style Sheet for the Endnote Text.

4. Choose the following options in the dialog section Footnotes:

• Offset — Defines the minimum offset between the body text and the Footnote Text.

• Prefix/Postfix — Define if and which character(s) should be inserted before and/or after the
Footnote Reference and the Footnote Label.

• Format — Defines how the Footnote Reference and the Footnote Label should be displayed.

• Numbering — Defines if the numbering should be Continuous or Chapter wise. With the option
Chapter wise the numbering starts from the beginning as soon as a chapter break is inserted in
the text. Please refer to the section Working with Text > Insert Variable.

• Start with — Defines the first number for the footnotes.

• Separator — Defines if a separator should be displayed between the body text and the footnote
text.

• Vertical Offset/Horizontal Indent — Define the position of the separator. Both positive and neg-
ative values are allowed.

• Line Width/Color/Line Style/Length — define the display of the Separator.

• Length — Absolute values (e.g. 100 mm) and relative values (e.g. 50%) are allowed. Relative
values relate to the width of the text object. With multi-column text objects the value relates to
the width of a text column.

5. Choose the following additional options in the dialog section Endnotes:

• Display Position — Defines if the Endnote at the end should be displayed After the Related Text,
In a new Text Column or In a new Text Object.

• Offset — Defines the minimum offset between the body text and the Endnote Text.

• Save to — Defines if the Endnotes should be displayed at End of Text or End of Chapter.

• Prefix/Postfix/Format/Numbering/Separator — Defined in the same way as the settings for foot-
notes.

Footnote Position

For every text object in a text chain, you can define how the footnotes should be positioned. This is
particularly helpful if the positioning for left and right hand pages is different. In this way you can
for example define that for a two-column text object the footnote should be in the right hand column
on the left hand page and the left hand column on the right hand page.
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Define the Footnote Position

1. Choose the text object in which the Footnotes are to be displayed. In new documents with an auto-
matic text object, select the text object on the appropriate Alias Page.

2. Choose Object > Special > Header & Footer in the menu or Special > Header & Footer in the context
menu.

3. Define the following options in the Footnotes section:

• Use the popup menu Position to define the position of the footnotes:

• Layout — The footnotes are displayed at the end of the Layout. If the body text contains no
Layout Break, the footnotes will be displayed in the same way as with the option On every text
column. If the body text flows over several text object columns, it may be that some footnotes
will be displayed in the previous text object columns and some at the end of the Layout.

• On every text column — The footnotes are displayed at the end of every text column.

• On text frame — The footnotes are displayed at the end of a text object. With multi-column text
objects the footnotes will always be output in the first column.

• Number of columns/Gutter — Defines the number of footnote columns within a text object col-
umn and their gutter.

• Start from column — Defines from which text object column the footnotes should be displayed.
This option can only be selected when the text object has more than one column.

• Width — Defines the width of the footnotes depending on the number of text object columns.
This option can only be selected when the text object has more than one column.

Working with Footnotes and Endnotes

After completing the preparations for the footnotes and endnotes, you can now begin inserting them.

Insert Footnotes and Endnotes

1. Position the Cursor at the point where the reference character for the footnote or endnote should
be inserted.

2. Choose Footnote or Endnote in the menu Text > Insert Character > Insert Variable or in the context
menu Insert Variable.

The number for the footnote or endnote will be inserted at the cursor position, and the Style Sheet
that was defined in the Preferences will be applied to it. At the same time, the footnote or endnote
number (label) followed by a default footnote or endnote text will be inserted (in the predefined
position), and the Style Sheet that was defined in the Preferences will be applied to them. You can
now overwrite the footnote or endnote text and replace it with your own.

Convert Footnotes and Endnotes

1. Position the Cursor exactly in front of the Footnote number or Endnote number (reference) in the
body text.

2. Choose Note Settings in the context menu.

3. Choose Footnote or Endnote in the popup menu Type.

4. If you still have the default note text (“Footnote text” or “Endnote text”) showing in the lower sec-
tion of the dialog, it is advisable to change it accordingly.
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5. Confirm the entry.

Automatic Numbering

All footnotes and endnotes are numbered automatically. If you insert a new footnote or endnote in
the body text, the program checks whether there are additional footnotes or endnotes before and
after, and changes the numbering of the footnotes and endnotes according to the preferences set.

You can switch the automatic numbering for individual footnotes or endnotes on or off. This can be
helpful if you want to insert a footnote or endnote that should not be counted with the others or if all
footnote or endnote references consist of a character (e.g. *). Such exceptions are often used if the
footnote contains a reference to the author of the article or if very few footnotes are used in the whole
body text.

Switch off Automatic Numbering

1. Position the Cursor exactly in front of the Footnote number or Endnote number (reference) in the
body text.

2. Choose Note Settings in the context menu.

3. Choose No in the popup menu Numbering if you want to enter a manual number or an appropriate
character for the footnote or endnote.

4. Enter the required character(s) in the Custom Text field. As default the program shows an asterisk
(*).

5. Confirm the entry.

You can change this setting at any time and switch the automatic numbering on again.

Switch on Automatic Numbering

1. Position the Cursor exactly in front of the Footnote number or Endnote number (reference) in the
body text.

2. Choose Note Settings in the context menu.

3. Choose Yes in the popup menu Numbering if the footnote or endnote should be numbered auto-
matically.

4. Confirm the entry.

Deleting Footnotes and Endnotes

Delete Footnotes and Endnotes
• Delete the Footnote Reference or Endnote Reference number in the body text.

• Alternatively, delete the Footnote Text or Endnote Text AND the Footnote Label or Endnote Label
(number).

The footnote and the Footnote Reference will then be deleted automatically. If necessary, the foot-
notes and/or endnotes will be renumbered.
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General Tips for Footnotes and Endnotes

- Deleting or overwriting The Footnote Label or Endnote Label has no influence on the numbering.

- Overwriting the Footnote Reference or Endnote Reference causes the connection to the automatic
numbering to be lost.

- Overwriting the Footnote Reference or Endnote Reference in the body text automatically deletes
the footnote or endnote.

- If you choose the option Select All in the footnote text, all the footnotes in the current text col-
umn will be selected.

- When using the command Cut in the body text for text containing a footnote or endnote, the
Footnote Text and/or the Endnote Text will be cut with it and copied to the Clipboard. If you
paste text containing a footnote or endnote, the Footnote Text and/or the Endnote Text will be
pasted with it.

- You can copy footnote or endnote text to other footnotes or endnotes as well as to the body text.

- In a footnote or endnote text it is not possible to insert a footnote, an endnote or a chapter
break. Although it is possible to insert a layout column break, a text object break or a layout
break, this is not recommended for technical reasons.

- Only the whole footnote or endnote text may be displayed.

- Breaking footnote or endnote text is not possible. If a footnote or endnote text cannot be dis-
played completely in a text column, the footnote and/or endnote text including the line in the
body text that contains the footnote or end note reference will be broken to the next column or
the next text object. If this is not possible, a text overflow will be displayed (providing you have
activated the guide lines with the shortcut keys Ctrl + L (Windows/Linux) or Command + L (Mac).

- Column settings for Layouts are not valid for footnote or endnote text.

- Column settings for footnotes can only be defined for the text object.

The Line Counter
With the Line Counter you activate a numbering of the text lines in a story and display the numbers
on the left or right text border. In ancient times, the line number next to the text was “invented” to
be able to pay the writer according to the number of lines written. In modern publications, the line
counter is used mostly for precise definition of source information.

Switch the Line Counter on or off for the whole text Story

1. Choose one of the following options:

• Choose the menu command Text > Story. The Line Counter tab is the first in the dialog and
therefore active as default.

• Go to the Story tab in the Module palette.

2. Choose an option in the popup menu Line Counter to switch the Line Counter on or off:

• Choose the option None to switch off the Line Counter for the whole Story .
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• Choose the option Left to switch on the Line Counter for the whole Story and display the num-
bers left of the text. Line numbers output on the left are aligned to the right automatically.

• Choose the option Right to switch on the Line Counter for the whole Story and display the num-
bers left of the text. Line numbers output on the right are aligned to the left automatically.

3. Define the start value of the counter with the option Start with.

4. Choose the option Range to define the interval between line numbers. The value “1! means that a
number will be assigned to each line, while the value “5” stands for every fifth line. If the start
value is “3”, however, the counter with the value “5” will be placed not in the fifth but on the third
line.

5. Choose the option Indent to define the distance between the line numbers and the appropriate
text object or column border. If you have text with several columns, make sure that the column
gutter is sufficiently wide to display the line numbers. If the gutter is not wide enough, the line
numbers may lie on top of the text in neighboring columns.

6. In the popup menu Restart every, choose one of the following options to influence the numbering:

• Choose the option Continue so as not to interrupt the counter in the whole story.

• Choose the option Text Column to restart the counter in every new text column in the whole
story. The term Text Column means text objects posessing several text columns that were
defined using the command Object > Special > Text Columns and each additional linked text
object, irrelevant of whether they have one or several text columns.

• Choose the option Text Layout Column to restart the counter in every new text column in the
whole story. The term Text Layout Column means text posessing several text columns that were
defined using the command Text > Layout > Columns or alternatively in the Layout tab of the
Module palette.

• Choose the option Text Object to restart the counter in every new text object in the whole story.

• Choose the option Layout to restart the counter after every layout break in the whole story. The
term Layout break means text with different layout options that were defined using the option
Text > Layout > Columns or alternatively in the Layout tab of the Module palette.

• Choose the option Chapter to restart the counter after every chapter break in the whole story.
The term Chapter break means text with different chapter options that were defined using the
option Text > Chapter or alternatively in the Chapter tab of the Module palette.

7. Choose the option Suppress Empty Paragraphs to automatically ignore all empty paragraphs con-
sisting of just a Return or another break character.

As well as empty paragraphs, paragraphs with text can also be suppressed by the line counter.

Suppress the line count for a paragraph

1. Place the cursor in the paragraph that is to be suppressed.

2. Choose one of the following options:

• Choose the menu command Text > Paragraph Options > Suppress Line Counter.

• Choose the option Suppress Line Counter in the Paragraph tab of the Module palette.

Changing Line Counter Preferences

You can define the display and the standard values for the Line Counter in the Preferences.
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Define font attributes for the Line counter

1. Choose the option Edit > Preferences > Program > Text > Line Counter (Windows/Linux) or VivaDesig-
ner > Preferences > Program > Text > Line Counter (Mac OS).

2. Choose the font for the Line Counter from the Font popup menu.

3. Choose the font size for the Line Counter from the Font Size popup menu.

4. Choose the color for the Line Counter from the Color popup menu.

5. Choose the the options for all new text objects as per the section Switch the Line Counter on or
off for the whole text Story from the Line Counter popup menu.

Please note that the settings are valid for the whole document.
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Working with Pictures
A picture is worth a thousand words. This ancient saying indicates the importance
of images in a document. This is precisely why a layout program must be able to
handle images with the same ease as text.

Poor images will not be improved by using this application. But, providing no mis-
takes are made, this is also true the other way around.

Before we describe how to create Picture objects and import images in depth, we
think it is useful first to introduce some basic concepts of computer images and
image formats.

This knowledge may potentially save not only the amateur, but also the practiced
professional much time, trouble and money. If you feel comfortable with the vari-
ous image for mats, you can ignore the following section and proceed with the par-
agraph Creating picture objects.

Raster or Vector Images
In computer images there is a basic difference between raster images and vector images, also known
as pixel and object images. Put simply, you can say that photographs taken with a digital camera are
saved as pixel images, and such items as company logos are usually saved as vector images.

A raster image with a size of 300 by 300 means this images is represented by 300 pixels in both the
horizontal and vertical direction. Unfortunately it is not possible to calculate the size of the image in
millimeters or inches on the basis of this information, as it is not known how many dots or pixels
occur in a unit length. This depends on the resolution of the image.

The resolution of a raster image is defined by the number of pixels per inch or centimeter. The com-
mon measurement unit for images is DPI, or dots per inch.

An image with 72 by 72 pixels and a resolution of 72 dpi has a physical size of 1 square inch.This is
naturally a very low resolution, as generally resolutions for raster images range from 144 dpi to 600
dpi, and even up to several thousand dpi.

The quality of a raster image is further specified by the Color Depth. This Color Depth defines the
number of available colors that a pixel may have. Simple raster images contain a single bit per pixel
which represents either black or white. Pictures with a Color Depth of 2 bits per pixel allow 4 (22) dif-
ferent colors. A Color Depth of 16 Bits allows up to 65,536 (216) different colors.

Resolution and Color Depth or bit-depth are directly related. An image with a resolution of 300 dpi
and a bit-depth of 8 bits may be of poorer quality than an image with a bit-depth of 16 bits and a
200 dpi resolution.
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The enlargement factor of raster images is also problematic. If a raster image with a resolution of 72
DPI is enlarged by 200% the image resolution decreases to 36 dpi. If the image is reduced 50% the res-
olution increases to 144 dpi. The amount of pixels never changes when scaling the picture.

By contrast to raster images, vector images do not save their image information as individual pixels
but as a collection of command chains.

While with a bitmap image graphic forms consist of thousands of pixels, vector image formats only
store information about drawing the image and its attributes (line weight, color, etc.). Vector graph-
ics can be created with an illustration program. VivaDesigner also stores its information about
graphic elements such as objects, frames, lines and texts as vector information.

With these commands any lines, curves or text may be drawn. The advantage of vector images com-
pared to bitmap images is that vector information is much more efficient in storage than pixel
images.

The main advantage however, is the resolution independence of vector images. The command to
draw a circle can be drawn at the maximum resolution supported by the output device, and is not
limited by the amount of pixels.

This means you do not need to worry about the resolution or re-scaling of a vector image(e.g. 200%).

Commonly used image formats
There are hundreds of different image formats. In the professional publishing field the TIFF, EPS and
PDF image formats play a dominant role. Other formats like JPEG, or the Scitex CT format are becom-
ing more popular. To be able to assess which format is best for which document, you need to have
some background knowledge. We will therefore examine these formats in more detail.

Generally you can recognize image formats by their suffixes.

Raster Image Formats

The TIFF Format
This format for raster images is very versatile and supports bit depth of 1 to 48 bits per pixel. At the
same time it supports different color models; black and white, gray scale, RGB, CIE, RGB indexed col-
ors and CMYK. Which color model is the right one depends on what additional work will be done with
the image. We will go into this in more detail later. The TIFF format supports various compression
methods like RLE, LZW, CCITT Group 3 and 4, and JPEG. CCITT-compression is mostly used for transmit-
ting images on fax machines. The desktop publishing environment mainly uses the LZW and JPEG
processes.

The TIFF format differs between images for Motorola and Intel processors. These formats are fre-
quently called Macintosh or IBM PC format. VivaDesigner supports both variations. Images in TIFF for-
mat have the suffix .tif or .tiff. On Mac OS X VivaDesigner recognizes an image in TIFF format even if it
has no suffix.

The JPEG format
This platform-crossing format for raster images was developed in 1992 by the Joint Photographic
Experts Group (JPEG). What (in the jargon) is called the JPEG file format is actually the JFIF file format,
which stands for JPEG File Interchange Format. As a suffix usually .jpg (more seldom:
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.jpeg or .jpe) or .jfif is used. The JPEG format is the most commonly used image format in the Internet
and in digital cameras. The advantage of the JPEG format lies in its high compression rate, which
however is not without losses. This means that the higher the compression rate, the greater is the loss
in quality. Therefore professional digital cam eras store their images in either JPEG or in loss-free, but
storage-intensive RAW format. For this reason the JPEG format is only suitable for color out put of high
quality layouts in a very limited way.

If possible, raster images in JPEG format should be converted to TIFF or EPS formats with the CMYK
color model.

You can however freely use JPEG images if:

- the document output will be exclusively for the monitor.

- the output is to be made on a laser printer or copier.

- a color output in exclusively composite mode is made.

If you are planning a high quality output, you should where possible avoid using JPEG images.
Should this not be possible, you should observe the following rules:

- Use JPEG images only for screenshots.

- Ensure that color raster images are supplied not in RGB, but in CMYK format. This information is
supplied after image import by the Module palette or the Picture Usage. The RGB color model has
a much larger spectrum than CMYK, but RGB colors must be converted into CMYK colors (print
colors) for a color separation.

- If you or your service provider have a modern RIP, which can convert RGB data perfectly to CMYK
colors, you should ensure that you use a low compression to minimize quality losses.

- Ensure that the JPEG images have a resolution of 300DPI, insofar as the size of the image is not
reduced.

The BMP format
Windows Bitmap, BMP for short, is a file format for raster images that was developed by Microsoft for
the operating systems Windows and OS/2 and was introduced with Windows 3.0. The suffix is .bmp,
occasionally .dib. Like the JPEG format, the BMP format is only suitable for professional output in a
very limited way. If possible, raster images in BMP for mat should be converted to TIFF or EPS formats
with the CMYK color model.

You can however freely use BMP images if:

- the document output will be exclusively for the monitor.

- the output is to be made on a laser printer or copier.

- a color output in exclusively composite mode is made.

If you are planning a high quality output, you should where possible avoid using BMP images. Should
this not be possible, you should only use BMP images for screenshots.

The PNG format
The PNG format (PNG stands for Portable Network Graphics) is a plat-form-crossing format for raster
images. By contrast to the JPEG format the data is saved without losses and may contain transparency
information. Despite this, the PNG format is not suitable for a professional output due to it being lim-
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ited to the RGB color model. If possible, you should convert raster images in PNG format to TIFF or EPS
formats with the CMYK color model.

You can however freely use PNG images if:

- the document output will be exclusively for the monitor.

- the output is to be made on a laser printer or copier.

- a color output in exclusively composite mode is made.

If you are planning a high quality output, you should where possible avoid using PNG images. Should
this not be possible, you should only use PNG images for screenshots.

The SCITEX formats
The application supports three image formats developed by SCITEX Corp., namely the CT (Continuous
Tone) format, the LW (Linework) format and the BM (Bitmap) format.

The CT-format was developed for maximum performance on SCITEX RIPS and exposure devices. The
format is a highly compressed bitmap format, containing color-separated data, optimized for SCITEX
proprietary hard ware devices.

The BM-format is a simple 256 pixel per bit screen format. This format may also contain color-sepa-
rated data. BM files are typically very com pact.

The LW-format is ideally suited to black-and-white line-art scans for instance. Since it basically con-
tains only two colors very large scans may be highly compressed and efficiently stored.

Vector Image Formats

The EPS Format
The EPS format is the most commonly used vector file format in the publishing field.

We differ between the actual EPS format (Encapsulated PostScript) with the suffix .eps and the
extended EPSF format for Macintosh with the suffix .epsf, which contains an integrated image preview
as a resource.

So that the commands to create an image on the printer for the monitor do not have to be prepared
again, some vector formats save a preview of the vector image. This preview displays a Bitmap in 72
DPI resolution which symbolizes the commands or elements of the file.

The special feature of PostScript format lies in the fact that, it can contain not only vector graphics
but also raster information (as with TIFF or PICT-format). Due to the simple and brief commands even
for complex graphics there is also a higher printing speed for EPS images, since for example in the
printing of a circle not all the points in the circle, but just the command to draw a circle is sent to the
printer. Therefore a vector-oriented EPS is also completely independent of the resolution of the output
device.

The advantage of a high printing speed disappears when only a small part of an EPS image is printed.
While with different Bitmap formats in part only the visible section of the image is sent to the printer,
the pro gram always has to transfer the whole EPS file. This is because it has no intelligence to know
which part(s) of the image make up the visible crop.
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Another advantage of the EPS-format is the support of transparency. While vector images always
support transparency, the unique thing about EPS is that it also supports transparency for raster
images under certain conditions.

The EPS/DCS Format
A particular instance of the EPS format is the DCS format (Desktop Color Separation). This format is
especially suited to fast color separation of EPS images and is available in two versions.

With the DCS 1.0 format an image consists of five files, a so-called Lay out file consisting of a preview
and references to the other four files, which contain the appropriate CMYK representations of the EPS.

With the DCS 2.0 format an image consists of one file, which contains all the color separations pre-
separated.

DCS images also have advantages and disadvantages. The advantage of the DCS format is the speed
with which color separations can be printed. Also the DCS-1 format allows you to distribute the layout
file for presentation purposes while data integrity is maintained since the preview cannot be printed
with the needed high resolution without the 4 corresponding data files.

A disadvantage of using the DCS format when outputting to color printers for proofing is that most
desktop printers do not allow you to print in CMYK format. In this case the program outputs the lay-
out file as on a laser printer.

The PDF Format
The PDF format is a document format that can save any text and images in a high quality, and which
may be displayed on and output from every operating system in high quality. Although PDF format is
not a classical image format, VivaDesigner can import PDF files into picture objects and output them
accordingly.

OPI Images
The so-called OPI images present a special feature in the use of image formats. OPI stands for Open
Press Interface and was developed in the nineties to reduce the data mass for images when working
with layout programs. OPI images are not created by an image or photographic pro gram, but by a
so-called OPI server. This server creates low resolution versions of images in TIFF or EPS format in the
form von Layout images. The OPI server creates for example from a 20MB TIFF or EPS file an 800KB lay-
out image. A layout image receives the same file name when it is created. According to the server set-
tings the layout image may receive the suffix of the high resolution original (also .eps or .tiff) or the
suffix .lay. Technically we are still dealing with images in TIFF or EPS format, which however possess
an additional commentary with the name and path of the high resolution file. The much smaller lay-
out images can be imported very quickly and save memory space. In the print output later you can
specify in the program if this commentary should be included in the output, so that the OPI server can
later replace the layout images with the high resolution original data.

EPSF Vector Images and Fonts
While text is saved in raster images as a collection of pixels, the EPS for mat is able to save the text and
its properties as a format reference in vector images.
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In order to print the text of a vector image correctly, most programs offer the possibility of embed-
ding the fonts used directly in the vector image (EPS or PDF). Some programs also offer the possibility
of converting the fonts used into outline paths (objects). You should only use this option when
embedding the fonts is not possible.

If fonts are not embedded or converted into outline paths, this can lead to output problems. In this
case the user must ensure that the fonts used are installed and possess exactly the same names.

To address this problem the application shows a Font Usage, which also lists fonts needed by
imported EPS image files. Without this special Font Usage facility it would be hard for the user to ver-
ify if fonts may be missing, which might cause problems during printing.

This is because the preview of the picture is saved as a Bitmap where type is normally displayed as a
collection of pixels. Therefore the user, in contrary to normal text in the VIVA-document, cannot real-
ize that the font used in the EPS might not be available.

For further explanation of this dialog please see the section entitled Font Usage.

Vector Images and Colors
When an EPS vector image is imported which contains colors not defined in the current document, the
colors will automatically be added to the available colors. Adding means that the application will
take over the color name, the color definition and also the color separation mode.

Colors that are taken into the color list through importing an EPS file can be edited with the menu
Edit/Colors, but these changes only affect objects that use these colors, but not the EPS file which also
contains the color.

Colors that are taken into the color list through importing an EPS file will remain in the color list even
if the EPS file that contains these colors has already been deleted from the document. Colors that are
taken into the color list from an EPS file can only be deleted when the appropriate EPS file is no longer
used in the document and also when other objects in the document do not use this color.

For further explanation of this dialog please see the section entitled Color Usage.
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Creating Picture Objects
VivaDesigner is an object-oriented typesetting and layout program. This means that as with text,
images are always displayed in closed picture objects. For this reason, a picture object must be cre-
ated before the required picture is imported. The picture will be displayed within this object.

1. Picture objects may have any arbitrary form as long as they are closed objects.

2. A new picture object is created by means of the closed object tools in Toolbar, or with shortcut
keys or menu commands.

Create a new picture object interactively

1. Choose one of the following options:

• Click the Picture Object Tool.

• Hold down the mouse button and select a tool form to create your picture object.

2. Click on the document page and create the picture object.

It may be quicker if you create a picture object using the menu or short cut keys.

Create a new picture object with menu/shortcut keys

1. Choose one of the following options:

• Press Ctrl + Shift + B (Windows/Linux) or Command + Shift + B (Mac).

• Choose Object > Content > Picture.

You can also create a picture object by converting another closed object to a picture object.

If you change a graphic object into a picture object the conversion will be immediate. However if a
text object is changed into a picture object an alert message may appear warning you that the text
will be lost.

Convert an existing object into a picture object

1. Choose an existing closed object.

2. Choose one of the following options:

• Press Ctrl + Shift + B (Windows/Linux) or Command + Shift + B (Mac).

• Choose Object > Content > Picture in the menu or Content > Picture in the context menu.

After the creation of the picture object a diagonal cross will appear, indicating the picture object is
empty.

Summary Creating Picture Objects
- Picture objects can be created by using the Toolbar Object tools.

- Picture objects can be created automatically using the shortcut keys Ctrl + Shift + B (Windows/
Linux) or Command + Shift + B (Mac) or with the menu command Object > Content > Picture, as
long as no other object is selected.

- Picture objects can be created by converting other object types.
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Image Mode

Activate/Leave Image Mode

To import an image or position an imported image you will need to enable the Picture mode. As you
already know the mouse pointer will automatically change into the appropriate pointer for the spe-
cific object type.

When the mouse pointer is positioned over a picture object it will change into the grabber pointer.

Activate Picture mode
Click with the mouse on the surface of a picture object.

- After the picture mode is selected by clicking in the object:

• The Picture menu will appear.

• The Module palette in Picture mode will appear if it was not specifically hidden.

• The object frame will be highlighted.This imaginary frame shows at which point the mouse
pointer will change into the object pointer with which you can select and move the object itself.

• Hollow handles will appear. These handles indicate that Picture mode is activated and where
the mouse pointer will change into the sizing pointer through which the object can be resized.

Note: To select a picture object which is part of a group of objects without ungrouping all the
objects, the Group Mode must be deactivated. Click anywhere on the page where there is no Object
to activate Object mode and Choose Object > Group Mode Active or Press Ctrl + Alt + U (Windows/
Linux) or Command + Option + U (Mac).

Ways of leaving Picture Mode
• If the picture mode is enabled and the mouse pointer is positioned on a handle it will change

into the sizing pointer. If the mouse button is held down the object can be resized. The pro-
gram will then change to Object mode.

• Click anywhere in the document where no object is present.

• Hold down the Ctrl key (Windows/Linux) or the Command key (Mac) while clicking the object.

Importing Pictures
You can import pictures using a selection dialog, interactively with Drag and Drop or with the Clip-
board.

The Import Command

You can import pictures (images or illustrations) using the import dialog. The program opens its own
dialog as the default for picture import, which is identical for all operating systems. You already
know the operation of this dialog from other sections.

Import picture with the dialog

1. Choose or create a picture object and activate the Picture Mode. The picture slider should appear
further down the page from the object.
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2. Choose one of the following options:

• Press Ctrl + E (Windows/Linux) or Command + E (Mac).

• Choose File > Import in the menu or Import in the context menu.

• Click the Import icon on the left hand side of the picture slider.

3. Set the required display of folders and files using the options familiar to you.

4. Use the many navigation assistants to select the folder in which your picture file is stored.

5. Choose the picture file with the mouse pointer or enter the name of the picture file in the entry
field File Name.

6. You may select an option in the popup menu File Type to limit the display of picture files.

7. You may click the OS Dialog button if you prefer to work directly with the operating system of your
computer (OS = Operating System).

8. Click the Open button when you want to import the picture file you have selected.

While importing a picture with the Import command the picture will not normally be embedded in the
document. The program just saves a preview, the picture name and the required path. This keeps the
size of the document within reasonable bounds.

The imported pictures have to be opened to produce the preview, then closed again so they may be
modified again immediately by other users in a network when necessary.

The program does offer the option of embedding the images used in the document. This will increase
the size of the document accordingly.

If you import an image in a picture object that already contains an image it will take on the current
attributes applied to the previous image. If you have modified the position or the scaling factor of the
previous picture, these parameters will automatically be applied to the new one.

If you want to import a picture into an empty picture object with certain special properties, the
parameters should be set beforehand in the Module palette in Picture mode.

Drag and Drop

Drag and Drop is a well-known technique with which you can move files and folders in the operating
system. You can use the mouse to import pictures directly from the desktop or any folder on your
computer, an external hard drive or local network.

Import pictures to existing picture objects with Drag and Drop

1. Open the folder containing the picture files.

• Make sure that both the icon of the picture file and the picture frame in the document window
are visible.

2. Click the picture file icon and with the mouse button held down, drag it over the picture frame in
the document window.

3. Release the mouse button to import the picture into the picture object.

You can also use the Drag and Drop function to import a picture and at the same time create a new
picture object. Simply drag the picture file to the document page and release it. The picture will be
imported in an object with a default size determined by the program, and you can then edit the pic-
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ture and object settings in the usual way. With this method you can also import a number of pictures
simultaneously.

Import several pictures with Drag and Drop

1. Open the folder in the operating system.

2. Mark the picture files you want to import and with the mouse button held down, drag them to the
document page.

3. Release the mouse button to import the pictures. The program will import and display them in a
default size determined by the program according to the number of pictures imported.

Clipboard

You can import pictures using the Clipboard of different programs. The clipboard is a memory area
that the operating system provides for the exchange of data between various programs. If a picture
or text is copied to the clipboard, other programs can import (paste) this data into their documents.

By contrast to the Import command, the imported picture is embedded in the document, since there
is no file which the program could refer to during output. Therefore pictures imported via the clip-
board only have a screen resolution and are therefore not suitable for high quality printing.

Deleting, Cutting and Copying Image Content
There are two ways to delete the content of a picture object. You can delete the picture and leave an
empty picture object, or you can import another picture into the same picture object.

To cut or copy the content of a picture object to another picture object, use the well-known com-
mands Cut, Copy and Paste.

Deleting/Cutting/Replacing picture content

1. Activate Picture Mode.

2. Choose one of the following options to delete an image:

• Press the Backspace or Delete key.

• Choose Edit > Delete in the menu or Delete in the context menu.

3. Choose one of the following options to cut an image when you want to paste the image into
another picture object:

• Press Ctrl-X (Windows/Linux) or Command + X (Mac).

• Choose Edit > Cut in the menu or Cut in the context menu.

4. Choose one of the following options to replace an image:

• Press Ctrl + E (Windows/Linux) or Command + E (Mac).

• Choose File > Import in the menu or Import in the context Menu.

Copy & Paste picture content

1. Activate the Picture Mode in the picture object you want to copy.

2. Choose one of the following options:
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• Press Ctrl + C (Windows/Linux) or Command + C (Mac).

• Choose File > Copy in the menu or Copy in the context menu.

3. Activate the Picture Mode in the picture object into which you want to paste the picture.

4. Choose one of the following options:

• Press Control-V (Windows/Linux) or Command + V (Mac).

• Choose File > Paste in the menu or Paste in the context menu.

Defining the Crop
As long as there are no preference properties set for a picture object an imported picture will be
placed in the upper left corner of the picture object. However you may move the picture in the picture
object in any desired direction. To do so there are several options:

- Interactive moving with the mouse/grabber hand.

- Interactive moving with the arrow keys.

- Precise positioning by means of parameter entrances in the Picture palette.

- Precise positioning by centering the picture in the picture object.

- Filling the object frame proportionally and centering the picture in the picture object.

- Skewing and rotating the picture.

- Resizing the picture object.

Moving Picture Content

The picture can be moved and aligned with the mouse/grabber hand, with the arrow keys or with
menu commands. In the default settings the picture preview will be displayed when the picture is
moved in the picture object. The preview is also shown with a frame to help with positioning.

Move picture content interactively

1. Activate Picture Mode.

2. Hold down the mouse button (Mac) or the left mouse button (Win dows/Linux) and drag the pic-
ture in any direction.

• Hold down the the Shift key to constrain the movement to 90 degrees horizontal/vertical.

3. Instead of the mouse, use the arrow keys to move the picture.

In all the cases described above, the current position of the pre view will be displayed immediately in
the Module palette (in Picture mode).

4. Alternatively, use the entry fields in the Module palette to define the top left hand position of the
preview in the picture frame. Both positive and negative values may be entered in all units of
measurement.

While moving the image interactively with the mouse/grabber hand or with the arrow keys, the actual
position is displayed immediately. This may slow down the speed of the program but undoubtedly it
enhances your control over the work.

160



Working with Pictures | Defining the Crop

The speed and display quality when moving pictures can be defined in the Document Preferences for
Pages & Objects.

Display options for moving pictures

1. Choose the option Pages & Objects in the Preferences.

2. Choose one of the following options in the popup menu Move Image Content:

• Gray out images — Only a (blue) frame instead of a preview should be displayed when moving
a picture. This option is suitable for very slow computers.

• Show preview in frame — The preview should be displayed when moving a picture. This option
is activated as default.

• Show complete preview — The complete pre view should be displayed when moving a picture. This
option is suitable for very precise picture positioning, and is intended for very fast computers.

3. Confirm the entry.

If when moving picture content you wait for a second with the mouse, the picture preview will flicker
briefly. This is a signal to the user that the program has temporarily changed the display mode for the
current movement of the picture:

• If in the Preferences the option Move Image Content has been activated, the program behaves
temporarily as if the option Show Pre view in Frame has been selected.

• If in the Preferences the option Show Image Size has been activated, the program behaves tem-
porarily as if the option Show Complete Pre view has been selected.

You can also move or align the picture preview using menu commands.

Move picture preview using menu

1. Choose one of the following options to center the picture horizontally and vertically in the Picture
object:

• Press Control-Shift + M (Windows/Linux) or Command + Shift + M (Mac).

• Choose Picture > Alignment > Center in the menu or Center in the context menu.

2. Choose one of the following options to align the picture horizontally on the left edge of the Picture
object:

• Press Ctrl-Shift + G (Windows/Linux) or Command + Shift + G (Mac).

• Choose Picture > Alignment > Left in the menu or Alignment > Left in the context Menu.

3. Choose one of the following options to align the picture horizontally on the right edge of the Pic-
ture object:

• Press Ctrl + Shift + R (Windows/Linux) or Command + Shift + R (Mac).

• Choose Picture > Alignment > Right in the menu or Alignment > Right in the context Menu.

4. Choose one of the following options to center the picture horizontally in the Picture object:

• Choose Picture > Alignment > Center Horizon tally in the menu or Alignment > Center Horizontally
in the con text menu.

5. Choose one of the following options to align the picture vertically on the top edge of the Picture
object:

• Choose Picture > Alignment > Top in the menu or Alignment > Top in the context Menu.
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6. Choose one of the following options to align the picture vertically on the bottom edge of the Pic-
ture object:

• Choose Picture > Alignment > Bottom in the menu or Alignment > Bottom in the context menu.

7. Choose one of the following options to center the picture vertically in the Picture object:

• Choose Picture > Alignment > Center Vertically in the menu or Alignment > Center Vertically in
the con text Menu.

When the image is centered in the object, an absolute value is calculated that does not change when
the height or width of the Picture object is changed.

Move picture preview precisely with the dialog

1. Choose a Picture object.

2. Choose an appropriate option:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Enter a value in the fields Horizontal and/or Vertical in the Off set section. Positive values move the
picture preview to the right or downwards, negative values move the picture preview to the left or
upwards. The reference point is top/left.

4. Confirm the entry.

Resizing Picture Object

The picture crop may of course also be determined by subsequently altering the size of the picture
object. If you resize the picture object upwards or to the left the image preview inside will follow the
movement, not changing its offset inside the picture object.

Resizing a picture object

1. Choose a picture object.

2. Resize the picture object and observe the image preview.

If however you select Crop image on all sides when stretching in the Preferences for Pages & Objects,
the picture remains in its position in relation to the page, and the offset within the picture object will
change.

The command Fit Frame to Picture in the Picture menu as well as the Context menu is related to resiz-
ing the picture object. The command causes the picture object to take the same size as the imported
image inside according to its current scale.

Fitting the picture object (frame) to the picture preview

1. Click the surface of a picture (Picture mode).

2. Choose an appropriate option:

• Choose Picture > Fit Frame to Picture in the menu or Fit Frame to Picture in the context menu.

The size of the picture object now corresponds to the size of the picture preview in its current scaling.
At the same time the picture preview is automatically centered in the picture object.
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Summary Moving Picture Content
- You may move the image preview interactively using the mouse or the arrow keys.

- You may position the image preview exactly by entering values for the vertical and horizontal
offset into the entry fields of the Module palette (Picture mode).

- You may center the image preview relatively according to the size of the picture object using the
Center command from the Picture > Alignment menu. You also may use the shortcut keys Ctrl +
Shift + M (Windows/Linux) or Command + Shift + M (Mac).

- You may position the image relatively according to its actual scale using the command Fit Frame
to Picture from the Picture menu.

- You may crop the image by resizing the picture object.

- If you resize the picture object upwards or to the left the position of the image inside will change
in relation to the page.

- If you resize the picture object upwards or to the left the position of the image inside will not
change in relation to the page if in the Document Preferences for Pages & Objects the option Crop
image on all sides when stretching is selected.

Mirror, Rotate and Skew
You can mirror, rotate and skew picture previews in picture objects.

Mirroring with the Picture Slider

1. Click the surface of a picture to activate the Picture mode. The slider should appear further down
the page.

2. Choose one of the following options:

• Click the Vertical Mirror icon on the right hand side of the slider to mirror the picture preview
vertically.

• Click the Horizontal Mirror icon on the right hand side of the slider to mirror the picture preview
horizontally.

Mirroring, rotating or skewing picture previews with the palette

1. Activate the Picture mode.

2. Click the checkbox Mirror Horizontally or Mirror Vertically in the Module palette or the appropriate
icons in the Quick Access palette (Picture mode) to mirror the picture.

3. Enter an angle between -360 and +360 degrees in the entry field Rotation to rotate the picture pre-
view in the picture object. Alternatively, click the arrow buttons on the right of the entry field to
rotate one degree at a time. Positive values rotate the picture preview anti-clockwise, negative
values rot ate the picture preview clockwise. The rotation occurs around the center point of the pic-
ture preview.
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4. Enter an angle between -75 and +75 degrees in the entry field Skew to skew the picture preview in
the picture object. Alternatively, click the arrow buttons on the right of the entry field to skew one
degree at a time. Positive values rotate the picture preview to the right, negative values rotate the
picture preview to the left.

Mirroring, rotating or skewing picture previews with the dialog

1. Choose a Picture object.

2. Choose an appropriate option to activate the Object mode:

• Click the object frame.

• Click on the image surface while holding down the Ctrl key (Win dows/Linux) or the
Command key (Mac).

• Move the mouse over the middle of the object until the gray Object Mode Select button appears
and click once. If the button does not appear, the object height or width is too small and you
must choose another option.

3. Choose one of the following options:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or with the mouse button held down, Special in the context
menu.

4. Click the checkbox Horizontal or Vertical in the Mirroring section to mirror the image.

5. Enter an angle between -360 and +360 degrees in the entry field Rotation to rotate the picture pre-
view in the picture object. Positive values rotate the picture preview anti-clockwise, negative val-
ues rot ate the picture preview clockwise. The rotation occurs around the center point of the picture
preview.

6. Enter an angle between -75 and +75 degrees in the entry field Skew, when you want to skew the
picture preview in the picture object. Positive values rotate the picture preview to the right, nega-
tive values rotate the picture preview to the left.

7. Click OK to close the dialog.

If while creating the document it is already determined that the image should be rotated it is
advisable to execute the action in the original illustration or drawing program. This will enhance
the printing speed later on considerably.

If a rotation in the program cannot be avoided, then a rotation without decimal places will hardly
slow down the printing speed. For display on the monitor this is not relevant.

The same goes for images requiring a skew factor.

Scaling Image Preview
The scaling of an image may be set horizontally or vertically independently. While doing so the origi-
nal file will not be altered, only the imported image in the document will be shown and printed with
the set size. Such changes therefore have no effect on the actual image file.

Although the program allows scaling factors between 1% and 1600% of the original size, you should
give careful consideration to the picture scaling with raster images, as:
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- If you enlarge a raster image considerably in the program this can result in undesired loss of
quality in the output.

- If you make a raster image considerably smaller in the program there will not be a loss of quality,
but the information sent to the output device is unnecessarily large which will slow down the
printing speed.

Vector images on the other hand may be given any scaling you like, as there will be no loss of quality
in the output.

The program offers many possibilities for changing the scaling proportionally and unproportionally:

Scaling image preview proportionally

1. Activate Picture Mode.

2. Choose one of the following options to apply one of the default scaling factors:

• Press Ctrl + Alt + 5 (Windows/Linux) or Command + Option + 5 (Mac) to apply a scaling of 50%.

• Press Ctrl + Alt + 7 (Windows/Linux) or Command + Option + 7 (Mac) to apply a scaling of 75%.

• Press Ctrl + Alt + 1 (Windows/Linux) or Command + Option + 1 (Mac) to apply a scaling of 100%
(original size), or Original Size in the context menu.

• Press Ctrl + Alt + 2 (Windows/Linux) or Command + Option + 2 (Mac) to apply a scaling of 200%.

• Press Ctrl + Alt + 4 (Windows/Linux) or Command + Option + 4 (Mac) to apply a scaling of 400%.

• Choose a scaling factor between25% and 400% in the Picture menu.

• Choose a scaling factor between25% and 400% in the popup menus Horizontal Scale and Verti-
cal Scale in the Module palette (choose the same setting for both).

3. Choose one of the following options to fit the image preview proportionally into the Picture object
and center it automatically:

• Choose Picture > Fit Picture Proportionally to Frame in the menu or Fit Picture Proportionally to
Frame in the context Menu.

4. If you have a mouse with a scroll wheel, hold down the Alt key (Windows/Linux) or the Option key
(Mac) and scroll in the appropriate direction to enlarge or reduce the picture pre view in 5% steps.

• Additionally, hold down the Shift key to enlarge or reduce the picture preview in 1% steps with
the scroll wheel.

5. Use the Sliding Scale to enlarge or reduce the picture preview. Every time you release the slider, it
will be reset to the middle and the enlargement or reduction of the image preview size will be
implemented.

6. To scale both the picture preview AND the picture object proportionally, choose one of the follow-
ing options in Object mode:

• Hold down the keys Ctrl + Shift (Win dows/Linux) or Command + Shift (Mac) while you resize the
object using the selection points at the corners of the object.

• Click the special Scaling selection point and hold down the mouse button. Drag in any direc-
tion to resize.

7. To fill the Picture object proportionally, do one of the following:
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• Choose Picture > Fill Frame proportionally in the menu or Fill Frame proportionally in the context
menu.

• Press Ctrl + Alt + 0 (Windows/Linux) or Command + Option + 0 (Mac).

• Click the icon Fill Frame proportionally in the Slider.

Scaling image preview unproportionally

1. Activate Picture Mode.

2. Choose an appropriate option in the Module palette:

• Choose an entry from the popup menus Horizontal Scale and/or Vertical Scale .

• Enter a value in the field for Horizontal Scale and/or Vertical Scale. The entry fields accept val-
ues bet ween 1% and 1600% in 0,001% steps.

• Enter a measurement in any measurement unit in the fields Width and Height.

3. Choose an appropriate option to fit the image preview into the Picture object unproportionally:

• Choose Picture > Fit Picture to Frame in the menu or Fit Picture to Frame in the context menu.

With this action the picture preview will be centered automatically.

4. To scale both the picture preview and the picture object unproportionally, hold down the keys
Control + Alt (Windows/Linux) or Command + Option (Mac) and resize the object.

Scaling image preview unproportionally with the dialog

1. Select a Picture object (Object mode).

2. Choose an appropriate option:

• Press Ctrl + Alt + M (Windows/Linux) or Command + Option + M (Mac).

• Choose Object > Special in the menu or Special in the context menu.

3. Enter a value in the field for Horizontal Scaling and/or Vertical Scaling. The entry fields accept val-
ues between 1% and 1600% in 0,001% steps.

4. Confirm the entry.

When the Picture palette is shown the actual scaling factors will be substituted in the entry fields.

It is not necessary to enter the %-mark as these entry fields are for percentages only. The program will
add the %-mark automatically after ent ering a value.

If the picture object is an oval or a polygon, the program will calculate the scaling factor according to
the rectangle enclosing the picture object. The actual position of the image within the object will be
ignored.

Preflight for Images
The application offers options in the Preferences for the Preflighting of images. You can activate
warning frames for images that have the color modes RGB, Gray scale or black and white (Bitmap),
warning frames for images with transparency or shadow, and set minimum resolutions for different
color modes.
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Tips and Tricks with Images
The application offers many options for steering the import, display and output of images.

Image import

• If you work with raster images in EPS or TIFF format, ensure that the image files are created with a
full size TIFF preview. In this case the program will not check through the entire file but will just
read and display the appropriate preview.

• If you work with vector images in EPS format, ensure that the image files are created with a TIFF
preview, so that the images can be displayed on all platforms.

• If a picture file has no image preview and no preview can be created by the program, a gray
surface will be displayed. At output or export as PostScript file the gray surface will be replaced
with the correct picture, providing that in the Objects tab of the output dialog the option High
Resolution has been selected.

• Use the setting EPS Image Preview in the Program Preferences for Images to define whether and
in which quality the preview of vector images in EPS format should be displayed. The higher the
quality, the longer it will take to import the image file.

Image display

• Use the setting Color Depth in the Document Preferences (Pages & Objects) to define in which
quality the preview should be displayed (8 Bit or 24 Bit). With the higher quality, more working
memory is needed.

• Use the command Quick Picture View in the View menu to define if the preview should be
switched on or off. If you click in a picture object and activate Picture Mode, the preview will
always be displayed, irrelevant of whether the command Quick Picture View is switched on or
not.

• The definition Limit image scaling to in the Document Preferences (Pages & Objects) is set to
1024 Pixel as default. You may increase this, but you must be aware that the higher the value,
the more working memory (RAM) will be required. Any change to the setting will only take
effect on newly imported images in the document.

The Pictures palette
The Pictures palette is a special library palette where not only document pictures are shown, but also
images from other documents that have been saved in the library with their paths as Favorites. The
palette also includes an “Explorer” function to display images stored in any folder on any drive (local
or network) accessible to your computer or recently imported images as well as a search function.
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Working with Tables

Working with Tables
A table is a collection and display of text, picture and graphic objects in the form
of rows, columns and cells. All horizontal cells are seen as rows, while all vertical
cells are seen as columns. Each cell may be (or may contain) a text, picture, table
or graphic object. The program offers extensive functions for the creation, man-
agement and display of table objects. Below is a brief overview:

- A table can have any number of rows and columns.

- A table cell can contain text, an image, another table, a graphic object or an
object group.

- Table cells can be extended over several columns and rows.

- The widths and heights of all table columns and rows may be fixed or vari-
able. With variable values, the width and height are oriented on the cell
content.

- Table columns, rows and cells can have individual separator lines, back-
ground colors and Style Sheets.

- A cell can have different indents on each side.

- Cell content can be rotated in 90 degree steps.

Create Tables

Create a table object

1. Choose the Table tool in the Toolbar.

2. Click at the position where the object should be displayed and hold down the mouse button.

3. Keeping the mouse button held down, drag the mouse in any direction.

4. Release the mouse button when the object has the required Width.

5. Define the number of columns and rows required in the Create Table dialog.

6. If default Character, Paragraph and Layout Style Sheets for the cells have already been created, these
may now be defined in the dialog.

7. Confirm the entry.

The table will now be displayed with the number of columns and rows you have set. The following
default settings will be applied:

- The table height, which is displayed as a manual setting in the Module palette in Object or Table
mode, is automatic.
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- The column width will be set to Manual. At the same time the program calculates the column width
so that all columns have the same width.

- The row height, which is displayed as a manual setting in the Module palette in Object or Table
mode, is also automatic. Here the program recognizes a minimum height for all rows and calcu-
lates an initial height for the table object.

- The content of all cells is set as Text.

- All Text cells will be assigned Style Sheets as defined in the Create Table dialog.

- All rows, columns and cells are transparent and the table object has a frame.

- The separator lines between columns and rows are switched off.

Selecting table rows, columns and cells
To select rows, columns and cells, you must activate the table mode.

Activate Table mode

1. Move the mouse pointer over the table until the table pointer is displayed (a white cross).

2. Click the mouse button. When Table mode is activated,

• the Table menu will be displayed,

• the Module palette will switch to Table mode,

• the appropriate cell will be marked,

• bars will appear on the left and the top of the table object. The row numbers are displayed on
the left, while the columns are assigned letters.

To activate the table mode for a table object that is part of a group, the group mode must be deacti-
vated unless you want to ungroup the group.

Leave Table mode
Choose one of the following options to leave Table mode:

• Click in an unselected cell.

• Position the mouse pointer on the object frame to select the table object and click the mouse
button when the graphic pointer appears.

• Click the object selection button (gray circle in the center of the object showing a graphic
pointer).

• Hold down the Ctrl key (Windows/Linux) or Command key (Mac) and click the mouse button
with the mouse anywhere over the table surface.

• Click anywhere in the document window where there is no object.

Select a table cell

1. Position the mouse pointer at the edge of the cell until the Table pointer (a white cross) appears.

2. Click once.

3. If necessary, use the arrow keys to navigate to and select the required cell.
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Select several table cells

1. Activate Table mode as described above.

2. Choose one of the following options:

• Holding down the mouse button, drag the mouse over several connected table cells.

• Hold down the Shift key and click additional cells to select several connected or unconnected
cells.

Select one or more table rows

1. Activate Table mode.

2. Position the mouse pointer in the row bar on the left, so that the mouse pointer changes to an
arrow.

3. Choose one of the following options:

• Click to select an individual row.

• Holding down the mouse button, drag the mouse over several rows that are connected to each
other.

• Hold down the Shift key and click additional rows to select several connected or unconnected
rows.

Select one or more table columns

1. Activate Table mode.

2. Position the mouse pointer in the column bar at the top, so that the mouse pointer changes to an
arrow.

3. Choose one of the following options:

• Click to select an individual column.

• Holding down the mouse button, drag the mouse over several columns that are connected to
each other.

• Hold down the Shift key and click additional columns to select several connected or unconnec-
ted columns.

Tip: If during the selection you hold down the Shift key, you can select rows, columns and cells
simultaneously.

Table width and height, column width and row height

Table width

The width of the table object is determined by the sum of all column widths, plus a possible line
width for the object frame. It may be determined by a numeric or a percentage value.

Table Width with numeric width entries

1. If you change the width of a table interactively with numeric width entries (sizing/selection han-
dles) or with the dialog, then the width of the columns will be adapted proportionally (increased
or decreased).
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2. If however the table has at least one column with a percentage column width, the change in the
table width will only affect the columns with a percentage width. Columns with a fixed width will
retain their width.

3. If in case 2 the table width is reduced to the point where it is less than the sum of the columns with
numeric widths (in this case all columns with a percentage column width have already been
reduced to a minimum), then the columns with numeric widths will also be reduced propor-
tionally.

Table Width with percentage width entries

1. The width of a table with a percentage width as a free-standing object is determined by the lay-
out.

2. The width of a table with a percentage width as a floating object in the text is determined by the
width of the text object, the object or layout column and the text attributes (indents, etc.).

3. If you change the width of a table that has a percentage width interactively (selection/sizing han-
dles), it will change into a table with numerical width. The column widths will then behave in
exactly the same way as for a table with numerical width (see previous section).

Column width

Column Width in a table (general)

1. You can set the column width to a fixed value, both interactively AND manually.

2. Interactive changes to a column width always take effect on the column to the left of the cursor.

3. If you change the width of a percentage column interactively, this will be changed into a manual
column width automatically. For these the same rules apply as in the previous example.

Column Width in a table with numeric width

1. If you change the column width interactively with the double-arrow tool in the HEADER of a table,
the change will affect the width of the column itself and also on the width of the table, if the table
has a fixed width and all its columns have fixed widths as well.

2. If you change the column width using the dialog, point 1 takes effect.

3. If you change the column width interactively with the double-arrow tool in the ROW of a table, the
change will affect only the left and right columns.The table width is retained in ALL cases, irrele-
vant of whether the table has a fixed or percentage width.

4. If the table has at least one column with a percentage width, then width changes in the dialog take
proportional effect only on the columns with a percentage width. Columns with a fixed width and
the table width remain unchanged.

Example
Table width: 150 mm

Column 1: 100% (=50 mm)

Column 2: 50 mm

Column 3: 50 mm
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- If the width of column 2 is changed interactively with the double-arrow tool in the column
HEADER, the relationship between columns 2 and 3 changes too: If the width of column 2 is raised
interactively to 80 mm the width of column 3 will be reduced to 20 mm.

- If the width of column 2 is changed manually with the dialog or the palette, the relationship
between column 2 and columns 1 and 3 changes too: If the width of column 2 is raised to 80 mm,
the table width will be increased by 30 mm. The value "100%" in column 1 and the value "50 mm"
in column 3 are retained.

- If all columns are set to a fixed width, the table width changes accordingly.

- If all columns are set to a percentage width, the table width is retained. The column widths are
shared equally.

Column Width in a table with percentage width

1. In a table with percentage width, changing the column width has NO influence on the table width.

2. If the table only has columns with fixed widths, these entries will be changed to suit the percent-
age width of the table.

Example
Table width: 100% (= 150 mm)

Column 1: 50 mm

Column 2: 50 mm

Column 3: 50 mm

Thus all values entered are automatically set to and displayed as 50 mm.

- If the width of column 1 is changed interactively, column 2 on its right will change accordingly: If
the width of column 1 is changed to 80 mm, the width of column 2 will reduce to 20 mm.

- The width of column 1 or 2 may be raised to a maximum of 99,002 mm (100 minus the minimum
width of 0.998 mm).

3. If the width of one or more columns is changed using the dialog, the program tries to sort these
entries according to the highest priority. The space left over will be applied on a percentage basis
to the remaining columns.

Example
Table width: 100% (= 150 mm)

Column 1: 50 mm

Column 2: 50 mm

Column 3: 50 mm

- If you enter a width of 100 mm for column 1, the entry will be reduced to 75 mm automatically.
The entries for columns 2 and 3 will be reduced to 37,5 mm automatically.

- If you enter a width of 200 mm for column 1 the entry will be reduced automatically to 100mm.
The entries for columns 2 and 3 will be reduced automatically to 25 mm.

174



Working with Tables

- If you enter a width of 90 mm for columns 1 AND 2, the entries for both columns will be reduced
automatically to 58.696 mm. The entry for column 3 will be reduced automatically to 32.609 mm.

- If you enter a width of 30 mm for column 1, the entry will be increased automatically to 34.615
mm. The entries for columns 2 and 3 will be increased automatically to 57.692 mm.

- If you enter a width of 30 mm for column 1 AND column 2, the entry will be increased automatic-
ally to 40.909 mm. The entry for column 3 will be reduced automatically to 68.182 mm.

- If you increase the width of column 1 to 100 mm, the widths of columns 2 and 3 will be reduced to
25 mm.

- If you increase the width of column 1 to 200 mm, the widths of columns 2 and 3 will both be
reduced to the minimum width of 1 mm. All values entered that are above 148 mm (150 mm less 2
x 1 mm minimum width) will be displayed automatically as 148 mm.

- If you increase the widths of columns 1 AND 2 to 90 mm, the width of column 3 will be reduced to
the minimum width (e.g. 1 mm). All values entered that are above 74.5 mm (75 mm - (2 / 1 mm))
will be displayed automatically as 74.5 mm.

- If you reduce the width of column 1 to 30 mm, the widths of columns 2 and 3 will be increased to
60 mm.

- If you reduce the widths of columns 1 AND 2 to 30 mm, the width of column 3 will increase to 90
mm.

Example with different fixed widths
Table width: 100% (= 150 mm)

Column 1: 60 mm

Column 2: 50 mm

Column 3: 40 mm

- If you enter a width of 100 mm for column 1, the entry will be reduced automatically to 78,947
mm. The width of column 2 will be reduced proportionally to 39.474 mm and the width of col-
umn 3 will be reduced proportionally to 31.579 mm.

- If you increase the width of column 1 to 100 mm, the width of column 2 will be reduced propor-
tionally to 27.777 mm and the width of column 3 will be reduced proportionally to 22.222 mm.

Table height

The height of a table object is calculated from the sum of all row heights, plus a possible line width
for the object frame.

You can define the table height interactively with the object’s sizing handles, or numerically with the
dialog or palette. If you change the object height, the values for the row heights will change auto-
matically in proportion.

Row height

1. You can define the row height interactively with the double-arrow pointer or manually with the
dialog or palette.
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2. The row height ALWAYS has a value. This value may have the suffix Exactly or Minimum.

3. Exactly means that the row height always remains the same and does not change. Rows with the
option Exactly have no minimum height and may also accept the value “0”. Cells of the type Text
with the option Exactly behave exactly like normal text objects, i.e. when there is an Overset an
overset symbol will be shown.

4. Minimum (default value for all rows) means that the row height is calculated from the content of
the highest cell, but in no case will go below the value defined. The actual height of a row may
therefore be greater than the value in the Row Height field! This is particularly true if the Row
Height value is smaller than the font size in one text cell in the row. It doesn’t matter if there is text
in the text cells. The height is determined by the font and the font size selected. The height of a
table object can therefore only be reduced to the point where at least one line of text can be dis-
played in the text cells.

5. Changing the row height interactively always affects the row above the cursor. The action only
changes the value, not the suffix (Exactly or Minimum).

Editing table rows and columns

Defining row height and column width

You can define row height and column width interactively or using dialogs.

Define row height or column width interactively

1. Activate Table mode.

2. Choose one of the following options:

• Position the mouse pointer on a column separator line in the column bar until the mouse
pointer changes into a double arrow.

• Position the mouse pointer on a column separator line in the column until the mouse pointer
changes into a double arrow.

• Position the mouse pointer on a row separator line in the row bar or in the row until the
mouse pointer changes into a double arrow.

3. Hold down the mouse button.

4. With the mouse button held down, drag the mouse in the required direction to increase or reduce
the row height or column width.

Note: If you change the column width with the mouse pointer in the column bar, the table width
will be changed at the same time. If you change the column width with the mouse pointer in the
column, only the column width will be changed and the table geometry will be retained.

Define row height or column width numerically

1. Activate Table mode.

2. Select a cell in the line or column that you want to change.

3. Choose one of the following options:
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• Choose Table > Column and Row Settings in the menu or Column and Row Settings in the con-
text menu.

• Choose the Column/Row tab in the Module palette.

4. Choose one of the following options in the fields Width (for columns) and/or Height (for rows):

• Manual — Enter a value in the entry field if the column should be given a fixed width.

• Percent — Enter a value in the entry field between 1% and 20.000% if the column should be
given a proportional width.

• Exactly — Enter a value in the entry field if the row should be given a fixed height.

• Minimum — Enter a value in the entry field if the row should be given a minimum height.

Notes for row height and column width

 • The entries in the fields for row height and column width may be made manually, or you can
click the counter arrows up or down.

 • All changes will result in an increase or decrease in the table object size.

 • Through changes in the column width it may occur that columns are difficult to see. The col-
umn width has a default minimum of 1mm. This ensures that the column is always visible and
selectable. In this case you can either increase the size of the table object or change the column
settings, or of course delete the column.

 • The row height has a default minimum which will be retained for every entry. This ensures that
the row is always visible and selectable.

 • Percentage values must be calculated by the user. If for example the width of a table with three
columns should be shared on a basis of 3:1:1, the column widths must be entered as respec-
tively 60%, 20% and 20% respectively so that the sum of the three is 100%.

Inserting/Adding rows and columns

You can insert single rows and columns in the middle of the table or add several rows at the bottom
or columns on the right.

Insert columns

1. Activate Table mode.

2. Choose a column before or after which the new column(s) should be inserted.

3. Mark/select the whole column as previously described.

4. Choose Table > Insert Column in the menu or Insert Column in the context menu.

5. Choose the number of columns to be inserted.

6. Choose the option Left or Right.

7. Choose one of the following options:

• Expand Table Geometry — Increases the width of the table object.

• Keep Table Geometry (if possible) — The size of the table object will not be increased unless
absolutely necessary.
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8. Confirm the entry.

Insert rows

1. Activate Table mode.

2. Choose a row before or after which the new row(s) should be inserted.

3. Mark the whole row as previously described.

4. Choose Table > Insert Row. in the menu or Insert Row in the context menu.

5. Choose the number of rows to be inserted.

6. Choose Before or After.

7. Choose one of the following options:

• Expand Table Geometry — increases the size of the table object.

• Keep Table Geometry (if possible) — the size of the table object will not be increased unless
absolutely necessary.

8. Confirm the entry.

Note: If you choose the option Left (columns) or Before (rows), the new column(s) or row(s) will
take over the attributes of those marked. The alternative options create columns/rows without
attributes.

Add rows and/or columns on the right or bottom of the table

1. Activate Table mode.

2. Choose one of the following options:

• Choose Table > Table Settings in the menu or Table Settings in the context menu.

• Choose the Table tab in the Module palette.

3. Increase the number of columns and/or rows. Confirm the entry.

Delete/Remove a column or row

1. Activate Table mode.

2. Select the row or column to be deleted.

3. Choose one of the following options:

• Choose Table > Remove Row or Table > Remove Column in the menu or Remove Row or Remove
Column in the context menu.

Delete/Remove rows and/or columns from the right or bottom of the table

1. Activate Table mode.

2. Choose one of the following options:

• Choose Table > Table Settings in the menu or Table Settings in the context menu.

• Choose the Table tab in the Module palette.

3. Reduce the number of columns and/or rows. Confirm the entry.
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Editing table cells

Extend cells

You can extend cells into neighboring rows and columns to create one big cell. This option is particu-
larly helpful if for example you want to create table headers that stretch over several columns.

Extend cells

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

• Choose Table > Cell Settings in the menu or Cell Settings in the context menu.

• Choose the Cell tab in the Module palette.

4. In the fields Columns and Rows enter values to define by how many columns and/or rows the cell
should be extended. With this extension function the program recognizes all columns to the right
of and all rows below the selected cell. The maximum extension follows up to the last column and/
or row.

Merge cells

The function Merge Cells presents another possibility for extending cells. You may already know this
function from MS-Excel or another table calculation program.

Merge cells

1. Activate Table mode.

2. Mark several cells (at least two) in the row or column.

3. Choose one of the following options:

• Choose the menu command Table > Merge Cells in the menu or Merge Cells in the context menu.

Split merged cells

1. Activate Table mode.

2. Mark the cells that have been merged.

3. Choose one of the following options:

• Choose Table > Split merged cells in the menu or Split merged cells in the context menu.

• Choose the Cell tab in the Module palette and reduce the number of columns or rows over which
the cell is extended to 1.

Note: The content of cells to the right or below the first cell will be set to the setting for the first cell
when they are unmerged. Please refer to the section Cell content.

Cell Indents

You can define indents for every cell in the table. This option is particularly helpful if you need to
define an offset between separator lines and cell content.
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Define cell indents

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

• Choose Table > Cell Settings in the menu or Cell Settings in the context menu.

• Choose the Cell tab in the Module palette.

4. In the Minimum Indents section, choose the options Left, Right, Top or Bottom and enter a value as
required for each side.

Cell content

In a newly created table the content of all cells is set to Text. These cells behave just like a single text
object. As with all objects you can change the content of a cell at any time. Thus a cell may contain
an image or even another table.

Define cell content

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

• Choose the menu command Table > Cell Content in the menu or Cell Content in the context
menu.

• Choose the Cell tab in the Module palette.

4. Choose one of the following options:

• None — The cell has no content. In cells of this type any objects can be inserted.

• Text — The cell can contain text. In a text cell you have all the options that are available in a
text object in Text mode.

• Picture — The cell can contain an image. In a picture cell you have all the options that are
available in a picture object in Picture mode.

• Table — The cell contains an additional table. For this table all the settings in Table mode are
valid, with the exception of the width and height, which are based on the height and width of
the cell.

Cell alignment

You can define a horizontal and vertical alignment for every cell. This option however only takes
effect on cells whose content option is None.

Define cell alignment

1. Activate Table mode.

2. Select a cell.

3. Choose one of the following options:

• Choose Table > Cell Settings in the menu or Cell Settings in the context menu.
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• Choose the Cell tab in the Module palette.

4. Choose one of the following options in the Alignment section to align the cell content horizontally
and/or vertically:

• Left, Center or Right.

• Top, Center or Bottom .

Define cell rotation

1. Activate Table mode.

2. Select a text cell and type a few characters.

3. Choose one of the following options:

• Choose the menu command Table > Cell Settings in the menu or Cell Settings in the context
menu.

• Choose the Cell tab in the Module palette.

4. Choose one of the options 0°, 90°, 180° or 270°.

5. Click OK to confirm.

6. Try the same option with a picture cell to rotate the picture.

Note: The picture rotation in the Module palette has no effect on a picture cell in a table. To achieve
an individual rotation, you must place a picture object in a cell with no content (graphic) and set
the desired rotation. This involves a lot of calculation which will slow down the program quite dra-
matically, so where possible it should be avoided.

Enter/import text in tables
When you have created your table to your requirements, you can start entering your text manually in
the cells. Please note that in the Preferences (Pages & Objects, Objects tab) the option Use Tab Key to
Navigate in Table is activated as default. This means that the entry of a tab will cause the cursor to
jump to the next available cell.

Navigation in Tables

1. Make sure that the tab key option as described above is actually activated.

2. Click the first cell in the table.

3. Navigate in the table as follows:

• Press the Tab key to navigate forwards from left to right.

• Press Shift + Tab to navigate backwards.

Type text into tables

You can type text into any text cell or group of cells. For this a single cell must be activated in Text
mode. Use the Tab and Shift + Tab keys for navigation between cells as described above. If you fill a
cell with text and continue typing, the row height and also the table object height will increase auto-
matically so that there is never an overset, PROVIDING the Row Height option is set to Minimum.
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Import text into tables

You can import text into any text cell or group of cells. For this a single cell must be activated in Text
mode, or several cells must be marked.

Import text into a cell

1. Move the mouse over the cell so that the text pointer (I-Beam) is displayed.

2. Click the cell so that the cursor blinks in the cell.

3. Choose a suitable option to import a text file:

• Press Strg + E (Windows/Linux) or Command + E (Mac).

• Choose File > Import.

4. Choose a *.txt- or an *.rtf file from the dialog.

5. Click Open. The text will be imported into the cell.

Note: When you import *.txt files, the program will open the dialog Select Text Encoding. In this
dialog you can choose the encoding for the text file you want to import.

When you import *.rtf files whose text has various attributes, then these too will be imported as far
as is possible.

The row height and also the table object height will increase automatically according to the text
length so that there is never a text overflow, PROVIDING the Row Height option is set to Minimum.

You can import tab stop separated text in a table object into the application using the Copy-Paste
process, so that columns and rows are filled, and even added to if necessary.

Import tab stop separated text

1. Open the required file in MS-Excel or in a text editor.

2. Mark the whole text and choose the command Copy.

3. Return to the application and activate the Table mode as described above.

4. Select/mark the cell where the imported text will start. Alternatively, mark the cells to be consid-
ered for the import, or mark all the cells in the table.

5. Import the copied text:

• Press Ctrl + V (Windows/Linux) or Command + V (Mac).

• Choose Edit > Paste in the menu or Paste in the context menu.

6. Choose an option from each of the areas Merged Cells/Non-Text Content and Additional
Columns/Rows in the Import Tab Text dialog:

• Merge & Suppress Content / Beware Table — Defines that only sufficient text will be imported to
completely fill the table. All following text characters will be suppressed. For this option all the
cells should be marked.

• Merge & Suppress Content / Insert New Columns/Rows — Defines that new columns and/or rows
will be created in the table in order to import the complete text. It may be that text copied
from Excel or another table application will have an additional row which must be removed
manually from the table.
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• Suppress Content / Beware Table — Defines that only sufficient text will be imported to com-
pletely fill the table. All following text characters will be suppressed.

• Suppress Content / Insert New Columns/Rows — Defines that new columns and/or rows will be
created in the table in order to import the complete text. It may be that text copied from Excel
or another table application will have an additional row which must be removed manually from
the table.

• Keep Content / Beware Table — Defines that only sufficient text will be imported to completely
fill the table. All following text characters will be suppressed.

• Keep Content / Insert New Columns/Rows — Defines that new columns and/or rows will be cre-
ated in the table in order to import the complete text. It may be that text copied from Excel or
another table application will have an additional row which must be removed manually from
the table.

Graphic attributes for Tables
Tables are objects and as such can be treated in the same way as any other objects. This means that
they may have a frame and a fill color, which may also be a blend. You can set the frame and the fill
color in the Table tab of the Table Settings dialog, or in the Module palette in Table mode or in the
Object Settings dialog.

Colors for cells, rows and columns

The appearance of your table can be adapted according to taste and preference. Different colors may
be applied to cells, rows and columns as you like, but before you start adapting your table, the fol-
lowing points must be considered:

- Row colors take precedence over column colors.

- Cell colors take precedence over row and column colors.

- If columns/rows are left with the default setting [White] + Transparent, any fill color and/or shade
that is applied to the table object will be visible in the transparent elements.

Separators

Separators may be applied to each individual cell or group of cells. You may well be familiar with the
separator/grid principle from Excel or other table calculation programs.

The graphic attributes of separators are edited in the Separators tab of the Table Settings dialog or
the Module palette in Table mode, and carry the same default settings as the object frame for graphic
objects or for line objects. The table frame is not included in the specification, so if for example you
select only the top left cell, the program will offer you the opportunity to set a Right Separator and a
Bottom Separator.

The most simple option is to create a table consisting of a grid whereby the separators all take the
default option.

Create table with standard grid

1. Create a table with several columns and rows.

2. Mark the whole table.
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3. Do one of the following:

• Choose the menu command Table > Show Separators in the menu or Show Separators in the con-
text menu.

The table will now be displayed with its grid. The Separators have the color [Black] and have the
default line width of 1 pt or 0.353 mm.

Edit the grid

1. Mark the whole table (all cells).

2. Choose one of the following options:

• Choose the menu command Table > Separator Settings in the menu or Separator Settings in the
context menu.

• Choose the Separator tab in the Module palette.

3. Set the Separator options for the Horizontal Separator and the Vertical Separator.

Switch grid off

1. Mark the whole table (all cells).

2. Choose one of the following options:

• Choose the menu command Table > Hide Separators in the menu or Hide Separators in the con-
text menu.

Define Separators for individual cells, columns or rows

1. Create a table with several columns and rows.

2. Mark the cell(s), row(s) or column(s) to which you want to apply a Separator.

3. Choose one of the following options:

• Choose the menu command Table > Separator Settings in the menu or Separator Settings in the
context menu.

• Choose the Separators Tab in the Module palette.

4. Click the required separator options to Yes and define the Left, Right, Top and Bottom Separators
and/or Horizontal Separator/Vertical Separator as available and according to your requirements.

You may have decided to have the Vertical Separator in red and the Horizontal Separator in black.
Depending on your requirements, you can choose one of the options Horizontal Separator above or
Vertical Separator above from the Table tab in the Table Settings dialog. The option you choose
defines which Separators will be output on top, i.e. above the others.

Graphic Style Sheets for Tables
You can also apply Style Sheets with graphic attributes to an entire table, to rows and/or columns
and to single cells. The rules regarding color priorities apply to these Style Sheets as described above.

General information regarding the use of Style Sheets can be found in the chapter Working with Style
Sheets.
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Create a Cell Style Sheet

1. Choose one of the following options:

• Choose Edit > Style Sheets and choose New.

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Right click (secondary mouse button) in the Style Sheets palette and choose the New in the
context menu.

2. Choose your own name for the Style Sheet, or alternatively select one of the predefined names
from the popup menu.

3. Choose the Style Sheet Type:

• Select the option Table Cell.

4. Apply a fill color such as [Red] 100%.

5. Define all four separators as [Black] 100% with a line width of 1mm.

6. Confirm the entry.

Create a Row Style Sheet

1. Choose one of the following options:

• Choose Edit > Style Sheets and choose New.

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Right click (secondary mouse button) in the Style Sheets Palette and choose the New in the con-
text menu.

2. Choose your own name for the Style Sheet, or alternatively select one of the predefined names
from the popup menu.

3. Choose the Style Sheet Type:

• Choose the option Table Row.

4. Apply a fill color such as [Green] 50%.

5. Confirm the entry.

Create a Column Style Sheet

1. Choose one of the following options:

• Choose Edit > Style Sheets and choose New.

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Right click (secondary mouse button) in the Style Sheets palette and choose the New in the
context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined names.

3. Select the Style Sheet Type:
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• Select the option Table Column.

4. Apply a fill color such as [Blue] 50%.

5. Confirm the entry.

Now you can create a table of your choice and apply the Style Sheets you have created to cells, rows
and columns to see the effects. You do not have to mark a whole row or column; if one cell is acti-
vated and you apply a Row or Column Style sheet, then the whole row or column will be assigned this
Style Sheet.

Now create 3 more Column Style Sheets and 3 more Row Style sheets, each with a different fill color.
When you have done this, you can create a Table Style Sheet with header, footer, and alternating col-
umns or rows.

Create a Table Style Sheet with alternating columns

1. Choose one of the following options:

• Choose Edit > Style Sheets and choose New.

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Right click (secondary mouse button) in the Style Sheets palette and choose the New in the
context menu.

2. Select your own name for the Style Sheet, or alternatively select one of the predefined names.

3. Select the Style Sheet Type:

• Select the option Table.

4. Choose the options for the table object in the section Table Settings as required:

• For the Fill, set the Color, Shade and Blend Angle (if your fill color is a blend).

• For the Frame, set the Line Color, Line Shade, Line Style and Line Width.

• Choose the Separator Sequence: Vertical Separator above or Horizontal Separator above.

5. Choose the column options in the section Column Settings as required:

• Set the popup menu Left Columns to Yes and select one of your four Column Style Sheets.

• Set the popup menu Right Columns to Yes and select one of your four Column Style Sheets.

• Set the popup menu Alternating Columns to Yes and select one of your four Column Style
Sheets for each alternating column.

6. Confirm the entry.

7. Create a table object with at least 6 columns, mark at least one cell and apply the table style sheet.

Create a Table Style Sheet with alternating rows

1. Create a new Table Style Sheet as described above.

2. Choose the row options in the section Row Settings as required:

• Set the popup menu Header to Yes and select one of your four Row Style Sheets.

• Set the popup menu Footer to Yes and select one of your four Row Style Sheets.
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• Set the popup menu Alternating Rows to Yes and select one of your four Row Style Sheets for
each alternating row.

3. Confirm the entry.

4. Create a table object with at least 6 rows and apply the table style sheet to it.

Note: You can now apply the Cell Style Sheet created earlier to any cell or cell group in either of the
above tables to achieve individual effects. Try applying Separators with different colors to differ-
ent Row or Column Style Sheets.
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Working with Style Sheets
A Style Sheet can be regarded as a collection of options for the assigning of attri-
butes to text, objects or images. Using Style Sheets, a whole series of options may
be applied simultaneously with a single keystroke.

Introduction
The advantage of Style Sheets lies not only in the fast application of several options, but also in flexi-
bility for additional editing. For this reason, a professional user will always work with a large number
of Style Sheets so as to complete his task quickly and in a structured way. The program offers exten-
sive functions for the creation, management and application of Style Sheets. Here below is a brief
overview:

• Style Sheets can be applied to text, objects and images.

• Text Style Sheets can be applied to characters, paragraphs and layouts.

• Style Sheets only change the options that have been defined in the Style Sheet.

• Style Sheets can be inherited, which means that they can be used as models or templates for
additional Style Sheet definitions.

Create/Import Text Style Sheets

Create Text Style Sheets

You can create a Text Style Sheet for characters, paragraphs and layouts. When you create a Character
Style Sheet, you have all the options available for characters. If you want to create a Paragraph Style
Sheet, you have all the options available for paragraphs, plus as an option all the options available
for characters. If you want to create a Layout Style Sheet, you have all the options available for layouts.

Create a simple Text Style Sheet:

1. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Choose Edit > Style Sheets and choose New.

• Right click in the Style Sheets palette and choose New in the context menu.

2. Enter your own Name for the Style Sheet in the Custom field, or alternatively select one of the
predefined names from the Standard popup menu.

3. Select a Style Sheet Type:

• Character if you want to create a Character Style Sheet.

• Paragraph if you want to create a Paragraph Style Sheet.

• Layout if you want to create a Layout Style Sheet.
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4. Choose Based on actual settings if you want to take over all corresponding attributes of the text in
which the cursor is currently placed. The option can be selected when the text mode is active.

5. In the dialog section General, choose a key or key combination for faster application. Click in the
entry field and press a single key or key combination. The program supports the following keys/
key combinations:

• the Numeric Keypad,

• the Numeric Keypad, in combination with the Ctrl key (Windows/Linux), or the Command key
(Mac) and/or the Alt key (Windows/Linux) or the Option key (Mac),

• the function keys F5 to F12,

• the function keys F1 to F12, in combination with the Ctrl key (Windows/Linux), or the Command
key (Mac) and/or the Alt key (Windows/Linux) or the Option key (Mac) and/or the Windows
key (Windows/Linux) or the ctrl key (Mac) and/or the Shift key.

Note: If your current document contains a Style Sheet operating with the same key combination
that has been assigned to a palette, then the palette activation and deactivation function of this
key will take precedence and the key combination will not work for the Style Sheet.

6. Choose the settings for characters, paragraphs or layouts in the respective dialogs. If you have
applied the option Based on actual settings, all the options are already predefined. If you have not
applied this option, you can decide individually which options you want to apply.

When the Style Sheet is applied in the text only those options will be applied that were defined in the
Style Sheet. You can work even more effectively with Style Sheets if when you create a new one you
apply an existing one as a template. This way of working is particularly helpful if for example you
want to create several Paragraph Style Sheets that all have the same character options. Instead of
repeating the character options in every Paragraph Style Sheet, you simply select a Character Style
Sheet as a template for every Paragraph Style Sheet. In this way you save not only the repeated set-
tings in all the Paragraph Style Sheets but also avoid possible errors arising from creating several
Style Sheets with the same settings. Furthermore, this method also enables you to change all related
Paragraph Style Sheets by changing a single Character Style Sheet.

Create a Text Style Sheet with a template:

1. Create a Style Sheet as described above or choose an existing Style Sheet.

2. In the General dialog area, choose a Template:

• For Character Style Sheets, choose an existing Character Style Sheet.

• For Paragraph Style Sheets, choose an existing Paragraph Style Sheet and/or a Character Style
Sheet. If you choose a Character Style Sheet, the character options will be deactivated auto-
matically.

• For Layout Style Sheets, choose an existing Layout Style Sheet.

• Choose None to cancel the selection of a template.

Notes on creating Text Style Sheets:

 • Style Sheet names must be unique in the entire document, irrelevant of their type. A name may
not be used twice.
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 • Predefined Style Sheet names are displayed in square brackets.

 • You can use the predefined Style Sheet names as often as you like. In this case the Style Sheets
are numbered by the program.

 • The use of predefined Style Sheet names is helpful if you are exchanging documents interna-
tionally, as these names are translated automatically. In this case, the structure of the text is
easily recognisable for a newcomer (e.g. Body Text, Chapter, Lists, etc.), even if he doesn’t
understand the text content in the relevant language.

 • With the use of templates, you can minimize the number of Style sheets and simplify the man-
agement of them. In this case we recommend not using the option Based on actual settings
and setting the options manually.

 • By using shortcut keys you can apply Style Sheets faster. If there are overlaps with program
shortcuts, the shortcuts for the Style Sheets will be ignored.

Importing Text Style Sheets

You can take over Style Sheets from other documents by selecting a text or a text object with the
appropriate Style Sheets, copying and pasting into the target document. When you take over Style
Sheets from other documents that have identical names to and are of the same type as those of the
target document, the settings in the target document will be applied to the imported text.

Assigning Text Style Sheets

Assigning Text Style Sheets manually

You can apply Character, Paragraph and Layout Style Sheets to a text both manually and automatic-
ally.

Assign Text Style Sheets manually:

1. Choose one of the following options:

• To assign a Character Style Sheet, mark the appropriate text.

• To assign a Paragraph Style Sheet to a paragraph, position the cursor anywhere in the para-
graph. Alternatively you can mark a text section within the paragraph.

• To assign a Paragraph Style Sheet to several paragraphs, mark the paragraphs. It is only neces-
sary to mark a part of each paragraph, marking the whole text is unnecessary.

• To assign a Layout Style Sheet, position the cursor anywhere in the text. If you are using several
layouts in the text, position the cursor in the appropriate Layout.

2. Choose one of the following options:

• Choose the required Style Sheet in the menu Text > Character Style Sheet or Text > Paragraph
Style Sheet or Text > Layout Style Sheet.

• Click the Style Sheet name in the Style Sheets palette.

• Press the shortcut key combination that is displayed after the Style Sheet name in the Style
Sheets palette.
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Notes on the manual assignment of Text Style Sheets:

 • If you assign a Style Sheet to a text that already posesses identical attributes, these identical
attributes in the Style Sheet will not be assigned. After the Style sheet has been assigned, a plus
sign will appear in the Style Sheets palette.

 • If you assign a Style Sheet to a text that already posesses identical attributes, you can overwrite
them with the settings in the Style Sheet by double-clicking the name of the Style Sheet in the
Style Sheets palette. This will cause the plus sign to disappear.

 • Alternatively you can click the name of the Style Sheet in the Style Sheets palette and choose
the option Overwrite all settings in selection.

 • Alternatively you can click the name of the Style Sheet in the Style Sheets palette and choose
the option Overwrite all settings in story.

Assigning Text Style sheets automatically

Text Style Sheets can also be assigned using the option Search & Replace. This option is particularly
helpful when

- you want to assign Style Sheets to a Text whose attributes have been assigned manually, or

- you want to replace Style Sheets in a text with other Style Sheets.

Assign Text Style Sheets automatically:

1. Choose one of the following options:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).

• Choose Text > Search & Replace.

2. In the Search section, choose a combination of Text, Font, Font Size, Text Color or Language to
enable the relevant text to be identified.

3. Choose an existing Character or Paragraph Style Sheet in the Replace section.

Replace Text Style Sheets automatically:

1. Choose one of the following options:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).

• Choose Text > Search & Replace.

2. In the Search section, choose a Style Sheet Type:

• Character Style Sheet to search for a Character Style Sheet.

• Paragraph Style Sheet to search for a Paragraph Style Sheet.

• Layout Style Sheet to search for a Layout Style Sheet.

3. Choose the Style Sheet you want to search for.

4. In the Replace section, choose a Style Sheet of the same type or of another type. Here you can for
example search for a Character Style sheet and replace it with a Paragraph Style Sheet.
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A very good method of assigning Style Sheets to new text automatically is provided by the options in
the Preferences. Here you can choose Character, Paragraph and Layout Style Sheets that will be
assigned to new text objects automatically.

Assign Text Style Sheets automatically using the Preferences:

1. Create a Text Style Sheet of your choice. If you do this without a document being open, this Style
Sheet will be available for all new documents.

2. Choose Edit > Preferences > Text (Windows/Linux) or {Application Name} > Preferences > Text (Mac).

3. Choose a Character, Paragraph and/or Layout Style Sheet from the Default Style Sheets section.

4. Confirm the entry. The settings take immediate and automatic effect on

• all new text and table objects.

• all new documents, if at the time of making the setting no document is open.

Changing the assignment of Text Style Sheets

You can change the assignment of Text Style Sheets at any time. This is done either by choosing the
option None or by assigning another Style Sheet. The option None has the effect that the assignment
of the Style Sheet is canceled. In this case the default options will be assigned to the text (default
font, default font size, etc.), but any manual settings that have been made will be retained. The
default options are not editable.

Cancel or change a Text Style Sheet assignment manually:

1. Choose one of the following options:

• To cancel or change the assignment of a Character Style Sheet, mark the appropriate text.

• To cancel or change the assignment of a Paragraph Style Sheet in one paragraph, place the
cursor anywhere in the relevant paragraph. As an alternative you can mark some of the text on
the paragraph.

• To cancel or change the assignment of a Paragraph Style Sheet in several paragraphs, mark the
paragraphs. It is only necessary to mark a part of each paragraph, marking all the paragraphs
completely is unnecessary.

• To cancel the assignment of a Layout Style Sheet that has been applied to the whole text, place
the cursor anywhere in the text.

• If you use several layouts in the text and want to cancel or change the assignment of one Lay-
out Style Sheet, place the cursor anywhere in the Layout.

2. Choose one of the following options:

• Choose the entry None in the menu Text > Character Style Sheet or Text > Paragraph Style Sheet
or Text > Layout Style Sheet to cancel the assignment, or choose another Style Sheet.

• Click the entry None in the Style Sheets palette to cancel the assignment, or click another Style
Sheet.

Cancel or change a Text Style Sheet assignment automatically:

1. Choose one of the following options:

• Press Ctrl + F (Windows/Linux) or Command + F (Mac).
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• Choose Text > Search & Replace.

2. In the Search section, choose a Style Sheet Type:

• Character Style Sheet if you want to search for a Character Style Sheet.

• Paragraph Style Sheet if you want to search for a Paragraph Style Sheet.

• Layout Style Sheet if you want to search for a Layout Style Sheet.

3. Choose the Style Sheet you want to search for.

4. In the Replace section, choose the option None, either for Style Sheets of the same type or for Style
Sheets of a different type. In this way you can for example search for the usage of a Paragraph
Style Sheet and there cancel all assignments of Character Style Sheets.

Editing Style Sheets
You can rename, duplicate or delete Style Sheets.

Renaming Style Sheets

You can rename individually named Style Sheets at any time. Renaming Style Sheets whose names are
in square brackets is not permitted. Therefore when naming your Style sheets individually, please
avoid the use of square brackets. The default names in square brackets can also not be renamed.

Rename Style Sheets:

1. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac).

• Choose Edit > Style Sheets.

• Choose the Style Sheet in the Style Sheets palette and choose Edit in the context menu.

2. Click the Style Sheet name so that it is marked/highlighted with a blinking cursor.

3. Enter the new name and complete your entry by pressing the Return key or by choosing another
Style Sheet. Confirm the entry.

Duplicate Style Sheets:

1. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac).

• Choose Edit > Style Sheets.

• Right click the name of the Style Sheet in the Style Sheets palette and choose the option Edit in
the context menu.

2. Click the Style Sheet symbol (if necessary) and click the Duplicate button.

3. Enter the new name.

4. Choose the required settings and confirm the entry.
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Delete one or more Style Sheets:

1. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac).

• Choose Edit > Style Sheets.

• Choose any Style Sheet in the Style Sheets palette and choose the option Edit in the context
menu.

2. Choose one of the following options:

• Click the Style Sheet symbol of a Style Sheet you want to delete and press the Del key to delete
the individual Style Sheet.

• Click the Clear All button to delete all the Style sheets that are not used in the document.

3. Confirm the entry.

All Style Sheets assigned in the document are locked and cannot be deleted

 • until the assignment has been canceled AND

 • the document has been correctly saved, closed and reopened.
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Graphic Style Sheets
We will begin by creating a simple graphic style sheet that applies a frame color to an object.

Create a simple graphic style sheet:

1. Ensure that Object Mode is active and choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Choose Edit > Style Sheets and choose New.

• Click in the Style Sheets palette and choose New in the context menu.

2. Enter the name Red frame in the entry field Custom in the New Style Sheet dialog.

3. Check that in the Type popup menu the type Graphic is selected and click OK.

4. In the bottom left Info section of the Style Sheets dialog, click Frame.

5. In the popup menu Line color choose the entry [Red].

• Click in the bottom left Info section to see your setting.

6. Confirm the entry.

Assigning Graphic Style Sheets

A Graphic Style Sheet may be assigned to any object. There are several possibilities available.

Assign Graphic Style Sheet with Style Sheets palette:

1. Ensure that the Style Sheets palette is visible. If this is not the case, choose one of the following
options:

• Press Ctrl + F11 (Windows/Linux) or Command + F11 (Mac).

• Choose Window > Style Sheets.

If the Style Sheets palette is visible, the Type, the Name and the shortcut (if available) will be shown.

2. Choose one or more Graphic Objects to which the Style Sheet should be assigned.

3. To assign the Style Sheet Red frame, click the entry in the Style Sheets palette. The Style Sheet will
be assigned to the objects selected and their frames will be shown in red.

• Instead of clicking in the Style Sheets palette to assign a Style Sheet, you can also use the short-
cut (if available).

Assign Graphic Style Sheet with a shortcut:

1. If your Style Sheet doesn’t yet have a shortcut, you can enter one:

• Choose the option to edit the Style Sheet and enter a shortcut as previously described.

2. Choose one or more graphic objects and press the shortcut keys you have set. The Style sheet will
be assigned to the objects selected and their frames will be shown in red.
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Graphic Style Sheets with Preference

If a Style Sheet consists of a series of attributes that are nearly identical with those of an existing
object, you can also create a Graphic Style Sheet with a preference.

Creating Object Style Sheets with Preferences:

1. Choose an object on the document page of the that already has the required attributes.

2. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Choose Edit + Style Sheets and choose New.

• Right click in the Style Sheets palette and choose New in the context menu.

3. Enter the name Style_1 in the entry field Custom in the New Style Sheet dialog.

4. Check that in the Type popup menu the type Graphic is selected and confirm the entry.

5. In the lower part of the Style Sheets dialog, all attributes relating to the selected object are now
displayed.

6. Confirm the entry.

7. Select an object on another document page and click the entry Style_1 in the Style Sheets palette.

The object selected will now take on ALL the attributes of the original object.

Assigning several Graphic Style Sheets

The advantage of creating a Style Sheet with a preference is that the Style Sheet definition as
described in the last section is achieved very quickly. The disadvantage is that attributes that are
sometimes not required (such as position or size) are also used. In our previous examples the position
and size of the object as well as the graphic attributes were set. So that certain attributes are not
taken over for the Style Sheets, the corresponding entry fields should contain no values. At the same
time the corresponding pop-up menus must be left empty or set to Undefined. In this way the user is
able to apply several Style Sheets to the same object without having to alter attributes that have been
applied previously.

Assign two Graphic Style Sheets:

1. Create two Graphic Style Sheets: Red Frame and Yellow Fill. In the Style Sheet Red Frame you just
define the frame color [Red]. In the Style Sheet Yellow Fill you just define the fill color [Yellow] in
the General section.

2. Create three closed objects – a Text Object, a Graphic Object and a Picture Object, and assign them
the Style Sheet Red Frame by clicking the entry in the Style Sheets palette. As the objects stay
selected, assign the Style Sheet Yellow Fill to the same objects.

3. You will see that visually just the Graphic Object has taken on the yellow fill and the red frame,
while the other two objects have not. The following should therefore be noted:
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• Text and picture objects have as default a frame/line width of zero and their fill color shade is
Transparent. If you deselect the Graphic Object so that just the other two are selected and check
their attributes in the Module palette (Object Mode), you will see that they have taken over the
frame color and the fill color from the Style Sheet.

4. Edit the two Style Sheets you have just created:

• In the Style Sheet Yellow Fill, define a Shade such as 50% for the Fill Color in the General Section.

• In the Style Sheet Red Frame, define a Line Width such as 1,5 mm in the Frame section.

5. Now mark the Objects again and click the Style Sheet names in the palette to update the attributes
of the objects.

Picture Style Sheets

Creating Picture Style Sheets

Let us start with the creation of a simple Picture Style Sheet which applies scaling to a picture.

Create a simple Picture Style Sheet:

1. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Choose Edit/Style Sheets and choose New.

• Right click in the Style Sheets palette and choose the option New in the context menu.

2. Enter the name 60% in the entry field Custom in the New Style Sheet dialog.

3. Check that in the Type popup menu the type Picture is selected and click OK.

4. Now enter the value 60% in each of the entry fields Horizontal Scale and Vertical Scale and confirm
the entry.

If you now create a Picture Object and activate Picture Mode by clicking in the object, the new Picture
Style Sheet will be shown in the Style Sheets palette.

Assigning Picture Style Sheets

Once created, a Picture Style Sheet can then be applied to any picture/image. For this you have sev-
eral alternatives.

Assign Picture Style sheet with the palette:

1. Ensure that the Style Sheets palette is visible. If this is not the case, choose one of the following
options:

• Press Ctrl + F11 (Windows/Linux) or Command + F11 (Mac).

• Choose Window > Style Sheets.

If the Style Sheets palette is visible, the Type, the Name and the shortcut (if available) will be shown.

199



Working with Style Sheets

2. Click the surface of the picture to which the Style Sheet is to be applied. The Picture menu will
appear and the Style Sheets palette will show the Picture Style Sheet(s) you have created.

3. To assign the Style Sheet 60%, click the entry in the Style Sheets palette. The picture selected will
now be displayed with its Style Sheet, 60% reduced.

• Instead of applying the Style Sheet through a click on the entry in the Style Sheets palette, you
can also use the shortcut (if available).

Picture Style Sheets with Preference

If a Style Sheet consists of a series of attributes that are nearly identical with those of an existing pic-
ture, you can also create a Picture Style Sheet with a preference.

Create a Picture Style Sheet with Preferences:

1. Activate an image which already has the required attributes.

2. Choose one of the following options:

• Press Ctrl + Alt + Shift + S (Windows/Linux) or Command + Option + Shift + S (Mac) and choose
New.

• Choose Edit > Style Sheets and choose New.

• Right click in the Style Sheets palette and choose the option New in the context menu.

3. Enter the name in the entry field Custom in the New Style Sheet dialog. The checkbox Based on
actual settings should be activated as default.

4. Check that in the Type popup menu the type Picture is selected and confirm the entry. In the sec-
tion Picture Settings all the attributes relating to the image selected are shown.

5. Confirm the entry.

6. Activate another image and click the new entry in the Style Sheets Palette. The image selected will
now receive the same attributes as the original image.

Assigning several Picture Style Sheets

The advantage of creating a Style Sheet with a preference is that the Style Sheet definition as
described in the last section is achieved very quickly. The disadvantage is that sometimes attributes
that are not required are also used.

So that certain attributes are not taken over for the Style Sheets, the corresponding entry fields should
contain no values. At the same time the corresponding popup menus must be left empty or set to
Undefined. In this way the user is able to apply several Style Sheets to the same object without having
to alter attributes that have been applied previously.

Assign two Picture Style Sheets:

1. Create the two Picture Style Sheets 60% and 5mm Offset. In the Style Sheet 60% you just define the
image scaling. In the Style Sheet 5mm Offset you just define the image position in the Picture
Object.

2. Activate Picture Mode by clicking an image and assign the first Style Sheet 60% by clicking the entry
in the Style Sheets palette.
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3. Since Picture Mode remains active, assign the second Style Sheet 5mm Offset to the same image.

As you see, the second Style Sheet 5mm Offset has been applied without affecting the 60% scaling,
since in the Style Sheet 5mm Offset no scaling is defined.

Style Sheets for Table Objects
The application offers additional special Style sheets for Table Objects, Table Columns, Table Rows
and Table Cells. Please refer to the section Working with Tables.
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Working with Colors
In the default configuration, the program provides you with a number of
predefined colors. If you want a different color, you can define new colors and
modify existing colors.

Create and manage colors

Open the Colors & Blends dialog:

1. Choose one of the following options:

• Press Ctrl + Alt + C (Windows/Linux) or Command + Option + C (Mac OS X).

• Choose Edit > Colors & Blends.

• Click the surface of the Colors palette with the secondary mouse button and choose the com-
mand Colors & Blends in the context menu.

You will then see a dialog box displaying the colors that have already been defined.

The Colors & Blends command may be selected at any time, regardless of the edit mode, as long as
the user access rights to this command have not been restricted by the administrator.

The Colors & Blends dialog is divided into two command fields.

The left field holds the list of currently defined colors.

The lower command field contains a row of buttons which will open further color editing options.

The list contains all colors which already have been created. If no colors have been defined, only the
default colors appear.

A list entry consists of a color swatch followed by the color name. The list is displayed in alphabetical
order.

To the right of each color name a number of symbols are displayed:

• A pencil with a diagonal line indicates that a color is not editable.

• A warning symbol indicates that the color cannot be deleted.

• A gray box indicates that the color will be separated into the four process colors (CMYK).

• A white box containing a gray circle indicates that the color is a spot color and may be output
to an extra separation.

• A colored symbol shows if the Color Model is CMYK, RGB, HSV or LAB. If a color from a color
library is selected, no color symbol will be shown.

• The color [Registration] is displayed with a registration mark symbol for clarity.

In addition to the standard colors [White] and [Black] as well as the process colors [Cyan], [Magenta],
[Yellow] (CMY), the list also contains the colors [Registration] and [Guide Objects] as well as a number
of predefined colors with standard names: [Blue], [Bronze], [Brown], [Gold], [Green], [Orange], [Pink],
[Red], [Salmon], [Silver], [Turquoise] and [Violet]. The color names of all the above are displayed in
square brackets. This means that if the program interface language is changed, the names of the col-
ors will change automatically to the appropriate language.
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The color [Guide Objects] is necessary so that Guide objects dragged from the Rulers have a color. Of
course this color may also be applied to other objects as well. Although the [Guide Objects] color may
be edited using the commands in the Colors & Blends dialog, it may, for safety purposes, not be
deleted. The color [Registration] is also displayed as a special color. If an object is assigned this color,
the object will appear on every separation plate. This will assure that an object such as a crop mark
appearing somewhere on a document page is printed on each separation plate. The color appears as
black and is not editable.

The New Color button allows you to create a new color. It is always available.

The New Blend button allows you to create a new blend of two or more colors. Blends (also known as
gradients) are treated as colors with certain restrictions, which will be described in the section
Define/create a new simple blend/gradient.

The Duplicate button allows you to duplicate a color. As default the program hangs a dash and a con-
secutive number (e.g. -2) on the end of the color name. The duplicate is fully editable and may be
deleted again as long as it is not used in the document.

The Delete button allows you to delete a color. It is available when a color is selected that is not in use
in the document. The colors [White] and [Black] as well as the process colors [Cyan], [Magenta], [Yel-
low] and the colors [Registration] and [Guide Objects] cannot be deleted.

The Clear All button allows you to delete all the colors in the document which are not in use, except
for those colors which cannot be deleted. It is available when there are unused colors in the list.

The Trapping tab allows you to trap or overprint colors in relation to an existing color. It is available
when a color is selected in the color list.

The Import button makes it possible to import colors from other Viva files. If there are colors in the
documents from which you are importing with the same attributes as those in the current document,
then only those colors having different names will be imported.

The Cancel button allows you to leave the dialog box. All new settings will be lost.

The OK button also allows you to close the dialog box and saves all new settings.

Define/create a new color:

1. Choose one of the following options:

• Open the Colors & Blends dialog as described above and click the New Color button.

• Click the surface of the Colors palette with the secondary mouse button and choose New Color
in the context menu.

The new color with the default 100% yellow will be created.

2. Click the default name (e.g. C0 M0 Y100 K0) to make the name editable and enter a new name for
your color. This is optional – you can leave the name as it is and the name will be adapted to the
color mix of your selection. The dialog cannot be closed if the new color name is already in use (a
warning will appear).

The Color tab of the Color Definition Area will show the current settings for the color.

3. Choose your settings for the new color:
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The Model popup menu displays a list of supported Color models. This includes HSV, LAB, RGB and
CMYK and may also include color libraries/swatches such as PANTONE and HKS. The HKS model is dis-
played in different paper types for newspaper (HKS-Z), art (fine) printing (HKS-K) and normal paper
(HKS-N).

4. Choose the separation in the Color Separation field:

• The default option CMYK determines that with a four-color separation one process color sepa-
ration for each part of the color will be output.

• The option Spot Color determines that the color should be output as an additional separation.

The Color View field displays the old and new color. If the color model chosen is HSV or LAB, the New
section will be divided into two sections. The left hand section shows the screen view of the color
defined with a warning symbol. The right hand section shows the color as it will be printed or as it
will appear in a PDF file. When an existing color is being edited, the Old data field will display the
existing color as it has previously been defined.

The Screen Angle popup menu allows you to set a Screen Value to a spot color. You may choose from
the Screen Angle for Black, Yellow, Magenta or Cyan. The Standard Screen values the program assigns
to the Process Colors are Black at 45°, Yellow at 90° (respectively 0°), Magenta at 75° and Cyan at 105°
(respectively 15°).

The Color Selection area contains commands that allow you to create the color. The Color Selection
area will alter depending on the settings made for the Color model.

If the Color model chosen from the Model popup menu is either HSV, LAB, RGB or CMYK, then a Color
Wheel is displayed. Beneath the Color Wheel a series of scroll bars and entry fields can be used to
define the color as well.

The entry fields for CMYK colors will accept values between 0% and 100% in 1% increments. The entry
fields for RGB colors will accept values between 0 and 255. For HSV colors, the H field will accept
entries between 0° and 359°, and the S and V fields will accept values between 0 and 255. The entry
fields for LAB colors will accept entries from 0 to 100 with up to 3 decimal places. If you use the scroll
bars, the values set will automatically appear in the value entry fields.

If the color model chosen from the Model popup menu is either Pantone, HKS or another licensed color
model library, then a Color Look-up Table will appear.

Beneath the Color Look-up Table a scroll bar is displayed to display all the colors in the table. When a
color is selected, the program will apply the color name in the Name list, overwriting any previous
name entered for the color. You will see the new name in the list if you click another color. Names
taken from color libraries can not be overwritten.

5. After you have created all the desired colors, confirm the entry.

All the newly created colors will appear in the color list in the Colors palette and in the Colors & Blends
dialog when it is reopened. If you are adding more than one color, simply follow the above-men-
tioned steps for each entry. However, if the Cancel button is clicked instead, then all of the new color
settings will be lost.

Define/create a new simple blend/gradient:

1. Choose one of the following options:

• Open the Colors & Blends dialog as described above and click the New Blend button.
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• Click the surface of the Colors palette with the secondary mouse button and choose the com-
mand New Blend in the context menu.

• Click with the secondary mouse button on the Blend tool in the toolbar.

The new default color blend will be created and may now be edited.

2. Choose a name for the blend or retain the default name “Blend”. In this case, further new blends
will be assigned a consecutive number starting with -2.

3. Choose the Type:

• Linear – The 1st Color is on the left and blends into the 2nd Color on the right.

• Radial – The 1st Color is in the middle and blends evenly into the 2nd Color on the outside.

• Focus – The 1st Color is on the outside and blends evenly into the 2nd Color in the middle.

• Rectangular – The 1st Color is on the outside and blends into the 2nd Color in the middle, form-
ing a cross.

4. Choose the 1st and 2nd Color and a shade/density for each one.

• Option: Right click in the slider field that displays the blend and choose the command Change
Direction to flip or mirror the direction of the color blend.

5. Enter a value between 1% and 99% in the Focus field and check the effect in the Preview field.

6. Confirm your entry.

All the newly created blends will appear in the color list in the Colors palette and in the Colors &
Blends dialog when it is reopened. If you are adding more than one blend, simply follow the above-
mentioned steps for each entry. However, if the Cancel button is clicked instead, then all of the new
color settings will be lost.

Note: Color blends are only available as fill colors for objects in Object mode. If you click the Frame
symbol in the Colors palette, the blends will be hidden.

If you click in a text object and thus activate text mode, the blends will not be displayed in the
Colors palette or in the popup menus for text color.

Create a complex blend with additional options:

1. Create a new blend as described above.

2. Move the mouse pointer to the height of the two color stops and click once to add a new color to
the blend. You can add as many colors as you like.

3. Click the color stops or the focal stop and drag left or right to change position and/or focus.

4. Choose an opacity value for one or more colors.

5. Confirm your entry.

Edit a Color or Blend:

1. Open the dialog as described above.

2. Ensure that the pencil symbol (not editable) is not displayed next to the color or blend name and
click the name in the color list.
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• Shortcut to edit: Right-click the color/blend you want to edit in the Colors palette and choose
the command Edit.

3. Make your changes:

• If necessary or permitted, change the name of the color or blend. If the color name has been
adapted from your settings (e.g. C0 M0 Y100 K0), you have the option of entering a new name.
If you do not enter a name, the name will only be changed according to any change made in
the color settings.

4. Click elsewhere in the list to see the altered color or blend.

5. Confirm the entry.

All objects to which the changed color or blend had been applied will be updated automatically.

Deleting a Color or Blend:

1. Open the dialog as described above.

2. Ensure that the warning symbol (cannot be deleted) is not displayed next to the name and click
the desired name in the list.

3. Choose one of the following options:

• Press the Del key.

• Click on the Delete button.

4. Confirm the entry.

The Delete command is only active when a color or blend that is not in use in the document has been
selected. Colors used in a Style Sheet may also not be deleted, regardless of whether or not that Style
Sheet is currently in use in the document.

For safety, the colors [Black], [White], [Registration] and [Guide Objects] may not be deleted, even if
these colors are not used in the document.

Clear all colors/blends:

1. Open the dialog as described above.

2. Click the Clear All button.

The button is only active if there is at least one color or blend which is not in use in the document.
Colors used in a Style Sheet will not be deleted, regardless of whether or not that Style Sheet is cur-
rently in use in the document.

3. Confirm the entry.

Import Colors:

1. Open the dialog as described above.

2. Click the Import button.

3. The dialog box Select Document will open, in which you may select a Viva file. Choose a file from
the list and confirm you selection by clicking the Open button.
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All the colors and blends contained in the selected document will be imported into your current doc-
ument. If the selected document has any colors with the same names as those in your current docu-
ment, then only those colors which have different names will be imported.

4. Confirm the entry.

Color Trapping

Color trapping regulates the overprinting, spreading and choking of colors. With choking, the object
containing the background color is reduced. With spreading, the size of the object is increased rela-
tive to the background color.

Specify trapping for a color:

1. Open the dialog as described above.

2.Select a color from the list and click the Trapping tab.

This tab is deactivated when the color [Registration] is selected. The Trapping tab is divided into two
sections. The Color List section shows all the colors and blends defined in the document. A list entry
consists of a Background Color followed by the Trapping Type. The list includes the options Any and
None. If no trap has been set manually, the trapping style will default to Automatic.

The commands in the Trapping Type section determine how the currently selected color traps with
respect to those in the list above. The Trapping Type is set by the user according to the relationship to
the current color to be trapped. In this example, the trap values for red with respect to black is set at .
0.02 millimeter. If black is set behind red, then red is given a spread value of 0.02 millimeters.

If the Trapping Type Automatic is selected, the program traps the selected background color accord-
ing to a specific algorithm. This algorithm compares the two black overprint limits and multiplies the
difference by the automatic trapping value.

Say, for instance, that the black overprint limit is 90% (for example, with yellow type on a black
background) and the automatic trap setting is a 0.1 pt. In this example, the yellow will be assigned a
spread value of 0.09 pt. This takes into account that lighter colors spread to darker colors, and that
darker colors choke with respect to lighter colors.

The entry field for Manual trapping gives the spread or choke value for the color being trapped and a
background color. The entry field becomes available when the Manual option is selected. You may
enter values between -5 pt and +5 pt, whereby negative values choke the object, and positive values
spread the object.

In order to set a manual trap for the designated color, a second color must be selected from the selec-
tion list. The new trapping values will appear after each color selected from the list when new traps
are set.

The measurement value for Trapping is determined by the default selected in the Measurements sec-
tion of the Preferences.

Overprint indicates that the shape containing the selected color will not knock out of the background
color, but overprint it. The program takes into account the object's frame color. If a circle filled with
magenta and having a cyan frame lies over a yellow rectangle, then the cyan frame and not the
magenta fill will be overprinted. If the circle has no frame, then the magenta fill will be overprinted.
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The Automatic and Manual options routinely knock out of the background object, as long as the
black overprint limit of the foreground object does not exceed the default setting made in the Pro-
gram section of the Preferences dialog.
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Printing

Introduction

You can print your documents on any printer or printing press. In many cases, you
can simply select the Print option and print immediately. However, to ensure cor-
rect output of your documents, we recommend that you first check the document
and look at the options for printing.

Print
1. Choose a document page if you want to print document pages or an Alias page if you want to

print Alias pages.

2. Check the document according to the instructions in the section Preparation.

3. Choose File > Print.

4. Choose the options according to the instructions in the section Printing Options, or select a print
preset according to the instructions in the Presets section.

5. Check your settings in the Page Preview dialog box.

6. Optionally, click the arrow icons in the Page Preview dialog box to check the number and appear-
ance of the selected pages.

7. Click Print.

8. The document is prepared for printing. The preparation is indicated by a progress bar in the Print
Information dialog.

9. Subsequently, the print dialog of the operating system opens. As an option, select on which
printer and with which printer-specific options the document should be output and confirm the
entry.

Preparation
When printing, problems may arise that are most often caused by fonts, colors, or images used in the
document. Therefore, we recommend checking the documents for possible errors or weaknesses
before printing.

Fonts

A problem with the printed output could be faulty fonts. The option Document > Font Usage gives you
an overview of the fonts used in the document. Please refer to the notes in the section Font Overview.

Missing fonts are additionally shown in the document with a pink text background and therefore are
also easy to recognize optically.
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Another problem with the printed output could be text passages that are cut off at the end of a text
object (so-called overset). An overset is automatically indicated by a red cross in a corner of the text
object if the option View > Show Guides is selected.

Colors

A problem with the print output could be erroneous definitions of colors. This may be the case if, for
example, you use RGB colors, but your print service provider expects CMYK colors.

The Document > Color Overview option gives an overview of the colors used in the document. Please
refer to the section Colors.

The option Edit > Colors & Blends allows the editing of colors. Please refer to the section Colors.

The option Edit > Preferences > Color Management (Windows/Linux) or {Application Name} > Prefer-
ences > Color Management (Mac) determines the appearance of colors for the screen. Please refer to
the section Colors.

The option File > Export > As a PDF File> PDF > Conversion allows the conversion of colors just for the
output. Please refer to the section PDF Export.

Images

A problem with printing could be broken links or modified pictures. If you select the Print option, the
program checks if there are broken links or modified images in the document. If this is the case, a
warning message appears with the option to open Document > Picture Overview. The picture overview
shows all used pictures and possible problems with pictures. Please refer to the section Working with
Pictures.

A problem with the printed output could be images whose resolution does not meet the printing
requirements. In addition to the image overview, you can use the option Preferences > Preflight to
verify that the images have the required resolution. Please refer to the section Preferences.

Printing options
The printing options control the output of the document and are stored in the document. As far as the
printing options can be visualized, you can check them in the Page Preview.

Pages

The options in the Pages tab determine the selection, the order and arrangement of the pages as well
as the selection of the objects to be output on the pages. All the information refers to physical and
not to logical page numbers.

1. Choose one of the following options to define the Page Selection:

• All Pages — All document pages will be output.

• Current Page — Just the current page will be output.
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• From / To — A contiguous number of document pages is output. If a page number is only
entered in the From field, all document pages are output from the specified page number to the
end of the document. If a page number is only entered in the To field, all document pages are
output from the beginning of the document to the specified page number.

• Page Selection — A non-contiguous number of document pages is output. For example, enter
“3, 5, 8-22” to output document pages 3 and 5, and 8 to 22.

2. Choose one of the following options to define the Page Type:

• All — All document pages will be output.

• Even only — Only document pages with even page numbers will be output.

• Odd only — Only document pages with odd page numbers will be output.

3. Choose one of the following options to define the Printing Order:

• Ascending — The document pages will be output in ascending order, starting from the begin-
ning of the document.

• Descending — The document pages will be output in descending order, starting from the end
of the document.

4. Choose one of the following options to define the Printing Order:

• Single Pages — The document pages will be output as single pages.

• Spreads — Facing pages will be output together as one page. The spread with the most adja-
cent document pages is used as the reference size. A white space is created for sheets with
fewer adjacent pages.

• Crop Spreads — Spreads with a different number of adjacent pages are trimmed so that no
white space is created.

5. Choose Print Empty Pages/Separations if you also want to output document pages that are empty/
blank. A document page is considered empty only if there are no objects on it and no objects from
neighboring pages need to be considered (e.g., with the Bleed option). It does not matter whether
these are original objects or alias objects or objects that do not have the Print option. When a color
separation is performed using the option Color Separations (VIVA), a document page is considered
empty only if there are no objects on it that contain the color separation.

6. Choose one of the following options to specify the layers. Please refer to the Layers section.

• Visible & Printable Layers — All layers with the options Show Layer AND Print Layer will be out-
put. Both conditions must be fulfilled.

• Visible Layers — All layers with the option Show Layer will be output.

• Printable Layers — All layers with the option Print Layer will be output.

• All Layers — All layers will be output, irrelevant of whether they are visible or printable.

The settings have an additive effect, meaning that your selection may result in not all or even no
document pages being output. Example: If you have chosen Current Page and Even Only and the
current page is “3”, no document page is output.

Format

The options in the Format tab determine the orientation, appearance, and layout of the page on the
output media.
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1. Choose one of the options below to specify the Marks:

• Crop Marks — The document pages or spreads are output with crop marks. Optionally, choose
the display of the crop marks.

• Registration Marks — Document pages or sheets are printed with registration marks, color bars
and a printing inscription. Optionally select the display of the registration marks. This option is
useful if you want to output a color separation. On the right hand side, a color bar is displayed,
representing the various color combinations of cyan, yellow, magenta and black, abbreviated
C, Y, M and K. When a four-color separation is output, only the color boxes needed for that
color are output on each separation. The color bar is automatically expanded by the program if
spot colors are to be output. On the left hand side there are two gray bars, each showing incre-
ments of ten percent. The upper gray bar is formed entirely of black and appears only on the
black separation. The lower gray bar is divided vertically by the program. The left half of the
gray bar is formed like the upper gray bar of black, the right half is formed by gradations of
cyan, yellow and magenta to the same color parts. This comparison makes it possible to detect
in a color printout whether one of the colors cyan, yellow or magenta is output incorrectly. The
upper part of the page displays the spread inscription, which consists of document name,
printing date, printing time, and the page number. For a color separation, the name of the
color separation appears after the page number. In the lower part of the page, the document
page format is displayed on the left. This page format represents the value entered by the user
in the Document Setup dialog. On the left hand side is the VIVA logo, followed by the program
version.

• Length — Defines the length of the crop marks.

• Offset — Defines the offset of the crop marks and the registration marks from the page edge.

• Bleed — Defines if and to what extent (e.g. “3 mm”) objects should be output outside the page
edge.

• No bleed in binding — Defines of the bleed in the binding should be suppressed for facing
pages. In this case, parts of the facing page are not displayed in the bleed.

2. Choose one of the following options to specify the Alignment. The settings only have an effect if
the output media is larger or smaller than the page size of the document, including possible crop
marks and registration marks.

• Horizontal — Choose Left, Center or Right to align the page horizontally on the left, center or
right of the output format.

• Vertical — Choose Top, Center or Bottom to align the page vertically at the top, center or bot-
tom of the output format.

3. Choose one of the following options to define the Output Format. The output format determines
the width and height of the page in the output. In most cases, it is not necessary to change the
default setting of this option. Choose Custom Web Press Format or Custom Offset Format only if you
want to crop or align a page on a press sheet.

• Automatic — The page should be output completely.

• Custom Web Press Format — The page should be output on a web press. Define the roll width.
The value “0” means that the page is output in its full width. Define the Offset and Distance.

• Custom Offset Format — The page should be printed on a sheetfed press. Define the width of the
press sheet. The value “0” means that the page is output in its full width. Define the height of
the press sheet. The value “0” indicates that the page is output in its full height.
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4. Choose one of the following options to determine the Tiling. This option is useful if, for example,
you want to output a large poster on a printer with a small paper size. With this option, the poster
will then be spread across different individual pages like a mosaic. You can check the settings in
the Page Preview.

• Off — The page should not be tiled.

• Regular — The page should be tiled. Use the Overlapping option to define the area around
which each part should overlap. The value “0” means that no overlapping should be made.

Colors

The settings in the Colors tab determine the output of colors used on each page.

1. Choose one of the following options to specify the Color Output:

• Composite — The colors are output as composite, which means the colors will be output as they
are displayed on the screen.

• Color Separations (Viva) — The colors are output separately in a color separation. The color
separation is calculated by the program. Choose the colors/separations to be output in the
color list.

• Color Separations (InRIP) — The colors are output separately in a color separation. The color
separation is calculated by a RIP (Raster Image Processor) with an InRip function. Choose the
colors/separations to be output in the color list.

Once a color separation method has been selected, a color list is displayed with all four process colors
and the spot colors used in the document. Process colors are displayed in brackets, spot colors with-
out brackets. During the output, a separate output for each chosen color of the document page. If the
process colors of a document have been set up for color separation, the program prints them using
the cyan, magenta, yellow, and black separations.

The program’s standard angle for the process colors is 45 degrees for black, 90 degrees for yellow (0
degrees respectively), 75 degrees for magenta, and 105 degrees for cyan (15 degrees respectively).
Spot colors are output with the screen angle assigned to them in the Colors & Blends dialog. Colors
that have been created as spot colors (eg HKS or Pantone colors) are printed out as a single separa-
tion. This also applies to colors imported into the document using an EPSF image. Whether the color is
a process color or a spot color can be controlled using the Colors & Blends and Color Overview
options.

2. Choose Black Overprint above to determine from which tone value the color black should be over-
printed. The input field accepts values between 0% and 100%. In a color separation, superimposed
colors that do not have a common process color are usually excluded. If a colored object whose
frame or fill color does not contain any black part intersects with an object that contains the color
black, the color will not be excluded from the separation if the color proportion is above the value
specified by the user in the input field.

3. Select Automatic Trapping to determine if and by what amount colors should be trapped when
outputting. Depending on the number of objects to be printed on a page, turning off the option
can accelerate the output considerably.

Objects

The options in the Objects tab determine whether and how text and images are output.
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1. Choose Print Images to output the contents of image objects. If the option is not selected, the
frame of the object is still output.

2. Select Print Text to output the content of text objects. If the option is not selected, the frame of the
object is still output.

3. Choose one of the following options to determine the Quality of the images:

• High Resolution — Images should be output in high quality. In this case the program uses the
data of the image file. If this is not possible, the program automatically returns to the preview
displayed in the document.

• Preview — Images should be output in low quality. In this case, the program will use the pre-
view displayed in the document.

4. Choose one of the following options to set the OPI options for images. For high-resolution print
output of OPI images, it is mandatory that the images are replaced by an OPI server:

• Automatic — The program checks automatically if there are any pictures in the document with
corresponding OPI comments, and exports only the OPI information and the preview. This
option is useful if you are not sure if the document contains images with corresponding OPI
comments.

• No OPI — The program does not check if there are any images with corresponding OPI com-
ments in the document. If there are still OPI images in the document, the OPI information is not
taken into account. This option is useful if you are sure that the document does not contain
images with corresponding OPI comments, or if there is no OPI server available to replace the
low-resolution images.

• TIFF only — The program only considers TIFF images and creates an OPI information for the
image and also considers the already existing OPI information during the export. A preview is
not exported. .

• EPS only — The program only considers EPS images and creates an OPI information for the
image and also considers the already existing OPI information during the export. A preview is
not exported.

• TIFF and EPS — The program considers both TIFF and EPS images and creates OPI information for
the image and also considers the already existing OPI information during the export. A preview
is not exported..

Print Presets
You can save all print settings in the form of presets and choose them when required. This option is
useful if you often want to output documents with different settings. Print presets are only available
for the option for which they were created. Thus a print preset that was created for printing is not
available for PDF export and vice versa.

Create a new preset

1. Choose File > Print.

2. Make the appropriate settings.

3. Click Save as to save the settings with a specific name.

4. Enter a name for the preset and confirm the entry.
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5. The name of the new preset now appears in the popup menu Output Settings.

Edit and save an existing preset

1. Choose File > Print.

2. Choose the option you want to change in the popup menu Output Settings.

3. Change the appropriate settings as required.

4. Click Save Settings to save your current preset.

Delete preset

1. Choose File > Print.

2. Choose the option you want to delete in the popup menu Output Settings.

3. Click Delete to delete the current preset.
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Export

Introduction

You can export entire documents, individual pages and objects as well as texts in
any format. These include PDF and PostScript formats, image formats such as EPS,
JPEG, PNG or SVG, text formats as well as document formats such as the InDesign
IDML or XML format.

PDF Export
PDF Export exports the document to any PDF format:

1. Check the document as instructed in the section Preparation.

2. Choose File > Export >As a PDF File.

3. Make your settings according to the instructions in the section Printing options and in the section
PDF Options or choose a preset according to the instructions in the section Presets.

4. Check your settings in the dialog section Page Preview.

5. Optionally, click the arrow icons in the dialog section Page Preview to check the number and dis-
play of the pages selected.

6. Click Export.

7. The document is exported. The export is displayed with the help of a progress bar in the Printing
Information dialog.

PDF Options
The PDF export options are completely based on the descriptions in the section Printing for the Pages,
Format, Colors and Objects tabs. Therefore, this section describes only the options in the PDF and Output
tabs that control the PDF export of the document. These settings are also saved in the document.

Compatibility and color settings

The compatibility and color settings options control to which PDF format the document should be
exported and how the program should deal with colors. In case of doubt, these options should be
agreed with partners or print service providers who may have technical requirements for the PDF doc-
ument. If possible, you should always choose the PDF or PDF/X version recommended by us.

1. Choose one of the following options to define the Compatibility:

• PDF 1.4 (Acrobat 5) — The PDF can be viewed and/or edited by any program that supports the
PDF 1.4 format. This option is useful if you want to create PDFs that can be processed by all
imaginable programs. However, the document should not have any transparencies or effects in
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this case unless they are converted into bitmaps (Flatten Transparency option). However, the
format does not support the embedding of OpenType fonts.

• PDF 1.5 (Acrobat 6) — Choose this option if you need PDF Layers, 128-bit RC4, and use JPEG2000
images in the document. However, the format does not support embedding OpenType fonts.

• PDF 1.6 (Acrobat 7) — Choose this option if you need PDF Layers, 128-bit RC4, and want to use
and embed OpenType fonts.

• PDF 1.7 (Acrobat 8,9,X) — (Recommended) Choose this option if you want to create PDFs
according to the PDF standard (Status Summer 2018).

• PDF 2.0 (Pre-Release) — Choose this option only if you want to test the PDF 2.0 format, as the
format has not yet been officially adopted and many print service providers and external pro-
grams do not yet support the format (as of summer 2018).

• PDF/X-1a — Choose this option only if there are compelling reasons for doing so. The document
may not have any transparencies or effects in this case unless they are converted into bitmaps
(Reduce Transparency option).

• PDF/X-3 — Choose this option only if there are compelling reasons for doing so. The document
may not have transparencies and effects in this case unless they are converted into bitmaps
(Reduce Transparency option).

• PDF/X-4 — (Recommended) Choose this option if you want to create PDF/X-compliant PDF files
that comply with the PDF/X-3 standard and also support native transparencies and effects as
well as layers. This option does not require any conversion of transparencies and effects into
bitmaps. Therefore, creating such PDF files is faster, less error prone and the PDF files are
smaller.

• PDF/X-4p — Choose this option only if the color profile is not to be integrated into the PDF and
forms an external reference.

• PDF/X-5g — Choose this option if you want to create PDF/X-compliant PDF files that comply with
the PDF/X-4 standard and also contain references to other PDF files that have the same or a
lower format. Note that not all print service providers and third party programs may support
this format.

• PDF/X-5pg — Choose this option only if the color profile is not to be integrated into the PDF and
forms an external reference.

2. Choose one of the following options to specify the color Conversion:

• No Color Conversion — no colors will be converted.

• Convert to Destination — The colors will be converted to the target profile.

• Convert to Destination (Preserve Numbers) — The colors are converted to the target profile only
if they do not match the color space of the target profile. Colors of the same color space are not
converted. For example, if a document contains RGB and CMYK colors and the target profile
matches a CMYK color profile, only the RGB colors are converted. The CMYK colors are retained.
This option is recommended when you perform a color conversion.

3. Destination — Choose a color profile to use for color conversion.

4. Include Profiles — The color profile is integrated into the PDF file.
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General

The settings in the General tab determine the output of layers, the compression and the output of
warnings in the PDF.

1. Choose Create PDF Layers if you also want to preserve the layers of the document in the PDF. This is
helpful if, for example, third-party software should recognize a special level for further process-
ing. It may also be helpful, for a printing varnish or a stamping contour. The name of the layer in
the program is also used as the name of the layer in the PDF. This option is only supported as of
PDF 1.5.

2. Choose one of the following options to specify the Compression:

• None — No compression will be made.

• ZIP — The data is compressed using the ZIP method. ZIP compression is well suited for images
with large monochrome areas or repetitive patterns, such as screenshots and simple images
created with drawing/illustration applications, and black and white images with repeating
sections. When using ZIP compression, there are no losses, that is, no data is removed to reduce
file size, and image quality is not compromised.

• JPEG — The data is compressed using the JPEG method. JPEG (Joint Photographic Experts Group)
compression is great for grayscale and color images, such as smooth-gradient photos that con-
tain more detail than can be displayed on screen or printed. JPEG compression can result in
loss, meaning that image data is removed and image quality may be compromised. However,
the loss of information in the reduction of the file size are kept as low as possible. Because JPEG
compression removes data, the resulting files are much smaller than ZIP compression.

• Quality — Defines the quality of the compression. Enter a value between 5% and 100%. The
higher the value, the lower the compression.

3. Choose Compress Text and Vector Graphics if you want to compress text and vector graphics loss-
free using the Flate method. Compression is independent of the compression options.

4. Choose Warning for Image Scale if you want the program to warn you when the scaling of images
falls below or exceeds a certain value. In this case, after creating the PDF file, the program will dis-
play a warning message in a dialog box when the Show Error Warnings option is selected on the
Output tab. Regardless of this, a PDF note will be added to the image in the layout. On the basis of
this PDF note you can see directly when scrolling in PDF, which image does not meet the criteria.
Please note that not every program for displaying PDF files supports PDF notes.

5. Choose Warning for Overset if you want the program to warn you if a text in the layout has been
truncated by a too small text object. In this case, after creating the PDF file, the program will dis-
play a warning message in a dialog box when the Show Error Warnings option is selected on the
Output tab. Regardless of this, a PDF note will be added to the text in the layout. With the help of
this PDF note, you can see directly where the text was cut off when you scroll through the PDF. The
PDF note contains the first 1,000 characters of the truncated text. Please note that not every pro-
gram for displaying PDF files supports PDF notes.

Optimize

The options in the Optimize tab determine how the PDF file is optimized with respect to file size. Please
note that almost all optimizations can slow down the PDF creation.
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1. Choose Optimize PDF for the Web if you want to optimize the PDF for display in a browser. The pro-
gram restructures the file to allow byte-serving download from a web server. This will speed up
access and display when transferring the file from the web or from a network.

2. Choose Flatten Transparency (if required) if you want to convert transparencies in the layout to bit-
maps. This option is useful if you want to save PDF files in a format that does not support native
transparencies. These include the formats PDF 1.3 to PDF 1.5, and PDF/X 1a to PDF/X 3. In higher for-
mats, the option is counterproductive, as it causes a larger volume of data. The value indicates the
resolution in which the bitmap is to be generated by the program. This option may increase the
file size.

3. Choose Convert PDF/EPS to Bitmaps if you want to convert vector images in layout to bitmaps. The
value indicates the resolution in which the bitmap is to be generated by the program. This option
may reduce or even increase the file size in individual cases.

4. Choose Crop Images if you want to crop the invisible parts of the images in the PDF. This option
may reduce the file size.

5. Choose one of the following options to specify the Method to reduce the resolution of raster
images. The reduction is only made if the effective resolution of the images is above the value of
the presets. The effective resolution results from the physical resolution of the file and the scaling
factor in the document. Example: An image with a physical resolution of 200 ppi and a scaling
factor of 50% has an effective resolution of 400 ppi.

• None — The resolution of raster images is not reduced.

• Preflight Preferences — The resolution of raster images is reduced according to the settings in
the Preferences > Preflight options. It does not matter if the option Preflight has been selected.

• Custom — The resolution of raster images is reduced according to the settings in the input
fields Color Images, Grayscale Images and Black/White Images (Bitmaps). The default values in
the input fields are the resolutions expected by most print providers.

Security

The options in the Security tab determine whether access to a PDF file should be restricted. You can
limit access to a PDF file by setting passwords and using certain features, such as locking the docu-
ment for printing or editing. If a document has access restrictions, tools and menu commands that
are not allowed in the program for viewing/editing PDF files are grayed out. A document can be pro-
vided with a password to open the document and a password to change the security settings. If a
document has both passwords, it can be opened with either one password or the other; however, to
change the security settings, the password to change the security settings must be used.

ATTENTION: If you have forgotten a password, there is no way to access the password in the docu-
ment. Therefore you should always store your passwords in a different, secure location.

1. Choose Administrator Password to define a password that a user must enter to set or change secu-
rity settings. Entries with a maximum of 32 Roman characters (Latin-1) are permitted.

2. Choose User Password to define a password that a user must enter to open the document. Entries
with a maximum of 32 Roman characters (Latin-1) are permitted.

3. Choose 40bit RC4- (Acrobat3, Acrobat4) to define an encryption that provides a lower level of
security, but is compatible with Acrobat 3 and 4 (PDF 1.1 - PDF 1.3). Then choose one of the follow-
ing options to specify which actions are allowed for the user:
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• No Printing — The PDF file can not be printed. This option is useful if the PDF file should only be
read by the user on the screen.

• No Changing the Document — The PDF file can not be changed. The user can neither fill out
form fields nor make any other changes.

• No Content Copying or Extraction, Disable Accessibility — Texts and other content can not be
copied. This option is useful if, for example, the text is legally protected and you want to
ensure that it is not otherwise used by copying and pasting.

• No Adding or Changing Comments and Form Fields — Form fields can be filled in, but no com-
ments can be entered or form fields changed.

4. Choose 128bit RC4- (Acrobat5) to define an encryption that provides a higher level of security, but is
compatible with Acrobat 5 (from PDF 1.4). Then choose one of the following options to specify
which actions are allowed for the user:

• Enable Content Access for the Visually Impaired — Users can read the document using screen
readers.

• Allow Content Copying and Extraction — Text and other content can be copied. This option is
useful if, for example, the text is legally protected and you want to ensure that it is not other-
wise used by copying and pasting. In this case, do not choose the option.

• Choose one of the following options to define the Changes Allowed:

• None — No changes are allowed.

• Only Document Assembly — Pages can be inserted, deleted and rotated. Bookmarks and
thumbnails can be created.

• Only Form Field Fill-in or Signing — All previous options are activated and additional forms can
be filled out.

• Comment Authoring Form field Fill-in or Signing — All previous options are enabled and you
can also fill out forms, sign and leave comments.

• General Editing, Comment and Form Field Authoring — All previous options are activated and
additionally contents can be copied and removed.

• Choose one of the following options to specify the Printing:

• Not Allowed — Printing is not allowed.

• Low Resolution — The document is created at a low resolution, where each page is converted to
a bitmap.

• Fully Allowed — Printing is allowed. There are no printing restrictions.

View

The options in the View tab determine how the PDF should be displayed when opened in a program
for viewing, editing, or printing PDFs.

Please note that not all programs for viewing and editing PDFs support the following options.

1. In the popup menu Navigation, choose which Windows are to be displayed:

• Page Only — Displays the document page only.

• Bookmarks Window and Page — Displays the bookmark window and the document page.

• Thumbnails Window and Page — Displays the thumbnails window and the document page.
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• Layers Window and Page — Displays the Layers window and the document page.

• Attachments Window and Page — Displays the Attachments window and the document page.

2. In the Page Layout pop-up menu, choose how to display the document pages:

• Default — The document pages are displayed in the default setting of the program to display
the PDF.

• Single Page — displays only single document pages.

• Single Page, continuous — Displays document pages continuously.

• Two Pages, odd pages on the left — Displays two document pages side by side, with odd pages
on the left.

• Two Pages, odd pages on the left, continuous — Displays two document pages continuously
side by side, with odd pages on the left.

• Two Pages, odd pages on the right — Displays two document pages, side by side, with odd
pages on the right.

• Two pages, odd page on the right, continuous — Displays two document pages continuously
side by side, with odd pages on the right.

3. Choose Fit Page in Window to fit the document window to the size of the first document page.

4. Choose Center Window to center the document window on the screen.

5. Choose Full Screen Mode if you want the document window to fill the entire screen. This will com-
pletely hide all other windows.

6. Choose Reading Direction to specify the reading direction of the document, which refers to the
scrolling order in double-sided view and the first page (left/right) in double-sided view.

• Choose Left to Right for writing systems that are primarily read from left to right.

• Choose Right to Left for Arabic, Hebrew, or Asian writing systems, including vertical writing
systems.

7. Choose one of the following user interface options to determine which control bars to display:

• Choose Hide Menu Bar to hide the program’s menu bar.

• Choose Hide Toolbar to hide the program’s toolbar.

• Choose Hide User Interface Window to hide the program’s User interface window.

Output

The options in the Output tab determine the handling of fonts, the location and further processing,
the division of the PDF into individual pages and their naming, as well as the output of spelling cor-
rections and warnings.

1. Choose one of the following options to set the font embedding:

• All — (Recommended) All fonts used are embedded.

• All except Standard 14 — All fonts are embedded. Exceptions are the 14 standard fonts “Cou-
rier” (in the font styles “Regular”, “Bold”, “Italic”, “Bold Italic”), “Helvetica” (in the font styles
“Regular”, “Bold”, “Italic” , “Bold Italic”), “Symbol”, “Times New Roman” (in Regular, Bold,
Italic, Bold Italics) and Zapf Dingbats.

• None — No fonts are embedded.
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2. Choose one of the following options to specify the location (Save Export File):

• In Actual Document Folder — The file is saved in the folder where the document is located. The
file path is displayed below the option.

• In User Defined Folder — The file is saved in an individual folder. Click Select, choose a folder
and confirm your entry. The selected file path appears below the option.

• With User Defined Name and Folder — The file is saved in an individual folder with a name of
your choice. Click Select, choose a folder, enter a file name (but without the file extension
“.pdf”) and confirm your entries. The selected file path and file name appear below the option.

3. Choose one of the following options below to determine whether the file should subsequently be
opened by a third party program. You can make the settings for these options in the Preferences >
Program > PS/PDF. These options are useful, for example, if you want to check the PDF file without
looking for it in the folder and then opening it manually. If you have additionally selected the
option Print Individual Pages, all files created will be opened.

• PDF viewing program — Opens the PDF file after creation in a program for viewing PDF files.

• PDF editing program — Opens the PDF file after creation in a program for editing PDF files.

• PDF printing program — Opens the PDF file after creation in a program for printing PDF files.

• Image editing program — Opens the PDF file after creation in a program for editing image files.

• Vector illustration program — Opens the PDF file after creation in a program for editing vector
illustration files.

4. Optionally choose one of the following options in the Pages per File dialog section to specify
whether to split the PDF into multiple PDFs. These options are useful, for example, if you want to
export each page of the document as a separate PDF file. This option is often requested by print
service providers for sheet-mounting (imposition):

• Print Individual Pages — The PDF file will be split into several PDF files.

• Pages per Job — Defines the number of pages per export file. For example, the value “1” defines
that each individual page should be output as a single PDF file.

• Append Page Number — The physical page number is automatically appended to the file
name.

• Replace with Page Number — Instead of the file name, only the page number is output.

• Minimum number of characters — Adds zeros to the page numbers. For example, the value “3”
determines that the page number “1” will be output as “001” and the page number “10” as
“010”. This option is useful for displaying the page number in ascending order in a folder, so
that page “11” does not follow page “1” instead of “2”.

• Page Numbering — Determines whether the page number is output according to the physical or
logical page number. Logical page numbering can lead to overlapping, because the same
page number can occur multiple times in the document. Since a file with the same name can
not be stored multiple times in a folder, in this case the last logical page number would over-
write all previous page numbers with the same number.

• Replace with Page Name — Each document page can be assigned an individual name. This
assignment is currently only possible via the API, and there are no input options for a user.

• Output Individual Color Separations — Every color separation will be exported as a single PDF
file.
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5. Print spell check warnings — The automatic spelling and grammar checker, which underlines texts
with a red and green line, is also output in the PDF.

6. Show Error Warnings — Possible warnings, such as for the scaling of images, truncated texts or
errors in images and fonts, are displayed in a dialog.

Postscript Export
PostScript export exports the document to PostScript (PostScript Level 2) format:

1. Check the document as instructed in the section Preparation.

2. Choose File > Export > As a PostScript File.

3. Make your settings according to the instructions in the section Printing options and in the section
PostScript Options or choose a preset according to the instructions in the section Presets.

4. Check your settings in the dialog section Page Preview.

5. Optionally, click the arrow icons in the dialog section Page Preview to check the number and dis-
play of the pages selected.

6. Click Export.

7. The document is exported. The export is displayed with the help of a progress bar in the Printing
Information dialog.

PostScript Options
The options for the PostScript export are based entirely on the descriptions in the section Printing for
the Pages, Format, Colors and Objects tabs, and the descriptions of the Output tabs in the section PDF
Options. Only the option Open in PostScript viewing program differs from the descriptions in that the
PostScript file is opened here after being created in a program for viewing PostScript files.

EPS Export
The EPS export exports the document to EPS format (PostScript level 2):

1. Check the document as instructed in the section Preparation.

2. Choose File > Export > As an EPS File.

3. Make your settings according to the instructions in the section Printing options and in the section
EPS-Options or choose a preset according to the instructions in the section Presets.

4. Check your settings in the dialog section Page Preview.

5. Optionally, click the arrow icons in the dialog section Page Preview to check the number and dis-
play of the pages selected.

6. Click Export.

7. The document is exported. The export is displayed with the help of a progress bar in the Printing
Information dialog.

227



Export | EPS Export Options

EPS Export Options
The options for the EPS export are based entirely on the descriptions in the section Printing for the
Pages, Format, Colors and Objects tabs, and the descriptions of the Output tabs in the section PDF
Options.

JPEG/PNG/SVG Export
You can export the document pages as well as individual objects or an object group.

Export document pages
The JPEG/PNG/SVG export exports the document in the JPEG, PNG or SVG format:

1. Check the document as instructed in the section Preparation.

2. Choose File > Export > As a JPEG/PNG/SVG File.

3. Make your settings according to the instructions in the section Printing options and in the section
JPEG/PNG/SVG Options or choose a preset according to the instructions in the section Presets.

4. Check your settings in the dialog section Page Preview.

5. Optionally, click the arrow icons in the dialog section Page Preview to check the number and dis-
play of the pages selected.

6. Click Export.

7. The document is exported. The export is displayed with the help of a progress bar in the Printing
Information dialog.

JPEG/PNG/SVG Options
The options for the JPEG/PNG/SVG Export are based entirely on the descriptions in the section Printing
for the Pages, Format, Colors and Objects tabs, and the descriptions of the Output tabs in the section
PDF Options. The options in the Picture dialog area are only available in this export.

1. Choose one of the following options to define the Format:

• JPEG — The document pages are saved in the pixel format JPEG. This option is useful when you
need extra small images.

• PNG — The document pages are saved in vector format PNG. This option is useful if you want to
resize the images without loss, which only applies to surfaces and borders of objects and paths.

• SVG (Tiny 1.2) — The document pages are saved in the SVG vector format. This option is useful if
you want to edit the files later in a graphics/illustration program. The program also supports
the import of SVG files so that the objects and paths in the files can be reworked later. Please
note that the format does not support the full functionality of the SVG format (Tiny 1.2).

2. Choose Quality to define the quality with which JPEG or PNG files are exported. Enter a value
between 5% and 100%. The higher the value, the lower the compression.

3. Choose Resolution to define the resolution. Enter a value between 10 and 1,000. The higher the
value, the higher the resolution but also the file size. The value “72” is sufficient for the display on
the screen, the value “300” is usually sufficient for a later print.
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4. Choose Width (max) to set the maximum width of the file in the Pixel unit of measure. The value
“0” means that the width is automatically determined based on the page size and resolution.

5. Choose Height (max) to set the maximum height of the file in the Pixel unit of measure. The value
“0” means that the height is automatically determined based on the page size and resolution.

Export objects

1. Check the document according to the instructions in the Print Preparation section.

2. Select an individual object or an object group.

3. Choose File > Export > Object in the menu or Export in the context menu.

4. Choose File Type > JPEG or File Type > PNG.

5. Enter a value for the Quality. A value of “100%” means maximum quality, “1%” means lowest qual-
ity. This option is available for JPEG export only.

6. Enter a value for the resolution. A value of “72 ppi” means a low resolution (screen quality), “300
ppi” means a high resolution (print quality).

7. Confirm the entry.

Exporting an InDesign file
You can export documents into the IDML format and then edit them in InDesign. Since both programs
have a similar range of functions, the layout can in many cases be one to one with the original.

However, this depends on the InDesign version used, the structure of the layout and the export
options used. In addition, there are both conceptual and functional differences between the two pro-
grams. Further information can be found on our website.

Export InDesign IDML file

1. Choose File > Export > Document and then File Type > InDesign Markup (*.IDML).

2. Optionally choose a different target folder and/or enter a different file name.

3. Click Save.

4. Choose one of the following options:

• Choose Use Image Paths From Document if you have access to the paths that were used to
import the images to the application.

• Choose Replace Image Path Prefix if you have no access to the paths that were used to import
the images to the application, or if the paths cannot be used on another operating system. This
option is particularly helpful if for example you want to replace Windows paths with Mac OS
paths.

• Choose Select Custom Path if you want to define explicitly with which path all existing paths
should be replaced.

5. Confirm the entry.

229



Export | XML Export

XML Export
You can export a single object, an object group or complete documents to the XML format and then
edit them with any text editor.

This option is useful if you

- want to edit or manipulate documents with third party software, or

- want to save documents in a text version as well as the binary version for security reasons, or

- want to save individual objects or groups in the sense of a library.

Note: With few exceptions (for example, access rights with passwords for documents), the file is
stored in a readable text file. However, there may be parts stored in the binary format. The techni-
cal description of the XML format can be found in the program folder. The XML file can then be
imported again 1: 1. Please refer to the notes in the section XML Import.

Export document

1. Choose one of the following options:

• Choose File > Save As and then File Type > VivaXML (*.XML).

• Choose File > Export > Document and then File Type > VivaXML (*.XML).

2. Optionally choose a different target folder and/or enter a different file name.

3. Click Save.

Export Objects

1. Choose a single object or an object group.

2. Choose File > Export > Object in the menu or Export in the context menu

3. Choose File Type > VivaXML (*.XML).

4. Optionally choose a different target folder and/or enter a different file name.

5. Click Save.

XML Export options
The XML export options have no influence on a possible re-import of the XML into the program. The
options are therefore only useful if the XML is to be processed in a third-party software. If this is not
the case, do not select the options, as this will unnecessarily increase the size of the XML file.

1. Choose Edit > Preferences (Windows/Linux) or {Application Name} > Preferences (Mac) and then
VivaXML.

2. Choose one or more of the following options:

• Save Page Preview — Saves the page preview of the pages in the XML document. For saving the
page preview, the preferences for pages & objects are decisive.

• Save Image Preview — Saves an image preview of the images in the XML document.

• Save Object Preview — Saves an object preview of the objects in the XML document. This option
is useful if you want to view the objects in third party software without rendering the docu-
ment.
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• Embed Previews — Saves the generated thumbnails in the XML document. If the option is not
selected, the program automatically saves the images in the “previews” subfolder of the docu-
ment folder.

• Export Custom Alias Pages — Saves custom Alias pages in the document. These include for
example forms from VivaNWP documents. The storage of these Alias pages may be in binary
format.
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Preferences
The program uses a number of predefined settings for the display and handling of
documents, objects, fonts, texts or even images. These settings are stored in the so-
called Preferences and are usually configured in such a way that you do not have to
change anything. This section explains how you can change the Preferences for the
programme as well as for new or existing documents.

Introduction
Choose Edit > Preferences (Windows/Linux) or {Application Name} > Preferences (Mac) to adapt the
program to your requirements. The dialog shows all programs and modules for which settings may be
made. For saving and using the options, the following rules apply:

• All settings in the dialog sections Program and Drives refer exclusively to the program. All other
settings are for documents only.

• All program-specific settings are not saved until the program is quit correctly.

• All document-specific settings are not saved until the document is saved properly.

• When a document is open, all document-specific settings relate only to the current document.

• If you want to define document-specific settings as a template for all new documents, you
must select the option if only the program has been started and no document has been
opened. In this special case we recommend that restart the program after all settings have been
made.

• All settings for the program and possible add-on modules are displayed in the dialog.

Manage preferences
While the document preferences are saved in the document, the program presets are stored in a sepa-
rate file. This file not only saves the options from the dialog, but also a lot of other information, such
as the position and size of individual dialogs.

You can reset the preferences at any time. This can be useful if, for example, another monitor is con-
nected, which has a different resolution, whereby certain parts of the program are no longer visible.

Reset preferences

1. Choose Edit > Preferences (Windows/Linux) or {Application Name} > Preferences (Mac).

2. Click Reset.

Reset preferences at program startup
If the program does not start or crashes on booting, you can also reset the Preferences when you start
the program. Please refer to the section on Program start (Emergency Mode).
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Program preferences

General program options

After Program Start — determines which action will be carried out at the Program start:

• Display Start Dialog (Once) — The program’s start dialog will only be displayed once when the
program is restarted.

• Display Start Dialog (Always) — The program‘s start dialog will always be displayed when no
document is open.

• New Document — After the program is launched, the Document Setup dialog box is opened to
create a new document.

• Existing Document — After the program is launched, the dialog box for opening existing docu-
ments opens automatically.

• Neither — Only the title line of the program is displayed after the program is launched.

Open Dialog — defines which Open Dialog will be used in the program:

• Program Dialog — the program’s own Open dialog will be used.

• Operating System Dialog — The operating system dialog will be displayed. With this option you
cannot access virtual drives or Favorites.

Layout aids — Defines how layout aids (guide lines, grid, etc.) will be displayed in the program:

• Front — The layout aids will be displayed in front of all objects.

• Behind — The layout aids will be displayed behind all objects.

Page Numbers — Defines how page numbers should be displayed in the Pages palette of the program:

• Logical — The page numbers that the user has chosen will be shown.

• Physical — The page numbers are counted from 1 to x, regardless of whether a page number has
been assigned multiple times.

Presentation Mode — Determines if and how the page transition is displayed:

• No Animation — The page transitions will not be animated.

• Move Orthogonal — Orthogonal (horizontal or vertical) page movement.

• Move Orthogonal (Bounce) — Orthogonal (horizontal or vertical) page movement with a
bounce effect.

• Move diagonal — Diagonal page movement.

• Fading — Pages are faded in and out.

• Random Animation — Random choice of the other options.

Page Preview — define whether a page preview will be shown in the Pages palette:

• No Preview (quicker) — Displays the page number in the page icon. This option is suitable for
slower computers.

• Small Preview (slower) — Displays the page with all objects as a small icon in the page palette.
This option is only recommended for faster computers.

• Large Preview (slower) — Displays the page with all objects as a large icon in the page palette.
This option is only recommended for faster computers.
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Interface-Design — Defines in which Interface-Design the program will be displayed. Note: For techni-
cal reasons these options are only activated after the program is restarted.

• Operating System Design — The program menus and document windows are displayed in the
typical design of the operating system.

• Neutral Design — The program menus and document windows are displayed in a neutral
design where the operating system is no longer recognizable. The neutral interface design was
developed for editing documents on the Web, but can also be used on the desktop. It takes
into account that users in the browser may not want to see any design in the sense of a desktop
program. With the new neutral design an integration of the program into a web application is
also optically possible. Compared to the classic operating system design, the neutral interface
design deliberately has fewer options. The classic menus have been replaced by icons. All
options behave in the same way as the options in the operating system design so that the
respective access rights are taken into account. However, the neutral interface design provides
some control that is not included in the operating system design. This includes the quick
search, the selection of style templates and the insertion of notes and special characters.

Selection Handles — Defines in which size the selection handles will be displayed in the program. This
option is useful if you want to operate the program on a computer with a motion-sensitive screen
and/or with a pen.

• Small — Selection handles are displayed in the standard size.

• Middle — Selection handles are displayed in 150% of the standard size.

• Large — Selection handles are displayed in 200% of the standard size.

• Extra Large — Selection handles are displayed in 400% of the standard size.

Paste Text Formatting — Defines the options for pasting copied text with different attributes and/or
Style sheets.

• Always (from all known applications) — Text formatting from third party programs is taken
over, insofar as they can be interpreted.

• Only within the application — Text formatting from third party programs will not be taken
over.

• Never — Neither text formatting from third party programs nor within the application will be
taken over. The text is always inserted as plain text.

Author — Name specified as the author for notes and change tracking.

Show Tooltips in Document Window — A help text window automatically appears in the document
window when you move the mouse pointer to a specific area and do nothing for a moment. The help
text window disappears automatically as soon as you move the mouse pointer.

Show Effects — Transparency effects are displayed in the interface. This includes the transparency of
tool tips and the pulsation of the virtual rectangle. This option is recommended for fast computers
and the web edition with good Internet connections.

Animate Start— The program start is animated.

Animate Objects — An additional frame is displayed when you move the mouse pointer over the
object. This option is useful to give feedback to the user as to which object he would edit in the event
of a mouse click. This option is recommended for faster computers and the web edition with good
Internet connections.
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Log File — The opening and saving of documents is logged. The log file is saved in the user directory
and logs the date, the time, the user name, the author, the document name including the file path as
well as the action (open and save) as a text file in CSV format. The data remains local to the user and
will not be transmitted to third parties.

Tabbed Document View — Document windows are shown as tabs.

Shadows for Dialogs — Program dialogs are displayed with a shadow. With some operating systems
and versions, this can lead to unsightly effects.

Rounded Corners — Program dialogs are displayed with round corners. With some operating systems
and versions, this can lead to unsightly effects

Scrolling

Gray Out Objects — When scrolling, image and text objects are grayed out.

• No — When scrolling, nothing is grayed out. This option is only recommended for extremely
fast computers with very powerful screen maps. It is not recommended for the Web edition.

• Text only — When scrolling, text objects are grayed out. As soon as you stop scrolling, all text
objects are displayed correctly. This option is also recommended for fast computers and the
web edition with normal or good Internet connections.

• Images and Text — When scrolling, image and text objects are grayed out. As soon as you stop
scrolling, all image and text objects are displayed correctly. This option is recommended for slower
computers and the web edition with particularly bad Internet connections.

Logarithm — Value by which the area to be scrolled increases.

Fonts

Update Fonts while working — The list of available fonts in the palettes and menus is updated as new
fonts are installed while the program is running. If the option is not selected, the update will be car-
ried out after restarting the program. If this option is selected, the update will take place after
switching to another program or the operating system. This option is useful if you often work with
additional programs for font management. However, since this option can greatly slow down the
work of the program when switching between other programs or the operating system, the option
should be used wisely.

Use Cache for Fonts — A buffer memory (cache) is generated for the fonts after the program starts.
This option greatly speeds up the restart of the program if no new fonts have been installed in the
meantime.

Images

EPS Image Preview — Use of the image preview for EPS image files.

• Use Embedded Preview - The embedded image preview is used to display EPS image files. This
option is often useful for importing EPS files very quickly, but depending on the size of the
image, it may have the disadvantage that no image preview can be displayed because the
embedded image preview can not be displayed on the platform in question (e.g. Mac OS X
Image preview under Windows or Linux), or the EPS image file does not contain a preview. In
this case, a gray area with the name of the image file is displayed in the image object.
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• Create Preview - For the display of EPS image files, a new image preview is generated, regard-
less of whether an embedded image preview exists. This option may be useful to increase the
quality of image preview display, but may have the disadvantage, depending on image size,
that it takes time to generate the preview.

Image Editing Program — Third-party application that opens raster image files. The option to open
raster image files in a third-party application can be selected when image mode is enabled in the
document. Click the Choose button and select an application of your choice that will be able to per-
form this task.

Vector Illustration Program — Third-party application that opens vector image files. The option to
open vector image files in a third party program can be selected if the image mode is enabled in the
document. Click the Choose button and select an application of your choice that will be able to per-
form this task.

Cache — Location and cache size for previewing image files.

PS/PDF

Optionally you can choose third-party applications that are responsible for viewing, editing and
printing PostScript and/or PDF files. Click the Choose button for the respective option and select the
application of your choice that is able to fulfill this task. As an additional option, you can even enter
program-specific parameters to control the third-party program.

PostScript viewing program — Third-party application that displays PostScript files. The option to
display PostScript files in a third-party application can be selected when exporting documents to
Postscript format.

PDF viewing program — Third-party application that displays PDF files. The option to display PDF files
in a third-party application can be selected when exporting documents to PDF format.

PDF editing program — Third-party application that processes PDF files. The option to edit PDF files in
a third-party application can be selected when exporting documents to PDF format.

PDF printing program — Third-party application that prints PDF files. The option to print PDF files in a
third-party application can be selected when exporting documents to PDF format.

Colors

Program colors — Specifies the colors in which control characters (Invisibles), the Ruler in the docu-
ment window, the Grid in the document window, and the Baseline Grid for pages and objects appear
in the text. Click on the color area for the respective option and choose a color.

Document Workspace — Colors or patterns in which the Document Workspace of document pages,
Alias pages and VivaIP forms as well as the Presentation Mode background are displayed.

• Color — Click the color area for the respective option and choose a color.

• Pattern — Then click the color area or pattern in the respective option and choose a pattern.

Palettes and Dialogs — Gray value in which the palettes and dialogs are displayed in the program.
Click on the arrow and move the mouse while holding down the mouse button. The changes are
immediately visible in the palettes and in the dialog. Release the mouse button as soon as you have
selected the desired setting.
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Backup

Background Save — Determines whether and at what intervals documents are saved automatically.
This option is identical to the Save option. This option is useful if you often do not remember to back
up the document at work manually. For example, a useful value is 10 minutes.

Create Backup When Saving — Automatically saves a copy of the open document in the user directory
when using the Save option. This option is useful if you want to prevent the loss of documents or save
multiple versions of the same document that you want to use later.

• Number of Backups — Number of copies made of each document. The value “2” means that in
addition to the original document a maximum of two further backup copies are saved. If the
number of copies is exceeded, the program automatically deletes older versions of the docu-
ment. Choose the option wisely and in terms of the available memory of the hard disk on which
the operating system is located.

• Maximum Disk Space — Maximum space reserved for the backups. This value is not exact and
can be exceeded in exceptional cases by up to 50%. If the size of the maximum storage space is
exceeded, the program automatically deletes backup copies of the oldest documents.

• Backup Folder — Location of backup copies. Click Select and select a folder of your choice.

Make sure that the selected location is always available and has a fast connection (for example, a
local hard drive) to avoid delays in the work.

Updates

Updates — The program searches for updates on the Viva Website. This option requires an Internet
connection. The program transmits the current program information about program type, version
and build number.

Check automatically — Time interval in which the update check takes place.The check may be made
Daily, Weekly, Monthly or On Program Start.

Download Automatically — Newer versions are automatically downloaded or the user decides for
himself whether a new program version will be downloaded.

Check Internet Connection — Click the button to check the Internet connection. If there is no Internet
connection, check if you can connect to the Internet using a browser. If this is not the case, the error
can not be found in the program settings. If so, you may need to make proxy settings.

Proxy Settings — Determines if and how the program makes an Internet connection based on proxy
settings.

• No Proxy — No proxy is used to set up the Internet connection.

• System — To set up the Internet connection, a proxy defined in the operating system is used.

• Manual — To set up the Internet connection, manual proxy settings are used. The settings for
an HTTP proxy refer to the search for updates and upgrades. The settings for the FTP proxy refer
to the Package & Send option, which sends data to an FTP server.
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Document preferences

Objects

Snap to Distance — Distance from which objects are automatically snapped to guide objects. The
attraction distance is specified in screen pixels and accurate in the original size. Therefore, the snap
to distance varies with different magnification factors.

Style Sheet — Newly created objects will automatically have a Graphic Style Sheet applied to them.
This popup menu shows all the Graphic Style Sheets that have been created. For an explanation of the
individual options please refer to the chapter Working with Style Sheets.

Horizontal Paste Offset — Horizontal paste offset for cut or copied objects on the document page.

Vertical Paste Offset — Vertical paste offset for cut or copied objects on the document page.

Ask for Images — Automatic display of the picture usage after opening a document if there are
images in the document whose original files have been modified or were not found. The user then has
the opportunity to search for or match these images.

Crop image on all sides when stretching — The image content retains its position on the page,
regardless of the sizing handle with which the image object is stretched. If the option is not selected,
the vertical and horizontal distance of the image content is relative to the zero point of the image
object. If the image object is stretched up or to the left, the image content will
follow this movement.

Move Image Content — Determines the behavior of the image view when the image is moved within
an object.

• Show complete preview — The image preview is displayed completely and in real time. It also
displays the parts of the image preview masked by the object shape. This option is recom-
mended for fast computers and the web edition with very good Internet connections.

• Show image preview in frame — The image preview is displayed within the object frame and in
real time. Parts of the image preview that are masked by the object shape are only displayed if
you keep the mouse pointer pressed for a while. This option is recommended for fast computers
and the web edition with good Internet connections.

• Gray out images — The image preview is not displayed. You can only recognize the position of the
image preview after releasing the mouse buttons. This option is recommended for very slow
computers and the web edition for very bad Internet connections.

Style Sheet — New images are automatically assigned a Picture Style Sheet. The option does not affect
existing images. The pop-up menu displays all created style sheets of type Picture. The explanation
of the individual options can be found in the corresponding manual chapter Working with Style
Sheets.

Color Depth — Color depth used by the program to create an image preview. The option does not
affect existing images. This option is useful if your computer has very little memory and/or a lot of
images are imported into the document.

Limit Picture Preview to — Maximum vertical or horizontal size of an image preview. The value “1024
pixels” is usually sufficient for pictures with an A4 size. You should increase this setting wisely, as the
memory requirement quadruples at double the size.
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Preview Quality Raster Images/Preview Quality Vector Images — Image preview resolution for Raster
(Bitmap) images/Vector images.

In most cases an image preview of the original image will be displayed in 72 DPI. In addition the size
of the image preview is limited using the option Limit Picture Preview to. If you greatly zoom in on the
image preview (for example, by magnifying the view and/or by a scaling factor greater than 100%),
you can see details (such as text with a small dot size) only blurred or not at all.

• Low Quality — The resolution of the image preview is calculated in 36 DPI. This option is useful
if your computer has very little memory and/or a lot of images are imported into the docu-
ment.

• Normal Quality — The resolution of the image preview is calculated in 72 DPI.

• High Quality — The resolution of the image preview is calculated in 144 DPI. This option is useful
when enlarging the image preview.

• Maximum Quality — The resolution of the image preview is calculated in 288 DPI. This option is
useful if the image preview is greatly increased.

The option affects only new images to be imported. Existing images can be changed manually with
the option of the same name in the Picture menu.

When choosing, keep in mind that file size and memory requirements increase significantly if you
choose high or maximum quality. You should therefore choose this option wisely.

Please note that if images are re-imported in the same image object, the settings will be lost and
must be reapplied as needed. This does not apply to updates to the same file or if you have made
the appropriate settings in the preferences that correspond to manual selection.

If there is no picture quality improvement when selecting the option, there can be several reasons:

 • The preview quality can not be improved.

 • The selected preview quality is already applied by the preferences.

 • The preview quality is limited by the maximum size settings.

Embed All Used Images— In addition to the image preview, all original images used in the document
are also embedded in the document. By default, the application saves only an image preview of the
original images used and a reference (path) to the original images in the document. This option is
useful if you want to make sure that you have a high-resolution output for printing even if you do not
have access to the original images.

The embedding is only successful if there is a valid link to the original images at the time of saving.
There is no warning if images are not linked properly. You should first check this using the option
Document > Picture Usage. Please note that this can significantly increase the size of the document.
The size of the document increases approximately by the value displayed by the option Document >
Picture Usage in the summary row and the File Size column.

When embedding the original images in the document, the original images on the media remain
untouched. The option Document > Image Picture Usage no longer shows the Path. Possible modifica-
tions of the original images are no longer checked and therefore are not registered by the program.
When outputting the documents with the option File > Print > Objects > High Resolution or File > Export
> As a PDF File > Objects > High Resolution, the program always returns to the embedded images.
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If the option is deactivated after it was activated when the document was last saved, all linked
images will be removed from the document the next time it is saved. The link to the original images is
preserved, provided that they still have the same path that you had at the time of embedding the
images. If this is not the case, it can be assumed that the link (path) to the original images was not
valid at embedding.

Embedded images are shown with a black symbol in the appropriate palettes and dialogs.

When saving the document as an XML file, no original images are embedded. However, if you open
an XML file with the setting, the images in the XML are automatically included in thir native format in
the native document the next time it is saved, provided that a valid path to the images exists.

Use Tab Key to Navigate in Table — The Tab key can be used for navigating within table objects. The
cursor jumps automatically to the next cell. Otherwise, the tab key has the same effect as within text
objects.

Object Properties

The Object Properties tab allows the definition of individual object properties. This option is useful if
you want to assign properties to objects that the program does not allow by default. You can define
any number of object properties of the type String or Boolean. For example, one scenario would be to
use an object property of the type Boolean to determine whether an object has been tested for con-
tent and with an object property of the type String establish who has made this check. The created
object properties are automatically displayed at the end of the module palette for objects and apply
to one document only. The object properties are adopted in XML format when the document is saved.

Pages

Position Chapter Page automatically — For documents created with the option Facing Pages, the doc-
ument pages are automatically repositioned if two even or two odd document pages follow each
other. This can be the case if you give a document page an individual page number, which differs
from the automatically assigned page number of the program. If the option is switched off, the page
sequence for the left and right side is retained, regardless of whether the document page has an even
or odd page number.

Reorganize Text Chains — The text links are reorganized, for example, when pages are moved, reposi-
tioned, or the Page Order changes (Left/Right to Right/Left).

• Only Automatic Text Chains — The reorganization is only performed for text objects with the
option Linkable with Original activated on the Alias page. There can be only one text object on
the Alias page with the option Linkable with Original. If you selected the option Automatic Text
Object when creating a new document, a text object with this option was also created auto-
matically on the Alias page.

• All Text Chains — The reorganization is performed on all text chains, regardless of whether they
were created automatically or manually.

Save small preview — A small preview of the document pages is saved in the document. This setting
allows you to preview the document pages in the program’s own Open dialog. The prerequisite is that
you have selected the Program dialog option in the program preferences.

Limit image scaling to — Maximum number of (horizontal) pixels in which the preview of the docu-
ment pages is stored in the document.
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Save large preview — A large preview of the document pages is saved in the document. This setting
allows you to preview the document pages in the program’s own Open dialog. The prerequisite is that
you have selected the Program dialog option in the program preferences.

Number of Pages — Number of document pages that are saved as previews in the document. If the
document has more than one document page and the specified number of pages is greater than “1”,
you can browse through the document pages in the program’s own Open dialog. The prerequisite is
that you have selected the Program dialog option in the program preferences.

Quality — Quality in which the preview of the document pages is saved. The storage takes place in
JPEG format. The quality of the preview is given as a percentage of 5% to 100%. A low number corre-
sponds to a low quality, a high number of a high quality.

Grid

Horizontal Distance — Horizontal distance between two grid lines.

Vertical Distance — Vertical distance between two grid lines.

Sections — The number of sections.

Grid in front — The grid is displayed in front of or behind all objects.

Embedded fonts

You have the option to embed fonts in the document. This option is useful if you want to edit the
document with the fonts on a machine that does not have fonts installed.

This option is not related to the option to embed fonts when creating a PDF or PostScript file.

Embed All Used Fonts — All fonts used and marked in the document are embedded in the document.
In this case, the program accesses the embedded fonts when displaying the font and creating a PDF.

Collaboration with third-party font management applications can not be guaranteed. Therefore it
may be necessary to install the fonts in the system so that they are correctly incorporated.

Add more fonts by clicking on the first column of the list.

Deactivate System Fonts — Only the embedded fonts are displayed. All other fonts are no longer
available.

 • Take note of the legal information in the header of the dialog.

 • Click the question mark button and note the explanation of abbreviations to the embedding
information, which may be different for each font.

Measurements

The options for the measurement units determine in which standard units absolute dimensions in dia-
logs and palettes are displayed or converted. If the unit “millimeters” is specified for an option and
the entry is made in “inches”, the inch value is automatically converted to millimeters.

The program recognizes the measurement units Millimeter (mm), Inch (“), Decimal Inch (dz), Point
Pica (pt), Point Didot (dd), Cicero (c), Centimeter (cm), Pica (8p) and Quart (q).
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Standard — The default measurement unit for all options that are not explicitly listed in the dialog.

Ruler — The measurement unit for the horizontal and vertical rulers in the document window.

Objects — The measurement unit for the horizontal and vertical position, the Width and Height as well
as for frames and lines.

Colors — The measurement unit for Trapping colors.

Images — The measurement unit for the height and width of images.

Text — The measurement unit for the Font Size, Indents, Tabs and Line spacing in the text.

Conversion — Conversion rates for Points/Inch and Ciceros/cm.

Search Paths

The Search Paths allow you to specify the folders in which the program should search for missing
images. The explanation of the individual options can be found in the corresponding manual chapter
Working with Pictures.

Text

Preferences for Styles
Underline — Offset of the line and the line weight for the style Underline. The program differentiates
between intervals for horizontal text (e.g. Roman text) and vertical text (e.g. Japanese or Chinese
text). The indications can be made in absolute (e.g. pt or mm) or relative units of measure (e.g.%).
The relative units of measurement refer to the font size. The option affects existing texts with this
style.

Strikethrough — Offset of the line and the line weight for the style Strikethrough. The program distin-
guishes between intervals for horizontal text (e.g. Roman text) and vertical text (e.g. Japanese or
Chinese text). The indications can be made in absolute (e.g. pt or mm) or relative units of measure
(e.g.%). The relative units of measurement refer to the font size. The option affects existing texts with
this style.

Superscript — The distance of the character from the baseline and the height and width of the charac-
ter for the style Superscript. The entries are in percent and refer to the font size. The option affects
existing texts with this style.

Subscript — The distance of the character from the baseline and the height and width of the character
for the style Subscript. The entries are in percent and refer to the font size. The option affects existing
texts with this style.

Superior — Character height and width for the style Superior. The entries are in percent and refer to
the font size. The option affects existing texts with this style.

Small Caps — Character height and width for the style Small Caps. The entries are in percent and refer
to the font size. The option affects existing texts with this style.

General Text Preferences
Line Counter — The font, font size, font color and representation of the line counter. Changes are dis-
played immediately in the document.
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Text Lines — Automatic line spacing and the method for calculating it. The entries for Automatic Line
Spacing (automatic leading) are made in percent and relate to the font size. The option takes imme-
diate effect on all text with this attribute.

Language — The default text language that will be applied automatically to all new text objects or
text chains. The option does not take effect on existing text objects or text chains. The popup menu
shows all the text languages that are available.

Greek Below — Value under which relative font size the text is displayed as a gray area. The relative
font size corresponds to the absolute font size in conjunction with the scaling factor. With an absolute
font size of 10 points and a scaling factor of 50%, the relative font size is 5 points.

Automatic Grammar Check — Text is automatically checked for grammar. The option affects all exist-
ing text. Please refer to the section Working with Text.

Automatic Spell Check — Text is automatically checked for spelling. The option affects all existing
text. Please refer to the section Working with Text.

Show Invisibles — The control characters (Invisibles) are displayed automatically.

Show Text Rulers — The text rulers will be switched on automatically.

Distance between standard tabs — Distance between tabs when no manual tabs are set in the text.
The option affects all existing text.

Typographic Quotation Marks — Quotation marks (") will be replaced automatically by the typo-
graphic quotation marks defined in the Language section. The option does not affect existing text.
Please refer to the section Language.

Force line break — A string that cannot be displayed in the text object due to its length and separa-
tion settings will result in an overset. The option forces a wrap to avoid an overset or to display at
least part of the string.

Visualize Style Sheets — Text to which Character and/or Paragraph Style sheets have been assigned is
displayed with colored background.

First Baseline — The position of the first baseline of text in a text object. Please refer to the section
Working with Text.

Baseline Grid — Start value and distance as well as the direction and numbering of the baseline grid
lines. The option affects all existing text.

Change Tracking — Change Tracking is activated. You can also set the style and color with which
Deleted Text, Inserted Text, Changed Attributes and Changed Lines will be displayed. The option
affects all existing text.

Preferences for Style Sheets
Default Style Sheets — A Character, Paragraph or Layout Style Sheet will be applied to a new text
automatically. The option does not affect existing text objects. The popup menu displays all the style
sheets of the types “Character”, “Paragraph” and “Layout” that have been created. Please refer to the
section Working with Style Sheets.

Footnote Style Sheets — Style sheets for the Footnote Reference, the Footnote Label and the Footnote
Text. The popup menu shows all the available Character Style Sheets for the Footnote Reference and
the Footnote Label and all the available Paragraph Style Sheets for the Footnote Text.
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Endnote Style Sheets — Style sheets for the Endnote Reference, the Endnote Label and the Endnote
Text. The popup menu shows all the available Character Style Sheets for the Endnote Reference and
the Endnote Label and all the available Paragraph Style Sheets for the Endnote Text.

Preferences for Footnotes
Define the preferences for Footnotes. Please refer to the section Working with Text.

Offset — Defines the minimum offset between the main text and the Footnote text.

Prefix/Postfix — Defines if and which text should be inserted before and/or after the Footnote Refer-
ence and the Footnote Number.

Format — Defines how the Footnote Reference and the Footnote Number should be displayed.

Numbering — Defines if the numbering should be Continuous or Chapter wise. With the option Chap-
ter wise the numbering starts from the beginning if a chapter break has been inserted in the text.

Start with — Defines the first footnote number.

Separator — Defines if a separator line should be displayed between the main text and the footnote
text.

Vertical Offset/Horizontal Indent — Defines the position of the separator. Both positive and negative
values are allowed.

Line Width/Color/Line Style/Length — Define the display of the Separator.

Length — Absolute values (e.g. 100 mm) and relative values (e.g. 50%) are allowed. Relative values
relate to the width of the text object. With multi-column text objects the value relates to the width of
a text column.

Preferences for Endnotes
Define the preferences for Endnotes. Please refer to the section Working with Text.

Display Position — Defines if the Endnote at the end should be displayed After the Related Text, In a
new Text Column or In a new Text Object.

Offset — Defines the minimum offset between the body text and the Endnote Text.

Save to — Defines if the Endnotes should be displayed at End of Text or End of Chapter.

Prefix/Postfix — Define if and which text should be inserted before and/or after the Endnote Reference
and the Endnote Number.

Format — Defines how the Endnote Reference and the Endnote Number should be displayed.

Numbering — Defines if the numbering should be Continuous or Chapter wise. With the option Chap-
ter wise the numbering starts from the beginning if a chapter break has been inserted in the text.

Start with — Defines the first Endnote number.

Separator — Defines if a separator line should be displayed between the main text and the Endnote
text.

Vertical Offset/Horizontal Indent — Define the position of the separator. Both positive and negative
values are allowed.

Line Width/Color/Line Style/Length — Define the display of the Separator.
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Length — Absolute values (e.g. 100 mm) and relative values (e.g. 50%) are allowed. Relative values
relate to the width of the text object. With multi-column text objects the value relates to the width of
a text column.

Language

Quotation Marks — Determines the Single and Double quotes for each language. Click the Quotation
Marks tab, and then click the pop-up menu in the Single and/or Double column and select the
required quotation marks.

Hyphenation — Defines the hyphenation module to use for each language. Click the Spelling &
Hyphenation tab and then the popup menu in the Hyphenation column and choose the module
required. If the Hyphenation column does not contain an entry or the entry Module is missing, no
module is available for the respective language.

Spell Check — Defines the Spell Check and Grammar Check (if available) modules to use for each lan-
guage. Click the Spelling & Hyphenation tab and then the popup menu in the Spell Check column and
choose the module required. If the Hyphenation column does not contain an entry or the entry Mod-
ule is missing, no module is available for the respective language.

Thesaurus — defines the Thesaurus module to use for each language. Click the Spelling & Hyphenation
tab and then the popup menu in the Thesaurus column and choose the module required.

You should only use the languages for which the corresponding module is available for the text in
the document. Otherwise, the hyphenation, spell checker, and/or thesaurus will not work. If you
pass on the document to a third party using a hyphenation module in the document that the recip-
ient does not have, a warning message appears on opening the document indicating that the
module is missing.

Depending on the program version, the software is delivered with a hyphenation and spell check
module for different languages. You can optionally install further languages from modules of
other manufacturers. Please refer to the notes in the Installation section.

User Dictionaries

The User Dictionaries allow the language-related extension of the dictionary including hyphenation.
This option is helpful if you are frequently using technical terms or proper names that the program
may under certain circumstances not be able to hyphenate as these words are not known. In such a
case, a user-defined dictionary can be created by language, which is checked during automatic
hyphenation. If hyphenation occurs, the program first of all checks the user dictionary before resort-
ing to program-related dictionaries and hyphenation algorithms.

Define hyphenation exceptions

1. Choose Edit > Preferences > User Dictionaries (Windows/Linux) or [Application Name] > Preferences >
User Dictionaries (Mac).

2. Choose the language for which the hyphenation exception should be created.

• Choose the language option Global if the word to be hyphenated appears in every language and
should always be hyphenated in the same way.

• If several hyphenation modules are available for a language, select the module that has sepa-
rated the word incorrectly or has not sepa rated it at all.
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3. Click in the entry field Word and enter a new character string using all possible hyphenations.

4. Click New to include the new string in the user dictionary.

Define a No Hyphenation
• If a word should never be hyphenated, enter the string without hyphens in the entry field

Word.

As well as the definition of a hyphenation exception, you can also influence the quality of the
hyphenation, which is important in some languages. While for example in Spanish there are no qual-
ity differences in hyphenation, German has a whole series of hyphenation qualities. This is because
the German language has a great many words that have been put together from other words, which
may then have hyphenations not only between syllables, but also between the original words. Such
hyphenations are also called Preferred Hyphenations. The quality of a hyphenation is defined by the
number of dashes entered between two syllables.

Define hyphenation quality

1. Enter a character string in the entry field Word.

2. Enter the hyphenation:

• A dash to create a possible hyphenation without any quality.

• Two dashes one after the other to create a good hyphenation.

• Enter three dashes one after the other to create an excellent quality hyphenation.

Taking as an example “Abcdefghijklmnop” enter “Abc-def --- ghi - jklmnop”. This shows that the
user rates the hyphenation between “abcdef” and “ghijklmnop” as optimal and between “ghi” and
“jklmnop” as good. The hyphenation between “Abc” and “def” is less good, but basically possible.

In some languages, not only the quality of hyphenation, but also the display of the word in the case
of a hyphenation plays an important role. In this case, the syllables change during the hyphenation.
When the hyphenation is removed, the strings are displayed in their original notation.

In principle, all language-related substitutions can be reduced to the following cases:

• The last character before the hyphen or the first character after the hyphen is deleted.

• The last character before the hyphen or the first character after the hyphen is replaced by one
or more characters.

Hyphenations with automatic substitution
• Enter “(=)” before or after a hyphen if you want the last character before or after the hyphen to

be deleted in the event of a hyphenation.
Example:
“Abc (=) - def” hyphenates as “Ab-def”,
“Abc - (=) def” hyphenates as “Abc-ef”,

• Enter the character string “(=characterstring)” if you want the last character before or after the
hyphen to be replaced by a single character in the event of a hyphenation.
Example:
”Abc (= x) -def” hyphenates as “Abx-def”,
“Abc (= xy) -def” hyphenates as “Abxy-def”,
“Abc - (= x) def” hyphenates as “Abc-xef”,
“Abc - (= xyz) def” hyphenates as “Abc-xyzef”.
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• Enter the character string “(characterstring)” if you want the last character before or after the
hyphen to be replaced by one or more characters in the event of a hyphenation.
Example:
”Abc (x) -def” hyphenates as “Abcx-def”,
“Abc (xy) -def” hyphenates as “Abcxy-def”,
“Abc (x) def” hyphenates as “Abc-xdef”,
“Abc- (xyz) def” hyphenates as “Abc-xyzdef”.

Please note that the descriptive examples only contain example characters, as most hyphenation
modules automatically apply these language-based hyphenation exceptions.

Color Management

Color Management allows you to determine the appearance of colors on the screen. The explanation
of the individual options can be found in the manual chapter Working with Colors.

Access Rights

The access rights make it possible to limit the editing of documents for third parties. These options
may require an additional license. Please refer to the section Working with Access Rights.

Drives

With the options in the Drives section, you can create connections to databases or Internet/Cloud ser-
vices. With the help of these (virtual) drives you can open documents as if from a normal drive and
save them or import images.

With the Option Disable Physical/Local Drives you can switch off any connections to local or network
drives. In this case, opening and saving documents as well as importing images is only carried out
via the named drives.

As default you can connect to Internet drives (VivaCloud), MySQL databases or databases with an
ODBC interface. Further connections to special databases (e.g. Canto or SixOMC) are also available.

The virtual drives are only available to you through the program and here too only through the
program dialog. The virtual drives therefore do not appear on your desktop or in any operating
system dialogs for choosing drives, folders and files. If in doubt please ask your network adminis-
trator and/or service provider for the exact connection data.

Set up a drive for VivaCloud
VivaCloud is a browser-based, digital asset management system (DAM) and editorial system from
the company VIVA, which allows the storage of any data and documents. The special feature of Viva-
Cloud is that you can edit layout documents with the VivaDesigner web version directly in the brow-
ser. Furthermore, with the help of forms, you can generate documents fully automatically (e.g. busi-
ness cards, etc.).

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose Web Drive.
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5. User – You may as an option enter the user name with which you are registered in the application.
If you do not enter a name, the user name will be prompted every time you access the drive.

6. Password – You may as an option enter the password that would authorize you to access the data-
base or service. If you do not enter a password, the password will be prompted every time you
access the drive.

7. Host – Enter the URL/network address “viva.cloud” or the address at which the application can be
reached.

8. Port – Enter the Port “443”.

9. Path – Enter “/fs”.

Set up a drive for a MySQL database
MySQL is a worldwide relational database available for various operating systems. The database can
be used for all imaginable purposes. In order for the program to open/save documents from the
MySQL database as well as import images, a table called “vivafs” is mandatory. The table must have
the following structure:

CREATE TABLE `vivafs` (
`id` int(10) unsigned NOT NULL AUTO_INCREMENT,
`name` varchar(255) NOT NULL,
`parentID` int(10) unsigned DEFAULT ‚0‘,
`document` longblob,
`modified` datetime NOT NULL DEFAULT ‚0000-00-00 00:00:00‘,
`created` datetime NOT NULL DEFAULT ‚0000-00-00 00:00:00‘,
`size` int(10) unsigned NOT NULL,
`isDir` tinyint(1) NOT NULL DEFAULT ‚1‘,
PRIMARY KEY (`id`)

);

In this table both documents and directories are managed, but the directories cannot be created via
the program dialog for opening and saving documents.

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose MySQL.

5. Drive Name – Enter the name of the database in which the table with the relevant records is
located.

6. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

7. Password – Optionally, enter the password that the user would use to authorize himself in the
application. If you do not enter anything, the password will be prompted every time the drive is
accessed.

8. Host – Enter the URL/network address at which the application can be reached.

9. Port – Enter Port “3306”.
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Set up a drive for an ODBC database
Open Database Connectivity (ODBC) is a standardized database interface that uses SQL as the data-
base language. It thus offers a programing interface (API) that allows a programmer to develop his
application relatively independently of the database management system (DBMS) used, if an ODBC
driver exists for it.

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose OBDC.

5. Drive Name – Enter the name of the database in which the table with the relevant records is
located.

6. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

7. Password – Optionally, enter the password that the user would use to authorize himself in the
application. If you do not enter anything, the password will be prompted every time the drive is
accessed.

8. Host – Enter the URL/network address at which the application can be reached.

9. Port – Enter the Port (e.g. “80”, “443”).

Set up a Drive for Canto Cumulus
Cumulus is a browser-based digital asset management system (DAM) from Canto that allows you to
store any type of data and documents.

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose Canto.

5. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

6. Password – Optionally, enter the password that the user would use to authorize himself in the
application. If you do not enter anything, the password will be prompted every time the drive is
accessed.

7. Host – Enter the URL/network address (e.g. “sandbox.canto.com”) at which the application can be
reached.

8. Port – Enter the Port (e.g. “80”, “443”).

9. Path – Enter “/CIP”. Please check if your license /version of Canto Cumulus supports this parame-
ter.

10. Parameter – You may for example optionally specify “catalogname=xyz” if you want to create a
direct connection to the catalog “xyz” in the application.
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Set up a drive for Six OMC
Six OMC is a browser-based digital asset management system (DAM) from Six that allows the storage
of any data and document.

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose Six.

5. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

6. Password – Optionally, enter the password that the user would use to authorize himself in the
application. If you do not enter anything, the password will be prompted every time the drive is
accessed.

7. Host – Enter the URL/network address (e.g. “opixweb.sample.com”) at which the application can
be reached.

8. Port – Enter the Port (e.g. “80”, “443”).

9. Path – Enter “/sixomc/services/sixomc”.

Set up a drive for Mediamid M@ars
M@rs is a browser-based, digital asset management system (DAM) from Mediamid, which allows the
storage of any data and documents.

1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose Mediamid.

5. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

6. Password – Optionally, enter the password that the user would use to authorize himself in the
application. If you do not enter anything, the password will be prompted every time the drive is
accessed.

7. Host – Enter the URL/network address (e.g. „www.mediamid.com“) at which the application can
be reached.

8. Port – Enter the Port (e.g. “80”, “443”).

9. Path – Enter “/mediamanager/REST”.

Set up a drive for ResourceSpace
ResourceSpace is a browser-based digital asset management system (DAM) from Montala Limited
that allows the storage of any data and documents. The program allows the import of images. The
search for “Browse by tag” and “My collections” is supported. A search from the “Themes” section is
not supported because the API does not offer this option (as of November 2020).
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1. Choose Preferences > Drives.

2. Click New.

3. Click Rename to enter a name for the drive that will later be displayed in the selection dialog.

4. Type – Choose ResourceSpace.

5. User – You may as an option enter a user name that is registered in the application. If you do not
enter a name, the user name will be prompted every time you access the drive.

6. Password – You may as an option enter the “Private API key” (i.e. NOT the user password), which is
stored in the application for the user. The “Private API key” consists of a combination of numbers
and letters with about 60 characters. If you don’t enter a “Private API key”, the “Private API key”
will be queried every time the drive is accessed. You can find the “Private API key” in the Web
Application under “Administration > Manage Users > Edit Users” (Status 2020).

7. Host – Host – Enter the URL/network address (e.g. “sample.resourcespace.com”) at which the
application can be reached.

8. Port – Enter the Port “443”.

Using the drive

1. Choose one of the following options:

• Choose File > Open if you want to open a document.

• Click in a picture object and choose File > Import if you want to import an image.

2. Click Computer to see all local and virtual drives.

3. Double-click the virtual drive.

4. Open further sub-folders (if available) or click the Search symbol (if available) to search for spe-
cific content.

5. If the virtual drive offers you a search facility, this is dynamically based on the fields and options
of the appropriate drive.

The virtual drives may be available to you in the Pictures palette to allow you for example to place an
image in the document using Drag & Drop.

Place images interactively

1. Choose Window > Pictures.

2. Click the Search symbol to search for specific content.

3. Choose the virtual drive. If the drive is not shown in the list, the search function is not supported.

4. Enter the search criteria.

5. Click Search.

6. Click a file in the search result and drag this to the document or the picture object.

Technical notes on drives
Each drive is saved as a separate file with the ending “.drive” in the VIVA user’s “Drives” folder. In
order to provide the virtual disks for a server process that does not have a user directory, the files with
the extension “.drive” must be saved in the folder “Drives” in the program folder.
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XMP Custom Info

The XMP Custom Info allows you to extend documents with additional information for third-party
programs. XMP is an XML format for describing document meta data. For example, the program saves
the preview of the document pages and the information from the Document Statistics option in XMP
format. The information is stored at the end of the file and can be evaluated by any third-party pro-
gram. A typical application for XMP Custom Info is specifying fields and field information for web-
to-print applications. The user can store in the document any information that can be evaluated by a
browser as long as these are entered in a correct XML/XMP syntax.

Preflight

The Preflight options enable visual recognition of possible printing problems.

Preflight Document — Activates the visual Preflight.

Minimum Image Resolution — Value for the minimum resolution for Color Images, Grayscale Images
and Black/White Images (bitmaps). The minimum resolution refers exclusively to raster/pixel images.
If the minimum resolution is not reached, the program displays a colored frame:

• If the resolution is within the tolerance range, a yellow translucent frame is displayed.

• If the resolution is outside the tolerance range, a red translucent frame is displayed.

Example: With a minimum resolution of 300 ppi and a Tolerance of “30%”, a yellow frame is dis-
played at a resolution of 210 ppi to 299 ppi. If the resolution is outside the tolerance, i.e. below 210
ppi, a red frame is displayed.

Tolerance means that the image does not have the required minimum resolution but is still printable.

Image Color Mode — Displays a red translucent frame when importing images with RGB, Grayscale or
Bitmap color spaces.

This option is less relevant than in previous years because the program can use color profiles to
convert images of any color space at any time during output. It is therefore not necessary to
always import images in certain color spaces.

Warning for Transparency — Displays a red translucent frame if an object has transparency effects or
transparency blends/gradients. This information is useful, for example, if you want to output the
document with a PDF option that does not support native transparencies (for example, PDF 1.4).

Warning for Effects — Displays a red translucent frame if an object uses Effects. This information is
useful, for example, if you want to output the document with a PDF option that does not support
native transparencies (for example, PDF 1.4).
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Working in a Team
Depending on the edition/license, the program has a number of options that allow
multiple users to work together worldwide and across languages. This includes the
collaboration of several users in the sense of an editorial system, as well as the col-
laboration between media service providers and end customers.

Overview of the team functions

Editing of documents

Multilingualism
The program offers multilingual user guidance in over 20 languages, as well as automatic translation
of colors and style sheets when certain rules are followed. You can enter texts in all languages and, if
necessary, translate them fully automatically into several target languages.

Change Tracking
With change tracking you can establish who has made which changes in a document. The program
creates a report with the exact time and which text was inserted, deleted or newly formatted by
whom.

Notes
With notes you can store nonprintable information and notes for other users for texts and objects.

Restrict document editing
With passwords for Alias pages, layers and program options, you can protect your documents and
restrict editing of documents for third parties. These options are especially useful if you want to cre-
ate documents that other users should only edit according to certain criteria or if users have little or
no knowledge of layout programs.

Tasks
Tasks can be used to organize documents so that several users can work on a document at the same
time.

Libraries
With the import and export of objects or groups in XML format, parts of documents can be saved and
re-inserted into other documents. All styles and colors are preserved. Please refer to the notes in the
Export section.

Embedded Fonts
This option allows you to share documents with other users who do not have these fonts and cannot
or do not want to install them. Please refer to the notes in the Preferences section.
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Embedded Images
This option allows you to embed all the images used in the document. This option is especially useful
when users import images into the document that are not accessible to third parties, but still need to
create printable documents. Please refer to the notes in the Preferences section.

Document Management

Drives
You can use the drives to save documents to databases or Internet drives and edit them directly. They
can establish connections to image databases from various manufacturers and optionally force the
user to import images only from these drives. Please refer to the notes in the Preferences section.

VivaCloud
With VivaCloud a web-based system for the administration of documents and files (Asset Manage-
ment System MAM) of all types is optionally available to you, which can also be used as an editorial
system.

Collection
With the Collection option, you can combine individual documents into a complete work (book,
magazine, journal, etc.). This option works on local drives, network drives or also Internet drives (e.g.
VivaCloud). Please refer to the notes in the section Working with Collections.

Status information
With the help of status information in VivaCloud, you can control exactly which processing stage your
documents are in. The status information is also displayed in collections.

Package & Send (VIVA FileSender)
Using the option “Package & Send” (VIVA FileSender) you can send a document to VIVA or to a speci-
fied address with all fonts and images fully automatically. You do not need an e-mail or FTP program
to do this. To send the data to an address other than VIVA, you need an appropriate communication
profile, which is available on request. Please refer to the notes in the Export section.
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Change Tracking
With change tracking you can establish who has made which changes in a document. The program
creates a report with the exact time and which text was inserted, deleted or newly formatted by
whom. Change tracking is therefore suited for users who work in a team, or for users who only want to
create a report protocol of their work.

Activate/Deactivate Change Tracking

You can activate change tracking at any time, and deactivate it either temporarily or permanently.

Activate/Deactivate Change Tracking

1. Choose the command View > Track Changes (Operating System Design) or Text > Track Changes
(Neutral VIVA Design).

• Alternatively, choose the option Track Changes in the context menu.

If you deactivate change tracking, you can edit the document without any changes being marked.
Deactivating change tracking will not remove any changes that were already marked. If you copy
text containing changes marked by change tracking, the change tracking attribute will also be cop-
ied although change tracking was deactivated.

Display of changed text passages

Different text changes are marked in different colors by the Change Tracking:

- Deleted text will not be removed from the text, but instead will be displayed in red with a strike-
through.

- Inserted text will be displayed in blue and underlined.

- Changed attributes (e.g. assignment of style sheets, changes to font size, etc.) will be displayed
with a yellow background.

Furthermore, a red correction bar will be displayed at the edge of the line. You can change the dis-
play for the current document in the Preferences at any time.

Accept/Reject changes

With the Change Tracking option you can check all changes and decide if you want to accept or reject
them. For each change the Date, Time and Change Type are displayed. Insofar as it is available, the
Author who made the changes will be displayed.

Accept or reject changes

1. Choose the option Window > Track Changes.

2. Choose one of the following actions:

• Click Next to spring to the next change.

• Click Previous to spring to the previous change.
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• Click Accept to accept a change. The program then springs automatically to the next change. It
may occur that with the next change the same text passage is marked if two text changes were
made simultaneously. This is for example the case when a text is inserted and then formatted
as well.

• Click Accept All if you want to accept all changes without any checking.

• Click Reject to reject a change. In this case all the newly inserted text will be deleted automatic-
ally and any formatting changes will be canceled.

• Click Reject All if you want to reject all changes without any checking.

Changing the preferences for change tracking

With the Preferences you can define the Author name and the display of the altered text passages.

Define the Author Name

1. Choose the option Edit > Preferences > Program > General (Windows/Linux) or [Application Name] >
Preferences > Program > General (Mac OS).

2. Enter the required name in the Author field.

Please note that the name is used not only for change tracking, but also for other options (e.g.
Notes).

If you are using VivaDesigner in the Web Edition, particularly with VivaCloud, you should not enter a
name for the author, as the author’s name changes with the user. In such cases the name of the author
can be transmitted during the session.

Define display of changed text passages

1. Choose the option Edit > Preferences > Text > Change Tracking (Windows/Linux) or
[Application Name] > Preferences > Text > Change Tracking (Mac OS).

2. Choose one of the following actions:

• Choose the option Activate Change Tracking to activate change tracking using the
Preferences.

• Choose options for Deleted Text, Inserted Text, Changed Attributes: Strikethrough, Underline,
Background Color or Foreground Color. If you choose the option None, the text changes will be
invisible. In this case you can still use the Change Tracking palette to spring to each change
and accept or reject it.

• Choose a color of your preference for Deleted Text, Inserted Text and Changed Attributes.

• Choose Left border or Right border to define on which side of changed lines a correction bar
should appear. Choose None if no correction bar should appear.
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Notes

Create Notes

With the Notes function you can apply non-printable information and tips for other users to text and
objects. Like change tracking, this option is suited for users who work in a team or for users who only
want to create a report of their work.

Create a Note for an object

1. Choose and select an object.

2. Choose one of the following options:

• Choose Object > Note in the menu.

• Choose Note in the context menu.

3. Enter the note in the entry field.

4. Confirm your entry.

Create a Note in a text

1. Place the cursor at the point in the text where the note will be set.

2. Choose one of the following options:

• Choose Text > Note (Operating System Design) in the menu or click the Note symbol (Neutral
VIVA Design).

• Choose Note in the context menu.

3. Enter the note in the entry field.

4. Confirm your entry.

A note is symbolised with a red speech bubble.

Change a Note for an Object

1. Select the Object containing the Note.

2. Choose one of the following options:

• Choose Object > Note in the menu.

• Choose Note in the context menu.

3. Change the note in the entry field.

4. Confirm your entry.

Change a Note in text

1. Place the cursor at the point in the text where the note is set.

2. Choose one of the following options:

• Choose Text > Note (Operating System Design) in the menu or click the Note symbol (Neutral
VIVA Design).

• Choose Note in the context menu.
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3. Change the note in the entry field.

4. Confirm your entry.

Managing notes

With the Notes option, you can check all the notes and decide if you want to change or delete them.
For each Note the Creation Date and Change Date with the appropriate Time are displayed. Insofar as it
is available, the Name of the Author who made the changes will be displayed.

1. Choose Window > Notes.

2. Choose one of the following actions:

• Click Next to spring to the next note. If only one note is available, a further click on Next will
have no effect.

• Click Previous to spring back to the previous note.

• Click Remove to delete a note.

• Click in the entry field and change the note. The change will be accepted if you click Next or
Previous, or if you click anywhere in the document.

Changing preferences for notes

You can change the name of the Author in the Preferences.

Define the Author Name

1. Choose Edit > Preferences > Program > General (Windows/Linux) or [Application Name] > Preferences
> Program > General (Mac OS).

2. Enter the required name in the Author field.

Please note that the name is used not only for notes, but also for other options (e.g. Change tracking).

Access Rights
The editing of documents can be limited for third parties using access rights. This function is particu-
larly helpful if as a user you want to create documents that other users are only allowed to edit
according to certain criteria. These users should for example only have the possibility of entering text
or moving images. As the creator of the documents you protect them with an individual password
and you can unlock the documents with the password to edit them yourself.

In addition to the access rights described below, the program also offers the option of protecting
Alias pages and layers. Please refer to the notes in the sections Working with Pages and Working
with Layers.
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Basic working methods

Static Access Rights (desktop workflow)
If other users edit the documents in a desktop version, you can restrict the editing using the access
rights but in this case you must assign a password. Without the assignment of a password, the
options have no effect. Passwords for layers or Alias pages are not affected.

The access rights options affect the desktop version immediately when you assign a password, confirm
the settings and save the document. You may also need to open the document again (File> Revert to
Saved). Users who do not have a program version for unlocking access rights or who do not know the
password can only edit the document according to the criteria that have been set. To unlock the doc-
ument for complete editing, you need the assigned password. Therefore, it can be helpful to back up
the document without a password, because if you forget the password, it can not be unlocked by
anyone! Furthermore, consider a concept by which you assign the password or always assign the
same password for all documents. Thus you will make editing easier.

If other users edit the documents on the desktop with a certain version, you may under certain cir-
cumstances be able to dispense with certain access rights as these options are not included in this
edition. The Free Edition does not include any options for layers, for example. Therefore you don’t
need to assign any password protection to individual layers.

Dynamic Access Rights (Web workflow)
If other users edit the documents in a Web version, you may under certain circumstances be able to
dispense completely with setting access rights and assigning passwords in the document (for
example in the VivaCloud). Passwords for layers or Alias pages remain unaffected. In the Web ver-
sion, all the access rights described here can be assigned dynamically. Depending on the application,
this assignment may be carried out with relation to user roles. Dynamic assignment works basically
according to the same rules as the static assignment in the document, with the exception that the
assignment of a password is superfluous.

Static and Dynamic Access Rights (Web workflow)
If you have assigned access rights both in the Web application and in the document, the relevant
options are only available if they are not deactivated in both cases. This function is helpful if you
apply a certain basis access right to a user group (e.g. Move Objects) but do want to switch this right
off for a single document.

Create/Unlock Access Rights

Create access rights for a document

1. Choose Edit > Preferences > Access Rights.

2. Choose one of the options described in the section Options for Access rights.

3. Click the Password button.

4. Enter a password in the Password entry field and repeat the entry in the next entry field. Choose
the option Make visible to display the password in clear text on the screen.

5. Confirm the entry.
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Change access rights for a document

1. Choose Edit > Preferences > Access Rights.

2. Choose one of the options described in the section Options for Access rights.

3. Click the Password button to optionally apply another password.

4. Confirm the entry.

Unlock access rights temporarily/permanently

1. Choose File > Unlock Access Rights.

2. Enter the password.

3. Optionally choose Unlock permanently.

4. Confirm the entry.

Options for Access Rights

The name of the option usually corresponds to the name of the option of the same name in the menu.
Please refer to the operation of each option in the relevant sections of the manual. Therefore, only
general information, in particular interaction with other options, is described in this section.

For these preferences the same rules apply as those for all other preferences. This means: All options
are only valid for the current document. If no document is open, then the settings will be valid for all
new documents.

Options for Documents
You define general preferences for the document in the Document dialog area.

Save — This option only makes sense if the user has corresponding writing rights.

Save As — This option is only useful if the user has corresponding writing rights. If no option to save
the document is selected, the document can not be saved. This is helpful, for example, if the user is
only allowed to make changes and to print, but the source document is not to be changed.

Import — Texts or pictures can be imported. This option is only useful if the option Edit Images and/
or Edit Text is selected.

Document Setup — This option is only useful if the option Objects is selected.

Preferences — This option is only useful if the user is allowed to change ALL preferences. There is the
danger that a user in the desktop version can change the access rights if he knows the password. In
the Web Edition this is prevented if the access rights are applied dynamically (e.g. VivaCloud).

Colors — This option is only useful if the option Edit Objects and/or Edit Text is selected.

Style Sheets — This option is only useful if the option Edit Objects and/or Edit Text is selected.

View — This option steers the View menu.

Zoom — This option steers the Zoom menu.

Options for Output
You define the output options for the document in the Output dialog area.
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Printing — In the Web Edition, the document can be printed on a local printer.

PDF Export — This option is only useful if the user has corresponding writing rights. This option has no
effect on editions that do not have PDF Export (for example, “Free Edition”).

EPS Export — This option is only useful if the user has corresponding writing rights.

PS Export — This option is only useful if the user has corresponding writing rights.

JPEG/PNG/SVG Export — This option is only useful if the user has corresponding writing rights.

Text Export — This option is only useful if the user has corresponding writing rights.

Object Export — This option is only useful if the user has corresponding writing rights.

High Resolution Output — This option is only useful if the images are embedded in the document or if
access to the original images is possible.

Options for Layout & Content
Objects — Allows switching on and off all options for the editing of objects.

Move Objects — Objects may be moved. If the option is selected, the corresponding tool will be dis-
played if the Tools option is also selected. Otherwise, the object can be moved without the Tools pal-
ette.

Stretch objects — The height and width of objects may be changed.

Edit Paths — Paths may be edited. If the option is not selected, no new paths can be created, selected
or deleted.

Modify Objects — Objects can be edited. If the option is not selected, no new objects can be created,
selected or deleted. This also applies to all Drag & Drop operations that are used for example to place
images on a document page in a new object. Object coordinates, colors or frame settings may be
changed.

Create Objects — This option is only useful if the if the Tools option is also selected.

Delete Objects — Objects may be deleted.

Pages — New pages may be created and existing pages may be deleted. If the option Pages is
selected, Alias pages may also be displayed and assigned to a document page.

Text — Allows the switching on and off for all options for editing text.

Edit Text — Text may be edited or entered (input, deletion, replacement, etc.). The possibilities a user
has for formatting text depend on the options Module and Style Sheets.

Change Tracking — Determines whether the user can switch the option in question on and off. If the
option is not selected, the settings in the document apply. This option is only useful if the Edit Text
option is selected.

Text Invisibles — Determines whether the user can switch the option in question on and off. If the
option is not selected, the settings in the document apply.

Insert Special Character — Determines whether the user can switch the option in question on and off.
If the option is not selected, the settings in the document apply.

Insert Break — Determines whether the user can switch the option in question on and off. If the option
is not selected, the settings in the document apply.
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Insert Space — Determines whether the user can switch the option in question on and off. If the option
is not selected, the settings in the document apply.

Insert Hyphen/Dash — Determines whether the user can switch the option in question on and off. If
the option is not selected, the settings in the document apply.

Insert Variable — Determines whether the user can switch the option in question on and off. If the
option is not selected, the settings in the document apply.

Insert Object — Determines whether the user can switch the option in question on and off. If the
option is not selected, the settings in the document apply.

Ruby Text (furigana) — Determines whether the user can switch the option in question on and off. If
the option is not selected, the settings in the document apply.

Pictures — Pictures can be edited (change image crop, scaling, etc.). The option can be limited by
other options (e.g. Modify Objects or Import).

Tables — Tables may be edited (columns, rows, cells, etc.). The option may be restricted by other
options (e.g. Modify Objects or Module).

If the option Module is not selected, the table settings can only be selected with the context menu.

If the option Modify Objects is not selected, only single cells and no table rows or columns may be
selected.

Options for displaying palettes
With the options in the Toolbars & Palettes dialog area, you define which palettes can be displayed. If
an option is not selected, the palette will be hidden automatically when switching between docu-
ments, and the appropriate options will either be hidden or grayed out in the Window menu.

Tools — Please note that not all tools may be displayed. The display of individual tools can be limited
by other options (e.g. Create Objects or Move Objects).

Navigation — Please note that not all options may be displayed. The display of individual options
may be restricted by other options (e.g. Pages).

Quick Access — Please note that not all options may be displayed. The display of individual options
can be restricted by other options (eg Edit Text).

Neutral Design — This option is only useful if the Neutral Design option is selected in the Preferences.
Please refer to the notes in the Preferences section. The palette allows the selection of character and
paragraph style sheets independently of the Style Sheets option.

Module — Please note that not all options may be displayed. The display of individual options may be
restricted by other options (eg Edit Text).

Pictures — This option is only useful if the option Edit Pictures is selected.

Layers — If the option is not selected, you cannot switch between several layers. In this case, new
objects will be created on the selected layer. This option is only useful if at least one option under Edit
Objects is selected.

Assignments — This option is only useful if the Edit Objects option is selected. This option is not
required for editing a task file.
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Pages — Please note that not all options may be displayed. The display of individual options can be
restricted by other options (e.g. Pages).

Colors — This option is only useful if the options Modify Objects and/or Edit Text are selected,

Style Sheets — This option is only useful if the options Modify Objects, Edit Text and/or Pictures are
selected,

Search & Replace — This option is only useful if the option Edit Text is selected. The Search & Replace
options work independently of the options for formatting text. Therefore a user could exchange fonts
or Style Sheets, although he is not allowed to do this by other options.

Spell Check — This option is only useful if the option Edit Text is selected.

Character Inspector — This option is only useful if the option Edit Text is selected.

Change Tracking — This option is only useful if the option Edit Text is selected.

Notes — This option is only useful if the options Modify Objects and/or Edit Text are selected,

Trapping — This option is only useful if the option Modify Objects is selected,

OpenType — This option is only useful if the option Edit Text is selected.

Help — This option is only useful if a Help text is available,

Hints for creating templates

Introduction
You can use access rights to restrict the editing options of open documents. The advantage of this
technique is that you can define an existing layout as a template in a few minutes. However, this
requires that certain aspects have been taken into account when creating a layout, which also makes
later editing possible.

With a few exceptions it does not matter whether you have built the layout in VivaDesigner or another
program (e.g. Adobe InDesign) and then imported it into VivaDesigner. The process is always the
same:

Step 1: — Think about a concept and which editing options you want to give a user for a document.
Each document can have different editing options.

Step 2: — Implement the concept for access rights in the layout. For existing documents, check
whether the concept has been implemented in all points.

Step 3: — Set the access rights for the document.

Step 4: — Check the functionality of the access rights to make sure that the user has all the options he
needs.

Conceptual notes
When creating and preparing documents, you should always consider what options are available to
the user based on the access rights to edit the document. For example, if a user has access rights
based on the fact that he

• cannot create his own pages and/or objects, all necessary pages and/or objects must already
exist in the document.
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• cannot stretch objects, all text objects must be created in such a way that they can hold the
desired amount of text.

• cannot move any objects, the layout must be set up/adjusted so that the position of dependent
objects is determined automatically.

• cannot mark up texts individually, all necessary style sheets must already be available in the
document.

• cannot mark up texts using style sheets either, corresponding sample texts must be available
and already marked up.

Against this background, you may have to adapt the structure of existing documents without chang-
ing the layout. When creating and preparing the templates, you should always keep in mind that
another user

• must be able to find the way around your document without training,

• has fewer functions for editing the document, depending on access rights,

• and should only modify the document in the way you intend.

The user will only find his way around your document immediately if he can immediately see which
functions are available to him. This applies when working with pages, objects, texts, style sheets or
images.

Notes on document pages
• Remove all superfluous document pages.

• Remove all superfluous Alias pages if the user has access to the Pages palette.

• Protect Alias pages optionally with a password.

Notes on objects and layers
• Delete all objects on the workspace so as not to confuse the user.

• Objects that are to be repeated on different pages and not edited can be placed on Alias
pages.

• All other objects that should not be edited can either be protected or placed on special layers
which may be locked.

• Alternatively you can place all objects to be edited on one layer and lock all other layers. In
both cases you do not need to protect the layer with a password if you do not give the user the
possibility to select a layer. However, make sure that when you save the document, the layer
that the user is to edit later is also selected.

• Note that not all Editions have the Layers palette.

• Optionally, choose View > Visualize Locked Objects to show the user which objects he can edit at
all.

Notes on graphic and picture objects
• Graphic objects should be created as graphic objects and not as empty picture objects. Other-

wise you get the impression that you can/should import images in these objects.

• Check if you already need to fill picture objects with corresponding sample images or if you
only want to offer empty picture objects to the user. Please note that when importing images,
the scaling options are automatically applied if an image has already been imported once in
the picture object. This is also a way to predefine the scaling for an picture object.
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Notes on text objects
• Think about a concept for sample texts. Check whether you already fill the text objects that the

user is to edit with sample texts and how you want to mark them up. Keep in mind that all texts
that the user does not delete or edit will be output later.

• Think about a concept for a dynamic arrangement. Check whether the layout adapts auto-
matically when the user enters more or less text:

• Headline and subsequent text should not be entered in separate text objects if the length of the
headline is variable.

• Images should be anchored in text if the position of the image depends on the amount of text.

• Images and text can be placed in tables with a fixed height so that the height of the images
adapts to the amount of text. To do this, you must set the line height for texts to Auto and the
line height for images to 100%.

Notes on text style sheets
• Only use style sheets for marking texts if the user is to mark up texts with style sheets only.

With the help of the option View > Text > Visualize Text Style Sheets, you can very quickly check
which texts have been marked with style sheets.

• Use style sheet names that indicate the function. (e.g. “Headline”, “Body text”, etc.).

• If possible, use the names for text style sheets predefined in the program if the document is to
be used in different countries. These names are automatically translated by the program when
the program language is changed.

• Create character style sheets for Bold, Italic, Superscript, Subscript, if such attributes are to be
used in the text and the Module palette is switched off.

• Texts which the user is not allowed to edit (e.g. on protected Alias pages or layers) should not
necessarily be marked with style sheets, because errors or text overflows in text objects or even
tables could occur if the user happens to be allowed to edit style sheets.

Hints for the creation of templates in InDesign

You can also use existing InDesign documents as templates. In principle, the same rules apply to
InDesign as to the program, provided that these options are also available in InDesign. Please refer to
the section Notes on creating templates and the section Exchange with InDesign.
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Working with Scripts
With scripts you can extend the functionality of the program almost indefinitely.
Scripts are especially suitable for automating recurring tasks. You can create your
own scripts or apply or modify existing scripts.

Introduction
Scripts are small programs whose program code is stored in a text file. Therefore, scripts can be
edited or changed by a user at any time. In contrast to complex applications, the source code of
scripts is not translated into machine code by a compiler, but is interpreted by the program at run-
time. Therefore, scripts can only be run within the VIVA programs.

Scripts for VIVA programs are created in the script language JavaScript (short JS) or ECMAScript. This
script language was originally developed for dynamic HTML in web browsers and is therefore widely
used. For the creation of scripts almost the entire functional range of the program is available. For this
you need the developer documentation, which is available separately.

- Please note that the script functionality may not be available in every program version or edi-
tion.

- If you have already created Java scripts in comparable programs, you cannot use these scripts in
VIVA programs without adaptation due to other function calls and parameters. The script code
can therefore be used as a template for a new script.

Manage scripts

Script file

The program recognizes all scripts that are located in certain folders and have the file extension .JS.
The program does not check whether the file content contains a valid script. We distinguish between
scripts that VIVA delivers with the program and individual scripts that are stored in the user direc-
tory. For reasons of compatibility you should not change any scripts that are delivered with the pro-
gram or copy them into the user directory, because otherwise you can no longer distinguish which
script has which origin. If you still want to change scripts that came with the program, you must
change the file name when copying the script into the user directory to make it unique.

Move/copy individual script file into the user folder

1. Choose Window > Scripts or alternatively press Ctrl + Alt + F11 (Windows/Linux) or Command +
Option + F11 (Mac) to access the Scripts palette.

2. Click the Folder icon.

3. The operating system displays the folder in the user directory that contains the individual scripts.
Move or copy new scripts to the folder. You should not use subfolders because scripts in subfolders
are not recognized by the program.

4. Click the Update icon.
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The new script now appears in the list. The list name corresponds to the file name of the script.

Using Scripts

Script files can be executed with a simple mouse click. However, you should only execute scripts from
trusted locations, since scripts can also be used to modify or even delete files on your computer.

Apply a script

1. Choose a script from the list.

2. Click Start.

Modify Scripts

Scripts for VIVA programs are created in the script language JavaScript (short JS) or ECMAScript. If
you are familiar with the language, you can edit or change the scripts at any time using a simple text
editor. The developer documentation shows which functions you can use in VIVA scripts.

Changing scripts is at your own risk. Unless expressly agreed upon in writing in a contract, VIVA does
not provide support for scripts or, if applicable, support only on a voluntary basis.

Example scripts

Legal information

VIVA creates scripts for general use from time to time. These scripts are either part of the program
installation or can be downloaded from our website. Scripts are fully covered by the terms of the soft-
ware license agreement that you have accepted by using the software. In modification of the software
license agreement you are allowed to modify the delivered scripts for personal, non-commercial use.
However, under no circumstances are you allowed to remove or change the copyright information,
publicly distribute or sell the scripts without written permission from VIVA.

Example 1: Import all images in a folder

This script imports all images in a folder and creates a new document page and image object for each
image. After starting the script you will be asked to select the desired folder with the images. In this
example, all files in TIFF, EPS, JPEG or PDF format are recognized as images. The image object is cre-
ated with a bleed of 5 mm, the image is scaled with the option Fill Frame Proportionally.

You can optionally modify the script if you want to change, for example, other image formats, the
number of images per page, the spacing between multiple images, the bleed, the order and the scal-
ing of the images. Please refer to the comments in the script. Normally, no programing knowledge or
developer documentation is required for these changes to the script.
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